aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
authorJacek Antonelli2011-05-18 16:54:33 -0500
committerJacek Antonelli2011-05-18 21:50:11 -0500
commit718d23b821e2a293e01e6086b0d0ae57263febca (patch)
tree15c467f49db6e4c5b17343de429ba227629ce6ec
parentChanged the cache and settings file names back to non-Experimental. (diff)
parentUse a more recent dbusglib package on Linux32. (diff)
downloadmeta-impy-718d23b821e2a293e01e6086b0d0ae57263febca.zip
meta-impy-718d23b821e2a293e01e6086b0d0ae57263febca.tar.gz
meta-impy-718d23b821e2a293e01e6086b0d0ae57263febca.tar.bz2
meta-impy-718d23b821e2a293e01e6086b0d0ae57263febca.tar.xz
Merge branch '1.3-maint' into next
Conflicts: linden/indra/llcommon/CMakeLists.txt linden/indra/newview/llvoavatar.cpp linden/indra/newview/viewer_manifest.py
-rw-r--r--RELEASE_NOTES.txt32
-rw-r--r--linden/indra/cmake/Audio.cmake16
-rw-r--r--linden/indra/cmake/LLWindow.cmake3
-rw-r--r--linden/indra/llcommon/CMakeLists.txt10
-rw-r--r--linden/indra/llmessage/CMakeLists.txt10
-rw-r--r--linden/indra/newview/llvoavatar.cpp6
-rwxr-xr-xlinden/install.xml20
7 files changed, 81 insertions, 16 deletions
diff --git a/RELEASE_NOTES.txt b/RELEASE_NOTES.txt
index bad35a9..b2532be 100644
--- a/RELEASE_NOTES.txt
+++ b/RELEASE_NOTES.txt
@@ -4,6 +4,38 @@
4 4
5 5
6 =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- 6 =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
7 =- 1.3.2 -=
8 =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
9
10 CHANGES
11
12 This version of Imprudence includes the following changes,
13 as compared to Imprudence 1.3.1.
14
15 * Updated the ogg-vorbis libraries to address an exploit that
16 allowed attackers to crash the viewer. libogg is now version
17 1.2.2; libvorbis is now version 1.3.2.
18
19 * Fixed VWR-25479: Avatar physics causing broken shapes on other
20 viewers. Thanks for the patch, Seraph Linden!
21
22 * Fixed the Vivox Acceptable Use Policy window appearing under
23 the wrong conditions.
24
25 * Fixed voice chat always being disabled at startup, even if you
26 had enabled it in your Preferences in the previous session.
27
28 * Fixed a startup error related to "libz.so" on certain Linux
29 distros. (IMP-790)
30
31 * Fixed the viewer encountering an error: "Vertex buffer
32 destroyed while mapped!"
33
34 * Tweaked the compile system so the viewer can link using "gold".
35
36
37
38 =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
7 =- 1.3.1 -= 39 =- 1.3.1 -=
8 =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- 40 =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
9 41
diff --git a/linden/indra/cmake/Audio.cmake b/linden/indra/cmake/Audio.cmake
index d23bc2f..10d11bb 100644
--- a/linden/indra/cmake/Audio.cmake
+++ b/linden/indra/cmake/Audio.cmake
@@ -32,6 +32,12 @@ else (STANDALONE)
32 set(VORBISENC_LIBRARIES vorbisenc) 32 set(VORBISENC_LIBRARIES vorbisenc)
33 set(VORBISFILE_LIBRARIES vorbisfile) 33 set(VORBISFILE_LIBRARIES vorbisfile)
34 endif (WINDOWS) 34 endif (WINDOWS)
35 if(LINUX AND ${ARCH} STREQUAL "x86_64")
36 set(VORBIS_LIBRARY_DIRS ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/lib)
37 set(VORBISENC_LIBRARY_DIRS ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/lib)
38 set(VORBISFILE_LIBRARY_DIRS ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/lib)
39 set(OGG_LIBRARY_DIRS ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/lib)
40 endif(LINUX AND ${ARCH} STREQUAL "x86_64")
35endif (STANDALONE) 41endif (STANDALONE)
36 42
37link_directories( 43link_directories(
@@ -40,3 +46,13 @@ link_directories(
40 ${VORBISFILE_LIBRARY_DIRS} 46 ${VORBISFILE_LIBRARY_DIRS}
41 ${OGG_LIBRARY_DIRS} 47 ${OGG_LIBRARY_DIRS}
42 ) 48 )
49
50if(NOT vorbis_link_msg)
51 set(vorbis_link_msg ON CACHE BOOL "ogg vorbis linked from:\n")
52 message("ogg vorbis linked from:\n"
53 ${VORBIS_LIBRARY_DIRS} "\n"
54 ${VORBISENC_LIBRARY_DIRS} "\n"
55 ${VORBISFILE_LIBRARY_DIRS} "\n"
56 ${OGG_LIBRARY_DIRS} "\n"
57 )
58endif(NOT vorbis_link_msg)
diff --git a/linden/indra/cmake/LLWindow.cmake b/linden/indra/cmake/LLWindow.cmake
index 1023693..345359a 100644
--- a/linden/indra/cmake/LLWindow.cmake
+++ b/linden/indra/cmake/LLWindow.cmake
@@ -45,4 +45,7 @@ else (SERVER AND LINUX)
45 comdlg32 45 comdlg32
46 ) 46 )
47 endif (WINDOWS) 47 endif (WINDOWS)
48 if (LINUX)
49 list(APPEND LLWINDOW_LIBRARIES fontconfig)
50 endif (LINUX)
48endif (SERVER AND LINUX) 51endif (SERVER AND LINUX)
diff --git a/linden/indra/llcommon/CMakeLists.txt b/linden/indra/llcommon/CMakeLists.txt
index ed04ca6..b6015a8 100644
--- a/linden/indra/llcommon/CMakeLists.txt
+++ b/linden/indra/llcommon/CMakeLists.txt
@@ -200,7 +200,7 @@ set_source_files_properties(${llcommon_HEADER_FILES}
200list(APPEND llcommon_SOURCE_FILES ${llcommon_HEADER_FILES}) 200list(APPEND llcommon_SOURCE_FILES ${llcommon_HEADER_FILES})
201 201
202add_library (llcommon SHARED ${llcommon_SOURCE_FILES}) 202add_library (llcommon SHARED ${llcommon_SOURCE_FILES})
203target_link_libraries( 203set (llcommon_link_LIBRARIES
204 llcommon 204 llcommon
205 ${APRUTIL_LIBRARIES} 205 ${APRUTIL_LIBRARIES}
206 ${APR_LIBRARIES} 206 ${APR_LIBRARIES}
@@ -218,3 +218,11 @@ if (DARWIN)
218 INSTALL_NAME_DIR "@executable_path/../Resources" 218 INSTALL_NAME_DIR "@executable_path/../Resources"
219 ) 219 )
220endif (DARWIN) 220endif (DARWIN)
221
222if (LINUX)
223 list(APPEND llcommon_link_LIBRARIES rt)
224endif (LINUX)
225
226target_link_libraries(
227 ${llcommon_link_LIBRARIES}
228 )
diff --git a/linden/indra/llmessage/CMakeLists.txt b/linden/indra/llmessage/CMakeLists.txt
index b3f2b4c..61b6418 100644
--- a/linden/indra/llmessage/CMakeLists.txt
+++ b/linden/indra/llmessage/CMakeLists.txt
@@ -208,13 +208,21 @@ set_source_files_properties(${llmessage_HEADER_FILES}
208list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES}) 208list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES})
209 209
210add_library (llmessage ${llmessage_SOURCE_FILES}) 210add_library (llmessage ${llmessage_SOURCE_FILES})
211target_link_libraries( 211set (llmessage_link_LIBRARIES
212 llmessage 212 llmessage
213 ${CURL_LIBRARIES} 213 ${CURL_LIBRARIES}
214 ${CARES_LIBRARIES} 214 ${CARES_LIBRARIES}
215 ${OPENSSL_LIBRARIES} 215 ${OPENSSL_LIBRARIES}
216 ${CRYPTO_LIBRARIES} 216 ${CRYPTO_LIBRARIES}
217 ${XMLRPCEPI_LIBRARIES} 217 ${XMLRPCEPI_LIBRARIES}
218)
219if (LINUX)
220 list(APPEND llmessage_link_LIBRARIES pthread)
221endif (LINUX)
222
223target_link_libraries(
224 ${llmessage_link_LIBRARIES}
225
218 ) 226 )
219 227
220IF (NOT LINUX AND VIEWER) 228IF (NOT LINUX AND VIEWER)
diff --git a/linden/indra/newview/llvoavatar.cpp b/linden/indra/newview/llvoavatar.cpp
index 3ba94fa..ed51a24 100644
--- a/linden/indra/newview/llvoavatar.cpp
+++ b/linden/indra/newview/llvoavatar.cpp
@@ -8754,7 +8754,6 @@ void LLVOAvatar::processAvatarAppearance( LLMessageSystem* mesgsys )
8754 8754
8755 if( !param ) 8755 if( !param )
8756 { 8756 {
8757 llwarns << "Number of params in AvatarAppearance msg does not match number of params in avatar xml file." << llendl;
8758 break; 8757 break;
8759 } 8758 }
8760 8759
@@ -8796,10 +8795,9 @@ void LLVOAvatar::processAvatarAppearance( LLMessageSystem* mesgsys )
8796 } 8795 }
8797 } 8796 }
8798 8797
8799 S32 expected_tweakable_count = getVisualParamCountInGroup(VISUAL_PARAM_GROUP_TWEAKABLE); // don't worry about VISUAL_PARAM_GROUP_TWEAKABLE_NO_TRANSMIT 8798 while( param && (param->getGroup() != VISUAL_PARAM_GROUP_TWEAKABLE) )
8800 if (num_blocks != expected_tweakable_count)
8801 { 8799 {
8802 llinfos << "Number of params in AvatarAppearance msg (" << num_blocks << ") does not match number of tweakable params in avatar xml file (" << expected_tweakable_count << "). Processing what we can. Object: " << getID() << llendl; 8800 param = getNextVisualParam();
8803 } 8801 }
8804 8802
8805 if (params_changed) 8803 if (params_changed)
diff --git a/linden/install.xml b/linden/install.xml
index 7ff8dc0..90d0ae5 100755
--- a/linden/install.xml
+++ b/linden/install.xml
@@ -1151,9 +1151,9 @@ Copyright (C) 2004-2005 Vladimir Berezniker @ http://public.xdi.org/=vmpn
1151 <key>ogg-vorbis</key> 1151 <key>ogg-vorbis</key>
1152 <map> 1152 <map>
1153 <key>copyright</key> 1153 <key>copyright</key>
1154 <string>Copyright (C) 2008 Xiph.org Foundation</string> 1154 <string>Copyright (C) Xiph.org Foundation</string>
1155 <key>description</key> 1155 <key>description</key>
1156 <string>Ogg: container format Vorbis: audio compression scheme</string> 1156 <string>Ogg: container format; Vorbis: audio compression scheme</string>
1157 <key>license</key> 1157 <key>license</key>
1158 <string>xiph-bsd</string> 1158 <string>xiph-bsd</string>
1159 <key>packages</key> 1159 <key>packages</key>
@@ -1161,30 +1161,30 @@ Copyright (C) 2004-2005 Vladimir Berezniker @ http://public.xdi.org/=vmpn
1161 <key>darwin</key> 1161 <key>darwin</key>
1162 <map> 1162 <map>
1163 <key>md5sum</key> 1163 <key>md5sum</key>
1164 <string>88eec3965fc2384436192faef1db2629</string> 1164 <string>30c75ce29c2ce2f6e8063067db31989d</string>
1165 <key>url</key> 1165 <key>url</key>
1166 <uri>http://imprudenceviewer.org/download/libs/ogg-vorbis-darwin-20100620.tar.bz2</uri> 1166 <uri>http://download.kokuaviewer.org/files/libs/ogg-vorbis-darwin-1.2.2-1.3.2-20110517.tar.bz2</uri>
1167 </map> 1167 </map>
1168 <key>linux</key> 1168 <key>linux</key>
1169 <map> 1169 <map>
1170 <key>md5sum</key> 1170 <key>md5sum</key>
1171 <string>72bde567859934024c8a4a70b97b24f5</string> 1171 <string>a132634c28f0d7fb0e7e4f62c82a0579</string>
1172 <key>url</key> 1172 <key>url</key>
1173 <uri>http://imprudenceviewer.org/download/libs/ogg-vorbis-linux-20091115.tar.bz2</uri> 1173 <uri>http://download.kokuaviewer.org/files/libs/ogg-vorbis-linux-1.2.2-1.3.2-20110514.tar.bz2</uri>
1174 </map> 1174 </map>
1175 <key>linux64</key> 1175 <key>linux64</key>
1176 <map> 1176 <map>
1177 <key>md5sum</key> 1177 <key>md5sum</key>
1178 <string>83c72b57a95e8c42560fb67955169f19</string> 1178 <string>dded849d4d46fb5d94f088c86407ec98</string>
1179 <key>url</key> 1179 <key>url</key>
1180 <uri>http://imprudenceviewer.org/download/libs/ogg-vorbis-linux64-20091202.tar.bz2</uri> 1180 <uri>http://download.kokuaviewer.org/files/libs/ogg-vorbis-linux64-1.2.2-1.3.2-20110514.tar.bz2</uri>
1181 </map> 1181 </map>
1182 <key>windows</key> 1182 <key>windows</key>
1183 <map> 1183 <map>
1184 <key>md5sum</key> 1184 <key>md5sum</key>
1185 <string>9bf1fea65e66b2cd3075e6ffd7eb57ad</string> 1185 <string>946bab72f6774220eaf139ce378ba671</string>
1186 <key>url</key> 1186 <key>url</key>
1187 <uri>http://s3.amazonaws.com/viewer-source-downloads/install_pkgs/ogg-vorbis-1.1.3-1.2.0-windows-20080723.tar.bz2</uri> 1187 <uri>http://download.kokuaviewer.org/files/libs/ogg-vorbis-windows-1.2.2-1.3.2-20110511.tar.bz2</uri>
1188 </map> 1188 </map>
1189 </map> 1189 </map>
1190 </map> 1190 </map>