aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/llcommon/CMakeLists.txt')
-rw-r--r--linden/indra/llcommon/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/linden/indra/llcommon/CMakeLists.txt b/linden/indra/llcommon/CMakeLists.txt
index ed04ca6..b6015a8 100644
--- a/linden/indra/llcommon/CMakeLists.txt
+++ b/linden/indra/llcommon/CMakeLists.txt
@@ -200,7 +200,7 @@ set_source_files_properties(${llcommon_HEADER_FILES}
200list(APPEND llcommon_SOURCE_FILES ${llcommon_HEADER_FILES}) 200list(APPEND llcommon_SOURCE_FILES ${llcommon_HEADER_FILES})
201 201
202add_library (llcommon SHARED ${llcommon_SOURCE_FILES}) 202add_library (llcommon SHARED ${llcommon_SOURCE_FILES})
203target_link_libraries( 203set (llcommon_link_LIBRARIES
204 llcommon 204 llcommon
205 ${APRUTIL_LIBRARIES} 205 ${APRUTIL_LIBRARIES}
206 ${APR_LIBRARIES} 206 ${APR_LIBRARIES}
@@ -218,3 +218,11 @@ if (DARWIN)
218 INSTALL_NAME_DIR "@executable_path/../Resources" 218 INSTALL_NAME_DIR "@executable_path/../Resources"
219 ) 219 )
220endif (DARWIN) 220endif (DARWIN)
221
222if (LINUX)
223 list(APPEND llcommon_link_LIBRARIES rt)
224endif (LINUX)
225
226target_link_libraries(
227 ${llcommon_link_LIBRARIES}
228 )