From ac778f69ee33d31b60ec190c3bcd84c026e41602 Mon Sep 17 00:00:00 2001
From: Armin Weatherwax
Date: Sun, 13 Mar 2011 09:16:20 +0100
Subject: fix voice doesn't kick in.
also fixed some LL_INFOS that should be LL_WARNS in the voice client.
(cherry picked from commit 56bf45f3493689b5eb60cf99580adf11d6b02508)
---
linden/indra/newview/llvoiceclient.cpp | 22 ++++++++++------------
1 file changed, 10 insertions(+), 12 deletions(-)
diff --git a/linden/indra/newview/llvoiceclient.cpp b/linden/indra/newview/llvoiceclient.cpp
index d67b9e3..a6cec7b 100644
--- a/linden/indra/newview/llvoiceclient.cpp
+++ b/linden/indra/newview/llvoiceclient.cpp
@@ -1527,12 +1527,10 @@ void LLVoiceClient::setState(state inState)
void LLVoiceClient::stateMachine()
{
- if(gDisconnected)
- {
- // The viewer has been disconnected from the sim. Disable voice.
- setVoiceEnabled(false);
- }
-
+
+ // Disable voice as long as the viewer is disconnected from the sim (login/relog)
+ setVoiceEnabled(!gDisconnected);
+
if(mVoiceEnabled)
{
updatePosition();
@@ -1549,7 +1547,7 @@ void LLVoiceClient::stateMachine()
if(!mConnected)
{
// if voice was turned off after the daemon was launched but before we could connect to it, we may need to issue a kill.
- LL_INFOS("Voice") << "Disabling voice before connection to daemon, terminating." << LL_ENDL;
+ LL_WARNS("Voice") << "Disabling voice before connection to daemon, terminating." << LL_ENDL;
killGateway();
}
@@ -1753,7 +1751,7 @@ void LLVoiceClient::stateMachine()
}
else
{
- LL_INFOS("Voice") << exe_path << " not found." << LL_ENDL;
+ LL_WARNS("Voice") << exe_path << " not found." << LL_ENDL;
mVoiceEnabled = false;
}
}
@@ -3772,7 +3770,7 @@ void LLVoiceClient::loginResponse(int statusCode, std::string &statusString, std
if ( statusCode == 401 )
{
// Login failure which is probably caused by the delay after a user's password being updated.
- LL_INFOS("Voice") << "Account.Login response failure (" << statusCode << "): " << statusString << LL_ENDL;
+ LL_WARNS("Voice") << "Account.Login response failure (" << statusCode << "): " << statusString << LL_ENDL;
setState(stateLoginRetry);
}
else if(statusCode != 0)
@@ -3950,7 +3948,7 @@ void LLVoiceClient::sessionAddedEvent(
}
else
{
- LL_INFOS("Voice") << "Could not generate caller id from uri, using hash of uri " << session->mSIPURI << LL_ENDL;
+ LL_WARNS("Voice") << "Could not generate caller id from uri, using hash of uri " << session->mSIPURI << LL_ENDL;
setUUIDFromStringHash(session->mCallerID, session->mSIPURI);
session->mSynthesizedCallerID = true;
@@ -4468,7 +4466,7 @@ void LLVoiceClient::participantUpdatedEvent(
}
else
{
- LL_INFOS("Voice") << "unknown session " << sessionHandle << LL_ENDL;
+ LL_WARNS("Voice") << "unknown session " << sessionHandle << LL_ENDL;
}
}
@@ -5062,7 +5060,7 @@ void LLVoiceClient::parcelChanged()
else
{
// The transition to stateNoChannel needs to kick this off again.
- LL_INFOS("Voice") << "not logged in yet, deferring" << LL_ENDL;
+ LL_WARNS("Voice") << "not logged in yet, deferring" << LL_ENDL;
}
}
--
cgit v1.1
From 9e43710ca3fd9352581355d92f27a3952090f8af Mon Sep 17 00:00:00 2001
From: Armin Weatherwax
Date: Sun, 20 Mar 2011 01:37:07 +0100
Subject: fix: voice always on, even if told not to be
introduced by 56bf45f >_>
(cherry picked from commit 8f92d7925f2ba9259a6597c80584b09e023902da)
---
linden/indra/newview/llvoiceclient.cpp | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/linden/indra/newview/llvoiceclient.cpp b/linden/indra/newview/llvoiceclient.cpp
index a6cec7b..dadc4e6 100644
--- a/linden/indra/newview/llvoiceclient.cpp
+++ b/linden/indra/newview/llvoiceclient.cpp
@@ -1529,7 +1529,9 @@ void LLVoiceClient::stateMachine()
{
// Disable voice as long as the viewer is disconnected from the sim (login/relog)
- setVoiceEnabled(!gDisconnected);
+ setVoiceEnabled(!gDisconnected
+ && gSavedSettings.getBOOL("EnableVoiceChat")
+ && !gSavedSettings.getBOOL("CmdLineDisableVoice") );
if(mVoiceEnabled)
{
--
cgit v1.1
From 7c6ad3ae7656a6034aa2481c89cb68b73e14840d Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Mon, 18 Oct 2010 15:55:50 -0700
Subject: Fixed the Vivox license prompt appearing when connecting to non-SL
grids on startup (cherry picked from commit
cea604cda04d783b989498055102674170864b5c)
---
linden/indra/newview/llstartup.cpp | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/linden/indra/newview/llstartup.cpp b/linden/indra/newview/llstartup.cpp
index 77a2694..ab3a721 100644
--- a/linden/indra/newview/llstartup.cpp
+++ b/linden/indra/newview/llstartup.cpp
@@ -1087,10 +1087,11 @@ bool idle_startup()
// color init must be after saved settings loaded
init_colors();
- if (gSavedSettings.getBOOL("VivoxLicenseAccepted"))
+ if (gSavedSettings.getBOOL("VivoxLicenseAccepted") || gHippoGridManager->getConnectedGrid()->isSecondLife())
{
// skipping over STATE_LOGIN_VOICE_LICENSE since we don't need it
// skipping over STATE_UPDATE_CHECK because that just waits for input
+ // We don't do this on non-SL grids either
LLStartUp::setStartupState( STATE_LOGIN_AUTH_INIT );
}
else
--
cgit v1.1
From 74175a06d08c736f7fbd44a1eab2a94989215772 Mon Sep 17 00:00:00 2001
From: McCabe Maxsted
Date: Tue, 19 Apr 2011 14:49:18 -0700
Subject: Fixed vivox license appearing on other grids rather than specifically
on second life login when voice is enabled.
(Partial cherry pick from commit a0902a050cc713f742990a09d2a610d4c135b7c7)
---
linden/indra/newview/llstartup.cpp | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/linden/indra/newview/llstartup.cpp b/linden/indra/newview/llstartup.cpp
index ab3a721..2104d9b 100644
--- a/linden/indra/newview/llstartup.cpp
+++ b/linden/indra/newview/llstartup.cpp
@@ -1087,7 +1087,9 @@ bool idle_startup()
// color init must be after saved settings loaded
init_colors();
- if (gSavedSettings.getBOOL("VivoxLicenseAccepted") || gHippoGridManager->getConnectedGrid()->isSecondLife())
+ if (!gSavedSettings.getBOOL("EnableVoiceChat") ||
+ (gSavedSettings.getBOOL("EnableVoiceChat") && gSavedSettings.getBOOL("VivoxLicenseAccepted")) ||
+ !gHippoGridManager->getConnectedGrid()->isSecondLife())
{
// skipping over STATE_LOGIN_VOICE_LICENSE since we don't need it
// skipping over STATE_UPDATE_CHECK because that just waits for input
--
cgit v1.1
From 2563ea26c2ac7fa48918f0fbf992243eee0641c7 Mon Sep 17 00:00:00 2001
From: Jacek Antonelli
Date: Fri, 13 May 2011 20:59:53 -0500
Subject: VWR-25479: Avatar physics causing broken shapes on other viewers.
Patch by Seraph Linden.
---
linden/indra/newview/llvoavatar.cpp | 8 +-------
1 file changed, 1 insertion(+), 7 deletions(-)
diff --git a/linden/indra/newview/llvoavatar.cpp b/linden/indra/newview/llvoavatar.cpp
index 5be5650..bcb0be8 100644
--- a/linden/indra/newview/llvoavatar.cpp
+++ b/linden/indra/newview/llvoavatar.cpp
@@ -8556,8 +8556,7 @@ void LLVOAvatar::processAvatarAppearance( LLMessageSystem* mesgsys )
if( !param )
{
- llwarns << "Number of params in AvatarAppearance msg does not match number of params in avatar xml file." << llendl;
- return;
+ break;
}
U8 value;
@@ -8602,11 +8601,6 @@ void LLVOAvatar::processAvatarAppearance( LLMessageSystem* mesgsys )
{
param = getNextVisualParam();
}
- if( param )
- {
- llwarns << "Number of params in AvatarAppearance msg does not match number of params in avatar xml file." << llendl;
- return;
- }
if (params_changed)
{
--
cgit v1.1
From 9da837e8587d21e83cea02fe9bf4c38aee45a6be Mon Sep 17 00:00:00 2001
From: Jacek Antonelli
Date: Sat, 19 Mar 2011 13:38:38 -0500
Subject: Package both libz.so.1 and libz.so (symlink) on Linux32. (IMP-790)
The viewer binary links against libz.so, but libvivoxsdk.so and some
other libraries link against libz.so.1.
(cherry picked from commit 74d6849a9730941839f00c1ec2b640958fd61cc9)
---
linden/indra/newview/viewer_manifest.py | 1 +
1 file changed, 1 insertion(+)
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py
index 6144fe6..62a585f 100755
--- a/linden/indra/newview/viewer_manifest.py
+++ b/linden/indra/newview/viewer_manifest.py
@@ -923,6 +923,7 @@ class Linux_i686Manifest(LinuxManifest):
self.path("libELFIO.so")
self.path("libopenjpeg.so.2")
self.path("libxml2.so.2")
+ self.path("libz.so")
self.path("libz.so.1")
# OpenAL
--
cgit v1.1
From e2257461cd1c95c31c70af4cd1905a2588008104 Mon Sep 17 00:00:00 2001
From: Jacek Antonelli
Date: Sat, 14 May 2011 01:53:36 -0500
Subject: Bumped version to 1.3.2.
---
linden/indra/newview/English.lproj/InfoPlist.strings | 4 ++--
linden/indra/newview/Info-Imprudence.plist | 2 +-
linden/indra/newview/app_settings/viewerversion.xml | 2 +-
linden/indra/newview/res/viewerRes.rc | 8 ++++----
4 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/linden/indra/newview/English.lproj/InfoPlist.strings b/linden/indra/newview/English.lproj/InfoPlist.strings
index 18d5489..37872fc 100644
--- a/linden/indra/newview/English.lproj/InfoPlist.strings
+++ b/linden/indra/newview/English.lproj/InfoPlist.strings
@@ -1,5 +1,5 @@
/* Localized versions of Info.plist keys */
CFBundleName = "Imprudence";
-CFBundleShortVersionString = "Imprudence 1.3.1";
-CFBundleGetInfoString = "Imprudence 1.3.1";
+CFBundleShortVersionString = "Imprudence 1.3.2";
+CFBundleGetInfoString = "Imprudence 1.3.2";
diff --git a/linden/indra/newview/Info-Imprudence.plist b/linden/indra/newview/Info-Imprudence.plist
index 0faab3a..b4ce43c 100644
--- a/linden/indra/newview/Info-Imprudence.plist
+++ b/linden/indra/newview/Info-Imprudence.plist
@@ -32,7 +32,7 @@
CFBundleVersion
- 1.3.1
+ 1.3.2
CSResourcesFileMapped
diff --git a/linden/indra/newview/app_settings/viewerversion.xml b/linden/indra/newview/app_settings/viewerversion.xml
index 6d1d5cb..403306f 100644
--- a/linden/indra/newview/app_settings/viewerversion.xml
+++ b/linden/indra/newview/app_settings/viewerversion.xml
@@ -17,7 +17,7 @@ need to be changed manually - MC
-
+
diff --git a/linden/indra/newview/res/viewerRes.rc b/linden/indra/newview/res/viewerRes.rc
index ed24119..665ecf4 100644
--- a/linden/indra/newview/res/viewerRes.rc
+++ b/linden/indra/newview/res/viewerRes.rc
@@ -138,8 +138,8 @@ TOOLMEDIAOPEN CURSOR "toolmediaopen.cur"
//
VS_VERSION_INFO VERSIONINFO
- FILEVERSION 1,3,0
- PRODUCTVERSION 1,3,0
+ FILEVERSION 1,3,2
+ PRODUCTVERSION 1,3,2
FILEFLAGSMASK 0x3fL
#ifdef _DEBUG
FILEFLAGS 0x1L
@@ -156,11 +156,11 @@ BEGIN
BEGIN
VALUE "CompanyName", "Imprudence Viewer Project"
VALUE "FileDescription", "Imprudence"
- VALUE "FileVersion", "1.3.1"
+ VALUE "FileVersion", "1.3.2"
VALUE "InternalName", "Imprudence"
VALUE "OriginalFilename", "Imprudence.exe"
VALUE "ProductName", "Imprudence"
- VALUE "ProductVersion", "1.3.1"
+ VALUE "ProductVersion", "1.3.2"
END
END
BLOCK "VarFileInfo"
--
cgit v1.1
From 9bc37dc4df634230d7ce3db8246c33396686216d Mon Sep 17 00:00:00 2001
From: Jacek Antonelli
Date: Tue, 17 May 2011 09:40:21 -0500
Subject: Updated ogg-vorbis package to 1.2.2 / 1.3.2 on all platforms.
---
linden/install.xml | 20 ++++++++++----------
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/linden/install.xml b/linden/install.xml
index a283dcf..22ac571 100755
--- a/linden/install.xml
+++ b/linden/install.xml
@@ -1193,9 +1193,9 @@ Copyright (C) 2004-2005 Vladimir Berezniker @ http://public.xdi.org/=vmpn
ogg-vorbis
--
cgit v1.1
From e3af3ea5c78486902f382934fdc57da98bb6b075 Mon Sep 17 00:00:00 2001
From: Jacek Antonelli
Date: Tue, 17 May 2011 16:51:10 -0500
Subject: Updated RELEASE_NOTES.txt for 1.3.2.
---
RELEASE_NOTES.txt | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
diff --git a/RELEASE_NOTES.txt b/RELEASE_NOTES.txt
index bad35a9..b2219c4 100644
--- a/RELEASE_NOTES.txt
+++ b/RELEASE_NOTES.txt
@@ -4,6 +4,33 @@
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
+ =- 1.3.2 -=
+ =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
+
+ CHANGES
+
+ This version of Imprudence includes the following changes,
+ as compared to Imprudence 1.3.1.
+
+ * Updated the ogg-vorbis libraries to address an exploit that
+ allowed attackers to crash the viewer. libogg is now version
+ 1.2.2; libvorbis is now version 1.3.2.
+
+ * Fixed VWR-25479: Avatar physics causing broken shapes on other
+ viewers. Thanks for the patch, Seraph Linden!
+
+ * Fixed the Vivox Acceptable Use Policy window appearing under
+ the wrong conditions.
+
+ * Fixed voice chat always being disabled at startup, even if you
+ had enabled it in your Preferences in the previous session.
+
+ * Fixed a startup error related to "libz.so" on certain Linux
+ distros. (IMP-790)
+
+
+
+ =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
=- 1.3.1 -=
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
--
cgit v1.1
--
cgit v1.1
From 52ea2c6628dfd440f188c58b0dfdbb89da37280b Mon Sep 17 00:00:00 2001
From: Armin Weatherwax
Date: Sat, 26 Feb 2011 11:15:10 +0100
Subject: fix llerrs crash "Vertex buffer destroyed while mapped!"
---
linden/indra/newview/llviewerjointmesh_sse2.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/linden/indra/newview/llviewerjointmesh_sse2.cpp b/linden/indra/newview/llviewerjointmesh_sse2.cpp
index 550044c..450582f 100644
--- a/linden/indra/newview/llviewerjointmesh_sse2.cpp
+++ b/linden/indra/newview/llviewerjointmesh_sse2.cpp
@@ -114,7 +114,7 @@ void LLViewerJointMesh::updateGeometrySSE2(LLFace *face, LLPolyMesh *mesh)
((LLV4Matrix3)blend_mat).multiply(normals[index], o_normals[index]);
}
- //setBuffer(0) called in LLVOAvatar::renderSkinned
+ buffer->setBuffer(0);
}
#else
--
cgit v1.1
From 37922d49b167ba282312d58628e59a60f07b01be Mon Sep 17 00:00:00 2001
From: Armin Weatherwax
Date: Tue, 17 May 2011 09:32:59 +0200
Subject: also link with ld.gold
thanks to Aleric and Siana for the idea
---
linden/indra/cmake/LLWindow.cmake | 3 +++
linden/indra/llcommon/CMakeLists.txt | 10 +++++++++-
linden/indra/llmessage/CMakeLists.txt | 10 +++++++++-
3 files changed, 21 insertions(+), 2 deletions(-)
diff --git a/linden/indra/cmake/LLWindow.cmake b/linden/indra/cmake/LLWindow.cmake
index 1023693..345359a 100644
--- a/linden/indra/cmake/LLWindow.cmake
+++ b/linden/indra/cmake/LLWindow.cmake
@@ -45,4 +45,7 @@ else (SERVER AND LINUX)
comdlg32
)
endif (WINDOWS)
+ if (LINUX)
+ list(APPEND LLWINDOW_LIBRARIES fontconfig)
+ endif (LINUX)
endif (SERVER AND LINUX)
diff --git a/linden/indra/llcommon/CMakeLists.txt b/linden/indra/llcommon/CMakeLists.txt
index 3f14be6..0a50852 100644
--- a/linden/indra/llcommon/CMakeLists.txt
+++ b/linden/indra/llcommon/CMakeLists.txt
@@ -189,10 +189,18 @@ set_source_files_properties(${llcommon_HEADER_FILES}
list(APPEND llcommon_SOURCE_FILES ${llcommon_HEADER_FILES})
add_library (llcommon ${llcommon_SOURCE_FILES})
-target_link_libraries(
+set (llcommon_link_LIBRARIES
llcommon
${APRUTIL_LIBRARIES}
${APR_LIBRARIES}
${EXPAT_LIBRARIES}
${ZLIB_LIBRARIES}
)
+
+if (LINUX)
+ list(APPEND llcommon_link_LIBRARIES rt)
+endif (LINUX)
+
+target_link_libraries(
+ ${llcommon_link_LIBRARIES}
+ )
diff --git a/linden/indra/llmessage/CMakeLists.txt b/linden/indra/llmessage/CMakeLists.txt
index 0f3e159..88233b9 100644
--- a/linden/indra/llmessage/CMakeLists.txt
+++ b/linden/indra/llmessage/CMakeLists.txt
@@ -201,13 +201,21 @@ set_source_files_properties(${llmessage_HEADER_FILES}
list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES})
add_library (llmessage ${llmessage_SOURCE_FILES})
-target_link_libraries(
+set (llmessage_link_LIBRARIES
llmessage
${CURL_LIBRARIES}
${CARES_LIBRARIES}
${OPENSSL_LIBRARIES}
${CRYPTO_LIBRARIES}
${XMLRPCEPI_LIBRARIES}
+)
+if (LINUX)
+ list(APPEND llmessage_link_LIBRARIES pthread)
+endif (LINUX)
+
+target_link_libraries(
+ ${llmessage_link_LIBRARIES}
+
)
IF (NOT LINUX AND VIEWER)
--
cgit v1.1
From aeeaabf84da0e10e6173aa10cb273e8b199cf9d1 Mon Sep 17 00:00:00 2001
From: Armin Weatherwax
Date: Tue, 17 May 2011 12:51:04 +0200
Subject: Linux64 fix linking and packaging of the new ogg/vorbis libs
---
linden/indra/cmake/Audio.cmake | 16 ++++++++++++++++
linden/indra/newview/viewer_manifest.py | 7 ++++---
2 files changed, 20 insertions(+), 3 deletions(-)
diff --git a/linden/indra/cmake/Audio.cmake b/linden/indra/cmake/Audio.cmake
index d23bc2f..10d11bb 100644
--- a/linden/indra/cmake/Audio.cmake
+++ b/linden/indra/cmake/Audio.cmake
@@ -32,6 +32,12 @@ else (STANDALONE)
set(VORBISENC_LIBRARIES vorbisenc)
set(VORBISFILE_LIBRARIES vorbisfile)
endif (WINDOWS)
+ if(LINUX AND ${ARCH} STREQUAL "x86_64")
+ set(VORBIS_LIBRARY_DIRS ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/lib)
+ set(VORBISENC_LIBRARY_DIRS ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/lib)
+ set(VORBISFILE_LIBRARY_DIRS ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/lib)
+ set(OGG_LIBRARY_DIRS ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/lib)
+ endif(LINUX AND ${ARCH} STREQUAL "x86_64")
endif (STANDALONE)
link_directories(
@@ -40,3 +46,13 @@ link_directories(
${VORBISFILE_LIBRARY_DIRS}
${OGG_LIBRARY_DIRS}
)
+
+if(NOT vorbis_link_msg)
+ set(vorbis_link_msg ON CACHE BOOL "ogg vorbis linked from:\n")
+ message("ogg vorbis linked from:\n"
+ ${VORBIS_LIBRARY_DIRS} "\n"
+ ${VORBISENC_LIBRARY_DIRS} "\n"
+ ${VORBISFILE_LIBRARY_DIRS} "\n"
+ ${OGG_LIBRARY_DIRS} "\n"
+ )
+endif(NOT vorbis_link_msg)
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py
index 62a585f..601ac92 100755
--- a/linden/indra/newview/viewer_manifest.py
+++ b/linden/indra/newview/viewer_manifest.py
@@ -1092,10 +1092,11 @@ class Linux_x86_64Manifest(LinuxManifest):
# Gstreamer plugin dependencies
self.path("libfaad.so.0")
- self.path("libogg.so.0")
+ self.path("../lib/libogg.so.0.7.1", "libogg.so.0")
self.path("libtheora.so.0")
- self.path("libvorbis.so.0")
- self.path("libvorbisenc.so.2")
+ self.path("../lib/libvorbis.so.0.4.5","libvorbis.so.0")
+ self.path("../lib/libvorbisenc.so.2.0.8","libvorbisenc.so.2")
+ self.path("../lib/libvorbisfile.so.3.3.4","libvorbisfile.so.3")
self.path("liboil-0.3.so.0")
# Gstreamer plugins
--
cgit v1.1
From 9bf45214d7d7333117d78e05c3085ee0d4bbab52 Mon Sep 17 00:00:00 2001
From: Jacek Antonelli
Date: Tue, 17 May 2011 20:11:47 -0500
Subject: Added two last-minute changes to RELEASE_NOTES.txt.
---
RELEASE_NOTES.txt | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/RELEASE_NOTES.txt b/RELEASE_NOTES.txt
index b2219c4..b2532be 100644
--- a/RELEASE_NOTES.txt
+++ b/RELEASE_NOTES.txt
@@ -28,6 +28,11 @@
* Fixed a startup error related to "libz.so" on certain Linux
distros. (IMP-790)
+ * Fixed the viewer encountering an error: "Vertex buffer
+ destroyed while mapped!"
+
+ * Tweaked the compile system so the viewer can link using "gold".
+
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
--
cgit v1.1
From ec9b4a0135f95ade76822ae91184cad65f968654 Mon Sep 17 00:00:00 2001
From: Jacek Antonelli
Date: Wed, 18 May 2011 13:34:43 -0500
Subject: Use a more recent dbusglib package on Linux32.
---
linden/install.xml | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/linden/install.xml b/linden/install.xml
index 22ac571..86a37c4 100755
--- a/linden/install.xml
+++ b/linden/install.xml
@@ -327,9 +327,9 @@
linux
md5sum
- eb25444142d4102b0ce1b7ffaadb071e
+ 5bbf7e33dadc7d046dcf44883a9ec3d0
url
- http://s3.amazonaws.com/viewer-source-downloads/install_pkgs/dbusglib-linux-20080707.tar.bz2
+ http://imprudenceviewer.org/download/libs/dbusglib-linux-20101031.tar.bz2
linux64
--
cgit v1.1