aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
-rw-r--r--ChangeLog.txt16
-rw-r--r--linden/indra/CMakeLists.txt4
-rw-r--r--linden/indra/cmake/CopyWinLibs.cmake48
-rw-r--r--linden/indra/cmake/LLKDU.cmake20
-rw-r--r--linden/indra/newview/CMakeLists.txt5
-rwxr-xr-xlinden/indra/newview/viewer_manifest.py13
-rw-r--r--linden/install.xml66
7 files changed, 17 insertions, 155 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt
index a554e0a..1175530 100644
--- a/ChangeLog.txt
+++ b/ChangeLog.txt
@@ -1,3 +1,19 @@
12008-12-29 McCabe Maxsted <hakushakukun@gmail.com>
2
3 * linden/indra/CMakeLists.txt:
4 Removed llkdu from cmake.
5 * linden/indra/cmake/CopyWinLibs.cmake:
6 Ditto.
7 * linden/indra/cmake/LLKDU.cmake:
8 Ditto.
9 * linden/indra/newview/CMakeLists.txt:
10 Ditto.
11 * linden/indra/newview/viewer_manifest.py:
12 Ditto.
13 * linden/install.xml:
14 Ditto.
15
16
12008-12-15 Jacek Antonelli <jacek.antonelli@gmail.com> 172008-12-15 Jacek Antonelli <jacek.antonelli@gmail.com>
2 18
3 * linden/install.xml: 19 * linden/install.xml:
diff --git a/linden/indra/CMakeLists.txt b/linden/indra/CMakeLists.txt
index eb06191..09fa753 100644
--- a/linden/indra/CMakeLists.txt
+++ b/linden/indra/CMakeLists.txt
@@ -45,10 +45,6 @@ add_subdirectory(${LIBS_OPEN_PREFIX}llvfs)
45add_subdirectory(${LIBS_OPEN_PREFIX}llwindow) 45add_subdirectory(${LIBS_OPEN_PREFIX}llwindow)
46add_subdirectory(${LIBS_OPEN_PREFIX}llxml) 46add_subdirectory(${LIBS_OPEN_PREFIX}llxml)
47 47
48if (EXISTS ${LIBS_CLOSED_DIR}llkdu AND NOT STANDALONE)
49 add_subdirectory(${LIBS_CLOSED_PREFIX}llkdu)
50endif (EXISTS ${LIBS_CLOSED_DIR}llkdu AND NOT STANDALONE)
51
52add_subdirectory(${LIBS_OPEN_PREFIX}lscript) 48add_subdirectory(${LIBS_OPEN_PREFIX}lscript)
53 49
54if (WINDOWS AND EXISTS ${LIBS_CLOSED_DIR}copy_win_scripts) 50if (WINDOWS AND EXISTS ${LIBS_CLOSED_DIR}copy_win_scripts)
diff --git a/linden/indra/cmake/CopyWinLibs.cmake b/linden/indra/cmake/CopyWinLibs.cmake
index 345761a..e2c45fd 100644
--- a/linden/indra/cmake/CopyWinLibs.cmake
+++ b/linden/indra/cmake/CopyWinLibs.cmake
@@ -105,51 +105,5 @@ copy_if_different(
105 ) 105 )
106set(all_targets ${all_targets} ${out_targets}) 106set(all_targets ${all_targets} ${out_targets})
107 107
108set(internal_llkdu_path "${CMAKE_SOURCE_DIR}/llkdu")
109if(EXISTS ${internal_llkdu_path})
110 set(internal_llkdu_src "${CMAKE_BINARY_DIR}/llkdu/${CMAKE_CFG_INTDIR}/llkdu.dll")
111 set(llkdu_dst "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llkdu.dll")
112 ADD_CUSTOM_COMMAND(
113 OUTPUT ${llkdu_dst}
114 COMMAND ${CMAKE_COMMAND} -E copy_if_different ${internal_llkdu_src} ${llkdu_dst}
115 DEPENDS ${internal_llkdu_src}
116 COMMENT "Copying llkdu.dll ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}"
117 )
118 set(all_targets ${all_targets} ${llkdu_dst})
119else(EXISTS ${internal_llkdu_path})
120 set(debug_llkdu_src "${debug_src_dir}/llkdu.dll")
121 set(debug_llkdu_dst "${CMAKE_CURRENT_BINARY_DIR}/Debug/llkdu.dll")
122 ADD_CUSTOM_COMMAND(
123 OUTPUT ${debug_llkdu_dst}
124 COMMAND ${CMAKE_COMMAND} -E copy_if_different ${debug_llkdu_src} ${debug_llkdu_dst}
125 DEPENDS ${debug_llkdu_src}
126 COMMENT "Copying llkdu.dll ${CMAKE_CURRENT_BINARY_DIR}/Debug"
127 )
128 set(all_targets ${all_targets} ${debug_llkdu_dst})
129 108
130 set(release_llkdu_src "${release_src_dir}/llkdu.dll") 109add_custom_target(copy_win_libs ALL DEPENDS ${all_targets}) \ No newline at end of file
131 set(release_llkdu_dst "${CMAKE_CURRENT_BINARY_DIR}/Release/llkdu.dll")
132 ADD_CUSTOM_COMMAND(
133 OUTPUT ${release_llkdu_dst}
134 COMMAND ${CMAKE_COMMAND} -E copy_if_different ${release_llkdu_src} ${release_llkdu_dst}
135 DEPENDS ${release_llkdu_src}
136 COMMENT "Copying llkdu.dll ${CMAKE_CURRENT_BINARY_DIR}/Release"
137 )
138 set(all_targets ${all_targets} ${release_llkdu_dst})
139
140 set(relwithdebinfo_llkdu_dst "${CMAKE_CURRENT_BINARY_DIR}/RelWithDebInfo/llkdu.dll")
141 ADD_CUSTOM_COMMAND(
142 OUTPUT ${relwithdebinfo_llkdu_dst}
143 COMMAND ${CMAKE_COMMAND} -E copy_if_different ${release_llkdu_src} ${relwithdebinfo_llkdu_dst}
144 DEPENDS ${release_llkdu_src}
145 COMMENT "Copying llkdu.dll ${CMAKE_CURRENT_BINARY_DIR}/RelWithDebInfo"
146 )
147 set(all_targets ${all_targets} ${relwithdebinfo_llkdu_dst})
148
149endif (EXISTS ${internal_llkdu_path})
150
151add_custom_target(copy_win_libs ALL DEPENDS ${all_targets})
152
153if(EXISTS ${internal_llkdu_path})
154 add_dependencies(copy_win_libs llkdu)
155endif(EXISTS ${internal_llkdu_path})
diff --git a/linden/indra/cmake/LLKDU.cmake b/linden/indra/cmake/LLKDU.cmake
deleted file mode 100644
index a02b5d9..0000000
--- a/linden/indra/cmake/LLKDU.cmake
+++ /dev/null
@@ -1,20 +0,0 @@
1# -*- cmake -*-
2include(Prebuilt)
3
4if (NOT STANDALONE AND EXISTS ${LIBS_CLOSED_DIR}/llkdu)
5 use_prebuilt_binary(kdu)
6 if (WINDOWS)
7 set(KDU_LIBRARY debug kdu_cored optimized kdu_core)
8 elseif (LINUX)
9 set(KDU_LIBRARY kdu_v42R)
10 else (WINDOWS)
11 set(KDU_LIBRARY kdu)
12 endif (WINDOWS)
13
14 set(KDU_INCLUDE_DIR ${LIBS_PREBUILT_DIR}/include)
15
16 set(LLKDU_LIBRARY llkdu)
17 set(LLKDU_STATIC_LIBRARY llkdu_static)
18 set(LLKDU_LIBRARIES ${LLKDU_LIBRARY})
19 set(LLKDU_STATIC_LIBRARIES ${LLKDU_STATIC_LIBRARY})
20endif (NOT STANDALONE AND EXISTS ${LIBS_CLOSED_DIR}/llkdu)
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index ddf6897..9b7a647 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -31,7 +31,6 @@ include(NDOF)
31include(TemplateCheck) 31include(TemplateCheck)
32include(UI) 32include(UI)
33include(UnixInstall) 33include(UnixInstall)
34include(LLKDU)
35include(ViewerMiscLibs) 34include(ViewerMiscLibs)
36 35
37if (WINDOWS) 36if (WINDOWS)
@@ -1272,10 +1271,6 @@ add_executable(imprudence-bin
1272 ) 1271 )
1273check_message_template(imprudence-bin) 1272check_message_template(imprudence-bin)
1274 1273
1275if (LLKDU_LIBRARY)
1276 add_dependencies(imprudence-bin ${LLKDU_LIBRARY})
1277endif (LLKDU_LIBRARY)
1278
1279set(PACKAGE OFF CACHE BOOL 1274set(PACKAGE OFF CACHE BOOL
1280 "Add a package target that builds an installer package.") 1275 "Add a package target that builds an installer package.")
1281 1276
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py
index 62c9537..f707d15 100755
--- a/linden/indra/newview/viewer_manifest.py
+++ b/linden/indra/newview/viewer_manifest.py
@@ -183,14 +183,6 @@ class WindowsManifest(ViewerManifest):
183 # the final exe is complicated because we're not sure where it's coming from, 183 # the final exe is complicated because we're not sure where it's coming from,
184 # nor do we have a fixed name for the executable 184 # nor do we have a fixed name for the executable
185 self.path(self.find_existing_file('debug/imprudence-bin.exe', 'release/imprudence-bin.exe', 'relwithdebinfo/imprudence-bin.exe'), dst=self.final_exe()) 185 self.path(self.find_existing_file('debug/imprudence-bin.exe', 'release/imprudence-bin.exe', 'relwithdebinfo/imprudence-bin.exe'), dst=self.final_exe())
186 # need to get the kdu dll from any of the build directories as well
187 #self.path(self.find_existing_file(
188 # *FIX:Mani we need to add support for packaging specific targets.
189 #'../llkdu/debug/llkdu.dll',
190 #'../llkdu/release/llkdu.dll',
191 #'../llkdu/relwithdebinfo/llkdu.dll',
192 #'../../libraries/i686-win32/lib/release/llkdu.dll'),
193 # dst='llkdu.dll')
194 186
195 self.gather_documents() 187 self.gather_documents()
196 188
@@ -448,9 +440,6 @@ class DarwinManifest(ViewerManifest):
448 #self.path("vivox-runtime/universal-darwin/SLVoice", "SLVoice") 440 #self.path("vivox-runtime/universal-darwin/SLVoice", "SLVoice")
449 #self.path("vivox-runtime/universal-darwin/SLVoiceAgent.app", "SLVoiceAgent.app") 441 #self.path("vivox-runtime/universal-darwin/SLVoiceAgent.app", "SLVoiceAgent.app")
450 442
451 # llkdu dynamic library
452# self.path("../../libraries/universal-darwin/lib_release/libllkdu.dylib", "libllkdu.dylib")
453
454 #libfmodwrapper.dylib 443 #libfmodwrapper.dylib
455 #self.path(self.args['configuration'] + "/libfmodwrapper.dylib", "libfmodwrapper.dylib") 444 #self.path(self.args['configuration'] + "/libfmodwrapper.dylib", "libfmodwrapper.dylib")
456 445
@@ -658,7 +647,6 @@ class Linux_i686Manifest(LinuxManifest):
658 self.path("app_settings/mozilla-runtime-linux-i686") 647 self.path("app_settings/mozilla-runtime-linux-i686")
659 648
660 if self.prefix("../../libraries/i686-linux/lib_release_client", dst="lib"): 649 if self.prefix("../../libraries/i686-linux/lib_release_client", dst="lib"):
661# self.path("libkdu_v42R.so")
662# self.path("libfmod-3.75.so") 650# self.path("libfmod-3.75.so")
663 self.path("libapr-1.so.0") 651 self.path("libapr-1.so.0")
664 self.path("libaprutil-1.so.0") 652 self.path("libaprutil-1.so.0")
@@ -673,7 +661,6 @@ class Linux_i686Manifest(LinuxManifest):
673 self.path("libopenjpeg.so.2") 661 self.path("libopenjpeg.so.2")
674 #self.path("libtcmalloc.so.0") - bugged 662 #self.path("libtcmalloc.so.0") - bugged
675 #self.path("libstacktrace.so.0") - probably bugged 663 #self.path("libstacktrace.so.0") - probably bugged
676# self.path("libllkdu.so", "../bin/libllkdu.so") # llkdu goes in bin for some reason
677 self.end_prefix("lib") 664 self.end_prefix("lib")
678 665
679 # Vivox runtimes 666 # Vivox runtimes
diff --git a/linden/install.xml b/linden/install.xml
index a6270be..6184335 100644
--- a/linden/install.xml
+++ b/linden/install.xml
@@ -490,72 +490,6 @@
490 </map> 490 </map>
491 </map> 491 </map>
492 </map> 492 </map>
493 <key>kdu</key>
494 <map>
495 <key>copyright</key>
496 <string>on file</string>
497 <key>description</key>
498 <string>Kakadu (KDU) JPEG-2000 decoder library. </string>
499 <key>license</key>
500 <string>kdu</string>
501 <key>packages</key>
502 <map>
503 <key>darwin</key>
504 <map>
505 <key>md5sum</key>
506 <string>9a91ecd80203a24fb347b1436155b013</string>
507 <key>url</key>
508 <uri>scp:install-packages.lindenlab.com:/local/www/install-packages/doc/kdu-5.2.1-darwin-20080716.tar.bz2</uri>
509 </map>
510 <key>linux</key>
511 <map>
512 <key>md5sum</key>
513 <string>daadd8c268e16f8c5f6145be8596b8b8</string>
514 <key>url</key>
515 <uri>scp:install-packages.lindenlab.com:/local/www/install-packages/doc/kdu-5.2.1-linux-20080716.tar.bz2</uri>
516 </map>
517 <key>windows</key>
518 <map>
519 <key>md5sum</key>
520 <string>15528c24ca657b524d9ab3ccbb33c766</string>
521 <key>url</key>
522 <uri>scp:install-packages.lindenlab.com:/local/www/install-packages/doc/kdu-5.2.1-windows-20080613.tar.bz2</uri>
523 </map>
524 </map>
525 </map>
526 <key>kdu-binaries</key>
527 <map>
528 <key>copyright</key>
529 <string>see kdu</string>
530 <key>description</key>
531 <string>see kdu</string>
532 <key>license</key>
533 <string>kdu</string>
534 <key>packages</key>
535 <map>
536 <key>darwin</key>
537 <map>
538 <key>md5sum</key>
539 <string>480fbeeb47c9b9c4a2f947e310c9821c</string>
540 <key>url</key>
541 <uri>http://s3.amazonaws.com/viewer-source-downloads/install_pkgs/kdu-binaries-5.2.1-darwin-20080617.tar.bz2</uri>
542 </map>
543 <key>linux</key>
544 <map>
545 <key>md5sum</key>
546 <string>ca87644e377a6cf16db4ba6dbd2f8689</string>
547 <key>url</key>
548 <uri>http://s3.amazonaws.com/viewer-source-downloads/install_pkgs/kdu-binaries-5.2.1-linux-20080617.tar.bz2</uri>
549 </map>
550 <key>windows</key>
551 <map>
552 <key>md5sum</key>
553 <string>87af253b1d76437290355e8e20029377</string>
554 <key>url</key>
555 <uri>http://s3.amazonaws.com/viewer-source-downloads/install_pkgs/kdu-binaries-5.2.1-windows-20080617.tar.bz2</uri>
556 </map>
557 </map>
558 </map>
559 <key>libmono</key> 493 <key>libmono</key>
560 <map> 494 <map>
561 <key>copyright</key> 495 <key>copyright</key>