aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden
diff options
context:
space:
mode:
authorJacek Antonelli2009-01-11 14:49:14 -0600
committerJacek Antonelli2009-01-11 14:49:14 -0600
commit14c528c88c9c72443ccf344aedc8a2d2b8d8f0cd (patch)
treedf00001263985283611f8c96b8bef5572190abf2 /linden
parentFixed changelog date (2009 not 2008). (diff)
downloadmeta-impy-14c528c88c9c72443ccf344aedc8a2d2b8d8f0cd.zip
meta-impy-14c528c88c9c72443ccf344aedc8a2d2b8d8f0cd.tar.gz
meta-impy-14c528c88c9c72443ccf344aedc8a2d2b8d8f0cd.tar.bz2
meta-impy-14c528c88c9c72443ccf344aedc8a2d2b8d8f0cd.tar.xz
Removed references to unused dbusglib.
Diffstat (limited to 'linden')
-rw-r--r--linden/indra/cmake/DBusGlib.cmake29
-rw-r--r--linden/indra/newview/CMakeLists.txt3
2 files changed, 0 insertions, 32 deletions
diff --git a/linden/indra/cmake/DBusGlib.cmake b/linden/indra/cmake/DBusGlib.cmake
deleted file mode 100644
index cfc4ccd..0000000
--- a/linden/indra/cmake/DBusGlib.cmake
+++ /dev/null
@@ -1,29 +0,0 @@
1# -*- cmake -*-
2include(Prebuilt)
3
4if (STANDALONE)
5 include(FindPkgConfig)
6
7 pkg_check_modules(DBUSGLIB REQUIRED dbus-glib-1)
8
9elseif (LINUX)
10 use_prebuilt_binary(dbusglib)
11 set(DBUSGLIB_FOUND ON FORCE BOOL)
12 set(DBUSGLIB_INCLUDE_DIRS
13 ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/include/glib-2.0
14 )
15 # We don't need to explicitly link against dbus-glib itself, because
16 # the viewer probes for the system's copy at runtime.
17 set(DBUSGLIB_LIBRARIES
18 gobject-2.0
19 glib-2.0
20 )
21endif (STANDALONE)
22
23if (DBUSGLIB_FOUND)
24 set(DBUSGLIB ON CACHE BOOL "Build with dbus-glib message bus support.")
25endif (DBUSGLIB_FOUND)
26
27if (DBUSGLIB)
28 add_definitions(-DLL_DBUS_ENABLED=1)
29endif (DBUSGLIB)
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 8d70751..4871e05 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -5,7 +5,6 @@ project(viewer)
5include(00-Common) 5include(00-Common)
6include(Boost) 6include(Boost)
7include(BuildVersion) 7include(BuildVersion)
8include(DBusGlib)
9include(DirectX) 8include(DirectX)
10include(ELFIO) 9include(ELFIO)
11include(FMOD) 10include(FMOD)
@@ -876,7 +875,6 @@ endif (DARWIN)
876 875
877if (LINUX) 876if (LINUX)
878 LIST(APPEND viewer_SOURCE_FILES llappviewerlinux.cpp) 877 LIST(APPEND viewer_SOURCE_FILES llappviewerlinux.cpp)
879 LIST(APPEND viewer_SOURCE_FILES llappviewerlinux_api_dbus.cpp)
880 LIST(APPEND CMAKE_EXE_LINKER_FLAGS -Wl,--as-needed) 878 LIST(APPEND CMAKE_EXE_LINKER_FLAGS -Wl,--as-needed)
881 879
882 set(viewer_LIBRARIES 880 set(viewer_LIBRARIES
@@ -1388,7 +1386,6 @@ target_link_libraries(imprudence-bin
1388 ${viewer_LIBRARIES} 1386 ${viewer_LIBRARIES}
1389 ${BOOST_PROGRAM_OPTIONS_LIBRARY} 1387 ${BOOST_PROGRAM_OPTIONS_LIBRARY}
1390 ${BOOST_REGEX_LIBRARY} 1388 ${BOOST_REGEX_LIBRARY}
1391 ${DBUSGLIB_LIBRARIES}
1392 ${OPENGL_LIBRARIES} 1389 ${OPENGL_LIBRARIES}
1393 ${FMODWRAPPER_LIBRARY} 1390 ${FMODWRAPPER_LIBRARY}
1394 ${OPENGL_LIBRARIES} 1391 ${OPENGL_LIBRARIES}