diff options
author | McCabe Maxsted | 2010-09-07 18:01:44 -0700 |
---|---|---|
committer | Armin Weatherwax | 2010-09-23 15:38:30 +0200 |
commit | 092fda55d8537e7655a545634e443c6c6c3dde0b (patch) | |
tree | 608feb0cf51cf5b704628ad1256b7f5bd4458093 /linden/indra | |
parent | Removed some bad merge entries from newview/CMakeLists.txt (diff) | |
download | meta-impy-092fda55d8537e7655a545634e443c6c6c3dde0b.zip meta-impy-092fda55d8537e7655a545634e443c6c6c3dde0b.tar.gz meta-impy-092fda55d8537e7655a545634e443c6c6c3dde0b.tar.bz2 meta-impy-092fda55d8537e7655a545634e443c6c6c3dde0b.tar.xz |
Added fix for word size from Snowglobe (only for Windows--didn't update Linux or Mac as I can't test them)
Diffstat (limited to 'linden/indra')
-rw-r--r-- | linden/indra/cmake/Variables.cmake | 1 | ||||
-rw-r--r-- | linden/indra/llplugin/llpluginsharedmemory.cpp | 7 | ||||
-rw-r--r-- | linden/indra/media_plugins/CMakeLists.txt | 2 | ||||
-rw-r--r-- | linden/indra/media_plugins/base/CMakeLists.txt | 8 | ||||
-rw-r--r-- | linden/indra/media_plugins/example/CMakeLists.txt | 10 | ||||
-rw-r--r-- | linden/indra/media_plugins/quicktime/CMakeLists.txt | 3 | ||||
-rw-r--r-- | linden/indra/media_plugins/webkit/CMakeLists.txt | 25 |
7 files changed, 48 insertions, 8 deletions
diff --git a/linden/indra/cmake/Variables.cmake b/linden/indra/cmake/Variables.cmake index 5d4dffe..cd5bfc1 100644 --- a/linden/indra/cmake/Variables.cmake +++ b/linden/indra/cmake/Variables.cmake | |||
@@ -45,6 +45,7 @@ if (${CMAKE_SYSTEM_NAME} MATCHES "Windows") | |||
45 | set(ARCH i686) | 45 | set(ARCH i686) |
46 | set(LL_ARCH ${ARCH}_win32) | 46 | set(LL_ARCH ${ARCH}_win32) |
47 | set(LL_ARCH_DIR ${ARCH}-win32) | 47 | set(LL_ARCH_DIR ${ARCH}-win32) |
48 | set(WORD_SIZE 32) | ||
48 | endif (${CMAKE_SYSTEM_NAME} MATCHES "Windows") | 49 | endif (${CMAKE_SYSTEM_NAME} MATCHES "Windows") |
49 | 50 | ||
50 | if (${CMAKE_SYSTEM_NAME} MATCHES "Linux") | 51 | if (${CMAKE_SYSTEM_NAME} MATCHES "Linux") |
diff --git a/linden/indra/llplugin/llpluginsharedmemory.cpp b/linden/indra/llplugin/llpluginsharedmemory.cpp index 2be4648..c946619 100644 --- a/linden/indra/llplugin/llpluginsharedmemory.cpp +++ b/linden/indra/llplugin/llpluginsharedmemory.cpp | |||
@@ -34,6 +34,13 @@ | |||
34 | 34 | ||
35 | #include "llpluginsharedmemory.h" | 35 | #include "llpluginsharedmemory.h" |
36 | 36 | ||
37 | #if LL_WINDOWS | ||
38 | #include <process.h> | ||
39 | #else // LL_WINDOWS | ||
40 | #include <sys/types.h> | ||
41 | #include <unistd.h> | ||
42 | #endif // LL_WINDOWS | ||
43 | |||
37 | // on Mac and Linux, we use the native shm_open/mmap interface by using | 44 | // on Mac and Linux, we use the native shm_open/mmap interface by using |
38 | // #define USE_SHM_OPEN_SHARED_MEMORY 1 | 45 | // #define USE_SHM_OPEN_SHARED_MEMORY 1 |
39 | // in the appropriate sections below. | 46 | // in the appropriate sections below. |
diff --git a/linden/indra/media_plugins/CMakeLists.txt b/linden/indra/media_plugins/CMakeLists.txt index d35afd8..cc03d9c 100644 --- a/linden/indra/media_plugins/CMakeLists.txt +++ b/linden/indra/media_plugins/CMakeLists.txt | |||
@@ -9,3 +9,5 @@ add_subdirectory(gstreamer010) | |||
9 | if (WINDOWS OR DARWIN) | 9 | if (WINDOWS OR DARWIN) |
10 | add_subdirectory(quicktime) | 10 | add_subdirectory(quicktime) |
11 | endif (WINDOWS OR DARWIN) | 11 | endif (WINDOWS OR DARWIN) |
12 | |||
13 | add_subdirectory(example) | ||
diff --git a/linden/indra/media_plugins/base/CMakeLists.txt b/linden/indra/media_plugins/base/CMakeLists.txt index f8d2dab..a3ee02e 100644 --- a/linden/indra/media_plugins/base/CMakeLists.txt +++ b/linden/indra/media_plugins/base/CMakeLists.txt | |||
@@ -25,6 +25,14 @@ include_directories( | |||
25 | 25 | ||
26 | ### media_plugin_base | 26 | ### media_plugin_base |
27 | 27 | ||
28 | if(WORD_SIZE EQUAL 64) | ||
29 | if(WINDOWS) | ||
30 | add_definitions(/FIXED:NO) | ||
31 | else(WINDOWS) # not windows therefore gcc LINUX and DARWIN | ||
32 | add_definitions(-fPIC) | ||
33 | endif(WINDOWS) | ||
34 | endif (WORD_SIZE EQUAL 64) | ||
35 | |||
28 | set(media_plugin_base_SOURCE_FILES | 36 | set(media_plugin_base_SOURCE_FILES |
29 | media_plugin_base.cpp | 37 | media_plugin_base.cpp |
30 | ) | 38 | ) |
diff --git a/linden/indra/media_plugins/example/CMakeLists.txt b/linden/indra/media_plugins/example/CMakeLists.txt index 4d82f27..b074a1d 100644 --- a/linden/indra/media_plugins/example/CMakeLists.txt +++ b/linden/indra/media_plugins/example/CMakeLists.txt | |||
@@ -29,6 +29,14 @@ include_directories( | |||
29 | 29 | ||
30 | ### media_plugin_example | 30 | ### media_plugin_example |
31 | 31 | ||
32 | if(WORD_SIZE EQUAL 64) | ||
33 | if(WINDOWS) | ||
34 | add_definitions(/FIXED:NO) | ||
35 | else(WINDOWS) # not windows therefore gcc LINUX and DARWIN | ||
36 | add_definitions(-fPIC) | ||
37 | endif(WINDOWS) | ||
38 | endif (WORD_SIZE EQUAL 64) | ||
39 | |||
32 | set(media_plugin_example_SOURCE_FILES | 40 | set(media_plugin_example_SOURCE_FILES |
33 | media_plugin_example.cpp | 41 | media_plugin_example.cpp |
34 | ) | 42 | ) |
@@ -71,4 +79,4 @@ if (DARWIN) | |||
71 | LINK_FLAGS "-exported_symbols_list ${CMAKE_CURRENT_SOURCE_DIR}/../base/media_plugin_base.exp" | 79 | LINK_FLAGS "-exported_symbols_list ${CMAKE_CURRENT_SOURCE_DIR}/../base/media_plugin_base.exp" |
72 | ) | 80 | ) |
73 | 81 | ||
74 | endif (DARWIN) \ No newline at end of file | 82 | endif (DARWIN) |
diff --git a/linden/indra/media_plugins/quicktime/CMakeLists.txt b/linden/indra/media_plugins/quicktime/CMakeLists.txt index f0b8f0d..df191f5 100644 --- a/linden/indra/media_plugins/quicktime/CMakeLists.txt +++ b/linden/indra/media_plugins/quicktime/CMakeLists.txt | |||
@@ -60,7 +60,8 @@ if (WINDOWS) | |||
60 | set_target_properties( | 60 | set_target_properties( |
61 | media_plugin_quicktime | 61 | media_plugin_quicktime |
62 | PROPERTIES | 62 | PROPERTIES |
63 | LINK_FLAGS "/MANIFEST:NO" | 63 | LINK_FLAGS "/MANIFEST:NO /NODEFAULTLIB:LIBCMT" |
64 | LINK_FLAGS_DEBUG "/MANIFEST:NO /NODEFAULTLIB:\"LIBCMT;LIBCMTD\"" | ||
64 | ) | 65 | ) |
65 | endif (WINDOWS) | 66 | endif (WINDOWS) |
66 | 67 | ||
diff --git a/linden/indra/media_plugins/webkit/CMakeLists.txt b/linden/indra/media_plugins/webkit/CMakeLists.txt index 5bccd58..54bc364 100644 --- a/linden/indra/media_plugins/webkit/CMakeLists.txt +++ b/linden/indra/media_plugins/webkit/CMakeLists.txt | |||
@@ -24,6 +24,7 @@ include_directories( | |||
24 | ${LLIMAGE_INCLUDE_DIRS} | 24 | ${LLIMAGE_INCLUDE_DIRS} |
25 | ${LLRENDER_INCLUDE_DIRS} | 25 | ${LLRENDER_INCLUDE_DIRS} |
26 | ${LLWINDOW_INCLUDE_DIRS} | 26 | ${LLWINDOW_INCLUDE_DIRS} |
27 | ${LLQTWEBKIT_INCLUDE_DIR} | ||
27 | ) | 28 | ) |
28 | 29 | ||
29 | 30 | ||
@@ -33,12 +34,15 @@ set(media_plugin_webkit_SOURCE_FILES | |||
33 | media_plugin_webkit.cpp | 34 | media_plugin_webkit.cpp |
34 | ) | 35 | ) |
35 | 36 | ||
36 | add_library(media_plugin_webkit | 37 | if(WORD_SIZE EQUAL 64) |
37 | SHARED | 38 | if(WINDOWS) |
38 | ${media_plugin_webkit_SOURCE_FILES} | 39 | add_definitions(/FIXED:NO) |
39 | ) | 40 | else(WINDOWS) # not windows therefore gcc LINUX and DARWIN |
41 | add_definitions(-fPIC) | ||
42 | endif(WINDOWS) | ||
43 | endif (WORD_SIZE EQUAL 64) | ||
40 | 44 | ||
41 | target_link_libraries(media_plugin_webkit | 45 | set(media_plugin_webkit_LINK_LIBRARIES |
42 | ${LLPLUGIN_LIBRARIES} | 46 | ${LLPLUGIN_LIBRARIES} |
43 | ${MEDIA_PLUGIN_BASE_LIBRARIES} | 47 | ${MEDIA_PLUGIN_BASE_LIBRARIES} |
44 | ${LLCOMMON_LIBRARIES} | 48 | ${LLCOMMON_LIBRARIES} |
@@ -46,6 +50,15 @@ target_link_libraries(media_plugin_webkit | |||
46 | ${PLUGIN_API_WINDOWS_LIBRARIES} | 50 | ${PLUGIN_API_WINDOWS_LIBRARIES} |
47 | ) | 51 | ) |
48 | 52 | ||
53 | |||
54 | |||
55 | add_library(media_plugin_webkit | ||
56 | SHARED | ||
57 | ${media_plugin_webkit_SOURCE_FILES} | ||
58 | ) | ||
59 | |||
60 | target_link_libraries(media_plugin_webkit ${media_plugin_webkit_LINK_LIBRARIES}) | ||
61 | |||
49 | add_dependencies(media_plugin_webkit | 62 | add_dependencies(media_plugin_webkit |
50 | ${LLPLUGIN_LIBRARIES} | 63 | ${LLPLUGIN_LIBRARIES} |
51 | ${MEDIA_PLUGIN_BASE_LIBRARIES} | 64 | ${MEDIA_PLUGIN_BASE_LIBRARIES} |
@@ -79,4 +92,4 @@ if (DARWIN) | |||
79 | DEPENDS media_plugin_webkit ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib | 92 | DEPENDS media_plugin_webkit ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib |
80 | ) | 93 | ) |
81 | 94 | ||
82 | endif (DARWIN) \ No newline at end of file | 95 | endif (DARWIN) |