aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/media_plugins/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/media_plugins/example/CMakeLists.txt')
-rw-r--r--linden/indra/media_plugins/example/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/linden/indra/media_plugins/example/CMakeLists.txt b/linden/indra/media_plugins/example/CMakeLists.txt
index 4d82f27..b074a1d 100644
--- a/linden/indra/media_plugins/example/CMakeLists.txt
+++ b/linden/indra/media_plugins/example/CMakeLists.txt
@@ -29,6 +29,14 @@ include_directories(
29 29
30### media_plugin_example 30### media_plugin_example
31 31
32if(WORD_SIZE EQUAL 64)
33 if(WINDOWS)
34 add_definitions(/FIXED:NO)
35 else(WINDOWS) # not windows therefore gcc LINUX and DARWIN
36 add_definitions(-fPIC)
37 endif(WINDOWS)
38endif (WORD_SIZE EQUAL 64)
39
32set(media_plugin_example_SOURCE_FILES 40set(media_plugin_example_SOURCE_FILES
33 media_plugin_example.cpp 41 media_plugin_example.cpp
34 ) 42 )
@@ -71,4 +79,4 @@ if (DARWIN)
71 LINK_FLAGS "-exported_symbols_list ${CMAKE_CURRENT_SOURCE_DIR}/../base/media_plugin_base.exp" 79 LINK_FLAGS "-exported_symbols_list ${CMAKE_CURRENT_SOURCE_DIR}/../base/media_plugin_base.exp"
72 ) 80 )
73 81
74endif (DARWIN) \ No newline at end of file 82endif (DARWIN)