aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/media_plugins/base
diff options
context:
space:
mode:
authorMcCabe Maxsted2010-09-07 18:01:44 -0700
committerArmin Weatherwax2010-09-23 15:38:30 +0200
commit092fda55d8537e7655a545634e443c6c6c3dde0b (patch)
tree608feb0cf51cf5b704628ad1256b7f5bd4458093 /linden/indra/media_plugins/base
parentRemoved some bad merge entries from newview/CMakeLists.txt (diff)
downloadmeta-impy-092fda55d8537e7655a545634e443c6c6c3dde0b.zip
meta-impy-092fda55d8537e7655a545634e443c6c6c3dde0b.tar.gz
meta-impy-092fda55d8537e7655a545634e443c6c6c3dde0b.tar.bz2
meta-impy-092fda55d8537e7655a545634e443c6c6c3dde0b.tar.xz
Added fix for word size from Snowglobe (only for Windows--didn't update Linux or Mac as I can't test them)
Diffstat (limited to 'linden/indra/media_plugins/base')
-rw-r--r--linden/indra/media_plugins/base/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/linden/indra/media_plugins/base/CMakeLists.txt b/linden/indra/media_plugins/base/CMakeLists.txt
index f8d2dab..a3ee02e 100644
--- a/linden/indra/media_plugins/base/CMakeLists.txt
+++ b/linden/indra/media_plugins/base/CMakeLists.txt
@@ -25,6 +25,14 @@ include_directories(
25 25
26### media_plugin_base 26### media_plugin_base
27 27
28if(WORD_SIZE EQUAL 64)
29 if(WINDOWS)
30 add_definitions(/FIXED:NO)
31 else(WINDOWS) # not windows therefore gcc LINUX and DARWIN
32 add_definitions(-fPIC)
33 endif(WINDOWS)
34endif (WORD_SIZE EQUAL 64)
35
28set(media_plugin_base_SOURCE_FILES 36set(media_plugin_base_SOURCE_FILES
29 media_plugin_base.cpp 37 media_plugin_base.cpp
30) 38)