aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llmessage
diff options
context:
space:
mode:
authorJacek Antonelli2011-05-18 16:54:33 -0500
committerJacek Antonelli2011-05-18 21:50:11 -0500
commit718d23b821e2a293e01e6086b0d0ae57263febca (patch)
tree15c467f49db6e4c5b17343de429ba227629ce6ec /linden/indra/llmessage
parentChanged the cache and settings file names back to non-Experimental. (diff)
parentUse a more recent dbusglib package on Linux32. (diff)
downloadmeta-impy-718d23b821e2a293e01e6086b0d0ae57263febca.zip
meta-impy-718d23b821e2a293e01e6086b0d0ae57263febca.tar.gz
meta-impy-718d23b821e2a293e01e6086b0d0ae57263febca.tar.bz2
meta-impy-718d23b821e2a293e01e6086b0d0ae57263febca.tar.xz
Merge branch '1.3-maint' into next
Conflicts: linden/indra/llcommon/CMakeLists.txt linden/indra/newview/llvoavatar.cpp linden/indra/newview/viewer_manifest.py
Diffstat (limited to 'linden/indra/llmessage')
-rw-r--r--linden/indra/llmessage/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/linden/indra/llmessage/CMakeLists.txt b/linden/indra/llmessage/CMakeLists.txt
index b3f2b4c..61b6418 100644
--- a/linden/indra/llmessage/CMakeLists.txt
+++ b/linden/indra/llmessage/CMakeLists.txt
@@ -208,13 +208,21 @@ set_source_files_properties(${llmessage_HEADER_FILES}
208list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES}) 208list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES})
209 209
210add_library (llmessage ${llmessage_SOURCE_FILES}) 210add_library (llmessage ${llmessage_SOURCE_FILES})
211target_link_libraries( 211set (llmessage_link_LIBRARIES
212 llmessage 212 llmessage
213 ${CURL_LIBRARIES} 213 ${CURL_LIBRARIES}
214 ${CARES_LIBRARIES} 214 ${CARES_LIBRARIES}
215 ${OPENSSL_LIBRARIES} 215 ${OPENSSL_LIBRARIES}
216 ${CRYPTO_LIBRARIES} 216 ${CRYPTO_LIBRARIES}
217 ${XMLRPCEPI_LIBRARIES} 217 ${XMLRPCEPI_LIBRARIES}
218)
219if (LINUX)
220 list(APPEND llmessage_link_LIBRARIES pthread)
221endif (LINUX)
222
223target_link_libraries(
224 ${llmessage_link_LIBRARIES}
225
218 ) 226 )
219 227
220IF (NOT LINUX AND VIEWER) 228IF (NOT LINUX AND VIEWER)