diff options
author | Jacek Antonelli | 2011-05-18 16:54:33 -0500 |
---|---|---|
committer | Jacek Antonelli | 2011-05-18 21:50:11 -0500 |
commit | 718d23b821e2a293e01e6086b0d0ae57263febca (patch) | |
tree | 15c467f49db6e4c5b17343de429ba227629ce6ec /linden/indra/llmessage | |
parent | Changed the cache and settings file names back to non-Experimental. (diff) | |
parent | Use a more recent dbusglib package on Linux32. (diff) | |
download | meta-impy-718d23b821e2a293e01e6086b0d0ae57263febca.zip meta-impy-718d23b821e2a293e01e6086b0d0ae57263febca.tar.gz meta-impy-718d23b821e2a293e01e6086b0d0ae57263febca.tar.bz2 meta-impy-718d23b821e2a293e01e6086b0d0ae57263febca.tar.xz |
Merge branch '1.3-maint' into next
Conflicts:
linden/indra/llcommon/CMakeLists.txt
linden/indra/newview/llvoavatar.cpp
linden/indra/newview/viewer_manifest.py
Diffstat (limited to 'linden/indra/llmessage')
-rw-r--r-- | linden/indra/llmessage/CMakeLists.txt | 10 |
1 files changed, 9 insertions, 1 deletions
diff --git a/linden/indra/llmessage/CMakeLists.txt b/linden/indra/llmessage/CMakeLists.txt index b3f2b4c..61b6418 100644 --- a/linden/indra/llmessage/CMakeLists.txt +++ b/linden/indra/llmessage/CMakeLists.txt | |||
@@ -208,13 +208,21 @@ set_source_files_properties(${llmessage_HEADER_FILES} | |||
208 | list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES}) | 208 | list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES}) |
209 | 209 | ||
210 | add_library (llmessage ${llmessage_SOURCE_FILES}) | 210 | add_library (llmessage ${llmessage_SOURCE_FILES}) |
211 | target_link_libraries( | 211 | set (llmessage_link_LIBRARIES |
212 | llmessage | 212 | llmessage |
213 | ${CURL_LIBRARIES} | 213 | ${CURL_LIBRARIES} |
214 | ${CARES_LIBRARIES} | 214 | ${CARES_LIBRARIES} |
215 | ${OPENSSL_LIBRARIES} | 215 | ${OPENSSL_LIBRARIES} |
216 | ${CRYPTO_LIBRARIES} | 216 | ${CRYPTO_LIBRARIES} |
217 | ${XMLRPCEPI_LIBRARIES} | 217 | ${XMLRPCEPI_LIBRARIES} |
218 | ) | ||
219 | if (LINUX) | ||
220 | list(APPEND llmessage_link_LIBRARIES pthread) | ||
221 | endif (LINUX) | ||
222 | |||
223 | target_link_libraries( | ||
224 | ${llmessage_link_LIBRARIES} | ||
225 | |||
218 | ) | 226 | ) |
219 | 227 | ||
220 | IF (NOT LINUX AND VIEWER) | 228 | IF (NOT LINUX AND VIEWER) |