aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/libgpg-error/libgpg-error-1.0/tests
diff options
context:
space:
mode:
authorJay Threeth2011-04-04 11:48:26 -0700
committerJay Threeth2011-04-04 11:48:26 -0700
commit3c9cc506f741b980565ff5b3b001cd8b6ee36b12 (patch)
treecb862c57b3d5f74177cde3bd962a53fc377166f6 /linden/indra/libgpg-error/libgpg-error-1.0/tests
parentbuild fixes, might build on linux now (diff)
downloadmeta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.zip
meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.gz
meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.bz2
meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.xz
add source to libraries, and cruft for building under windows
Diffstat (limited to 'linden/indra/libgpg-error/libgpg-error-1.0/tests')
-rwxr-xr-xlinden/indra/libgpg-error/libgpg-error-1.0/tests/Makefile.am28
-rwxr-xr-xlinden/indra/libgpg-error/libgpg-error-1.0/tests/Makefile.in518
-rwxr-xr-xlinden/indra/libgpg-error/libgpg-error-1.0/tests/t-strerror.c63
3 files changed, 609 insertions, 0 deletions
diff --git a/linden/indra/libgpg-error/libgpg-error-1.0/tests/Makefile.am b/linden/indra/libgpg-error/libgpg-error-1.0/tests/Makefile.am
new file mode 100755
index 0000000..0530cf8
--- /dev/null
+++ b/linden/indra/libgpg-error/libgpg-error-1.0/tests/Makefile.am
@@ -0,0 +1,28 @@
1# Makefile.am for libgpg-error/tests.
2# Copyright (C) 2003 g10 Code GmbH
3#
4# This file is part of libgpg-error.
5#
6# libgpg-error is free software; you can redistribute it and/or modify
7# it under the terms of the GNU Lesser General Public License as
8# published by the Free Software Foundation; either version 2.1 of the
9# License, or (at your option) any later version.
10#
11# libgpg-error is distributed in the hope that it will be useful,
12# but WITHOUT ANY WARRANTY; without even the implied warranty of
13# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14# GNU Lesser General Public License for more details.
15#
16# You should have received a copy of the GNU Lesser General Public
17# License along with this program; if not, write to the Free Software
18# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
19
20## Process this file with automake to produce Makefile.in
21
22TESTS = t-strerror
23
24INCLUDES = -I$(top_builddir)/src
25
26LDADD = ../src/libgpg-error.la
27
28noinst_PROGRAMS = $(TESTS)
diff --git a/linden/indra/libgpg-error/libgpg-error-1.0/tests/Makefile.in b/linden/indra/libgpg-error/libgpg-error-1.0/tests/Makefile.in
new file mode 100755
index 0000000..9938cf7
--- /dev/null
+++ b/linden/indra/libgpg-error/libgpg-error-1.0/tests/Makefile.in
@@ -0,0 +1,518 @@
1# Makefile.in generated by automake 1.7.9 from Makefile.am.
2# @configure_input@
3
4# Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003
5# Free Software Foundation, Inc.
6# This Makefile.in is free software; the Free Software Foundation
7# gives unlimited permission to copy and/or distribute it,
8# with or without modifications, as long as this notice is preserved.
9
10# This program is distributed in the hope that it will be useful,
11# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
12# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
13# PARTICULAR PURPOSE.
14
15@SET_MAKE@
16
17# Makefile.am for libgpg-error/tests.
18# Copyright (C) 2003 g10 Code GmbH
19#
20# This file is part of libgpg-error.
21#
22# libgpg-error is free software; you can redistribute it and/or modify
23# it under the terms of the GNU Lesser General Public License as
24# published by the Free Software Foundation; either version 2.1 of the
25# License, or (at your option) any later version.
26#
27# libgpg-error is distributed in the hope that it will be useful,
28# but WITHOUT ANY WARRANTY; without even the implied warranty of
29# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
30# GNU Lesser General Public License for more details.
31#
32# You should have received a copy of the GNU Lesser General Public
33# License along with this program; if not, write to the Free Software
34# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
35
36srcdir = @srcdir@
37top_srcdir = @top_srcdir@
38VPATH = @srcdir@
39pkgdatadir = $(datadir)/@PACKAGE@
40pkglibdir = $(libdir)/@PACKAGE@
41pkgincludedir = $(includedir)/@PACKAGE@
42top_builddir = ..
43
44am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
45INSTALL = @INSTALL@
46install_sh_DATA = $(install_sh) -c -m 644
47install_sh_PROGRAM = $(install_sh) -c
48install_sh_SCRIPT = $(install_sh) -c
49INSTALL_HEADER = $(INSTALL_DATA)
50transform = $(program_transform_name)
51NORMAL_INSTALL = :
52PRE_INSTALL = :
53POST_INSTALL = :
54NORMAL_UNINSTALL = :
55PRE_UNINSTALL = :
56POST_UNINSTALL = :
57host_triplet = @host@
58ACLOCAL = @ACLOCAL@
59AMDEP_FALSE = @AMDEP_FALSE@
60AMDEP_TRUE = @AMDEP_TRUE@
61AMTAR = @AMTAR@
62AUTOCONF = @AUTOCONF@
63AUTOHEADER = @AUTOHEADER@
64AUTOMAKE = @AUTOMAKE@
65AWK = @AWK@
66CC = @CC@
67CCDEPMODE = @CCDEPMODE@
68CC_FOR_BUILD = @CC_FOR_BUILD@
69CFLAGS = @CFLAGS@
70CPP = @CPP@
71CPPFLAGS = @CPPFLAGS@
72CYGPATH_W = @CYGPATH_W@
73DEFS = @DEFS@
74DEPDIR = @DEPDIR@
75ECHO = @ECHO@
76ECHO_C = @ECHO_C@
77ECHO_N = @ECHO_N@
78ECHO_T = @ECHO_T@
79EGREP = @EGREP@
80EXEEXT = @EXEEXT@
81GMSGFMT = @GMSGFMT@
82GPG_ERROR_CONFIG_CFLAGS = @GPG_ERROR_CONFIG_CFLAGS@
83GPG_ERROR_CONFIG_LIBS = @GPG_ERROR_CONFIG_LIBS@
84INSTALL_DATA = @INSTALL_DATA@
85INSTALL_PROGRAM = @INSTALL_PROGRAM@
86INSTALL_SCRIPT = @INSTALL_SCRIPT@
87INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
88INTLLIBS = @INTLLIBS@
89LDFLAGS = @LDFLAGS@
90LIBGPG_ERROR_LT_AGE = @LIBGPG_ERROR_LT_AGE@
91LIBGPG_ERROR_LT_CURRENT = @LIBGPG_ERROR_LT_CURRENT@
92LIBGPG_ERROR_LT_REVISION = @LIBGPG_ERROR_LT_REVISION@
93LIBICONV = @LIBICONV@
94LIBINTL = @LIBINTL@
95LIBOBJS = @LIBOBJS@
96LIBS = @LIBS@
97LIBTOOL = @LIBTOOL@
98LN_S = @LN_S@
99LTLIBICONV = @LTLIBICONV@
100LTLIBINTL = @LTLIBINTL@
101LTLIBOBJS = @LTLIBOBJS@
102MAINT = @MAINT@
103MAINTAINER_MODE_FALSE = @MAINTAINER_MODE_FALSE@
104MAINTAINER_MODE_TRUE = @MAINTAINER_MODE_TRUE@
105MAKEINFO = @MAKEINFO@
106MKINSTALLDIRS = @MKINSTALLDIRS@
107MSGFMT = @MSGFMT@
108MSGMERGE = @MSGMERGE@
109OBJEXT = @OBJEXT@
110PACKAGE = @PACKAGE@
111PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
112PACKAGE_NAME = @PACKAGE_NAME@
113PACKAGE_STRING = @PACKAGE_STRING@
114PACKAGE_TARNAME = @PACKAGE_TARNAME@
115PACKAGE_VERSION = @PACKAGE_VERSION@
116PATH_SEPARATOR = @PATH_SEPARATOR@
117POSUB = @POSUB@
118RANLIB = @RANLIB@
119SET_MAKE = @SET_MAKE@
120SHELL = @SHELL@
121STRIP = @STRIP@
122USE_NLS = @USE_NLS@
123VERSION = @VERSION@
124XGETTEXT = @XGETTEXT@
125ac_ct_CC = @ac_ct_CC@
126ac_ct_RANLIB = @ac_ct_RANLIB@
127ac_ct_STRIP = @ac_ct_STRIP@
128am__fastdepCC_FALSE = @am__fastdepCC_FALSE@
129am__fastdepCC_TRUE = @am__fastdepCC_TRUE@
130am__include = @am__include@
131am__leading_dot = @am__leading_dot@
132am__quote = @am__quote@
133bindir = @bindir@
134build = @build@
135build_alias = @build_alias@
136build_cpu = @build_cpu@
137build_os = @build_os@
138build_vendor = @build_vendor@
139datadir = @datadir@
140exec_prefix = @exec_prefix@
141host = @host@
142host_alias = @host_alias@
143host_cpu = @host_cpu@
144host_os = @host_os@
145host_vendor = @host_vendor@
146includedir = @includedir@
147infodir = @infodir@
148install_sh = @install_sh@
149libdir = @libdir@
150libexecdir = @libexecdir@
151localstatedir = @localstatedir@
152mandir = @mandir@
153oldincludedir = @oldincludedir@
154prefix = @prefix@
155program_transform_name = @program_transform_name@
156sbindir = @sbindir@
157sharedstatedir = @sharedstatedir@
158sysconfdir = @sysconfdir@
159target_alias = @target_alias@
160
161TESTS = t-strerror
162
163INCLUDES = -I$(top_builddir)/src
164
165LDADD = ../src/libgpg-error.la
166
167noinst_PROGRAMS = $(TESTS)
168subdir = tests
169ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
170mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
171CONFIG_HEADER = $(top_builddir)/config.h
172CONFIG_CLEAN_FILES =
173noinst_PROGRAMS = t-strerror$(EXEEXT)
174PROGRAMS = $(noinst_PROGRAMS)
175
176t_strerror_SOURCES = t-strerror.c
177t_strerror_OBJECTS = t-strerror.$(OBJEXT)
178t_strerror_LDADD = $(LDADD)
179t_strerror_DEPENDENCIES = ../src/libgpg-error.la
180t_strerror_LDFLAGS =
181
182DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
183depcomp = $(SHELL) $(top_srcdir)/depcomp
184am__depfiles_maybe = depfiles
185@AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/t-strerror.Po
186COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
187 $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
188LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
189 $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
190CCLD = $(CC)
191LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
192 $(AM_LDFLAGS) $(LDFLAGS) -o $@
193DIST_SOURCES = t-strerror.c
194DIST_COMMON = $(srcdir)/Makefile.in Makefile.am
195SOURCES = t-strerror.c
196
197all: all-am
198
199.SUFFIXES:
200.SUFFIXES: .c .lo .o .obj
201$(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ Makefile.am $(top_srcdir)/configure.ac $(ACLOCAL_M4)
202 cd $(top_srcdir) && \
203 $(AUTOMAKE) --gnu tests/Makefile
204Makefile: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.in $(top_builddir)/config.status
205 cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)
206
207clean-noinstPROGRAMS:
208 @list='$(noinst_PROGRAMS)'; for p in $$list; do \
209 f=`echo $$p|sed 's/$(EXEEXT)$$//'`; \
210 echo " rm -f $$p $$f"; \
211 rm -f $$p $$f ; \
212 done
213t-strerror$(EXEEXT): $(t_strerror_OBJECTS) $(t_strerror_DEPENDENCIES)
214 @rm -f t-strerror$(EXEEXT)
215 $(LINK) $(t_strerror_LDFLAGS) $(t_strerror_OBJECTS) $(t_strerror_LDADD) $(LIBS)
216
217mostlyclean-compile:
218 -rm -f *.$(OBJEXT) core *.core
219
220distclean-compile:
221 -rm -f *.tab.c
222
223@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/t-strerror.Po@am__quote@
224
225.c.o:
226@am__fastdepCC_TRUE@ if $(COMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" \
227@am__fastdepCC_TRUE@ -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<; \
228@am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; \
229@am__fastdepCC_TRUE@ else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; \
230@am__fastdepCC_TRUE@ fi
231@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
232@AMDEP_TRUE@@am__fastdepCC_FALSE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@
233@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
234@am__fastdepCC_FALSE@ $(COMPILE) -c `test -f '$<' || echo '$(srcdir)/'`$<
235
236.c.obj:
237@am__fastdepCC_TRUE@ if $(COMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" \
238@am__fastdepCC_TRUE@ -c -o $@ `if test -f '$<'; then $(CYGPATH_W) '$<'; else $(CYGPATH_W) '$(srcdir)/$<'; fi`; \
239@am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; \
240@am__fastdepCC_TRUE@ else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; \
241@am__fastdepCC_TRUE@ fi
242@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
243@AMDEP_TRUE@@am__fastdepCC_FALSE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@
244@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
245@am__fastdepCC_FALSE@ $(COMPILE) -c `if test -f '$<'; then $(CYGPATH_W) '$<'; else $(CYGPATH_W) '$(srcdir)/$<'; fi`
246
247.c.lo:
248@am__fastdepCC_TRUE@ if $(LTCOMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" \
249@am__fastdepCC_TRUE@ -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<; \
250@am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Plo"; \
251@am__fastdepCC_TRUE@ else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; \
252@am__fastdepCC_TRUE@ fi
253@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
254@AMDEP_TRUE@@am__fastdepCC_FALSE@ depfile='$(DEPDIR)/$*.Plo' tmpdepfile='$(DEPDIR)/$*.TPlo' @AMDEPBACKSLASH@
255@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
256@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
257
258mostlyclean-libtool:
259 -rm -f *.lo
260
261clean-libtool:
262 -rm -rf .libs _libs
263
264distclean-libtool:
265 -rm -f libtool
266uninstall-info-am:
267
268ETAGS = etags
269ETAGSFLAGS =
270
271CTAGS = ctags
272CTAGSFLAGS =
273
274tags: TAGS
275
276ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
277 list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
278 unique=`for i in $$list; do \
279 if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
280 done | \
281 $(AWK) ' { files[$$0] = 1; } \
282 END { for (i in files) print i; }'`; \
283 mkid -fID $$unique
284
285TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
286 $(TAGS_FILES) $(LISP)
287 tags=; \
288 here=`pwd`; \
289 list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
290 unique=`for i in $$list; do \
291 if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
292 done | \
293 $(AWK) ' { files[$$0] = 1; } \
294 END { for (i in files) print i; }'`; \
295 test -z "$(ETAGS_ARGS)$$tags$$unique" \
296 || $(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
297 $$tags $$unique
298
299ctags: CTAGS
300CTAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
301 $(TAGS_FILES) $(LISP)
302 tags=; \
303 here=`pwd`; \
304 list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
305 unique=`for i in $$list; do \
306 if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
307 done | \
308 $(AWK) ' { files[$$0] = 1; } \
309 END { for (i in files) print i; }'`; \
310 test -z "$(CTAGS_ARGS)$$tags$$unique" \
311 || $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
312 $$tags $$unique
313
314GTAGS:
315 here=`$(am__cd) $(top_builddir) && pwd` \
316 && cd $(top_srcdir) \
317 && gtags -i $(GTAGS_ARGS) $$here
318
319distclean-tags:
320 -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
321
322check-TESTS: $(TESTS)
323 @failed=0; all=0; xfail=0; xpass=0; skip=0; \
324 srcdir=$(srcdir); export srcdir; \
325 list='$(TESTS)'; \
326 if test -n "$$list"; then \
327 for tst in $$list; do \
328 if test -f ./$$tst; then dir=./; \
329 elif test -f $$tst; then dir=; \
330 else dir="$(srcdir)/"; fi; \
331 if $(TESTS_ENVIRONMENT) $${dir}$$tst; then \
332 all=`expr $$all + 1`; \
333 case " $(XFAIL_TESTS) " in \
334 *" $$tst "*) \
335 xpass=`expr $$xpass + 1`; \
336 failed=`expr $$failed + 1`; \
337 echo "XPASS: $$tst"; \
338 ;; \
339 *) \
340 echo "PASS: $$tst"; \
341 ;; \
342 esac; \
343 elif test $$? -ne 77; then \
344 all=`expr $$all + 1`; \
345 case " $(XFAIL_TESTS) " in \
346 *" $$tst "*) \
347 xfail=`expr $$xfail + 1`; \
348 echo "XFAIL: $$tst"; \
349 ;; \
350 *) \
351 failed=`expr $$failed + 1`; \
352 echo "FAIL: $$tst"; \
353 ;; \
354 esac; \
355 else \
356 skip=`expr $$skip + 1`; \
357 echo "SKIP: $$tst"; \
358 fi; \
359 done; \
360 if test "$$failed" -eq 0; then \
361 if test "$$xfail" -eq 0; then \
362 banner="All $$all tests passed"; \
363 else \
364 banner="All $$all tests behaved as expected ($$xfail expected failures)"; \
365 fi; \
366 else \
367 if test "$$xpass" -eq 0; then \
368 banner="$$failed of $$all tests failed"; \
369 else \
370 banner="$$failed of $$all tests did not behave as expected ($$xpass unexpected passes)"; \
371 fi; \
372 fi; \
373 dashes="$$banner"; \
374 skipped=""; \
375 if test "$$skip" -ne 0; then \
376 skipped="($$skip tests were not run)"; \
377 test `echo "$$skipped" | wc -c` -gt `echo "$$banner" | wc -c` && \
378 dashes="$$skipped"; \
379 fi; \
380 report=""; \
381 if test "$$failed" -ne 0 && test -n "$(PACKAGE_BUGREPORT)"; then \
382 report="Please report to $(PACKAGE_BUGREPORT)"; \
383 test `echo "$$report" | wc -c` -gt `echo "$$banner" | wc -c` && \
384 dashes="$$report"; \
385 fi; \
386 dashes=`echo "$$dashes" | sed s/./=/g`; \
387 echo "$$dashes"; \
388 echo "$$banner"; \
389 test -n "$$skipped" && echo "$$skipped"; \
390 test -n "$$report" && echo "$$report"; \
391 echo "$$dashes"; \
392 test "$$failed" -eq 0; \
393 else :; fi
394DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
395
396top_distdir = ..
397distdir = $(top_distdir)/$(PACKAGE)-$(VERSION)
398
399distdir: $(DISTFILES)
400 @srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
401 topsrcdirstrip=`echo "$(top_srcdir)" | sed 's|.|.|g'`; \
402 list='$(DISTFILES)'; for file in $$list; do \
403 case $$file in \
404 $(srcdir)/*) file=`echo "$$file" | sed "s|^$$srcdirstrip/||"`;; \
405 $(top_srcdir)/*) file=`echo "$$file" | sed "s|^$$topsrcdirstrip/|$(top_builddir)/|"`;; \
406 esac; \
407 if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
408 dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
409 if test "$$dir" != "$$file" && test "$$dir" != "."; then \
410 dir="/$$dir"; \
411 $(mkinstalldirs) "$(distdir)$$dir"; \
412 else \
413 dir=''; \
414 fi; \
415 if test -d $$d/$$file; then \
416 if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \
417 cp -pR $(srcdir)/$$file $(distdir)$$dir || exit 1; \
418 fi; \
419 cp -pR $$d/$$file $(distdir)$$dir || exit 1; \
420 else \
421 test -f $(distdir)/$$file \
422 || cp -p $$d/$$file $(distdir)/$$file \
423 || exit 1; \
424 fi; \
425 done
426check-am: all-am
427 $(MAKE) $(AM_MAKEFLAGS) check-TESTS
428check: check-am
429all-am: Makefile $(PROGRAMS)
430
431installdirs:
432install: install-am
433install-exec: install-exec-am
434install-data: install-data-am
435uninstall: uninstall-am
436
437install-am: all-am
438 @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
439
440installcheck: installcheck-am
441install-strip:
442 $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
443 install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
444 `test -z '$(STRIP)' || \
445 echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
446mostlyclean-generic:
447
448clean-generic:
449
450distclean-generic:
451 -rm -f $(CONFIG_CLEAN_FILES)
452
453maintainer-clean-generic:
454 @echo "This command is intended for maintainers to use"
455 @echo "it deletes files that may require special tools to rebuild."
456clean: clean-am
457
458clean-am: clean-generic clean-libtool clean-noinstPROGRAMS \
459 mostlyclean-am
460
461distclean: distclean-am
462 -rm -rf ./$(DEPDIR)
463 -rm -f Makefile
464distclean-am: clean-am distclean-compile distclean-generic \
465 distclean-libtool distclean-tags
466
467dvi: dvi-am
468
469dvi-am:
470
471info: info-am
472
473info-am:
474
475install-data-am:
476
477install-exec-am:
478
479install-info: install-info-am
480
481install-man:
482
483installcheck-am:
484
485maintainer-clean: maintainer-clean-am
486 -rm -rf ./$(DEPDIR)
487 -rm -f Makefile
488maintainer-clean-am: distclean-am maintainer-clean-generic
489
490mostlyclean: mostlyclean-am
491
492mostlyclean-am: mostlyclean-compile mostlyclean-generic \
493 mostlyclean-libtool
494
495pdf: pdf-am
496
497pdf-am:
498
499ps: ps-am
500
501ps-am:
502
503uninstall-am: uninstall-info-am
504
505.PHONY: CTAGS GTAGS all all-am check check-TESTS check-am clean \
506 clean-generic clean-libtool clean-noinstPROGRAMS ctags \
507 distclean distclean-compile distclean-generic distclean-libtool \
508 distclean-tags distdir dvi dvi-am info info-am install \
509 install-am install-data install-data-am install-exec \
510 install-exec-am install-info install-info-am install-man \
511 install-strip installcheck installcheck-am installdirs \
512 maintainer-clean maintainer-clean-generic mostlyclean \
513 mostlyclean-compile mostlyclean-generic mostlyclean-libtool pdf \
514 pdf-am ps ps-am tags uninstall uninstall-am uninstall-info-am
515
516# Tell versions [3.59,3.63) of GNU make to not export all variables.
517# Otherwise a system limit (for SysV at least) may be exceeded.
518.NOEXPORT:
diff --git a/linden/indra/libgpg-error/libgpg-error-1.0/tests/t-strerror.c b/linden/indra/libgpg-error/libgpg-error-1.0/tests/t-strerror.c
new file mode 100755
index 0000000..e02b302
--- /dev/null
+++ b/linden/indra/libgpg-error/libgpg-error-1.0/tests/t-strerror.c
@@ -0,0 +1,63 @@
1/* t-strerror.c - Regression test.
2 Copyright (C) 2003 g10 Code GmbH
3
4 This file is part of libgpg-error.
5
6 libgpg-error is free software; you can redistribute it and/or
7 modify it under the terms of the GNU Lesser General Public License
8 as published by the Free Software Foundation; either version 2.1 of
9 the License, or (at your option) any later version.
10
11 libgpg-error is distributed in the hope that it will be useful, but
12 WITHOUT ANY WARRANTY; without even the implied warranty of
13 MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
14 Lesser General Public License for more details.
15
16 You should have received a copy of the GNU Lesser General Public
17 License along with libgpgme-error; if not, write to the Free
18 Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
19 02111-1307, USA. */
20
21#if HAVE_CONFIG_H
22#include <config.h>
23#endif
24
25#include <stdio.h>
26#if HAVE_STDLIB_H
27#include <stdlib.h>
28#endif
29
30#include <gpg-error.h>
31
32int
33main (int argc, char *argv[])
34{
35 if (argc > 1)
36 {
37 int i = 1;
38 while (i + 1 < argc)
39 {
40 gpg_error_t err = gpg_err_make (atoi (argv[i]), atoi (argv[i + 1]));
41 printf ("%s: %s\n", gpg_strsource (err), gpg_strerror (err));
42 i += 2;
43 }
44 }
45 else
46 {
47 struct
48 {
49 gpg_err_source_t src;
50 gpg_err_code_t code;
51 } list[] = { { 0, 0 }, { 1, 201 }, { 2, 2 }, { 3, 102 },
52 { 4, 100 }, { 5, 99 }, { 6, 110 }, { 7, 7 }, { 8, 888 } };
53 int i = 0;
54
55 while (i < sizeof (list) / sizeof (list[0]))
56 {
57 gpg_error_t err = gpg_err_make (list[i].src, list[i].code);
58 printf ("%s: %s\n", gpg_strsource (err), gpg_strerror (err));
59 i++;
60 }
61 }
62 return 0;
63}