diff options
author | Jay Threeth | 2011-04-04 11:48:26 -0700 |
---|---|---|
committer | Jay Threeth | 2011-04-04 11:48:26 -0700 |
commit | 3c9cc506f741b980565ff5b3b001cd8b6ee36b12 (patch) | |
tree | cb862c57b3d5f74177cde3bd962a53fc377166f6 /linden/indra/libgpg-error/libgpg-error-1.0/tests | |
parent | build fixes, might build on linux now (diff) | |
download | meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.zip meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.gz meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.bz2 meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.xz |
add source to libraries, and cruft for building under windows
Diffstat (limited to 'linden/indra/libgpg-error/libgpg-error-1.0/tests')
3 files changed, 609 insertions, 0 deletions
diff --git a/linden/indra/libgpg-error/libgpg-error-1.0/tests/Makefile.am b/linden/indra/libgpg-error/libgpg-error-1.0/tests/Makefile.am new file mode 100755 index 0000000..0530cf8 --- /dev/null +++ b/linden/indra/libgpg-error/libgpg-error-1.0/tests/Makefile.am | |||
@@ -0,0 +1,28 @@ | |||
1 | # Makefile.am for libgpg-error/tests. | ||
2 | # Copyright (C) 2003 g10 Code GmbH | ||
3 | # | ||
4 | # This file is part of libgpg-error. | ||
5 | # | ||
6 | # libgpg-error is free software; you can redistribute it and/or modify | ||
7 | # it under the terms of the GNU Lesser General Public License as | ||
8 | # published by the Free Software Foundation; either version 2.1 of the | ||
9 | # License, or (at your option) any later version. | ||
10 | # | ||
11 | # libgpg-error is distributed in the hope that it will be useful, | ||
12 | # but WITHOUT ANY WARRANTY; without even the implied warranty of | ||
13 | # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the | ||
14 | # GNU Lesser General Public License for more details. | ||
15 | # | ||
16 | # You should have received a copy of the GNU Lesser General Public | ||
17 | # License along with this program; if not, write to the Free Software | ||
18 | # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA | ||
19 | |||
20 | ## Process this file with automake to produce Makefile.in | ||
21 | |||
22 | TESTS = t-strerror | ||
23 | |||
24 | INCLUDES = -I$(top_builddir)/src | ||
25 | |||
26 | LDADD = ../src/libgpg-error.la | ||
27 | |||
28 | noinst_PROGRAMS = $(TESTS) | ||
diff --git a/linden/indra/libgpg-error/libgpg-error-1.0/tests/Makefile.in b/linden/indra/libgpg-error/libgpg-error-1.0/tests/Makefile.in new file mode 100755 index 0000000..9938cf7 --- /dev/null +++ b/linden/indra/libgpg-error/libgpg-error-1.0/tests/Makefile.in | |||
@@ -0,0 +1,518 @@ | |||
1 | # Makefile.in generated by automake 1.7.9 from Makefile.am. | ||
2 | # @configure_input@ | ||
3 | |||
4 | # Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003 | ||
5 | # Free Software Foundation, Inc. | ||
6 | # This Makefile.in is free software; the Free Software Foundation | ||
7 | # gives unlimited permission to copy and/or distribute it, | ||
8 | # with or without modifications, as long as this notice is preserved. | ||
9 | |||
10 | # This program is distributed in the hope that it will be useful, | ||
11 | # but WITHOUT ANY WARRANTY, to the extent permitted by law; without | ||
12 | # even the implied warranty of MERCHANTABILITY or FITNESS FOR A | ||
13 | # PARTICULAR PURPOSE. | ||
14 | |||
15 | @SET_MAKE@ | ||
16 | |||
17 | # Makefile.am for libgpg-error/tests. | ||
18 | # Copyright (C) 2003 g10 Code GmbH | ||
19 | # | ||
20 | # This file is part of libgpg-error. | ||
21 | # | ||
22 | # libgpg-error is free software; you can redistribute it and/or modify | ||
23 | # it under the terms of the GNU Lesser General Public License as | ||
24 | # published by the Free Software Foundation; either version 2.1 of the | ||
25 | # License, or (at your option) any later version. | ||
26 | # | ||
27 | # libgpg-error is distributed in the hope that it will be useful, | ||
28 | # but WITHOUT ANY WARRANTY; without even the implied warranty of | ||
29 | # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the | ||
30 | # GNU Lesser General Public License for more details. | ||
31 | # | ||
32 | # You should have received a copy of the GNU Lesser General Public | ||
33 | # License along with this program; if not, write to the Free Software | ||
34 | # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA | ||
35 | |||
36 | srcdir = @srcdir@ | ||
37 | top_srcdir = @top_srcdir@ | ||
38 | VPATH = @srcdir@ | ||
39 | pkgdatadir = $(datadir)/@PACKAGE@ | ||
40 | pkglibdir = $(libdir)/@PACKAGE@ | ||
41 | pkgincludedir = $(includedir)/@PACKAGE@ | ||
42 | top_builddir = .. | ||
43 | |||
44 | am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd | ||
45 | INSTALL = @INSTALL@ | ||
46 | install_sh_DATA = $(install_sh) -c -m 644 | ||
47 | install_sh_PROGRAM = $(install_sh) -c | ||
48 | install_sh_SCRIPT = $(install_sh) -c | ||
49 | INSTALL_HEADER = $(INSTALL_DATA) | ||
50 | transform = $(program_transform_name) | ||
51 | NORMAL_INSTALL = : | ||
52 | PRE_INSTALL = : | ||
53 | POST_INSTALL = : | ||
54 | NORMAL_UNINSTALL = : | ||
55 | PRE_UNINSTALL = : | ||
56 | POST_UNINSTALL = : | ||
57 | host_triplet = @host@ | ||
58 | ACLOCAL = @ACLOCAL@ | ||
59 | AMDEP_FALSE = @AMDEP_FALSE@ | ||
60 | AMDEP_TRUE = @AMDEP_TRUE@ | ||
61 | AMTAR = @AMTAR@ | ||
62 | AUTOCONF = @AUTOCONF@ | ||
63 | AUTOHEADER = @AUTOHEADER@ | ||
64 | AUTOMAKE = @AUTOMAKE@ | ||
65 | AWK = @AWK@ | ||
66 | CC = @CC@ | ||
67 | CCDEPMODE = @CCDEPMODE@ | ||
68 | CC_FOR_BUILD = @CC_FOR_BUILD@ | ||
69 | CFLAGS = @CFLAGS@ | ||
70 | CPP = @CPP@ | ||
71 | CPPFLAGS = @CPPFLAGS@ | ||
72 | CYGPATH_W = @CYGPATH_W@ | ||
73 | DEFS = @DEFS@ | ||
74 | DEPDIR = @DEPDIR@ | ||
75 | ECHO = @ECHO@ | ||
76 | ECHO_C = @ECHO_C@ | ||
77 | ECHO_N = @ECHO_N@ | ||
78 | ECHO_T = @ECHO_T@ | ||
79 | EGREP = @EGREP@ | ||
80 | EXEEXT = @EXEEXT@ | ||
81 | GMSGFMT = @GMSGFMT@ | ||
82 | GPG_ERROR_CONFIG_CFLAGS = @GPG_ERROR_CONFIG_CFLAGS@ | ||
83 | GPG_ERROR_CONFIG_LIBS = @GPG_ERROR_CONFIG_LIBS@ | ||
84 | INSTALL_DATA = @INSTALL_DATA@ | ||
85 | INSTALL_PROGRAM = @INSTALL_PROGRAM@ | ||
86 | INSTALL_SCRIPT = @INSTALL_SCRIPT@ | ||
87 | INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@ | ||
88 | INTLLIBS = @INTLLIBS@ | ||
89 | LDFLAGS = @LDFLAGS@ | ||
90 | LIBGPG_ERROR_LT_AGE = @LIBGPG_ERROR_LT_AGE@ | ||
91 | LIBGPG_ERROR_LT_CURRENT = @LIBGPG_ERROR_LT_CURRENT@ | ||
92 | LIBGPG_ERROR_LT_REVISION = @LIBGPG_ERROR_LT_REVISION@ | ||
93 | LIBICONV = @LIBICONV@ | ||
94 | LIBINTL = @LIBINTL@ | ||
95 | LIBOBJS = @LIBOBJS@ | ||
96 | LIBS = @LIBS@ | ||
97 | LIBTOOL = @LIBTOOL@ | ||
98 | LN_S = @LN_S@ | ||
99 | LTLIBICONV = @LTLIBICONV@ | ||
100 | LTLIBINTL = @LTLIBINTL@ | ||
101 | LTLIBOBJS = @LTLIBOBJS@ | ||
102 | MAINT = @MAINT@ | ||
103 | MAINTAINER_MODE_FALSE = @MAINTAINER_MODE_FALSE@ | ||
104 | MAINTAINER_MODE_TRUE = @MAINTAINER_MODE_TRUE@ | ||
105 | MAKEINFO = @MAKEINFO@ | ||
106 | MKINSTALLDIRS = @MKINSTALLDIRS@ | ||
107 | MSGFMT = @MSGFMT@ | ||
108 | MSGMERGE = @MSGMERGE@ | ||
109 | OBJEXT = @OBJEXT@ | ||
110 | PACKAGE = @PACKAGE@ | ||
111 | PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@ | ||
112 | PACKAGE_NAME = @PACKAGE_NAME@ | ||
113 | PACKAGE_STRING = @PACKAGE_STRING@ | ||
114 | PACKAGE_TARNAME = @PACKAGE_TARNAME@ | ||
115 | PACKAGE_VERSION = @PACKAGE_VERSION@ | ||
116 | PATH_SEPARATOR = @PATH_SEPARATOR@ | ||
117 | POSUB = @POSUB@ | ||
118 | RANLIB = @RANLIB@ | ||
119 | SET_MAKE = @SET_MAKE@ | ||
120 | SHELL = @SHELL@ | ||
121 | STRIP = @STRIP@ | ||
122 | USE_NLS = @USE_NLS@ | ||
123 | VERSION = @VERSION@ | ||
124 | XGETTEXT = @XGETTEXT@ | ||
125 | ac_ct_CC = @ac_ct_CC@ | ||
126 | ac_ct_RANLIB = @ac_ct_RANLIB@ | ||
127 | ac_ct_STRIP = @ac_ct_STRIP@ | ||
128 | am__fastdepCC_FALSE = @am__fastdepCC_FALSE@ | ||
129 | am__fastdepCC_TRUE = @am__fastdepCC_TRUE@ | ||
130 | am__include = @am__include@ | ||
131 | am__leading_dot = @am__leading_dot@ | ||
132 | am__quote = @am__quote@ | ||
133 | bindir = @bindir@ | ||
134 | build = @build@ | ||
135 | build_alias = @build_alias@ | ||
136 | build_cpu = @build_cpu@ | ||
137 | build_os = @build_os@ | ||
138 | build_vendor = @build_vendor@ | ||
139 | datadir = @datadir@ | ||
140 | exec_prefix = @exec_prefix@ | ||
141 | host = @host@ | ||
142 | host_alias = @host_alias@ | ||
143 | host_cpu = @host_cpu@ | ||
144 | host_os = @host_os@ | ||
145 | host_vendor = @host_vendor@ | ||
146 | includedir = @includedir@ | ||
147 | infodir = @infodir@ | ||
148 | install_sh = @install_sh@ | ||
149 | libdir = @libdir@ | ||
150 | libexecdir = @libexecdir@ | ||
151 | localstatedir = @localstatedir@ | ||
152 | mandir = @mandir@ | ||
153 | oldincludedir = @oldincludedir@ | ||
154 | prefix = @prefix@ | ||
155 | program_transform_name = @program_transform_name@ | ||
156 | sbindir = @sbindir@ | ||
157 | sharedstatedir = @sharedstatedir@ | ||
158 | sysconfdir = @sysconfdir@ | ||
159 | target_alias = @target_alias@ | ||
160 | |||
161 | TESTS = t-strerror | ||
162 | |||
163 | INCLUDES = -I$(top_builddir)/src | ||
164 | |||
165 | LDADD = ../src/libgpg-error.la | ||
166 | |||
167 | noinst_PROGRAMS = $(TESTS) | ||
168 | subdir = tests | ||
169 | ACLOCAL_M4 = $(top_srcdir)/aclocal.m4 | ||
170 | mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs | ||
171 | CONFIG_HEADER = $(top_builddir)/config.h | ||
172 | CONFIG_CLEAN_FILES = | ||
173 | noinst_PROGRAMS = t-strerror$(EXEEXT) | ||
174 | PROGRAMS = $(noinst_PROGRAMS) | ||
175 | |||
176 | t_strerror_SOURCES = t-strerror.c | ||
177 | t_strerror_OBJECTS = t-strerror.$(OBJEXT) | ||
178 | t_strerror_LDADD = $(LDADD) | ||
179 | t_strerror_DEPENDENCIES = ../src/libgpg-error.la | ||
180 | t_strerror_LDFLAGS = | ||
181 | |||
182 | DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir) | ||
183 | depcomp = $(SHELL) $(top_srcdir)/depcomp | ||
184 | am__depfiles_maybe = depfiles | ||
185 | @AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/t-strerror.Po | ||
186 | COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \ | ||
187 | $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) | ||
188 | LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \ | ||
189 | $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) | ||
190 | CCLD = $(CC) | ||
191 | LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \ | ||
192 | $(AM_LDFLAGS) $(LDFLAGS) -o $@ | ||
193 | DIST_SOURCES = t-strerror.c | ||
194 | DIST_COMMON = $(srcdir)/Makefile.in Makefile.am | ||
195 | SOURCES = t-strerror.c | ||
196 | |||
197 | all: all-am | ||
198 | |||
199 | .SUFFIXES: | ||
200 | .SUFFIXES: .c .lo .o .obj | ||
201 | $(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ Makefile.am $(top_srcdir)/configure.ac $(ACLOCAL_M4) | ||
202 | cd $(top_srcdir) && \ | ||
203 | $(AUTOMAKE) --gnu tests/Makefile | ||
204 | Makefile: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.in $(top_builddir)/config.status | ||
205 | cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe) | ||
206 | |||
207 | clean-noinstPROGRAMS: | ||
208 | @list='$(noinst_PROGRAMS)'; for p in $$list; do \ | ||
209 | f=`echo $$p|sed 's/$(EXEEXT)$$//'`; \ | ||
210 | echo " rm -f $$p $$f"; \ | ||
211 | rm -f $$p $$f ; \ | ||
212 | done | ||
213 | t-strerror$(EXEEXT): $(t_strerror_OBJECTS) $(t_strerror_DEPENDENCIES) | ||
214 | @rm -f t-strerror$(EXEEXT) | ||
215 | $(LINK) $(t_strerror_LDFLAGS) $(t_strerror_OBJECTS) $(t_strerror_LDADD) $(LIBS) | ||
216 | |||
217 | mostlyclean-compile: | ||
218 | -rm -f *.$(OBJEXT) core *.core | ||
219 | |||
220 | distclean-compile: | ||
221 | -rm -f *.tab.c | ||
222 | |||
223 | @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/t-strerror.Po@am__quote@ | ||
224 | |||
225 | .c.o: | ||
226 | @am__fastdepCC_TRUE@ if $(COMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" \ | ||
227 | @am__fastdepCC_TRUE@ -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<; \ | ||
228 | @am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; \ | ||
229 | @am__fastdepCC_TRUE@ else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; \ | ||
230 | @am__fastdepCC_TRUE@ fi | ||
231 | @AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@ | ||
232 | @AMDEP_TRUE@@am__fastdepCC_FALSE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@ | ||
233 | @AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@ | ||
234 | @am__fastdepCC_FALSE@ $(COMPILE) -c `test -f '$<' || echo '$(srcdir)/'`$< | ||
235 | |||
236 | .c.obj: | ||
237 | @am__fastdepCC_TRUE@ if $(COMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" \ | ||
238 | @am__fastdepCC_TRUE@ -c -o $@ `if test -f '$<'; then $(CYGPATH_W) '$<'; else $(CYGPATH_W) '$(srcdir)/$<'; fi`; \ | ||
239 | @am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; \ | ||
240 | @am__fastdepCC_TRUE@ else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; \ | ||
241 | @am__fastdepCC_TRUE@ fi | ||
242 | @AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@ | ||
243 | @AMDEP_TRUE@@am__fastdepCC_FALSE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@ | ||
244 | @AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@ | ||
245 | @am__fastdepCC_FALSE@ $(COMPILE) -c `if test -f '$<'; then $(CYGPATH_W) '$<'; else $(CYGPATH_W) '$(srcdir)/$<'; fi` | ||
246 | |||
247 | .c.lo: | ||
248 | @am__fastdepCC_TRUE@ if $(LTCOMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" \ | ||
249 | @am__fastdepCC_TRUE@ -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<; \ | ||
250 | @am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Plo"; \ | ||
251 | @am__fastdepCC_TRUE@ else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; \ | ||
252 | @am__fastdepCC_TRUE@ fi | ||
253 | @AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@ | ||
254 | @AMDEP_TRUE@@am__fastdepCC_FALSE@ depfile='$(DEPDIR)/$*.Plo' tmpdepfile='$(DEPDIR)/$*.TPlo' @AMDEPBACKSLASH@ | ||
255 | @AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@ | ||
256 | @am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$< | ||
257 | |||
258 | mostlyclean-libtool: | ||
259 | -rm -f *.lo | ||
260 | |||
261 | clean-libtool: | ||
262 | -rm -rf .libs _libs | ||
263 | |||
264 | distclean-libtool: | ||
265 | -rm -f libtool | ||
266 | uninstall-info-am: | ||
267 | |||
268 | ETAGS = etags | ||
269 | ETAGSFLAGS = | ||
270 | |||
271 | CTAGS = ctags | ||
272 | CTAGSFLAGS = | ||
273 | |||
274 | tags: TAGS | ||
275 | |||
276 | ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES) | ||
277 | list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \ | ||
278 | unique=`for i in $$list; do \ | ||
279 | if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \ | ||
280 | done | \ | ||
281 | $(AWK) ' { files[$$0] = 1; } \ | ||
282 | END { for (i in files) print i; }'`; \ | ||
283 | mkid -fID $$unique | ||
284 | |||
285 | TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \ | ||
286 | $(TAGS_FILES) $(LISP) | ||
287 | tags=; \ | ||
288 | here=`pwd`; \ | ||
289 | list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \ | ||
290 | unique=`for i in $$list; do \ | ||
291 | if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \ | ||
292 | done | \ | ||
293 | $(AWK) ' { files[$$0] = 1; } \ | ||
294 | END { for (i in files) print i; }'`; \ | ||
295 | test -z "$(ETAGS_ARGS)$$tags$$unique" \ | ||
296 | || $(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \ | ||
297 | $$tags $$unique | ||
298 | |||
299 | ctags: CTAGS | ||
300 | CTAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \ | ||
301 | $(TAGS_FILES) $(LISP) | ||
302 | tags=; \ | ||
303 | here=`pwd`; \ | ||
304 | list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \ | ||
305 | unique=`for i in $$list; do \ | ||
306 | if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \ | ||
307 | done | \ | ||
308 | $(AWK) ' { files[$$0] = 1; } \ | ||
309 | END { for (i in files) print i; }'`; \ | ||
310 | test -z "$(CTAGS_ARGS)$$tags$$unique" \ | ||
311 | || $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \ | ||
312 | $$tags $$unique | ||
313 | |||
314 | GTAGS: | ||
315 | here=`$(am__cd) $(top_builddir) && pwd` \ | ||
316 | && cd $(top_srcdir) \ | ||
317 | && gtags -i $(GTAGS_ARGS) $$here | ||
318 | |||
319 | distclean-tags: | ||
320 | -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags | ||
321 | |||
322 | check-TESTS: $(TESTS) | ||
323 | @failed=0; all=0; xfail=0; xpass=0; skip=0; \ | ||
324 | srcdir=$(srcdir); export srcdir; \ | ||
325 | list='$(TESTS)'; \ | ||
326 | if test -n "$$list"; then \ | ||
327 | for tst in $$list; do \ | ||
328 | if test -f ./$$tst; then dir=./; \ | ||
329 | elif test -f $$tst; then dir=; \ | ||
330 | else dir="$(srcdir)/"; fi; \ | ||
331 | if $(TESTS_ENVIRONMENT) $${dir}$$tst; then \ | ||
332 | all=`expr $$all + 1`; \ | ||
333 | case " $(XFAIL_TESTS) " in \ | ||
334 | *" $$tst "*) \ | ||
335 | xpass=`expr $$xpass + 1`; \ | ||
336 | failed=`expr $$failed + 1`; \ | ||
337 | echo "XPASS: $$tst"; \ | ||
338 | ;; \ | ||
339 | *) \ | ||
340 | echo "PASS: $$tst"; \ | ||
341 | ;; \ | ||
342 | esac; \ | ||
343 | elif test $$? -ne 77; then \ | ||
344 | all=`expr $$all + 1`; \ | ||
345 | case " $(XFAIL_TESTS) " in \ | ||
346 | *" $$tst "*) \ | ||
347 | xfail=`expr $$xfail + 1`; \ | ||
348 | echo "XFAIL: $$tst"; \ | ||
349 | ;; \ | ||
350 | *) \ | ||
351 | failed=`expr $$failed + 1`; \ | ||
352 | echo "FAIL: $$tst"; \ | ||
353 | ;; \ | ||
354 | esac; \ | ||
355 | else \ | ||
356 | skip=`expr $$skip + 1`; \ | ||
357 | echo "SKIP: $$tst"; \ | ||
358 | fi; \ | ||
359 | done; \ | ||
360 | if test "$$failed" -eq 0; then \ | ||
361 | if test "$$xfail" -eq 0; then \ | ||
362 | banner="All $$all tests passed"; \ | ||
363 | else \ | ||
364 | banner="All $$all tests behaved as expected ($$xfail expected failures)"; \ | ||
365 | fi; \ | ||
366 | else \ | ||
367 | if test "$$xpass" -eq 0; then \ | ||
368 | banner="$$failed of $$all tests failed"; \ | ||
369 | else \ | ||
370 | banner="$$failed of $$all tests did not behave as expected ($$xpass unexpected passes)"; \ | ||
371 | fi; \ | ||
372 | fi; \ | ||
373 | dashes="$$banner"; \ | ||
374 | skipped=""; \ | ||
375 | if test "$$skip" -ne 0; then \ | ||
376 | skipped="($$skip tests were not run)"; \ | ||
377 | test `echo "$$skipped" | wc -c` -gt `echo "$$banner" | wc -c` && \ | ||
378 | dashes="$$skipped"; \ | ||
379 | fi; \ | ||
380 | report=""; \ | ||
381 | if test "$$failed" -ne 0 && test -n "$(PACKAGE_BUGREPORT)"; then \ | ||
382 | report="Please report to $(PACKAGE_BUGREPORT)"; \ | ||
383 | test `echo "$$report" | wc -c` -gt `echo "$$banner" | wc -c` && \ | ||
384 | dashes="$$report"; \ | ||
385 | fi; \ | ||
386 | dashes=`echo "$$dashes" | sed s/./=/g`; \ | ||
387 | echo "$$dashes"; \ | ||
388 | echo "$$banner"; \ | ||
389 | test -n "$$skipped" && echo "$$skipped"; \ | ||
390 | test -n "$$report" && echo "$$report"; \ | ||
391 | echo "$$dashes"; \ | ||
392 | test "$$failed" -eq 0; \ | ||
393 | else :; fi | ||
394 | DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST) | ||
395 | |||
396 | top_distdir = .. | ||
397 | distdir = $(top_distdir)/$(PACKAGE)-$(VERSION) | ||
398 | |||
399 | distdir: $(DISTFILES) | ||
400 | @srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \ | ||
401 | topsrcdirstrip=`echo "$(top_srcdir)" | sed 's|.|.|g'`; \ | ||
402 | list='$(DISTFILES)'; for file in $$list; do \ | ||
403 | case $$file in \ | ||
404 | $(srcdir)/*) file=`echo "$$file" | sed "s|^$$srcdirstrip/||"`;; \ | ||
405 | $(top_srcdir)/*) file=`echo "$$file" | sed "s|^$$topsrcdirstrip/|$(top_builddir)/|"`;; \ | ||
406 | esac; \ | ||
407 | if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \ | ||
408 | dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \ | ||
409 | if test "$$dir" != "$$file" && test "$$dir" != "."; then \ | ||
410 | dir="/$$dir"; \ | ||
411 | $(mkinstalldirs) "$(distdir)$$dir"; \ | ||
412 | else \ | ||
413 | dir=''; \ | ||
414 | fi; \ | ||
415 | if test -d $$d/$$file; then \ | ||
416 | if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \ | ||
417 | cp -pR $(srcdir)/$$file $(distdir)$$dir || exit 1; \ | ||
418 | fi; \ | ||
419 | cp -pR $$d/$$file $(distdir)$$dir || exit 1; \ | ||
420 | else \ | ||
421 | test -f $(distdir)/$$file \ | ||
422 | || cp -p $$d/$$file $(distdir)/$$file \ | ||
423 | || exit 1; \ | ||
424 | fi; \ | ||
425 | done | ||
426 | check-am: all-am | ||
427 | $(MAKE) $(AM_MAKEFLAGS) check-TESTS | ||
428 | check: check-am | ||
429 | all-am: Makefile $(PROGRAMS) | ||
430 | |||
431 | installdirs: | ||
432 | install: install-am | ||
433 | install-exec: install-exec-am | ||
434 | install-data: install-data-am | ||
435 | uninstall: uninstall-am | ||
436 | |||
437 | install-am: all-am | ||
438 | @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am | ||
439 | |||
440 | installcheck: installcheck-am | ||
441 | install-strip: | ||
442 | $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \ | ||
443 | install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \ | ||
444 | `test -z '$(STRIP)' || \ | ||
445 | echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install | ||
446 | mostlyclean-generic: | ||
447 | |||
448 | clean-generic: | ||
449 | |||
450 | distclean-generic: | ||
451 | -rm -f $(CONFIG_CLEAN_FILES) | ||
452 | |||
453 | maintainer-clean-generic: | ||
454 | @echo "This command is intended for maintainers to use" | ||
455 | @echo "it deletes files that may require special tools to rebuild." | ||
456 | clean: clean-am | ||
457 | |||
458 | clean-am: clean-generic clean-libtool clean-noinstPROGRAMS \ | ||
459 | mostlyclean-am | ||
460 | |||
461 | distclean: distclean-am | ||
462 | -rm -rf ./$(DEPDIR) | ||
463 | -rm -f Makefile | ||
464 | distclean-am: clean-am distclean-compile distclean-generic \ | ||
465 | distclean-libtool distclean-tags | ||
466 | |||
467 | dvi: dvi-am | ||
468 | |||
469 | dvi-am: | ||
470 | |||
471 | info: info-am | ||
472 | |||
473 | info-am: | ||
474 | |||
475 | install-data-am: | ||
476 | |||
477 | install-exec-am: | ||
478 | |||
479 | install-info: install-info-am | ||
480 | |||
481 | install-man: | ||
482 | |||
483 | installcheck-am: | ||
484 | |||
485 | maintainer-clean: maintainer-clean-am | ||
486 | -rm -rf ./$(DEPDIR) | ||
487 | -rm -f Makefile | ||
488 | maintainer-clean-am: distclean-am maintainer-clean-generic | ||
489 | |||
490 | mostlyclean: mostlyclean-am | ||
491 | |||
492 | mostlyclean-am: mostlyclean-compile mostlyclean-generic \ | ||
493 | mostlyclean-libtool | ||
494 | |||
495 | pdf: pdf-am | ||
496 | |||
497 | pdf-am: | ||
498 | |||
499 | ps: ps-am | ||
500 | |||
501 | ps-am: | ||
502 | |||
503 | uninstall-am: uninstall-info-am | ||
504 | |||
505 | .PHONY: CTAGS GTAGS all all-am check check-TESTS check-am clean \ | ||
506 | clean-generic clean-libtool clean-noinstPROGRAMS ctags \ | ||
507 | distclean distclean-compile distclean-generic distclean-libtool \ | ||
508 | distclean-tags distdir dvi dvi-am info info-am install \ | ||
509 | install-am install-data install-data-am install-exec \ | ||
510 | install-exec-am install-info install-info-am install-man \ | ||
511 | install-strip installcheck installcheck-am installdirs \ | ||
512 | maintainer-clean maintainer-clean-generic mostlyclean \ | ||
513 | mostlyclean-compile mostlyclean-generic mostlyclean-libtool pdf \ | ||
514 | pdf-am ps ps-am tags uninstall uninstall-am uninstall-info-am | ||
515 | |||
516 | # Tell versions [3.59,3.63) of GNU make to not export all variables. | ||
517 | # Otherwise a system limit (for SysV at least) may be exceeded. | ||
518 | .NOEXPORT: | ||
diff --git a/linden/indra/libgpg-error/libgpg-error-1.0/tests/t-strerror.c b/linden/indra/libgpg-error/libgpg-error-1.0/tests/t-strerror.c new file mode 100755 index 0000000..e02b302 --- /dev/null +++ b/linden/indra/libgpg-error/libgpg-error-1.0/tests/t-strerror.c | |||
@@ -0,0 +1,63 @@ | |||
1 | /* t-strerror.c - Regression test. | ||
2 | Copyright (C) 2003 g10 Code GmbH | ||
3 | |||
4 | This file is part of libgpg-error. | ||
5 | |||
6 | libgpg-error is free software; you can redistribute it and/or | ||
7 | modify it under the terms of the GNU Lesser General Public License | ||
8 | as published by the Free Software Foundation; either version 2.1 of | ||
9 | the License, or (at your option) any later version. | ||
10 | |||
11 | libgpg-error is distributed in the hope that it will be useful, but | ||
12 | WITHOUT ANY WARRANTY; without even the implied warranty of | ||
13 | MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU | ||
14 | Lesser General Public License for more details. | ||
15 | |||
16 | You should have received a copy of the GNU Lesser General Public | ||
17 | License along with libgpgme-error; if not, write to the Free | ||
18 | Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA | ||
19 | 02111-1307, USA. */ | ||
20 | |||
21 | #if HAVE_CONFIG_H | ||
22 | #include <config.h> | ||
23 | #endif | ||
24 | |||
25 | #include <stdio.h> | ||
26 | #if HAVE_STDLIB_H | ||
27 | #include <stdlib.h> | ||
28 | #endif | ||
29 | |||
30 | #include <gpg-error.h> | ||
31 | |||
32 | int | ||
33 | main (int argc, char *argv[]) | ||
34 | { | ||
35 | if (argc > 1) | ||
36 | { | ||
37 | int i = 1; | ||
38 | while (i + 1 < argc) | ||
39 | { | ||
40 | gpg_error_t err = gpg_err_make (atoi (argv[i]), atoi (argv[i + 1])); | ||
41 | printf ("%s: %s\n", gpg_strsource (err), gpg_strerror (err)); | ||
42 | i += 2; | ||
43 | } | ||
44 | } | ||
45 | else | ||
46 | { | ||
47 | struct | ||
48 | { | ||
49 | gpg_err_source_t src; | ||
50 | gpg_err_code_t code; | ||
51 | } list[] = { { 0, 0 }, { 1, 201 }, { 2, 2 }, { 3, 102 }, | ||
52 | { 4, 100 }, { 5, 99 }, { 6, 110 }, { 7, 7 }, { 8, 888 } }; | ||
53 | int i = 0; | ||
54 | |||
55 | while (i < sizeof (list) / sizeof (list[0])) | ||
56 | { | ||
57 | gpg_error_t err = gpg_err_make (list[i].src, list[i].code); | ||
58 | printf ("%s: %s\n", gpg_strsource (err), gpg_strerror (err)); | ||
59 | i++; | ||
60 | } | ||
61 | } | ||
62 | return 0; | ||
63 | } | ||