aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
authorChris Tuchs2011-07-18 01:54:48 -0700
committerChris Tuchs2011-07-18 01:54:48 -0700
commit37e6a5d6cf0d293a97191e233ddc840fd73153f7 (patch)
tree85f5fc7954d613602fcb22f9c1f60b331e05a9ea
parentFix the linux build of OTR and friends. Hope I did not break Windows. (diff)
downloadmeta-impy-37e6a5d6cf0d293a97191e233ddc840fd73153f7.zip
meta-impy-37e6a5d6cf0d293a97191e233ddc840fd73153f7.tar.gz
meta-impy-37e6a5d6cf0d293a97191e233ddc840fd73153f7.tar.bz2
meta-impy-37e6a5d6cf0d293a97191e233ddc840fd73153f7.tar.xz
some changes to build on windows, not enough though
-rw-r--r--linden/indra/CMakeLists.txt6
-rw-r--r--linden/indra/libotr/CMakeLists.txt7
2 files changed, 9 insertions, 4 deletions
diff --git a/linden/indra/CMakeLists.txt b/linden/indra/CMakeLists.txt
index e3643d3..de5dee8 100644
--- a/linden/indra/CMakeLists.txt
+++ b/linden/indra/CMakeLists.txt
@@ -46,8 +46,10 @@ endif (WINDOWS)
46# if off will use the systems libotr.so but won't be fully compatible with windows version 46# if off will use the systems libotr.so but won't be fully compatible with windows version
47set(STATIC_LIBOTR_ETC 1) 47set(STATIC_LIBOTR_ETC 1)
48 48
49add_subdirectory(${LIBS_OPEN_PREFIX}libgpg-error) 49if (NOT WINDOWS)
50add_subdirectory(${LIBS_OPEN_PREFIX}libgcrypt) 50 add_subdirectory(${LIBS_OPEN_PREFIX}libgpg-error)
51 add_subdirectory(${LIBS_OPEN_PREFIX}libgcrypt)
52endif (NOT WINDOWS)
51# [/$PLOTR$] 53# [/$PLOTR$]
52 54
53add_subdirectory(${LIBS_OPEN_PREFIX}llaudio) 55add_subdirectory(${LIBS_OPEN_PREFIX}llaudio)
diff --git a/linden/indra/libotr/CMakeLists.txt b/linden/indra/libotr/CMakeLists.txt
index f0561d8..282535f 100644
--- a/linden/indra/libotr/CMakeLists.txt
+++ b/linden/indra/libotr/CMakeLists.txt
@@ -66,6 +66,9 @@ target_link_libraries(libotr
66 66
67# Not sure if either or both are needed, does not seem to hurt. 67# Not sure if either or both are needed, does not seem to hurt.
68# Still does not make things build in the right sequence. sigh 68# Still does not make things build in the right sequence. sigh
69add_dependencies(libotr EP_libgcrpt) 69if (NOT WINDOWS)
70add_dependencies(libotr libgcrypt) 70 add_dependencies(libotr EP_libgcrpt)
71else (NOT WINDOWS)
72 add_dependencies(libotr libgcrypt)
73endif (NOT WINDOWS)
71 74