diff options
Diffstat (limited to 'linden/indra/newview')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 45 |
1 files changed, 24 insertions, 21 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index e729e6c..cdc2a9a 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -15,6 +15,24 @@ include(HUNSPELL) | |||
15 | include(FindOpenGL) | 15 | include(FindOpenGL) |
16 | include(JsonCpp) | 16 | include(JsonCpp) |
17 | include(LLAddBuildTest) | 17 | include(LLAddBuildTest) |
18 | |||
19 | # [$PLOTR$] | ||
20 | include(libgpg-error) | ||
21 | include(libgcrypt) | ||
22 | |||
23 | if (WINDOWS) | ||
24 | include(libotr) | ||
25 | # on windows always build libotr from source and statically link in libgcrypt and libgpg-error | ||
26 | endif (WINDOWS) | ||
27 | if (DARWIN OR LINUX) | ||
28 | if (STATIC_LIBOTR_ETC) | ||
29 | include(libotr) # to build libotr from source and statically link in libgcrypt and libgpg-error | ||
30 | else (STATIC_LIBOTR_ETC) | ||
31 | include(libotrb) | ||
32 | endif (STATIC_LIBOTR_ETC) | ||
33 | endif (DARWIN OR LINUX) | ||
34 | # [/$PLOTR$] | ||
35 | |||
18 | include(LLAudio) | 36 | include(LLAudio) |
19 | include(LLCharacter) | 37 | include(LLCharacter) |
20 | include(LLCommon) | 38 | include(LLCommon) |
@@ -43,23 +61,6 @@ if (WINDOWS) | |||
43 | include(CopyWinLibs) | 61 | include(CopyWinLibs) |
44 | endif (WINDOWS) | 62 | endif (WINDOWS) |
45 | 63 | ||
46 | # [$PLOTR$] | ||
47 | include(libgcrypt) | ||
48 | include(libgpg-error) | ||
49 | |||
50 | if (WINDOWS) | ||
51 | include(libotr) | ||
52 | # on windows always build libotr from source and statically link in libgcrypt and libgpg-error | ||
53 | endif (WINDOWS) | ||
54 | if (DARWIN OR LINUX) | ||
55 | if (STATIC_LIBOTR_ETC) | ||
56 | include(libotr) # to build libotr from source and statically link in libgcrypt and libgpg-error | ||
57 | else (STATIC_LIBOTR_ETC) | ||
58 | include(libotrb) | ||
59 | endif (STATIC_LIBOTR_ETC) | ||
60 | endif (DARWIN OR LINUX) | ||
61 | # [/$PLOTR$] | ||
62 | |||
63 | include_directories( | 64 | include_directories( |
64 | ${DBUSGLIB_INCLUDE_DIRS} | 65 | ${DBUSGLIB_INCLUDE_DIRS} |
65 | ${HUNSPELL_INCLUDE_DIR} | 66 | ${HUNSPELL_INCLUDE_DIR} |
@@ -1072,13 +1073,13 @@ if (LINUX) | |||
1072 | # [$PLOTR$] | 1073 | # [$PLOTR$] |
1073 | if (STATIC_LIBOTR_ETC) # defined in .../linden/indra/CMakeLists.txt | 1074 | if (STATIC_LIBOTR_ETC) # defined in .../linden/indra/CMakeLists.txt |
1074 | set(viewer_LIBRARIES | 1075 | set(viewer_LIBRARIES |
1075 | Xinerama | 1076 | Xinerama |
1076 | gpg-error | 1077 | #gpg-error |
1077 | gcrypt # to build libotr from source and statically link in libgcrypt and libgpg-error | 1078 | #gcrypt # to build libotr from source and statically link in libgcrypt and libgpg-error |
1078 | ) | 1079 | ) |
1079 | else (STATIC_LIBOTR_ETC) # below for dynamically linked, unmodified libotr | 1080 | else (STATIC_LIBOTR_ETC) # below for dynamically linked, unmodified libotr |
1080 | set(viewer_LIBRARIES | 1081 | set(viewer_LIBRARIES |
1081 | Xinerama | 1082 | Xinerama |
1082 | ) | 1083 | ) |
1083 | endif (STATIC_LIBOTR_ETC) | 1084 | endif (STATIC_LIBOTR_ETC) |
1084 | # [/$PLOTR$] | 1085 | # [/$PLOTR$] |
@@ -1449,6 +1450,8 @@ if (WINDOWS) | |||
1449 | else (WINDOWS) | 1450 | else (WINDOWS) |
1450 | if (STATIC_LIBOTR_ETC) | 1451 | if (STATIC_LIBOTR_ETC) |
1451 | set(otr_link_libs ${LIBOTR_LIBRARIES} | 1452 | set(otr_link_libs ${LIBOTR_LIBRARIES} |
1453 | ${LIBGCRYPT_LIBRARIES} | ||
1454 | ${LIBGPG-ERROR_LIBRARIES} | ||
1452 | ) # statically linked libotr, built from source | 1455 | ) # statically linked libotr, built from source |
1453 | else (STATIC_LIBOTR_ETC) | 1456 | else (STATIC_LIBOTR_ETC) |
1454 | set(otr_link_libs ${OTR_LIBRARY} | 1457 | set(otr_link_libs ${OTR_LIBRARY} |