aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/viewer_manifest.py
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/newview/viewer_manifest.py')
-rwxr-xr-xlinden/indra/newview/viewer_manifest.py125
1 files changed, 92 insertions, 33 deletions
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py
index e350af0..b67af99 100755
--- a/linden/indra/newview/viewer_manifest.py
+++ b/linden/indra/newview/viewer_manifest.py
@@ -232,21 +232,15 @@ class WindowsManifest(ViewerManifest):
232 232
233 def construct(self): 233 def construct(self):
234 super(WindowsManifest, self).construct() 234 super(WindowsManifest, self).construct()
235 # the final exe is complicated because we're not sure where it's coming from, 235 # Come out, come out, where ever you are.
236 # nor do we have a fixed name for the executable 236 executable = self.find_existing_file('release/meta-impy-bin.exe', 'releasesse2/meta-impy-bin.exe', 'relwithdebinfo/meta-impy-bin.exe', 'debug/meta-impy-bin.exe', './meta-impy-bin.exe')
237 # Actually, we know on both counts -- MC 237 nmake = False
238 if self.configuration().lower() == "release": 238 self.path(executable, dst=self.final_exe())
239 self.path(self.find_existing_file('release/meta-impy-bin.exe'), dst=self.final_exe())
240 elif self.configuration().lower() == "releasesse2":
241 self.path(self.find_existing_file('releasesse2/meta-impy-bin.exe'), dst=self.final_exe())
242 elif self.configuration().lower() == "relwithdebinfo":
243 self.path(self.find_existing_file('relwithdebinfo/meta-impy-bin.exe'), dst=self.final_exe())
244 elif self.configuration().lower() == "debug":
245 self.path(self.find_existing_file('debug/meta-impy-bin.exe'), dst=self.final_exe())
246 else:
247 self.path(self.find_existing_file('release/meta-impy-bin.exe', 'releasesse2/meta-impy-bin.exe', 'relwithdebinfo/meta-impy-bin.exe', 'debug/meta-impy-bin.exe'), dst=self.final_exe())
248 239
249 # copy over the the pdb file for the regular or SSE2 versions if we don't already have one copied 240 # copy over the the pdb file for the regular or SSE2 versions if we don't already have one copied
241 # Don't think this ever worked, the destination seems bogus.
242 # It's trying to copy a built file outside of the source tree, a file we have anyway.
243 # TODO - do we even need this?
250 symbol_ver = '.'.join(self.args['version']) 244 symbol_ver = '.'.join(self.args['version'])
251 symbol_file = 'meta-impy-%s.%s.pdb' % (symbol_ver, self.args['configuration']) 245 symbol_file = 'meta-impy-%s.%s.pdb' % (symbol_ver, self.args['configuration'])
252 symbol_path = '../../../../../pdb_files/%s' % (symbol_file) 246 symbol_path = '../../../../../pdb_files/%s' % (symbol_file)
@@ -255,26 +249,28 @@ class WindowsManifest(ViewerManifest):
255 else: 249 else:
256 #print "%s doesn't exist yet" % (os.getcwd() + symbol_path) 250 #print "%s doesn't exist yet" % (os.getcwd() + symbol_path)
257 try: 251 try:
258 self.path(self.find_existing_file('release/meta-impy-bin.pdb'), dst="../%s" % (symbol_path)) 252 self.path(self.find_existing_file(executable.split('/', 1)[0] % '/meta-impy-bin.pdb'), dst="../%s" % (symbol_path))
259 pass 253 pass
260 except: 254 except:
261 print "Can't save symbol file %s, skipping" % (symbol_path) 255 print "Can't save symbol file %s, skipping" % (symbol_path)
262 pass 256 pass
263 257
264 self.gather_documents() 258 self.gather_documents()
265 259
266 if self.prefix("../..", dst="doc"): 260 if self.prefix("../..", dst="doc"):
267 self.path("LICENSE-libraries.txt") 261 self.path("LICENSE-libraries.txt")
268 self.end_prefix("../..") 262 self.end_prefix("../..")
269 263
270
271 self.path("meta-impy.url") 264 self.path("meta-impy.url")
272 265
273 # Plugin host application 266 # Plugin host application
274 self.path(os.path.join(os.pardir, 267 try:
275 'llplugin', 'slplugin', self.args['configuration'], "SLPlugin.exe"), 268 self.path(os.path.join(os.pardir, 'llplugin', 'slplugin', self.args['configuration'], "SLPlugin.exe"), "SLPlugin.exe")
276 "SLPlugin.exe") 269 except:
277 270 # Probably an nmake build, which is not putting exe's into the configuration folders.
271 self.path(os.path.join(os.pardir, 'llplugin', 'slplugin', "SLPlugin.exe"), "SLPlugin.exe")
272 # Propogate our wild guess.
273 nmake = True
278 274
279 self.path("featuretable.txt") 275 self.path("featuretable.txt")
280 276
@@ -283,17 +279,17 @@ class WindowsManifest(ViewerManifest):
283 279
284 # For using FMOD for sound... DJS 280 # For using FMOD for sound... DJS
285 #self.path("fmod.dll") 281 #self.path("fmod.dll")
286 282
287 # For spellchecking 283 # For spellchecking
288 if self.prefix(src=self.args['configuration'], dst=""): 284 if self.prefix(self.args['configuration'], dst=""):
289 self.path("libhunspell.dll") 285 self.path("libhunspell.dll")
290 self.end_prefix() 286 self.end_prefix()
291 287
292 # Copy the llkdu DSO .config 288 # Copy the llkdu DSO .config
293 self.path("llkdu.dll.2.config") 289 self.path("llkdu.dll.2.config")
294 290
295 # Get llcommon and deps. 291 # Get llcommon and deps.
296 if self.prefix(src=self.args['configuration'], dst=""): 292 if self.prefix(self.args['configuration'], dst=""):
297 self.path('libapr-1.dll') 293 self.path('libapr-1.dll')
298 self.path('libaprutil-1.dll') 294 self.path('libaprutil-1.dll')
299 self.path('libapriconv-1.dll') 295 self.path('libapriconv-1.dll')
@@ -309,23 +305,28 @@ class WindowsManifest(ViewerManifest):
309 if self.prefix(src="../../libraries/i686-win32/lib/release", dst=""): 305 if self.prefix(src="../../libraries/i686-win32/lib/release", dst=""):
310 self.path("openal32.dll") 306 self.path("openal32.dll")
311 self.path("alut.dll") 307 self.path("alut.dll")
312 self.end_prefix() 308 self.end_prefix()
313 309
310 # TODO - Yes, I know, would be better if nmake builds put stuff in the right place, track that down and fix it later.
311 if nmake:
312 config = ''
313 else:
314 config = self.args['configuration']
314 # Media plugins - QuickTime 315 # Media plugins - QuickTime
315 if self.prefix(src='../media_plugins/quicktime/%s' % self.args['configuration'], dst="llplugin"): 316 if self.prefix(src='../media_plugins/quicktime/%s' % config, dst="llplugin"):
316 self.path("media_plugin_quicktime.dll") 317 self.path("media_plugin_quicktime.dll")
317 self.end_prefix() 318 self.end_prefix()
318 319
319 # Media plugins - WebKit/Qt 320 # Media plugins - WebKit/Qt
320 if self.prefix(src='../media_plugins/webkit/%s' % self.args['configuration'], dst="llplugin"): 321 if self.prefix(src='../media_plugins/webkit/%s' % config, dst="llplugin"):
321 self.path("media_plugin_webkit.dll") 322 self.path("media_plugin_webkit.dll")
322 self.end_prefix() 323 self.end_prefix()
323 324
324 # Media plugins - GStreamer 325 # Media plugins - GStreamer
325 if self.prefix(src='../media_plugins/gstreamer010/%s' % self.args['configuration'], dst="llplugin"): 326 if self.prefix(src='../media_plugins/gstreamer010/%s' % config, dst="llplugin"):
326 self.path("media_plugin_gstreamer010.dll") 327 self.path("media_plugin_gstreamer010.dll")
327 self.end_prefix() 328 self.end_prefix()
328 329
329 # For WebKit/Qt plugin runtimes 330 # For WebKit/Qt plugin runtimes
330 if self.prefix(src="../../libraries/i686-win32/lib/release", dst="llplugin"): 331 if self.prefix(src="../../libraries/i686-win32/lib/release", dst="llplugin"):
331 self.path("libeay32.dll") 332 self.path("libeay32.dll")
@@ -476,13 +477,15 @@ class WindowsManifest(ViewerManifest):
476 sse_string = "-(SSE2-optimized)" 477 sse_string = "-(SSE2-optimized)"
477 478
478 version = '.'.join(self.args['version']) 479 version = '.'.join(self.args['version'])
479 base_filename = self.installer_prefix() + version + sse_string 480 version_number = version.split('-', 1)[0]
481 base_filename = self.installer_prefix() + version + "-Windows-x86" + sse_string
480 app_name = self.channel() 482 app_name = self.channel()
481 app_ver_name="%s %s" % (app_name, version) 483 app_ver_name="%s %s" % (app_name, version)
482 484
483 new_script = base_filename + ".iss" 485 new_script = base_filename + ".iss"
484 self.replace_in("installers/windows/meta-impy_installer_template.iss", new_script, { 486 self.replace_in("installers/windows/meta-impy_installer_template.iss", new_script, {
485 "%%VERSION%%":version, 487 "%%VERSION%%":version,
488 "%%VERSIONNUMBER%%":version_number,
486 "%%INSTALLERFILENAME%%":base_filename, 489 "%%INSTALLERFILENAME%%":base_filename,
487 "%%PACKAGEFILES%%":self.args['dest'], 490 "%%PACKAGEFILES%%":self.args['dest'],
488 "%%APPNAME%%":app_name, 491 "%%APPNAME%%":app_name,
@@ -1035,13 +1038,32 @@ class Linux_i686Manifest(LinuxManifest):
1035 #self.path("libgstvolume.so") 1038 #self.path("libgstvolume.so")
1036 #self.path("libgstvorbis.so") 1039 #self.path("libgstvorbis.so")
1037 #self.path("libgstwavparse.so") 1040 #self.path("libgstwavparse.so")
1038 1041
1039 #self.end_prefix("gstreamer-plugins") 1042 #self.end_prefix("gstreamer-plugins")
1040 1043
1041# [$PLOTR$] these two are not needed when STATIC_LIBOTR_ETC is on in .../linden/indra/CMakeLists.txt 1044# [$PLOTR$] these two are not needed when STATIC_LIBOTR_ETC is on in .../linden/indra/CMakeLists.txt
1042# self.path("libotr.so.2.2.0") 1045# self.path("libotr.so.2.2.0")
1043# self.path("libotr.so.2") 1046# self.path("libotr.so.2")
1044# [/$PLOTR$] 1047# [/$PLOTR$]
1048
1049 # Wish I could kill it with fire. lol
1050 self.path("libboost_date_time-mt.so")
1051 self.path("libboost_date_time-mt.so.1.52.0")
1052 self.path("libboost_filesystem-mt.so")
1053 self.path("libboost_filesystem-mt.so.1.52.0")
1054 self.path("libboost_iostreams-mt.so")
1055 self.path("libboost_iostreams-mt.so.1.52.0")
1056 self.path("libboost_program_options-mt.so")
1057 self.path("libboost_program_options-mt.so.1.52.0")
1058 self.path("libboost_regex-mt.so")
1059 self.path("libboost_regex-mt.so.1.52.0")
1060 self.path("libboost_signals-mt.so")
1061 self.path("libboost_signals-mt.so.1.52.0")
1062 self.path("libboost_system-mt.so")
1063 self.path("libboost_system-mt.so.1.52.0")
1064 self.path("libboost_thread-mt.so")
1065 self.path("libboost_thread-mt.so.1.52.0")
1066
1045 self.end_prefix("lib") 1067 self.end_prefix("lib")
1046 1068
1047 # Vivox runtimes and libs 1069 # Vivox runtimes and libs
@@ -1124,11 +1146,48 @@ class Linux_x86_64Manifest(LinuxManifest):
1124# self.path("libpangoxft-1.0.so.0") # So we depend system gdk pixbufs and pango anyway. 1146# self.path("libpangoxft-1.0.so.0") # So we depend system gdk pixbufs and pango anyway.
1125 ##self.path("libpixman-1.so.0") 1147 ##self.path("libpixman-1.so.0")
1126 1148
1127 #self.end_prefix("gstreamer-plugins")
1128# [$PLOTR$] these two are not needed when STATIC_LIBOTR_ETC is on in .../linden/indra/CMakeLists.txt 1149# [$PLOTR$] these two are not needed when STATIC_LIBOTR_ETC is on in .../linden/indra/CMakeLists.txt
1129# self.path("libotr.so.2.2.0") 1150# self.path("libotr.so.2.2.0")
1130# self.path("libotr.so.2") 1151# self.path("libotr.so.2")
1131# [/$PLOTR$] 1152# [/$PLOTR$]
1153
1154#KILL IT WITH FIRE
1155 ## Gstreamer libs
1156 #self.end_prefix("gstreamer-plugins")
1157 #self.path("libgstbase-0.10.so.0")
1158 #self.path("libgstreamer-0.10.so.0")
1159 #self.path("libgstaudio-0.10.so.0")
1160 #self.path("libgstbase-0.10.so.0")
1161 #self.path("libgstcontroller-0.10.so.0")
1162 #self.path("libgstdataprotocol-0.10.so.0")
1163 #self.path("libgstinterfaces-0.10.so.0")
1164 #self.path("libgstnetbuffer-0.10.so.0")
1165 #self.path("libgstpbutils-0.10.so.0")
1166 #self.path("libgstriff-0.10.so.0")
1167 #self.path("libgstrtp-0.10.so.0")
1168 #self.path("libgstrtsp-0.10.so.0")
1169 #self.path("libgstsdp-0.10.so.0")
1170 #self.path("libgsttag-0.10.so.0")
1171 #self.path("libgstvideo-0.10.so.0")
1172
1173 # Wish I could kill it with fire. lol
1174 self.path("libboost_date_time-mt.so")
1175 self.path("libboost_date_time-mt.so.1.52.0")
1176 self.path("libboost_filesystem-mt.so")
1177 self.path("libboost_filesystem-mt.so.1.52.0")
1178 self.path("libboost_iostreams-mt.so")
1179 self.path("libboost_iostreams-mt.so.1.52.0")
1180 self.path("libboost_program_options-mt.so")
1181 self.path("libboost_program_options-mt.so.1.52.0")
1182 self.path("libboost_regex-mt.so")
1183 self.path("libboost_regex-mt.so.1.52.0")
1184 self.path("libboost_signals-mt.so")
1185 self.path("libboost_signals-mt.so.1.52.0")
1186 self.path("libboost_system-mt.so")
1187 self.path("libboost_system-mt.so.1.52.0")
1188 self.path("libboost_thread-mt.so")
1189 self.path("libboost_thread-mt.so.1.52.0")
1190
1132 self.end_prefix("lib64") 1191 self.end_prefix("lib64")
1133 1192
1134 1193