aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/newview/CMakeLists.txt')
-rw-r--r--linden/indra/newview/CMakeLists.txt68
1 files changed, 34 insertions, 34 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 4050d80..1fc5f42 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -92,7 +92,7 @@ set(viewer_SOURCE_FILES
92 jcfloaterareasearch.cpp 92 jcfloaterareasearch.cpp
93 kokuastreamingaudio.cpp 93 kokuastreamingaudio.cpp
94 kowopenregionsettings.cpp 94 kowopenregionsettings.cpp
95 lightshare.cpp 95 llettherebelight.cpp
96 llagent.cpp 96 llagent.cpp
97 llagentaccess.cpp 97 llagentaccess.cpp
98 llagentdata.cpp 98 llagentdata.cpp
@@ -274,6 +274,7 @@ set(viewer_SOURCE_FILES
274 llmaniprotate.cpp 274 llmaniprotate.cpp
275 llmanipscale.cpp 275 llmanipscale.cpp
276 llmaniptranslate.cpp 276 llmaniptranslate.cpp
277 llmediadataclient.cpp
277 llmapresponders.cpp 278 llmapresponders.cpp
278 llmediaremotectrl.cpp 279 llmediaremotectrl.cpp
279 llmemoryview.cpp 280 llmemoryview.cpp
@@ -506,6 +507,7 @@ set(viewer_SOURCE_FILES
506 wlfloatermanager.cpp 507 wlfloatermanager.cpp
507 wlfloaterwindlightsend.cpp 508 wlfloaterwindlightsend.cpp
508 wlretrievesettings.cpp 509 wlretrievesettings.cpp
510 rcmoapradar.cpp
509 ) 511 )
510 512
511set(VIEWER_BINARY_NAME "imprudence-bin" CACHE STRING 513set(VIEWER_BINARY_NAME "imprudence-bin" CACHE STRING
@@ -529,7 +531,7 @@ set(viewer_HEADER_FILES
529 CMakeLists.txt 531 CMakeLists.txt
530 ViewerInstall.cmake 532 ViewerInstall.cmake
531 aoremotectrl.h 533 aoremotectrl.h
532 chatbar_as_cmdline.h 534 chatbar_as_cmdline.h
533 emeraldboobutils.h 535 emeraldboobutils.h
534 floaterao.h 536 floaterao.h
535 floaterbusy.h 537 floaterbusy.h
@@ -548,11 +550,11 @@ set(viewer_HEADER_FILES
548 jcfloater_animation_list.h 550 jcfloater_animation_list.h
549 jcfloaterareasearch.h 551 jcfloaterareasearch.h
550 kokuastreamingaudio.h 552 kokuastreamingaudio.h
551 lightshare.h 553 llettherebelight.h
552 lggautocorrectfloater.h 554 lggautocorrectfloater.h
553 lggautocorrect.h 555 lggautocorrect.h
554 lggdicdownload.h 556 lggdicdownload.h
555 lgghunspell_wrapper.h 557 lgghunspell_wrapper.h
556 llagent.h 558 llagent.h
557 llagentaccess.h 559 llagentaccess.h
558 llagentdata.h 560 llagentdata.h
@@ -735,6 +737,7 @@ set(viewer_HEADER_FILES
735 llmaniprotate.h 737 llmaniprotate.h
736 llmanipscale.h 738 llmanipscale.h
737 llmaniptranslate.h 739 llmaniptranslate.h
740 llmediadataclient.h
738 llmapresponders.h 741 llmapresponders.h
739 llmediaremotectrl.h 742 llmediaremotectrl.h
740 llmemoryview.h 743 llmemoryview.h
@@ -978,6 +981,7 @@ set(viewer_HEADER_FILES
978 wlfloatermanager.h 981 wlfloatermanager.h
979 wlfloaterwindlightsend.h 982 wlfloaterwindlightsend.h
980 wlretrievesettings.h 983 wlretrievesettings.h
984 rcmoapradar.h
981 ) 985 )
982 986
983source_group("CMake Rules" FILES ViewerInstall.cmake) 987source_group("CMake Rules" FILES ViewerInstall.cmake)
@@ -1197,19 +1201,15 @@ set(viewer_APPSETTINGS_FILES
1197 app_settings/cmd_line.xml 1201 app_settings/cmd_line.xml
1198 app_settings/default_grids.xml 1202 app_settings/default_grids.xml
1199 app_settings/grass.xml 1203 app_settings/grass.xml
1200 app_settings/high_graphics.xml
1201 app_settings/keys.ini 1204 app_settings/keys.ini
1202 app_settings/keywords.ini 1205 app_settings/keywords.ini
1203 app_settings/logcontrol.xml 1206 app_settings/logcontrol.xml
1204 app_settings/low_graphics.xml
1205 app_settings/mid_graphics.xml
1206 app_settings/settings.xml 1207 app_settings/settings.xml
1207 app_settings/settings_crash_behavior.xml 1208 app_settings/settings_crash_behavior.xml
1208 app_settings/settings_files.xml 1209 app_settings/settings_files.xml
1209 app_settings/settings_per_account.xml 1210 app_settings/settings_per_account.xml
1210 app_settings/std_bump.ini 1211 app_settings/std_bump.ini
1211 app_settings/trees.xml 1212 app_settings/trees.xml
1212 app_settings/ultra_graphics.xml
1213 app_settings/viewerart.xml 1213 app_settings/viewerart.xml
1214 ${CMAKE_SOURCE_DIR}/../etc/message.xml 1214 ${CMAKE_SOURCE_DIR}/../etc/message.xml
1215 ${CMAKE_SOURCE_DIR}/../scripts/messages/message_template.msg 1215 ${CMAKE_SOURCE_DIR}/../scripts/messages/message_template.msg
@@ -1319,7 +1319,7 @@ if (WINDOWS)
1319 1319
1320 # sets the 'working directory' for debugging from visual studio. 1320 # sets the 'working directory' for debugging from visual studio.
1321 if (NOT UNATTENDED) 1321 if (NOT UNATTENDED)
1322 if (NOT self.using_express) 1322 if (USE_VSTOOL)
1323 add_custom_command( 1323 add_custom_command(
1324 TARGET ${VIEWER_BINARY_NAME} PRE_BUILD 1324 TARGET ${VIEWER_BINARY_NAME} PRE_BUILD
1325 COMMAND ${CMAKE_SOURCE_DIR}/tools/vstool/vstool.exe 1325 COMMAND ${CMAKE_SOURCE_DIR}/tools/vstool/vstool.exe
@@ -1331,7 +1331,7 @@ if (WINDOWS)
1331 ${CMAKE_CURRENT_SOURCE_DIR} 1331 ${CMAKE_CURRENT_SOURCE_DIR}
1332 COMMENT "Setting the ${VIEWER_BINARY_NAME} working directory for debugging." 1332 COMMENT "Setting the ${VIEWER_BINARY_NAME} working directory for debugging."
1333 ) 1333 )
1334 endif (NOT self.using_express) 1334 endif (USE_VSTOOL)
1335 endif (NOT UNATTENDED) 1335 endif (NOT UNATTENDED)
1336 1336
1337 add_custom_command( 1337 add_custom_command(
@@ -1341,7 +1341,7 @@ if (WINDOWS)
1341 -E 1341 -E
1342 copy_if_different 1342 copy_if_different
1343 ${CMAKE_CURRENT_SOURCE_DIR}/../../scripts/messages/message_template.msg 1343 ${CMAKE_CURRENT_SOURCE_DIR}/../../scripts/messages/message_template.msg
1344 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings/message_template.msg 1344 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/app_settings/message_template.msg
1345 COMMENT "Copying message_template.msg to the runtime folder." 1345 COMMENT "Copying message_template.msg to the runtime folder."
1346 ) 1346 )
1347 1347
@@ -1352,7 +1352,7 @@ if (WINDOWS)
1352 -E 1352 -E
1353 copy_if_different 1353 copy_if_different
1354 ${CMAKE_CURRENT_SOURCE_DIR}/../../etc/message.xml 1354 ${CMAKE_CURRENT_SOURCE_DIR}/../../etc/message.xml
1355 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings/message.xml 1355 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/app_settings/message.xml
1356 COMMENT "Copying message.xml to the runtime folder." 1356 COMMENT "Copying message.xml to the runtime folder."
1357 ) 1357 )
1358 1358
@@ -1363,11 +1363,11 @@ if (WINDOWS)
1363 endif (EXISTS ${CMAKE_SOURCE_DIR}/copy_win_scripts) 1363 endif (EXISTS ${CMAKE_SOURCE_DIR}/copy_win_scripts)
1364 1364
1365 add_custom_command( 1365 add_custom_command(
1366 OUTPUT ${CMAKE_CFG_INTDIR}/touched.bat 1366 OUTPUT ${VIEWER_CFG_INTDIR}/touched.bat
1367 COMMAND ${PYTHON_EXECUTABLE} 1367 COMMAND ${PYTHON_EXECUTABLE}
1368 ARGS 1368 ARGS
1369 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py 1369 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1370 --configuration=${CMAKE_CFG_INTDIR} 1370 --configuration=${VIEWER_CFG_INTDIR}
1371 --channel=${VIEWER_CHANNEL} 1371 --channel=${VIEWER_CHANNEL}
1372 --login_channel=${VIEWER_LOGIN_CHANNEL} 1372 --login_channel=${VIEWER_LOGIN_CHANNEL}
1373 --standalone=${STANDALONE} 1373 --standalone=${STANDALONE}
@@ -1376,15 +1376,15 @@ if (WINDOWS)
1376 --source=${CMAKE_CURRENT_SOURCE_DIR} 1376 --source=${CMAKE_CURRENT_SOURCE_DIR}
1377 --artwork=${ARTWORK_DIR} 1377 --artwork=${ARTWORK_DIR}
1378 --build=${CMAKE_CURRENT_BINARY_DIR} 1378 --build=${CMAKE_CURRENT_BINARY_DIR}
1379 --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/package 1379 --dest=${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/package
1380 --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/touched.bat 1380 --touch=${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/touched.bat
1381 DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py 1381 DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1382 ) 1382 )
1383 1383
1384 add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010) 1384 add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010)
1385 1385
1386 if (PACKAGE) 1386 if (PACKAGE)
1387 add_custom_target(package ALL DEPENDS ${CMAKE_CFG_INTDIR}/touched.bat) 1387 add_custom_target(package ALL DEPENDS ${VIEWER_CFG_INTDIR}/touched.bat)
1388 add_dependencies(package windows-updater windows-crash-logger) 1388 add_dependencies(package windows-updater windows-crash-logger)
1389 endif (PACKAGE) 1389 endif (PACKAGE)
1390endif (WINDOWS) 1390endif (WINDOWS)
@@ -1519,8 +1519,8 @@ if (DARWIN)
1519 --artwork=${ARTWORK_DIR} 1519 --artwork=${ARTWORK_DIR}
1520 --build=${CMAKE_CURRENT_BINARY_DIR} 1520 --build=${CMAKE_CURRENT_BINARY_DIR}
1521 --buildtype=${CMAKE_BUILD_TYPE} 1521 --buildtype=${CMAKE_BUILD_TYPE}
1522 --configuration=${CMAKE_CFG_INTDIR} 1522 --configuration=${VIEWER_CFG_INTDIR}
1523 --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app 1523 --dest=${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/${product}.app
1524 --grid=${GRID} 1524 --grid=${GRID}
1525 --source=${CMAKE_CURRENT_SOURCE_DIR} 1525 --source=${CMAKE_CURRENT_SOURCE_DIR}
1526 --standalone=${STANDALONE} 1526 --standalone=${STANDALONE}
@@ -1551,8 +1551,8 @@ if (WINDOWS)
1551 -E 1551 -E
1552 copy_if_different 1552 copy_if_different
1553 ${BUILT_LLCOMMON} 1553 ${BUILT_LLCOMMON}
1554 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR} 1554 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}
1555 COMMENT "Copying llcommon.dll to the runtime folder." 1555 COMMENT "Copying llcommon.dll to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}."
1556 ) 1556 )
1557 1557
1558 get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION) 1558 get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION)
@@ -1563,8 +1563,8 @@ if (WINDOWS)
1563 -E 1563 -E
1564 copy_if_different 1564 copy_if_different
1565 ${BUILT_SLPLUGIN} 1565 ${BUILT_SLPLUGIN}
1566 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR} 1566 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}
1567 COMMENT "Copying SLPlugin executable to the runtime folder." 1567 COMMENT "Copying SLPlugin executable to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}."
1568 ) 1568 )
1569 1569
1570 get_target_property(BUILT_WEBKIT_PLUGIN media_plugin_webkit LOCATION) 1570 get_target_property(BUILT_WEBKIT_PLUGIN media_plugin_webkit LOCATION)
@@ -1575,8 +1575,8 @@ if (WINDOWS)
1575 -E 1575 -E
1576 copy_if_different 1576 copy_if_different
1577 ${BUILT_WEBKIT_PLUGIN} 1577 ${BUILT_WEBKIT_PLUGIN}
1578 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin 1578 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin
1579 COMMENT "Copying WebKit Plugin to the runtime folder." 1579 COMMENT "Copying WebKit Plugin to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin."
1580 ) 1580 )
1581 1581
1582 get_target_property(BUILT_GSTREAMER_PLUGIN media_plugin_gstreamer010 LOCATION) 1582 get_target_property(BUILT_GSTREAMER_PLUGIN media_plugin_gstreamer010 LOCATION)
@@ -1587,8 +1587,8 @@ if (WINDOWS)
1587 -E 1587 -E
1588 copy_if_different 1588 copy_if_different
1589 ${BUILT_GSTREAMER_PLUGIN} 1589 ${BUILT_GSTREAMER_PLUGIN}
1590 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin 1590 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin
1591 COMMENT "Copying Gstreamer Plugin to the runtime folder." 1591 COMMENT "Copying Gstreamer Plugin to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin."
1592 ) 1592 )
1593 1593
1594 get_target_property(BUILT_QUICKTIME_PLUGIN media_plugin_quicktime LOCATION) 1594 get_target_property(BUILT_QUICKTIME_PLUGIN media_plugin_quicktime LOCATION)
@@ -1599,13 +1599,13 @@ if (WINDOWS)
1599 -E 1599 -E
1600 copy_if_different 1600 copy_if_different
1601 ${BUILT_QUICKTIME_PLUGIN} 1601 ${BUILT_QUICKTIME_PLUGIN}
1602 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin 1602 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin
1603 COMMENT "Copying Quicktime Plugin to the runtime folder." 1603 COMMENT "Copying Quicktime Plugin to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin."
1604 ) 1604 )
1605 1605
1606 # Copying the mime_types.xml file to app_settings 1606 # Copying the mime_types.xml file to app_settings
1607 set(mime_types_source "${CMAKE_SOURCE_DIR}/newview/skins/default/xui/en-us") 1607 set(mime_types_source "${CMAKE_SOURCE_DIR}/newview/skins/default/xui/en-us")
1608 set(mime_types_dest "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings") 1608 set(mime_types_dest "${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/app_settings")
1609 add_custom_command( 1609 add_custom_command(
1610 TARGET ${VIEWER_BINARY_NAME} POST_BUILD 1610 TARGET ${VIEWER_BINARY_NAME} POST_BUILD
1611 COMMAND ${CMAKE_COMMAND} 1611 COMMAND ${CMAKE_COMMAND}
@@ -1622,7 +1622,7 @@ endif (WINDOWS)
1622if (DARWIN) 1622if (DARWIN)
1623# Don't do this here -- it's taken care of by viewer_manifest.py 1623# Don't do this here -- it's taken care of by viewer_manifest.py
1624# add_custom_command(TARGET ${VIEWER_BINARY_NAME} POST_BUILD 1624# add_custom_command(TARGET ${VIEWER_BINARY_NAME} POST_BUILD
1625# COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin/ 1625# COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin/
1626# DEPENDS ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib 1626# DEPENDS ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib
1627# ) 1627# )
1628endif (DARWIN) 1628endif (DARWIN)