aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/newview/CMakeLists.txt')
-rw-r--r--linden/indra/newview/CMakeLists.txt46
1 files changed, 23 insertions, 23 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index b9c41fc..907fa5c 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -1326,7 +1326,7 @@ if (WINDOWS)
1326 1326
1327 # sets the 'working directory' for debugging from visual studio. 1327 # sets the 'working directory' for debugging from visual studio.
1328 if (NOT UNATTENDED) 1328 if (NOT UNATTENDED)
1329 if (NOT self.using_express) 1329 if (USE_VSTOOL)
1330 add_custom_command( 1330 add_custom_command(
1331 TARGET ${VIEWER_BINARY_NAME} PRE_BUILD 1331 TARGET ${VIEWER_BINARY_NAME} PRE_BUILD
1332 COMMAND ${CMAKE_SOURCE_DIR}/tools/vstool/vstool.exe 1332 COMMAND ${CMAKE_SOURCE_DIR}/tools/vstool/vstool.exe
@@ -1338,7 +1338,7 @@ if (WINDOWS)
1338 ${CMAKE_CURRENT_SOURCE_DIR} 1338 ${CMAKE_CURRENT_SOURCE_DIR}
1339 COMMENT "Setting the ${VIEWER_BINARY_NAME} working directory for debugging." 1339 COMMENT "Setting the ${VIEWER_BINARY_NAME} working directory for debugging."
1340 ) 1340 )
1341 endif (NOT self.using_express) 1341 endif (USE_VSTOOL)
1342 endif (NOT UNATTENDED) 1342 endif (NOT UNATTENDED)
1343 1343
1344 add_custom_command( 1344 add_custom_command(
@@ -1348,7 +1348,7 @@ if (WINDOWS)
1348 -E 1348 -E
1349 copy_if_different 1349 copy_if_different
1350 ${CMAKE_CURRENT_SOURCE_DIR}/../../scripts/messages/message_template.msg 1350 ${CMAKE_CURRENT_SOURCE_DIR}/../../scripts/messages/message_template.msg
1351 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings/message_template.msg 1351 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/app_settings/message_template.msg
1352 COMMENT "Copying message_template.msg to the runtime folder." 1352 COMMENT "Copying message_template.msg to the runtime folder."
1353 ) 1353 )
1354 1354
@@ -1359,7 +1359,7 @@ if (WINDOWS)
1359 -E 1359 -E
1360 copy_if_different 1360 copy_if_different
1361 ${CMAKE_CURRENT_SOURCE_DIR}/../../etc/message.xml 1361 ${CMAKE_CURRENT_SOURCE_DIR}/../../etc/message.xml
1362 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings/message.xml 1362 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/app_settings/message.xml
1363 COMMENT "Copying message.xml to the runtime folder." 1363 COMMENT "Copying message.xml to the runtime folder."
1364 ) 1364 )
1365 1365
@@ -1370,11 +1370,11 @@ if (WINDOWS)
1370 endif (EXISTS ${CMAKE_SOURCE_DIR}/copy_win_scripts) 1370 endif (EXISTS ${CMAKE_SOURCE_DIR}/copy_win_scripts)
1371 1371
1372 add_custom_command( 1372 add_custom_command(
1373 OUTPUT ${CMAKE_CFG_INTDIR}/touched.bat 1373 OUTPUT ${VIEWER_CFG_INTDIR}/touched.bat
1374 COMMAND ${PYTHON_EXECUTABLE} 1374 COMMAND ${PYTHON_EXECUTABLE}
1375 ARGS 1375 ARGS
1376 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py 1376 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1377 --configuration=${CMAKE_CFG_INTDIR} 1377 --configuration=${VIEWER_CFG_INTDIR}
1378 --channel=${VIEWER_CHANNEL} 1378 --channel=${VIEWER_CHANNEL}
1379 --login_channel=${VIEWER_LOGIN_CHANNEL} 1379 --login_channel=${VIEWER_LOGIN_CHANNEL}
1380 --standalone=${STANDALONE} 1380 --standalone=${STANDALONE}
@@ -1383,15 +1383,15 @@ if (WINDOWS)
1383 --source=${CMAKE_CURRENT_SOURCE_DIR} 1383 --source=${CMAKE_CURRENT_SOURCE_DIR}
1384 --artwork=${ARTWORK_DIR} 1384 --artwork=${ARTWORK_DIR}
1385 --build=${CMAKE_CURRENT_BINARY_DIR} 1385 --build=${CMAKE_CURRENT_BINARY_DIR}
1386 --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/package 1386 --dest=${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/package
1387 --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/touched.bat 1387 --touch=${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/touched.bat
1388 DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py 1388 DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1389 ) 1389 )
1390 1390
1391 add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010) 1391 add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010)
1392 1392
1393 if (PACKAGE) 1393 if (PACKAGE)
1394 add_custom_target(package ALL DEPENDS ${CMAKE_CFG_INTDIR}/touched.bat) 1394 add_custom_target(package ALL DEPENDS ${VIEWER_CFG_INTDIR}/touched.bat)
1395 add_dependencies(package windows-updater windows-crash-logger) 1395 add_dependencies(package windows-updater windows-crash-logger)
1396 endif (PACKAGE) 1396 endif (PACKAGE)
1397endif (WINDOWS) 1397endif (WINDOWS)
@@ -1526,8 +1526,8 @@ if (DARWIN)
1526 --artwork=${ARTWORK_DIR} 1526 --artwork=${ARTWORK_DIR}
1527 --build=${CMAKE_CURRENT_BINARY_DIR} 1527 --build=${CMAKE_CURRENT_BINARY_DIR}
1528 --buildtype=${CMAKE_BUILD_TYPE} 1528 --buildtype=${CMAKE_BUILD_TYPE}
1529 --configuration=${CMAKE_CFG_INTDIR} 1529 --configuration=${VIEWER_CFG_INTDIR}
1530 --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app 1530 --dest=${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/${product}.app
1531 --grid=${GRID} 1531 --grid=${GRID}
1532 --source=${CMAKE_CURRENT_SOURCE_DIR} 1532 --source=${CMAKE_CURRENT_SOURCE_DIR}
1533 --standalone=${STANDALONE} 1533 --standalone=${STANDALONE}
@@ -1558,8 +1558,8 @@ if (WINDOWS)
1558 -E 1558 -E
1559 copy_if_different 1559 copy_if_different
1560 ${BUILT_LLCOMMON} 1560 ${BUILT_LLCOMMON}
1561 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR} 1561 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}
1562 COMMENT "Copying llcommon.dll to the runtime folder." 1562 COMMENT "Copying llcommon.dll to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}."
1563 ) 1563 )
1564 1564
1565 get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION) 1565 get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION)
@@ -1570,8 +1570,8 @@ if (WINDOWS)
1570 -E 1570 -E
1571 copy_if_different 1571 copy_if_different
1572 ${BUILT_SLPLUGIN} 1572 ${BUILT_SLPLUGIN}
1573 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR} 1573 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}
1574 COMMENT "Copying SLPlugin executable to the runtime folder." 1574 COMMENT "Copying SLPlugin executable to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}."
1575 ) 1575 )
1576 1576
1577 get_target_property(BUILT_WEBKIT_PLUGIN media_plugin_webkit LOCATION) 1577 get_target_property(BUILT_WEBKIT_PLUGIN media_plugin_webkit LOCATION)
@@ -1582,8 +1582,8 @@ if (WINDOWS)
1582 -E 1582 -E
1583 copy_if_different 1583 copy_if_different
1584 ${BUILT_WEBKIT_PLUGIN} 1584 ${BUILT_WEBKIT_PLUGIN}
1585 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin 1585 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin
1586 COMMENT "Copying WebKit Plugin to the runtime folder." 1586 COMMENT "Copying WebKit Plugin to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin."
1587 ) 1587 )
1588 1588
1589 get_target_property(BUILT_GSTREAMER_PLUGIN media_plugin_gstreamer010 LOCATION) 1589 get_target_property(BUILT_GSTREAMER_PLUGIN media_plugin_gstreamer010 LOCATION)
@@ -1594,8 +1594,8 @@ if (WINDOWS)
1594 -E 1594 -E
1595 copy_if_different 1595 copy_if_different
1596 ${BUILT_GSTREAMER_PLUGIN} 1596 ${BUILT_GSTREAMER_PLUGIN}
1597 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin 1597 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin
1598 COMMENT "Copying Gstreamer Plugin to the runtime folder." 1598 COMMENT "Copying Gstreamer Plugin to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin."
1599 ) 1599 )
1600 1600
1601 get_target_property(BUILT_QUICKTIME_PLUGIN media_plugin_quicktime LOCATION) 1601 get_target_property(BUILT_QUICKTIME_PLUGIN media_plugin_quicktime LOCATION)
@@ -1606,13 +1606,13 @@ if (WINDOWS)
1606 -E 1606 -E
1607 copy_if_different 1607 copy_if_different
1608 ${BUILT_QUICKTIME_PLUGIN} 1608 ${BUILT_QUICKTIME_PLUGIN}
1609 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin 1609 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin
1610 COMMENT "Copying Quicktime Plugin to the runtime folder." 1610 COMMENT "Copying Quicktime Plugin to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin."
1611 ) 1611 )
1612 1612
1613 # Copying the mime_types.xml file to app_settings 1613 # Copying the mime_types.xml file to app_settings
1614 set(mime_types_source "${CMAKE_SOURCE_DIR}/newview/skins/default/xui/en-us") 1614 set(mime_types_source "${CMAKE_SOURCE_DIR}/newview/skins/default/xui/en-us")
1615 set(mime_types_dest "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings") 1615 set(mime_types_dest "${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/app_settings")
1616 add_custom_command( 1616 add_custom_command(
1617 TARGET ${VIEWER_BINARY_NAME} POST_BUILD 1617 TARGET ${VIEWER_BINARY_NAME} POST_BUILD
1618 COMMAND ${CMAKE_COMMAND} 1618 COMMAND ${CMAKE_COMMAND}
@@ -1629,7 +1629,7 @@ endif (WINDOWS)
1629if (DARWIN) 1629if (DARWIN)
1630# Don't do this here -- it's taken care of by viewer_manifest.py 1630# Don't do this here -- it's taken care of by viewer_manifest.py
1631# add_custom_command(TARGET ${VIEWER_BINARY_NAME} POST_BUILD 1631# add_custom_command(TARGET ${VIEWER_BINARY_NAME} POST_BUILD
1632# COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin/ 1632# COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin/
1633# DEPENDS ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib 1633# DEPENDS ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib
1634# ) 1634# )
1635endif (DARWIN) 1635endif (DARWIN)