aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/media_plugins/webkit
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/media_plugins/webkit')
-rw-r--r--linden/indra/media_plugins/webkit/CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/linden/indra/media_plugins/webkit/CMakeLists.txt b/linden/indra/media_plugins/webkit/CMakeLists.txt
index 2ab4a95..303a774 100644
--- a/linden/indra/media_plugins/webkit/CMakeLists.txt
+++ b/linden/indra/media_plugins/webkit/CMakeLists.txt
@@ -2,10 +2,6 @@
2 2
3project(media_plugin_webkit) 3project(media_plugin_webkit)
4 4
5if(HAVE_64_BIT)
6 set(REQUIRE_PIC)
7endif(HAVE_64_BIT)
8
9include(00-Common) 5include(00-Common)
10include(LLCommon) 6include(LLCommon)
11include(LLImage) 7include(LLImage)
@@ -34,20 +30,12 @@ include_directories(
34 ${LLQTWEBKIT_INCLUDE_DIR} 30 ${LLQTWEBKIT_INCLUDE_DIR}
35) 31)
36 32
37
38### media_plugin_webkit 33### media_plugin_webkit
39 34
40set(media_plugin_webkit_SOURCE_FILES 35set(media_plugin_webkit_SOURCE_FILES
41 media_plugin_webkit.cpp 36 media_plugin_webkit.cpp
42 ) 37 )
43 38
44if(NOT CMAKE_SIZEOF_VOID_P MATCHES 4)
45 if(WINDOWS)
46 add_definitions(/FIXED:NO)
47 else(WINDOWS) # not windows therefore gcc LINUX and DARWIN
48 add_definitions(-fPIC)
49 endif(WINDOWS)
50endif (NOT CMAKE_SIZEOF_VOID_P MATCHES 4)
51set(media_plugin_webkit_HEADER_FILES 39set(media_plugin_webkit_HEADER_FILES
52 volume_catcher.h 40 volume_catcher.h
53 ) 41 )