diff options
Diffstat (limited to 'linden/indra/media_plugins/webkit/CMakeLists.txt')
-rw-r--r-- | linden/indra/media_plugins/webkit/CMakeLists.txt | 7 |
1 files changed, 7 insertions, 0 deletions
diff --git a/linden/indra/media_plugins/webkit/CMakeLists.txt b/linden/indra/media_plugins/webkit/CMakeLists.txt index 54bc364..1c999ba 100644 --- a/linden/indra/media_plugins/webkit/CMakeLists.txt +++ b/linden/indra/media_plugins/webkit/CMakeLists.txt | |||
@@ -9,6 +9,7 @@ include(LLPlugin) | |||
9 | include(LLMath) | 9 | include(LLMath) |
10 | include(LLRender) | 10 | include(LLRender) |
11 | include(LLWindow) | 11 | include(LLWindow) |
12 | include(UI) | ||
12 | include(Linking) | 13 | include(Linking) |
13 | include(PluginAPI) | 14 | include(PluginAPI) |
14 | include(MediaPluginBase) | 15 | include(MediaPluginBase) |
@@ -50,6 +51,11 @@ set(media_plugin_webkit_LINK_LIBRARIES | |||
50 | ${PLUGIN_API_WINDOWS_LIBRARIES} | 51 | ${PLUGIN_API_WINDOWS_LIBRARIES} |
51 | ) | 52 | ) |
52 | 53 | ||
54 | if(LINUX) | ||
55 | list(APPEND media_plugin_webkit_LINK_LIBRARIES | ||
56 | ${UI_LIBRARIES} # for glib/GTK | ||
57 | ) | ||
58 | endif(LINUX) | ||
53 | 59 | ||
54 | 60 | ||
55 | add_library(media_plugin_webkit | 61 | add_library(media_plugin_webkit |
@@ -93,3 +99,4 @@ if (DARWIN) | |||
93 | ) | 99 | ) |
94 | 100 | ||
95 | endif (DARWIN) | 101 | endif (DARWIN) |
102 | |||