diff options
Diffstat (limited to 'linden/indra/mac_updater')
-rw-r--r-- | linden/indra/mac_updater/CMakeLists.txt | 13 | ||||
-rw-r--r-- | linden/indra/mac_updater/FSCopyObject.h | 2 | ||||
-rw-r--r-- | linden/indra/mac_updater/GenLinkedList.h | 2 | ||||
-rw-r--r-- | linden/indra/mac_updater/MoreFilesX.h | 2 | ||||
-rw-r--r-- | linden/indra/mac_updater/mac_updater.cpp | 2 |
5 files changed, 9 insertions, 12 deletions
diff --git a/linden/indra/mac_updater/CMakeLists.txt b/linden/indra/mac_updater/CMakeLists.txt index ef87b29..0eac76f 100644 --- a/linden/indra/mac_updater/CMakeLists.txt +++ b/linden/indra/mac_updater/CMakeLists.txt | |||
@@ -42,7 +42,6 @@ list(APPEND mac_updater_SOURCE_FILES ${mac_updater_HEADER_FILES}) | |||
42 | 42 | ||
43 | 43 | ||
44 | set(mac_updater_RESOURCE_FILES | 44 | set(mac_updater_RESOURCE_FILES |
45 | Info.plist | ||
46 | AutoUpdater.nib/ | 45 | AutoUpdater.nib/ |
47 | ) | 46 | ) |
48 | set_source_files_properties( | 47 | set_source_files_properties( |
@@ -50,19 +49,18 @@ set_source_files_properties( | |||
50 | PROPERTIES | 49 | PROPERTIES |
51 | HEADER_FILE_ONLY TRUE | 50 | HEADER_FILE_ONLY TRUE |
52 | ) | 51 | ) |
53 | set_source_files_properties( | ||
54 | Info.plist | ||
55 | PROPERTIES | ||
56 | MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist | ||
57 | ) | ||
58 | SOURCE_GROUP("Resources" FILES ${mac_updater_RESOURCE_FILES}) | 52 | SOURCE_GROUP("Resources" FILES ${mac_updater_RESOURCE_FILES}) |
59 | list(APPEND mac_updater_SOURCE_FILES ${mac_updater_RESOURCE_FILES}) | 53 | list(APPEND mac_updater_SOURCE_FILES ${mac_updater_RESOURCE_FILES}) |
60 | 54 | ||
61 | |||
62 | add_executable(mac-updater | 55 | add_executable(mac-updater |
63 | MACOSX_BUNDLE | 56 | MACOSX_BUNDLE |
64 | ${mac_updater_SOURCE_FILES}) | 57 | ${mac_updater_SOURCE_FILES}) |
65 | 58 | ||
59 | set_target_properties(mac-updater | ||
60 | PROPERTIES | ||
61 | MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist | ||
62 | ) | ||
63 | |||
66 | target_link_libraries(mac-updater | 64 | target_link_libraries(mac-updater |
67 | ${LLVFS_LIBRARIES} | 65 | ${LLVFS_LIBRARIES} |
68 | ${CURL_LIBRARIES} | 66 | ${CURL_LIBRARIES} |
@@ -79,4 +77,3 @@ add_custom_command( | |||
79 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib | 77 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib |
80 | ) | 78 | ) |
81 | 79 | ||
82 | |||
diff --git a/linden/indra/mac_updater/FSCopyObject.h b/linden/indra/mac_updater/FSCopyObject.h index 1781fc4..c9b76f7 100644 --- a/linden/indra/mac_updater/FSCopyObject.h +++ b/linden/indra/mac_updater/FSCopyObject.h | |||
@@ -4,7 +4,7 @@ | |||
4 | * | 4 | * |
5 | * $LicenseInfo:firstyear=2004&license=viewergpl$ | 5 | * $LicenseInfo:firstyear=2004&license=viewergpl$ |
6 | * | 6 | * |
7 | * Copyright (c) 2004-2008, Linden Research, Inc. | 7 | * Copyright (c) 2004-2009, Linden Research, Inc. |
8 | * | 8 | * |
9 | * Second Life Viewer Source Code | 9 | * Second Life Viewer Source Code |
10 | * The source code in this file ("Source Code") is provided by Linden Lab | 10 | * The source code in this file ("Source Code") is provided by Linden Lab |
diff --git a/linden/indra/mac_updater/GenLinkedList.h b/linden/indra/mac_updater/GenLinkedList.h index b96cd23..3db9bdd 100644 --- a/linden/indra/mac_updater/GenLinkedList.h +++ b/linden/indra/mac_updater/GenLinkedList.h | |||
@@ -4,7 +4,7 @@ | |||
4 | * | 4 | * |
5 | * $LicenseInfo:firstyear=2004&license=viewergpl$ | 5 | * $LicenseInfo:firstyear=2004&license=viewergpl$ |
6 | * | 6 | * |
7 | * Copyright (c) 2004-2008, Linden Research, Inc. | 7 | * Copyright (c) 2004-2009, Linden Research, Inc. |
8 | * | 8 | * |
9 | * Second Life Viewer Source Code | 9 | * Second Life Viewer Source Code |
10 | * The source code in this file ("Source Code") is provided by Linden Lab | 10 | * The source code in this file ("Source Code") is provided by Linden Lab |
diff --git a/linden/indra/mac_updater/MoreFilesX.h b/linden/indra/mac_updater/MoreFilesX.h index b6793db..bcc299a 100644 --- a/linden/indra/mac_updater/MoreFilesX.h +++ b/linden/indra/mac_updater/MoreFilesX.h | |||
@@ -4,7 +4,7 @@ | |||
4 | * | 4 | * |
5 | * $LicenseInfo:firstyear=2004&license=viewergpl$ | 5 | * $LicenseInfo:firstyear=2004&license=viewergpl$ |
6 | * | 6 | * |
7 | * Copyright (c) 2004-2008, Linden Research, Inc. | 7 | * Copyright (c) 2004-2009, Linden Research, Inc. |
8 | * | 8 | * |
9 | * Second Life Viewer Source Code | 9 | * Second Life Viewer Source Code |
10 | * The source code in this file ("Source Code") is provided by Linden Lab | 10 | * The source code in this file ("Source Code") is provided by Linden Lab |
diff --git a/linden/indra/mac_updater/mac_updater.cpp b/linden/indra/mac_updater/mac_updater.cpp index 7bffff5..b78d029 100644 --- a/linden/indra/mac_updater/mac_updater.cpp +++ b/linden/indra/mac_updater/mac_updater.cpp | |||
@@ -4,7 +4,7 @@ | |||
4 | * | 4 | * |
5 | * $LicenseInfo:firstyear=2006&license=viewergpl$ | 5 | * $LicenseInfo:firstyear=2006&license=viewergpl$ |
6 | * | 6 | * |
7 | * Copyright (c) 2006-2008, Linden Research, Inc. | 7 | * Copyright (c) 2006-2009, Linden Research, Inc. |
8 | * | 8 | * |
9 | * Second Life Viewer Source Code | 9 | * Second Life Viewer Source Code |
10 | * The source code in this file ("Source Code") is provided by Linden Lab | 10 | * The source code in this file ("Source Code") is provided by Linden Lab |