aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/mac_updater
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/mac_updater')
-rw-r--r--linden/indra/mac_updater/CMakeLists.txt2
-rw-r--r--linden/indra/mac_updater/mac_updater.cpp6
2 files changed, 4 insertions, 4 deletions
diff --git a/linden/indra/mac_updater/CMakeLists.txt b/linden/indra/mac_updater/CMakeLists.txt
index 0eac76f..5ae7dd8 100644
--- a/linden/indra/mac_updater/CMakeLists.txt
+++ b/linden/indra/mac_updater/CMakeLists.txt
@@ -74,6 +74,6 @@ add_custom_command(
74 -E 74 -E
75 copy_directory 75 copy_directory
76 ${CMAKE_CURRENT_SOURCE_DIR}/AutoUpdater.nib 76 ${CMAKE_CURRENT_SOURCE_DIR}/AutoUpdater.nib
77 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib 77 ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib
78 ) 78 )
79 79
diff --git a/linden/indra/mac_updater/mac_updater.cpp b/linden/indra/mac_updater/mac_updater.cpp
index 43d9955..79783d3 100644
--- a/linden/indra/mac_updater/mac_updater.cpp
+++ b/linden/indra/mac_updater/mac_updater.cpp
@@ -68,8 +68,8 @@ EventHandlerRef gEventHandler = NULL;
68OSStatus gFailure = noErr; 68OSStatus gFailure = noErr;
69Boolean gCancelled = false; 69Boolean gCancelled = false;
70 70
71char *gUpdateURL; 71const char *gUpdateURL;
72char *gProductName; 72const char *gProductName;
73 73
74void *updatethreadproc(void*); 74void *updatethreadproc(void*);
75 75
@@ -1032,7 +1032,7 @@ void *updatethreadproc(void*)
1032 if(!mountOutput.empty()) 1032 if(!mountOutput.empty())
1033 { 1033 {
1034 const char *s = mountOutput.c_str(); 1034 const char *s = mountOutput.c_str();
1035 char *prefix = "/dev/"; 1035 const char *prefix = "/dev/";
1036 char *sub = strstr(s, prefix); 1036 char *sub = strstr(s, prefix);
1037 1037
1038 if(sub != NULL) 1038 if(sub != NULL)