diff options
Diffstat (limited to 'linden/indra/mac_crash_logger/CMakeLists.txt')
-rw-r--r-- | linden/indra/mac_crash_logger/CMakeLists.txt | 13 |
1 files changed, 5 insertions, 8 deletions
diff --git a/linden/indra/mac_crash_logger/CMakeLists.txt b/linden/indra/mac_crash_logger/CMakeLists.txt index 371b6fb..daf3e10 100644 --- a/linden/indra/mac_crash_logger/CMakeLists.txt +++ b/linden/indra/mac_crash_logger/CMakeLists.txt | |||
@@ -3,7 +3,6 @@ | |||
3 | project(mac_crash_logger) | 3 | project(mac_crash_logger) |
4 | 4 | ||
5 | include(00-Common) | 5 | include(00-Common) |
6 | include(Boost) | ||
7 | include(LLCommon) | 6 | include(LLCommon) |
8 | include(LLCrashLogger) | 7 | include(LLCrashLogger) |
9 | include(LLMath) | 8 | include(LLMath) |
@@ -36,7 +35,6 @@ set_source_files_properties(${mac_crash_logger_HEADER_FILES} | |||
36 | list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_HEADER_FILES}) | 35 | list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_HEADER_FILES}) |
37 | 36 | ||
38 | set(mac_crash_logger_RESOURCE_FILES | 37 | set(mac_crash_logger_RESOURCE_FILES |
39 | Info.plist | ||
40 | CrashReporter.nib/ | 38 | CrashReporter.nib/ |
41 | ) | 39 | ) |
42 | set_source_files_properties( | 40 | set_source_files_properties( |
@@ -44,11 +42,6 @@ set_source_files_properties( | |||
44 | PROPERTIES | 42 | PROPERTIES |
45 | HEADER_FILE_ONLY TRUE | 43 | HEADER_FILE_ONLY TRUE |
46 | ) | 44 | ) |
47 | set_source_files_properties( | ||
48 | Info.plist | ||
49 | PROPERTIES | ||
50 | MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist | ||
51 | ) | ||
52 | SOURCE_GROUP("Resources" FILES ${mac_crash_logger_RESOURCE_FILES}) | 45 | SOURCE_GROUP("Resources" FILES ${mac_crash_logger_RESOURCE_FILES}) |
53 | list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_RESOURCE_FILES}) | 46 | list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_RESOURCE_FILES}) |
54 | 47 | ||
@@ -56,6 +49,11 @@ add_executable(mac-crash-logger | |||
56 | MACOSX_BUNDLE | 49 | MACOSX_BUNDLE |
57 | ${mac_crash_logger_SOURCE_FILES}) | 50 | ${mac_crash_logger_SOURCE_FILES}) |
58 | 51 | ||
52 | set_target_properties(mac-crash-logger | ||
53 | PROPERTIES | ||
54 | MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist | ||
55 | ) | ||
56 | |||
59 | target_link_libraries(mac-crash-logger | 57 | target_link_libraries(mac-crash-logger |
60 | ${LLCRASHLOGGER_LIBRARIES} | 58 | ${LLCRASHLOGGER_LIBRARIES} |
61 | ${LLVFS_LIBRARIES} | 59 | ${LLVFS_LIBRARIES} |
@@ -64,7 +62,6 @@ target_link_libraries(mac-crash-logger | |||
64 | ${LLVFS_LIBRARIES} | 62 | ${LLVFS_LIBRARIES} |
65 | ${LLMATH_LIBRARIES} | 63 | ${LLMATH_LIBRARIES} |
66 | ${LLCOMMON_LIBRARIES} | 64 | ${LLCOMMON_LIBRARIES} |
67 | ${BOOST_SIGNALS_LIBRARY} | ||
68 | ) | 65 | ) |
69 | 66 | ||
70 | add_custom_command( | 67 | add_custom_command( |