diff options
Diffstat (limited to 'linden/indra/llmedia/CMakeLists.txt')
-rw-r--r-- | linden/indra/llmedia/CMakeLists.txt | 20 |
1 files changed, 6 insertions, 14 deletions
diff --git a/linden/indra/llmedia/CMakeLists.txt b/linden/indra/llmedia/CMakeLists.txt index 8ef8006..026afc1 100644 --- a/linden/indra/llmedia/CMakeLists.txt +++ b/linden/indra/llmedia/CMakeLists.txt | |||
@@ -29,6 +29,9 @@ set(llmedia_SOURCE_FILES | |||
29 | llmediaimplexample2.cpp | 29 | llmediaimplexample2.cpp |
30 | llmediaimplfactory.cpp | 30 | llmediaimplfactory.cpp |
31 | llmediamanager.cpp | 31 | llmediamanager.cpp |
32 | llmediaimplgstreamer.cpp | ||
33 | llmediaimplgstreamer_syms.cpp | ||
34 | llmediaimplgstreamervidplug.cpp | ||
32 | ) | 35 | ) |
33 | 36 | ||
34 | set(llmedia_HEADER_FILES | 37 | set(llmedia_HEADER_FILES |
@@ -43,21 +46,11 @@ set(llmedia_HEADER_FILES | |||
43 | llmediaimplregister.h | 46 | llmediaimplregister.h |
44 | llmediamanager.h | 47 | llmediamanager.h |
45 | llmediaobserver.h | 48 | llmediaobserver.h |
49 | llmediaimplgstreamer.h | ||
50 | llmediaimplgstreamervidplug.h | ||
51 | llmediaimplgstreamer_syms.h | ||
46 | ) | 52 | ) |
47 | 53 | ||
48 | if (GSTREAMER) | ||
49 | list(APPEND llmedia_SOURCE_FILES | ||
50 | llmediaimplgstreamer.cpp | ||
51 | llmediaimplgstreamer_syms.cpp | ||
52 | llmediaimplgstreamervidplug.cpp | ||
53 | ) | ||
54 | |||
55 | list(APPEND llmedia_HEADER_FILES | ||
56 | llmediaimplgstreamer.h | ||
57 | llmediaimplgstreamervidplug.h | ||
58 | llmediaimplgstreamer_syms.h | ||
59 | ) | ||
60 | |||
61 | # Work around a bad interaction between broken gstreamer headers and | 54 | # Work around a bad interaction between broken gstreamer headers and |
62 | # g++ 4.3's increased strictness. | 55 | # g++ 4.3's increased strictness. |
63 | 56 | ||
@@ -65,7 +58,6 @@ if (GSTREAMER) | |||
65 | set_source_files_properties(llmediaimplgstreamervidplug.cpp PROPERTIES | 58 | set_source_files_properties(llmediaimplgstreamervidplug.cpp PROPERTIES |
66 | COMPILE_FLAGS -Wno-error=write-strings) | 59 | COMPILE_FLAGS -Wno-error=write-strings) |
67 | endif (${CXX_VERSION} MATCHES "4.[23]") | 60 | endif (${CXX_VERSION} MATCHES "4.[23]") |
68 | endif (GSTREAMER) | ||
69 | 61 | ||
70 | if (MOZLIB) | 62 | if (MOZLIB) |
71 | list(APPEND llmedia_SOURCE_FILES llmediaimplllmozlib.cpp) | 63 | list(APPEND llmedia_SOURCE_FILES llmediaimplllmozlib.cpp) |