diff options
Diffstat (limited to 'linden/indra/llimagej2coj')
-rw-r--r-- | linden/indra/llimagej2coj/CMakeLists.txt | 31 | ||||
-rw-r--r-- | linden/indra/llimagej2coj/files.lst | 1 | ||||
-rw-r--r-- | linden/indra/llimagej2coj/llimagej2coj.cpp | 6 | ||||
-rwxr-xr-x | linden/indra/llimagej2coj/llimagej2coj.vcproj | 161 |
4 files changed, 34 insertions, 165 deletions
diff --git a/linden/indra/llimagej2coj/CMakeLists.txt b/linden/indra/llimagej2coj/CMakeLists.txt new file mode 100644 index 0000000..ed3ff3c --- /dev/null +++ b/linden/indra/llimagej2coj/CMakeLists.txt | |||
@@ -0,0 +1,31 @@ | |||
1 | # -*- cmake -*- | ||
2 | |||
3 | project(llimagej2coj) | ||
4 | |||
5 | include(00-Common) | ||
6 | include(LLCommon) | ||
7 | include(LLImage) | ||
8 | include(OpenJPEG) | ||
9 | |||
10 | include_directories( | ||
11 | ${LLCOMMON_INCLUDE_DIRS} | ||
12 | ${LLIMAGE_INCLUDE_DIRS} | ||
13 | ${OPENJPEG_INCLUDE_DIR} | ||
14 | ) | ||
15 | |||
16 | set(llimagej2coj_SOURCE_FILES | ||
17 | llimagej2coj.cpp | ||
18 | ) | ||
19 | |||
20 | set(llimagej2coj_HEADER_FILES | ||
21 | CMakeLists.txt | ||
22 | |||
23 | llimagej2coj.h | ||
24 | ) | ||
25 | |||
26 | set_source_files_properties(${llimagej2coj_HEADER_FILES} | ||
27 | PROPERTIES HEADER_FILE_ONLY TRUE) | ||
28 | |||
29 | list(APPEND llimagej2coj_SOURCE_FILES ${llimagej2coj_HEADER_FILES}) | ||
30 | |||
31 | add_library (llimagej2coj ${llimagej2coj_SOURCE_FILES}) | ||
diff --git a/linden/indra/llimagej2coj/files.lst b/linden/indra/llimagej2coj/files.lst deleted file mode 100644 index bbf359c..0000000 --- a/linden/indra/llimagej2coj/files.lst +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | llimagej2coj/llimagej2coj.cpp | ||
diff --git a/linden/indra/llimagej2coj/llimagej2coj.cpp b/linden/indra/llimagej2coj/llimagej2coj.cpp index 478cc84..983241c 100644 --- a/linden/indra/llimagej2coj/llimagej2coj.cpp +++ b/linden/indra/llimagej2coj/llimagej2coj.cpp | |||
@@ -33,7 +33,7 @@ | |||
33 | #include "llimagej2coj.h" | 33 | #include "llimagej2coj.h" |
34 | 34 | ||
35 | // this is defined so that we get static linking. | 35 | // this is defined so that we get static linking. |
36 | #include "openjpeg/openjpeg.h" | 36 | #include "openjpeg.h" |
37 | 37 | ||
38 | #include "lltimer.h" | 38 | #include "lltimer.h" |
39 | #include "llmemory.h" | 39 | #include "llmemory.h" |
@@ -268,12 +268,12 @@ BOOL LLImageJ2COJ::encodeImpl(LLImageJ2C &base, const LLImageRaw &raw_image, con | |||
268 | 268 | ||
269 | if (!comment_text) | 269 | if (!comment_text) |
270 | { | 270 | { |
271 | parameters.cp_comment = ""; | 271 | parameters.cp_comment = (char *) ""; |
272 | } | 272 | } |
273 | else | 273 | else |
274 | { | 274 | { |
275 | // Awful hacky cast, too lazy to copy right now. | 275 | // Awful hacky cast, too lazy to copy right now. |
276 | parameters.cp_comment = (char *)comment_text; | 276 | parameters.cp_comment = (char *) comment_text; |
277 | } | 277 | } |
278 | 278 | ||
279 | // | 279 | // |
diff --git a/linden/indra/llimagej2coj/llimagej2coj.vcproj b/linden/indra/llimagej2coj/llimagej2coj.vcproj deleted file mode 100755 index 637c81f..0000000 --- a/linden/indra/llimagej2coj/llimagej2coj.vcproj +++ /dev/null | |||
@@ -1,161 +0,0 @@ | |||
1 | <?xml version="1.0" encoding="Windows-1252"?> | ||
2 | <VisualStudioProject | ||
3 | ProjectType="Visual C++" | ||
4 | Version="7.10" | ||
5 | Name="llimagej2coj" | ||
6 | ProjectGUID="{4C8D64D5-649F-481E-96BE-EF1E82A77ACB}" | ||
7 | Keyword="CustomAppWizProj"> | ||
8 | <Platforms> | ||
9 | <Platform | ||
10 | Name="Win32"/> | ||
11 | </Platforms> | ||
12 | <Configurations> | ||
13 | <Configuration | ||
14 | Name="Debug|Win32" | ||
15 | OutputDirectory="../lib_$(ConfigurationName)/i686-win32" | ||
16 | IntermediateDirectory="$(ConfigurationName)" | ||
17 | ConfigurationType="4"> | ||
18 | <Tool | ||
19 | Name="VCCLCompilerTool" | ||
20 | Optimization="0" | ||
21 | AdditionalIncludeDirectories="..\llcommon;..\llmath; ..\llimage; ..\..\libraries\i686-win32\include;..\..\libraries\include\" | ||
22 | PreprocessorDefinitions="WIN32;_DEBUG;_LIB;LL_WINDOWS;LL_DEBUG" | ||
23 | MinimalRebuild="TRUE" | ||
24 | BasicRuntimeChecks="3" | ||
25 | RuntimeLibrary="1" | ||
26 | StructMemberAlignment="4" | ||
27 | ForceConformanceInForLoopScope="TRUE" | ||
28 | WarningLevel="3" | ||
29 | WarnAsError="TRUE" | ||
30 | DebugInformationFormat="4"/> | ||
31 | <Tool | ||
32 | Name="VCCustomBuildTool"/> | ||
33 | <Tool | ||
34 | Name="VCLibrarianTool"/> | ||
35 | <Tool | ||
36 | Name="VCMIDLTool"/> | ||
37 | <Tool | ||
38 | Name="VCPostBuildEventTool"/> | ||
39 | <Tool | ||
40 | Name="VCPreBuildEventTool"/> | ||
41 | <Tool | ||
42 | Name="VCPreLinkEventTool"/> | ||
43 | <Tool | ||
44 | Name="VCResourceCompilerTool"/> | ||
45 | <Tool | ||
46 | Name="VCWebServiceProxyGeneratorTool"/> | ||
47 | <Tool | ||
48 | Name="VCXMLDataGeneratorTool"/> | ||
49 | <Tool | ||
50 | Name="VCManagedWrapperGeneratorTool"/> | ||
51 | <Tool | ||
52 | Name="VCAuxiliaryManagedWrapperGeneratorTool"/> | ||
53 | </Configuration> | ||
54 | <Configuration | ||
55 | Name="Release|Win32" | ||
56 | OutputDirectory="../lib_$(ConfigurationName)/i686-win32" | ||
57 | IntermediateDirectory="$(ConfigurationName)" | ||
58 | ConfigurationType="4"> | ||
59 | <Tool | ||
60 | Name="VCCLCompilerTool" | ||
61 | AdditionalOptions="/Oy-" | ||
62 | GlobalOptimizations="TRUE" | ||
63 | InlineFunctionExpansion="2" | ||
64 | EnableIntrinsicFunctions="TRUE" | ||
65 | OptimizeForProcessor="3" | ||
66 | OptimizeForWindowsApplication="TRUE" | ||
67 | AdditionalIncludeDirectories="..\llcommon;..\llmath; ..\llimage; ..\..\libraries\i686-win32\include;..\..\libraries\include\" | ||
68 | PreprocessorDefinitions="WIN32;NDEBUG;_LIB;LL_WINDOWS;LL_RELEASE" | ||
69 | RuntimeLibrary="0" | ||
70 | ForceConformanceInForLoopScope="TRUE" | ||
71 | WarningLevel="3" | ||
72 | DebugInformationFormat="3"/> | ||
73 | <Tool | ||
74 | Name="VCCustomBuildTool"/> | ||
75 | <Tool | ||
76 | Name="VCLibrarianTool"/> | ||
77 | <Tool | ||
78 | Name="VCMIDLTool"/> | ||
79 | <Tool | ||
80 | Name="VCPostBuildEventTool"/> | ||
81 | <Tool | ||
82 | Name="VCPreBuildEventTool"/> | ||
83 | <Tool | ||
84 | Name="VCPreLinkEventTool"/> | ||
85 | <Tool | ||
86 | Name="VCResourceCompilerTool"/> | ||
87 | <Tool | ||
88 | Name="VCWebServiceProxyGeneratorTool"/> | ||
89 | <Tool | ||
90 | Name="VCXMLDataGeneratorTool"/> | ||
91 | <Tool | ||
92 | Name="VCManagedWrapperGeneratorTool"/> | ||
93 | <Tool | ||
94 | Name="VCAuxiliaryManagedWrapperGeneratorTool"/> | ||
95 | </Configuration> | ||
96 | <Configuration | ||
97 | Name="ReleaseNoOpt|Win32" | ||
98 | OutputDirectory="../lib_$(ConfigurationName)/i686-win32" | ||
99 | IntermediateDirectory="$(ConfigurationName)" | ||
100 | ConfigurationType="4"> | ||
101 | <Tool | ||
102 | Name="VCCLCompilerTool" | ||
103 | AdditionalOptions="/Oy-" | ||
104 | Optimization="0" | ||
105 | GlobalOptimizations="FALSE" | ||
106 | InlineFunctionExpansion="0" | ||
107 | EnableIntrinsicFunctions="FALSE" | ||
108 | OptimizeForProcessor="0" | ||
109 | OptimizeForWindowsApplication="FALSE" | ||
110 | AdditionalIncludeDirectories="..\llcommon;..\llmath; ..\llimage; ..\..\libraries\i686-win32\include;..\..\libraries\include\" | ||
111 | PreprocessorDefinitions="WIN32;NDEBUG;_LIB;LL_WINDOWS;LL_RELEASE" | ||
112 | RuntimeLibrary="0" | ||
113 | ForceConformanceInForLoopScope="TRUE" | ||
114 | WarningLevel="3" | ||
115 | WarnAsError="TRUE" | ||
116 | DebugInformationFormat="3"/> | ||
117 | <Tool | ||
118 | Name="VCCustomBuildTool"/> | ||
119 | <Tool | ||
120 | Name="VCLibrarianTool"/> | ||
121 | <Tool | ||
122 | Name="VCMIDLTool"/> | ||
123 | <Tool | ||
124 | Name="VCPostBuildEventTool"/> | ||
125 | <Tool | ||
126 | Name="VCPreBuildEventTool"/> | ||
127 | <Tool | ||
128 | Name="VCPreLinkEventTool"/> | ||
129 | <Tool | ||
130 | Name="VCResourceCompilerTool"/> | ||
131 | <Tool | ||
132 | Name="VCWebServiceProxyGeneratorTool"/> | ||
133 | <Tool | ||
134 | Name="VCXMLDataGeneratorTool"/> | ||
135 | <Tool | ||
136 | Name="VCManagedWrapperGeneratorTool"/> | ||
137 | <Tool | ||
138 | Name="VCAuxiliaryManagedWrapperGeneratorTool"/> | ||
139 | </Configuration> | ||
140 | </Configurations> | ||
141 | <References> | ||
142 | </References> | ||
143 | <Files> | ||
144 | <Filter | ||
145 | Name="Source Files" | ||
146 | Filter=""> | ||
147 | <File | ||
148 | RelativePath=".\llimagej2coj.cpp"> | ||
149 | </File> | ||
150 | </Filter> | ||
151 | <Filter | ||
152 | Name="Header Files" | ||
153 | Filter=""> | ||
154 | <File | ||
155 | RelativePath=".\llimagej2coj.h"> | ||
156 | </File> | ||
157 | </Filter> | ||
158 | </Files> | ||
159 | <Globals> | ||
160 | </Globals> | ||
161 | </VisualStudioProject> | ||