diff options
Diffstat (limited to 'linden/indra/llcommon/CMakeLists.txt')
-rw-r--r-- | linden/indra/llcommon/CMakeLists.txt | 22 |
1 files changed, 22 insertions, 0 deletions
diff --git a/linden/indra/llcommon/CMakeLists.txt b/linden/indra/llcommon/CMakeLists.txt index beacce3..7d001ae 100644 --- a/linden/indra/llcommon/CMakeLists.txt +++ b/linden/indra/llcommon/CMakeLists.txt | |||
@@ -44,6 +44,7 @@ set(llcommon_SOURCE_FILES | |||
44 | llmetrics.cpp | 44 | llmetrics.cpp |
45 | llmortician.cpp | 45 | llmortician.cpp |
46 | llprocessor.cpp | 46 | llprocessor.cpp |
47 | llprocesslauncher.cpp | ||
47 | llqueuedthread.cpp | 48 | llqueuedthread.cpp |
48 | llrand.cpp | 49 | llrand.cpp |
49 | llrun.cpp | 50 | llrun.cpp |
@@ -138,6 +139,7 @@ set(llcommon_HEADER_FILES | |||
138 | llnametable.h | 139 | llnametable.h |
139 | llpreprocessor.h | 140 | llpreprocessor.h |
140 | llpriqueuemap.h | 141 | llpriqueuemap.h |
142 | llprocesslauncher.h | ||
141 | llprocessor.h | 143 | llprocessor.h |
142 | llptrskiplist.h | 144 | llptrskiplist.h |
143 | llptrskipmap.h | 145 | llptrskipmap.h |
@@ -198,3 +200,23 @@ target_link_libraries( | |||
198 | ${EXPAT_LIBRARIES} | 200 | ${EXPAT_LIBRARIES} |
199 | ${ZLIB_LIBRARIES} | 201 | ${ZLIB_LIBRARIES} |
200 | ) | 202 | ) |
203 | |||
204 | if(HAVE_64_BIT) | ||
205 | add_library (llcommonPIC ${llcommon_SOURCE_FILES}) | ||
206 | add_dependencies(llcommonPIC prepare) | ||
207 | |||
208 | if(WINDOWS) | ||
209 | add_definitions(/FIXED:NO) | ||
210 | else(WINDOWS) # not windows therefore gcc LINUX and DARWIN | ||
211 | add_definitions(-fPIC) | ||
212 | endif(WINDOWS) | ||
213 | |||
214 | target_link_libraries( | ||
215 | llcommonPIC | ||
216 | ${APRUTIL_LIBRARIES} | ||
217 | ${APR_LIBRARIES} | ||
218 | ${EXPAT_LIBRARIES} | ||
219 | ${ZLIB_LIBRARIES} | ||
220 | ) | ||
221 | endif(HAVE_64_BIT) | ||
222 | |||