diff options
Diffstat (limited to 'linden/indra/libotr')
-rw-r--r-- | linden/indra/libotr/CMakeLists.txt | 10 |
1 files changed, 7 insertions, 3 deletions
diff --git a/linden/indra/libotr/CMakeLists.txt b/linden/indra/libotr/CMakeLists.txt index f81e71a..b9da8f1 100644 --- a/linden/indra/libotr/CMakeLists.txt +++ b/linden/indra/libotr/CMakeLists.txt | |||
@@ -1,5 +1,7 @@ | |||
1 | # -*- cmake -*- | 1 | # -*- cmake -*- |
2 | 2 | ||
3 | project(libgpg-error) | ||
4 | project(libgcrypt) | ||
3 | project(libotr) | 5 | project(libotr) |
4 | 6 | ||
5 | if (WINDOWS) | 7 | if (WINDOWS) |
@@ -12,7 +14,8 @@ if (WINDOWS) | |||
12 | ) | 14 | ) |
13 | else (WINDOWS) | 15 | else (WINDOWS) |
14 | include_directories( | 16 | include_directories( |
15 | ../libgpg-error/libgpg-error-1.0/src | 17 | ${LIBGPG-ERROR_INCLUDE_DIRS} |
18 | ${LIBGCRYPT_INCLUDE_DIRS} | ||
16 | ../libgcrypt/libgcrypt-1.2.2/src | 19 | ../libgcrypt/libgcrypt-1.2.2/src |
17 | ) | 20 | ) |
18 | endif (WINDOWS) | 21 | endif (WINDOWS) |
@@ -56,6 +59,7 @@ set_source_files_properties(${libotr_HEADER_FILES} | |||
56 | list(APPEND libotr_SOURCE_FILES ${libotr_HEADER_FILES}) | 59 | list(APPEND libotr_SOURCE_FILES ${libotr_HEADER_FILES}) |
57 | 60 | ||
58 | add_library (libotr ${libotr_SOURCE_FILES}) | 61 | add_library (libotr ${libotr_SOURCE_FILES}) |
59 | target_link_libraries( | 62 | target_link_libraries(libotr |
60 | libotr | 63 | gcrypt |
64 | gpg-error | ||
61 | ) | 65 | ) |