aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/libotr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/libotr/CMakeLists.txt')
-rwxr-xr-xlinden/indra/libotr/CMakeLists.txt61
1 files changed, 61 insertions, 0 deletions
diff --git a/linden/indra/libotr/CMakeLists.txt b/linden/indra/libotr/CMakeLists.txt
new file mode 100755
index 0000000..974a68f
--- /dev/null
+++ b/linden/indra/libotr/CMakeLists.txt
@@ -0,0 +1,61 @@
1# -*- cmake -*-
2
3project(libotr)
4
5if (WINDOWS)
6 include_directories(
7 ../gpg.vs/inc.vs
8 ../gpg.vs/libgpg-error-1.1.vs/custom
9 ../gpg.vs/libgcrypt-1.2.2.vs/custom
10 ../libgpg-error/libgpg-error-1.0/src
11 ../libgcrypt/libgcrypt-1.2.2/src
12 )
13else (WINDOWS)
14 include_directories(
15 ../libgpg-error/libgpg-error-1.0/src
16 ../libgcrypt/libgcrypt-1.2.2/src
17 )
18endif (WINDOWS)
19
20set(libotr_SOURCE_FILES
21 libotr-3.2.0/src/auth.c
22 libotr-3.2.0/src/b64.c
23 libotr-3.2.0/src/context.c
24 libotr-3.2.0/src/dh.c
25 libotr-3.2.0/src/mem.c
26 libotr-3.2.0/src/message.c
27 libotr-3.2.0/src/privkey.c
28 libotr-3.2.0/src/proto.c
29 libotr-3.2.0/src/sm.c
30 libotr-3.2.0/src/tlv.c
31 libotr-3.2.0/src/userstate.c
32 )
33
34set(libotr_HEADER_FILES
35 CMakeLists.txt
36
37 libotr-3.2.0/src/auth.h
38 libotr-3.2.0/src/b64.h
39 libotr-3.2.0/src/context.h
40 libotr-3.2.0/src/dh.h
41 libotr-3.2.0/src/mem.h
42 libotr-3.2.0/src/message.h
43 libotr-3.2.0/src/privkey-t.h
44 libotr-3.2.0/src/privkey.h
45 libotr-3.2.0/src/proto.h
46 libotr-3.2.0/src/serial.h
47 libotr-3.2.0/src/sm.h
48 libotr-3.2.0/src/tlv.h
49 libotr-3.2.0/src/userstate.h
50 libotr-3.2.0/src/version.h
51 )
52
53set_source_files_properties(${libotr_HEADER_FILES}
54 PROPERTIES HEADER_FILE_ONLY TRUE)
55
56list(APPEND libotr_SOURCE_FILES ${libotr_HEADER_FILES})
57
58add_library (libotr ${libotr_SOURCE_FILES})
59target_link_libraries(
60 libotr
61 )