diff options
Diffstat (limited to 'linden/indra/libgcrypt/libgcrypt-1.2.2/src/Makefile.am')
-rw-r--r--[-rwxr-xr-x] | linden/indra/libgcrypt/libgcrypt-1.2.2/src/Makefile.am | 94 |
1 files changed, 47 insertions, 47 deletions
diff --git a/linden/indra/libgcrypt/libgcrypt-1.2.2/src/Makefile.am b/linden/indra/libgcrypt/libgcrypt-1.2.2/src/Makefile.am index 2e5612c..265f136 100755..100644 --- a/linden/indra/libgcrypt/libgcrypt-1.2.2/src/Makefile.am +++ b/linden/indra/libgcrypt/libgcrypt-1.2.2/src/Makefile.am | |||
@@ -1,47 +1,47 @@ | |||
1 | # Copyright (C) 1998,1999,2000,2001,2002,2003,2004 Free Software Foundation, Inc. | 1 | # Copyright (C) 1998,1999,2000,2001,2002,2003,2004 Free Software Foundation, Inc. |
2 | # | 2 | # |
3 | # This file is part of Libgcrypt. | 3 | # This file is part of Libgcrypt. |
4 | # | 4 | # |
5 | # Libgcrypt is free software; you can redistribute it and/or modify | 5 | # Libgcrypt is free software; you can redistribute it and/or modify |
6 | # it under the terms of the GNU Lesser General Public License as | 6 | # it under the terms of the GNU Lesser General Public License as |
7 | # published by the Free Software Foundation; either version 2.1 of | 7 | # published by the Free Software Foundation; either version 2.1 of |
8 | # the License, or (at your option) any later version. | 8 | # the License, or (at your option) any later version. |
9 | # | 9 | # |
10 | # Libgcrypt is distributed in the hope that it will be useful, | 10 | # Libgcrypt is distributed in the hope that it will be useful, |
11 | # but WITHOUT ANY WARRANTY; without even the implied warranty of | 11 | # but WITHOUT ANY WARRANTY; without even the implied warranty of |
12 | # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the | 12 | # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the |
13 | # GNU Lesser General Public License for more details. | 13 | # GNU Lesser General Public License for more details. |
14 | # | 14 | # |
15 | # You should have received a copy of the GNU Lesser General Public | 15 | # You should have received a copy of the GNU Lesser General Public |
16 | # License along with this program; if not, write to the Free Software | 16 | # License along with this program; if not, write to the Free Software |
17 | # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA | 17 | # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA |
18 | 18 | ||
19 | ## Process this file with automake to produce Makefile.in | 19 | ## Process this file with automake to produce Makefile.in |
20 | 20 | ||
21 | EXTRA_DIST = Manifest libgcrypt-config.in libgcrypt.m4 libgcrypt.vers | 21 | EXTRA_DIST = Manifest libgcrypt-config.in libgcrypt.m4 libgcrypt.vers |
22 | bin_SCRIPTS = libgcrypt-config | 22 | bin_SCRIPTS = libgcrypt-config |
23 | m4datadir = $(datadir)/aclocal | 23 | m4datadir = $(datadir)/aclocal |
24 | m4data_DATA = libgcrypt.m4 | 24 | m4data_DATA = libgcrypt.m4 |
25 | include_HEADERS = gcrypt.h gcrypt-module.h | 25 | include_HEADERS = gcrypt.h gcrypt-module.h |
26 | 26 | ||
27 | lib_LTLIBRARIES = libgcrypt.la | 27 | lib_LTLIBRARIES = libgcrypt.la |
28 | 28 | ||
29 | if HAVE_LD_VERSION_SCRIPT | 29 | if HAVE_LD_VERSION_SCRIPT |
30 | libgcrypt_version_script_cmd = -Wl,--version-script=$(srcdir)/libgcrypt.vers | 30 | libgcrypt_version_script_cmd = -Wl,--version-script=$(srcdir)/libgcrypt.vers |
31 | else | 31 | else |
32 | libgcrypt_version_script_cmd = | 32 | libgcrypt_version_script_cmd = |
33 | endif | 33 | endif |
34 | 34 | ||
35 | libgcrypt_la_CFLAGS = @GPG_ERROR_CFLAGS@ | 35 | libgcrypt_la_CFLAGS = @GPG_ERROR_CFLAGS@ |
36 | libgcrypt_la_SOURCES = g10lib.h types.h cipher.h \ | 36 | libgcrypt_la_SOURCES = g10lib.h types.h cipher.h \ |
37 | misc.c global.c sexp.c \ | 37 | misc.c global.c sexp.c \ |
38 | stdmem.c stdmem.h secmem.c secmem.h \ | 38 | stdmem.c stdmem.h secmem.c secmem.h \ |
39 | mpi.h missing-string.c module.c \ | 39 | mpi.h missing-string.c module.c \ |
40 | ath.h ath.c | 40 | ath.h ath.c |
41 | 41 | ||
42 | libgcrypt_la_LDFLAGS = $(libgcrypt_version_script_cmd) -version-info \ | 42 | libgcrypt_la_LDFLAGS = $(libgcrypt_version_script_cmd) -version-info \ |
43 | @LIBGCRYPT_LT_CURRENT@:@LIBGCRYPT_LT_REVISION@:@LIBGCRYPT_LT_AGE@ | 43 | @LIBGCRYPT_LT_CURRENT@:@LIBGCRYPT_LT_REVISION@:@LIBGCRYPT_LT_AGE@ |
44 | libgcrypt_la_DEPENDENCIES = ../cipher/libcipher.la ../mpi/libmpi.la \ | 44 | libgcrypt_la_DEPENDENCIES = ../cipher/libcipher.la ../mpi/libmpi.la \ |
45 | $(srcdir)/libgcrypt.vers | 45 | $(srcdir)/libgcrypt.vers |
46 | libgcrypt_la_LIBADD = ../cipher/libcipher.la ../mpi/libmpi.la \ | 46 | libgcrypt_la_LIBADD = ../cipher/libcipher.la ../mpi/libmpi.la \ |
47 | @LTLIBOBJS@ @GPG_ERROR_LIBS@ | 47 | @LTLIBOBJS@ @GPG_ERROR_LIBS@ |