diff options
Diffstat (limited to '')
-rw-r--r-- | linden/indra/cmake/00-Common.cmake | 13 | ||||
-rw-r--r-- | linden/indra/cmake/CMakeLists.txt | 1 | ||||
-rw-r--r-- | linden/indra/cmake/Variables.cmake | 11 | ||||
-rw-r--r-- | linden/indra/cmake/ViewerArtwork.cmake | 16 | ||||
-rw-r--r-- | linden/indra/cmake/gpg.vs.cmake | 1 | ||||
-rw-r--r-- | linden/indra/cmake/libgcrypt.cmake | 10 | ||||
-rw-r--r-- | linden/indra/cmake/libgpg-error.cmake | 10 | ||||
-rw-r--r-- | linden/indra/cmake/libotr.cmake | 2 | ||||
-rw-r--r-- | linden/indra/cmake/libotrb.cmake | 2 |
9 files changed, 44 insertions, 22 deletions
diff --git a/linden/indra/cmake/00-Common.cmake b/linden/indra/cmake/00-Common.cmake index 1177fc2..6a97391 100644 --- a/linden/indra/cmake/00-Common.cmake +++ b/linden/indra/cmake/00-Common.cmake | |||
@@ -24,6 +24,11 @@ list(REMOVE_DUPLICATES TYPES) | |||
24 | set(CMAKE_CONFIGURATION_TYPES ${TYPES} CACHE STRING "Supported build types." FORCE) | 24 | set(CMAKE_CONFIGURATION_TYPES ${TYPES} CACHE STRING "Supported build types." FORCE) |
25 | unset(TYPES) | 25 | unset(TYPES) |
26 | 26 | ||
27 | # Work around nmake / VS difference. | ||
28 | set(VIEWER_CFG_INTDIR ${CMAKE_CFG_INTDIR}) | ||
29 | if (NMAKE) | ||
30 | set(VIEWER_CFG_INTDIR ${CMAKE_BUILD_TYPE}) | ||
31 | endif(NMAKE) | ||
27 | 32 | ||
28 | # Determine the number of bits of this processor | 33 | # Determine the number of bits of this processor |
29 | 34 | ||
@@ -68,7 +73,6 @@ if (WINDOWS) | |||
68 | /DUNICODE | 73 | /DUNICODE |
69 | /D_UNICODE | 74 | /D_UNICODE |
70 | /GS | 75 | /GS |
71 | /TP | ||
72 | /W3 | 76 | /W3 |
73 | /c | 77 | /c |
74 | /Zc:forScope | 78 | /Zc:forScope |
@@ -95,9 +99,10 @@ if (WINDOWS) | |||
95 | endif (MSVC80 OR MSVC90) | 99 | endif (MSVC80 OR MSVC90) |
96 | 100 | ||
97 | # Are we using the crummy Visual Studio KDU build workaround? | 101 | # Are we using the crummy Visual Studio KDU build workaround? |
98 | if (NOT VS_DISABLE_FATAL_WARNINGS) | 102 | # FIXME: Let's just disable this for now, see if it's needed, coz I have no idea what that work around is about. |
99 | add_definitions(/WX) | 103 | # if (NOT VS_DISABLE_FATAL_WARNINGS) |
100 | endif (NOT VS_DISABLE_FATAL_WARNINGS) | 104 | # add_definitions(/WX) |
105 | # endif (NOT VS_DISABLE_FATAL_WARNINGS) | ||
101 | endif (WINDOWS) | 106 | endif (WINDOWS) |
102 | 107 | ||
103 | 108 | ||
diff --git a/linden/indra/cmake/CMakeLists.txt b/linden/indra/cmake/CMakeLists.txt index 4a7d633..aca7b5a 100644 --- a/linden/indra/cmake/CMakeLists.txt +++ b/linden/indra/cmake/CMakeLists.txt | |||
@@ -93,7 +93,6 @@ set(cmake_SOURCE_FILES | |||
93 | UI.cmake | 93 | UI.cmake |
94 | UnixInstall.cmake | 94 | UnixInstall.cmake |
95 | Variables.cmake | 95 | Variables.cmake |
96 | ViewerArtwork.cmake | ||
97 | ViewerMiscLibs.cmake | 96 | ViewerMiscLibs.cmake |
98 | WebKitLibPlugin.cmake | 97 | WebKitLibPlugin.cmake |
99 | XmlRpcEpi.cmake | 98 | XmlRpcEpi.cmake |
diff --git a/linden/indra/cmake/Variables.cmake b/linden/indra/cmake/Variables.cmake index 88c0c5c..dfb0e70 100644 --- a/linden/indra/cmake/Variables.cmake +++ b/linden/indra/cmake/Variables.cmake | |||
@@ -81,10 +81,19 @@ endif (${CMAKE_SYSTEM_NAME} MATCHES "Linux") | |||
81 | 81 | ||
82 | if (${CMAKE_SYSTEM_NAME} MATCHES "Darwin") | 82 | if (${CMAKE_SYSTEM_NAME} MATCHES "Darwin") |
83 | set(DARWIN 1) | 83 | set(DARWIN 1) |
84 | |||
85 | # Incorporated settings from | ||
86 | # http://imprudenceviewer.org/w/index.php?title=How_to_compile&oldid=1647#Mac | ||
87 | # so that people don't have to set them every time they run develop.py | ||
88 | set(CMAKE_XCODE_ATTRIBUTE_GCC_VERSION "4.0") | ||
89 | set(CMAKE_XCODE_ATTRIBUTE_ARCHS '$(ARCHS_STANDARD_32_BIT)') | ||
90 | set(CMAKE_XCODE_ATTRIBUTE_VALID_ARCHS "i386 ppc") | ||
91 | # set(CMAKE_XCODE_ATTRIBUTE_ONLY_ACTIVE_ARCH "NO") | ||
92 | |||
84 | # set this dynamically from the build system now - | 93 | # set this dynamically from the build system now - |
85 | # NOTE: wont have a distributable build unless you add this on the configure line with: | 94 | # NOTE: wont have a distributable build unless you add this on the configure line with: |
86 | # -DCMAKE_OSX_ARCHITECTURES:STRING='i386;ppc' | 95 | # -DCMAKE_OSX_ARCHITECTURES:STRING='i386;ppc' |
87 | set(CMAKE_OSX_ARCHITECTURES i386) | 96 | set(CMAKE_OSX_ARCHITECTURES i386;ppc) |
88 | set(CMAKE_OSX_SYSROOT /Developer/SDKs/MacOSX10.5.sdk) | 97 | set(CMAKE_OSX_SYSROOT /Developer/SDKs/MacOSX10.5.sdk) |
89 | if (CMAKE_OSX_ARCHITECTURES MATCHES "i386") | 98 | if (CMAKE_OSX_ARCHITECTURES MATCHES "i386") |
90 | set(ARCH i386) | 99 | set(ARCH i386) |
diff --git a/linden/indra/cmake/ViewerArtwork.cmake b/linden/indra/cmake/ViewerArtwork.cmake deleted file mode 100644 index 20210fc..0000000 --- a/linden/indra/cmake/ViewerArtwork.cmake +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | # -*- cmake -*- | ||
2 | # | ||
3 | # Download viewer artwork even when using standalone | ||
4 | |||
5 | include(Variables) | ||
6 | include(Prebuilt) | ||
7 | |||
8 | if (NOT STANDALONE) | ||
9 | use_prebuilt_binary(artwork) | ||
10 | use_prebuilt_binary(fonts) | ||
11 | else (NOT STANDALONE) | ||
12 | set(STANDALONE OFF) | ||
13 | use_prebuilt_binary(artwork) | ||
14 | use_prebuilt_binary(fonts) | ||
15 | set(STANDALONE ON) | ||
16 | endif (NOT STANDALONE) | ||
diff --git a/linden/indra/cmake/gpg.vs.cmake b/linden/indra/cmake/gpg.vs.cmake index a5220f4..c551b3a 100644 --- a/linden/indra/cmake/gpg.vs.cmake +++ b/linden/indra/cmake/gpg.vs.cmake | |||
@@ -4,3 +4,4 @@ | |||
4 | # make the libgcrypt, libgpg-error, and libotr compile. | 4 | # make the libgcrypt, libgpg-error, and libotr compile. |
5 | 5 | ||
6 | set(gpg.vs_INCLUDE_DIRS ) | 6 | set(gpg.vs_INCLUDE_DIRS ) |
7 | add_definitions( /DHAVE_CONFIG_H=1 ) | ||
diff --git a/linden/indra/cmake/libgcrypt.cmake b/linden/indra/cmake/libgcrypt.cmake index 4d19467..19ef1f8 100644 --- a/linden/indra/cmake/libgcrypt.cmake +++ b/linden/indra/cmake/libgcrypt.cmake | |||
@@ -2,9 +2,19 @@ | |||
2 | 2 | ||
3 | set(LIBGCRYPT_INCLUDE_DIRS | 3 | set(LIBGCRYPT_INCLUDE_DIRS |
4 | ${CMAKE_BINARY_DIR}/libgcrypt/include | 4 | ${CMAKE_BINARY_DIR}/libgcrypt/include |
5 | ${LIBS_OPEN_DIR}/libgcrypt/libgcrypt-1.2.2/src | ||
5 | ) | 6 | ) |
6 | 7 | ||
8 | if (DARWIN OR LINUX) | ||
7 | set(LIBGCRYPT_LIBRARIES | 9 | set(LIBGCRYPT_LIBRARIES |
8 | ${CMAKE_BINARY_DIR}/libgcrypt/lib/libgcrypt.a | 10 | ${CMAKE_BINARY_DIR}/libgcrypt/lib/libgcrypt.a |
9 | ) | 11 | ) |
12 | endif (DARWIN OR LINUX) | ||
10 | 13 | ||
14 | if (WINDOWS) | ||
15 | set(LIBGCRYPT_LIBRARIES | ||
16 | ${CMAKE_BINARY_DIR}/libgcrypt/gcrypt.lib | ||
17 | ) | ||
18 | endif (WINDOWS) | ||
19 | |||
20 | add_definitions( /DHAVE_CONFIG_H=1 ) | ||
diff --git a/linden/indra/cmake/libgpg-error.cmake b/linden/indra/cmake/libgpg-error.cmake index 417ad19..4ec0926 100644 --- a/linden/indra/cmake/libgpg-error.cmake +++ b/linden/indra/cmake/libgpg-error.cmake | |||
@@ -2,9 +2,19 @@ | |||
2 | 2 | ||
3 | set(LIBGPG-ERROR_INCLUDE_DIRS | 3 | set(LIBGPG-ERROR_INCLUDE_DIRS |
4 | ${CMAKE_BINARY_DIR}/libgpg-error/include | 4 | ${CMAKE_BINARY_DIR}/libgpg-error/include |
5 | ${LIBS_OPEN_DIR}/libgpg-error/libgpg-error-1.0/src | ||
5 | ) | 6 | ) |
6 | 7 | ||
8 | if (DARWIN OR LINUX) | ||
7 | set(LIBGPG-ERROR_LIBRARIES | 9 | set(LIBGPG-ERROR_LIBRARIES |
8 | ${CMAKE_BINARY_DIR}/libgpg-error/lib/libgpg-error.a | 10 | ${CMAKE_BINARY_DIR}/libgpg-error/lib/libgpg-error.a |
9 | ) | 11 | ) |
12 | endif (DARWIN OR LINUX) | ||
10 | 13 | ||
14 | if (WINDOWS) | ||
15 | set(LIBGPG-ERROR_LIBRARIES | ||
16 | ${CMAKE_BINARY_DIR}/libgpg-error/gpg-error.lib | ||
17 | ) | ||
18 | endif (WINDOWS) | ||
19 | |||
20 | add_definitions( /DHAVE_CONFIG_H=1 ) | ||
diff --git a/linden/indra/cmake/libotr.cmake b/linden/indra/cmake/libotr.cmake index 30544f8..6fd61f2 100644 --- a/linden/indra/cmake/libotr.cmake +++ b/linden/indra/cmake/libotr.cmake | |||
@@ -6,3 +6,5 @@ set(LIBOTR_INCLUDE_DIRS | |||
6 | set(LIBOTR_LIBRARIES | 6 | set(LIBOTR_LIBRARIES |
7 | otr | 7 | otr |
8 | ) | 8 | ) |
9 | |||
10 | add_definitions( /DHAVE_CONFIG_H=1 ) | ||
diff --git a/linden/indra/cmake/libotrb.cmake b/linden/indra/cmake/libotrb.cmake index eb8522f..e9290e8 100644 --- a/linden/indra/cmake/libotrb.cmake +++ b/linden/indra/cmake/libotrb.cmake | |||
@@ -2,3 +2,5 @@ | |||
2 | include(Prebuilt) | 2 | include(Prebuilt) |
3 | 3 | ||
4 | set(OTR_LIBRARY otr) | 4 | set(OTR_LIBRARY otr) |
5 | |||
6 | add_definitions( /DHAVE_CONFIG_H=1 ) | ||