aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/ChangeLog.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog.txt')
-rw-r--r--ChangeLog.txt168
1 files changed, 168 insertions, 0 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt
index 9a56462..f7636d9 100644
--- a/ChangeLog.txt
+++ b/ChangeLog.txt
@@ -1,3 +1,171 @@
12009-11-15 McCabe Maxsted <hakushakukun@gmail.com>
2
3 * Fixed CMake setting errors.
4
5 modified: linden/indra/cmake/00-Common.cmake
6 modified: linden/indra/cmake/CopyWinLibs.cmake
7
8
92009-11-14 McCabe Maxsted <hakushakukun@gmail.com>
10
11 * Moved blog and forums menu option alerts to new notifications system.
12
13 modified: linden/indra/newview/skins/default/xui/en-us/alerts.xml
14 modified: linden/indra/newview/skins/default/xui/en-us/notifications.x
15
16
172009-11-13 McCabe Maxsted <hakushakukun@gmail.com>
18
19 * Force Imprudence to use the correst boost libraries, e.g:
20 #pragma comment( lib, "libboost_signals-vc80-mt-1_36.lib" )
21
22 modified: linden/indra/newview/llappviewerwin32.cpp
23
24
25 * Fixed linker error (onClickHome in llfloaterhtmlhelp.cpp).
26
27 modified: linden/indra/newview/llfloaterhtmlhelp.cpp
28
29
30 * Disable unreachable code in boost/lexical_cast.hpp errors in Windows.
31
32 modified: linden/indra/newview/llpaneldirfind.cpp
33 modified: linden/indra/newview/llvoavatar.cpp
34
35
362009-11-10 McCabe Maxsted <hakushakukun@gmail.com>
37
38 * Viewer compiles, but still trying to get everything to link on Windows.
39
40 modified: linden/indra/cmake/Boost.cmake
41 modified: linden/indra/llcommon/linden_common.h
42 modified: linden/indra/llmath/llmath.h
43 modified: linden/indra/newview/llfloaterhtmlhelp.cpp
44 modified: linden/indra/newview/llfloaterhtmlhelp.h
45 modified: linden/install.xml
46
47
482009-11-09 McCabe Maxsted <hakushakukun@gmail.com>
49
50 * Fixed llstartup header issue and removed WIN32_LEAN_AND_MEAN define.
51
52 modified: linden/indra/newview/llstartup.cpp
53
54
55 * Removed deprecated EGridInfo from llloginhandler.
56
57 modified: linden/indra/newview/llloginhandler.cpp
58
59
60 * Updated primbackup from latest meerkat svn (r246).
61
62 modified: linden/indra/newview/primbackup.cpp
63 modified: linden/indra/newview/primbackup.h
64
65
66 * Attachment size limits need to use the max prim size set in llmanipscale.
67
68 modified: linden/indra/newview/llvoavatar.cpp
69
70
71 * Updated streaming video callback in llviewerparcelmedia.
72
73 modified: linden/indra/newview/llviewerparcelmedia.cpp
74
75
76 * llpanellogin and llviewermessage now compile.
77
78 modified: linden/indra/newview/llpanellogin.cpp
79 modified: linden/indra/newview/llviewermessage.cpp
80
81
82 * Updated several menu entries to 1.23.
83
84 modified: linden/indra/newview/llviewermenu.cpp
85
86
87 * Removed unused menu entries (still merging 1.23).
88
89 modified: linden/indra/newview/llviewermenu.cpp
90 modified: linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml
91
92
93 * Updated asset browser from old font system.
94
95 modified: linden/indra/newview/llfloaterassetbrowser.cpp
96
97
98 * Media browser now compiles (TODO: rewrite this file again).
99
100 modified: linden/indra/newview/llfloaterhtmlhelp.cpp
101 modified: linden/indra/newview/llfloaterhtmlhelp.h
102 modified: linden/indra/newview/skins/default/xui/en-us/notifications.x
103
104
105 * Moved 1.2 alerts to the new notification system.
106
107 modified: linden/indra/newview/llfloatertools.cpp
108 modified: linden/indra/newview/llimpanel.cpp
109 modified: linden/indra/newview/llinventorybridge.cpp
110 modified: linden/indra/newview/llinventorybridge.h
111 modified: linden/indra/newview/llmutelist.cpp
112 modified: linden/indra/newview/llmutelist.h
113 modified: linden/indra/newview/llpanelface.cpp
114 modified: linden/indra/newview/llpanelobject.cpp
115 modified: linden/indra/newview/llviewermenu.cpp
116 modified: linden/indra/newview/llviewerwindow.cpp
117 modified: linden/indra/newview/llviewerwindow.h
118 modified: linden/indra/newview/panelradar.cpp
119 modified: linden/indra/newview/panelradar.h
120 modified: linden/indra/newview/rlvdefines.h
121 modified: linden/indra/newview/skins/default/xui/en-us/alerts.xml
122 modified: linden/indra/newview/skins/default/xui/en-us/notifications.xml
123
124
1252009-11-08 McCabe Maxsted <hakushakukun@gmail.com>
126
127 * Removed unused CMake resource files.
128
129 modified: linden/indra/newview/CMakeLists.txt
130
131
132 * Merged in nearly-done 1.2 with 1.3.
133
134 Conflicts:
135 ChangeLog.txt
136 linden/indra/llmedia/llmediaimplllmozlib.cpp
137 linden/indra/llui/llalertdialog.cpp
138 linden/indra/newview/llinventorybridge.cpp
139 linden/indra/newview/llpanelcontents.cpp
140 linden/indra/newview/llpanelinput.cpp
141 linden/indra/newview/res/viewerRes.rc
142 linden/indra/newview/skins/default/xui/de/alerts.xml
143 linden/indra/newview/skins/default/xui/de/notify.xml
144 linden/indra/newview/skins/default/xui/en-us/alerts.xml
145 linden/indra/newview/skins/default/xui/es/alerts.xml
146 linden/indra/newview/skins/default/xui/fr/alerts.xml
147 linden/indra/newview/skins/default/xui/fr/notify.xml
148 linden/indra/newview/skins/default/xui/ja/alerts.xml
149 linden/indra/newview/skins/default/xui/ja/notify.xml
150 linden/indra/newview/skins/default/xui/ko/alerts.xml
151 linden/indra/newview/skins/default/xui/ko/notify.xml
152 linden/indra/newview/skins/default/xui/pt/alerts.xml
153 linden/indra/newview/skins/default/xui/pt/notify.xml
154 linden/indra/newview/skins/default/xui/zh/alerts.xml
155 linden/install.xml
156
157
1582009-10-18 McCabe Maxsted <hakushakukun@gmail.com>
159
160 * Merged working branch of 1.2 into LL 1.23 merge.
161
162
163
1642009-08-29 Jacek Antonelli <jacek.antonelli@gmail.com>
165
166 * Updated Imprudence to be based on SL 1.23.4.
167
168
1=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- 169=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
2=- 1.2.0 -= 170=- 1.2.0 -=
3=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- 171=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-