diff options
-rw-r--r-- | linden/indra/lscript/lscript_compile/CMakeLists.txt | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/linden/indra/lscript/lscript_compile/CMakeLists.txt b/linden/indra/lscript/lscript_compile/CMakeLists.txt index 252085b..f6d5212 100644 --- a/linden/indra/lscript/lscript_compile/CMakeLists.txt +++ b/linden/indra/lscript/lscript_compile/CMakeLists.txt | |||
@@ -103,7 +103,7 @@ if (WINDOWS) | |||
103 | PROPERTIES COMPILE_FLAGS /DYY_NO_UNISTD_H) | 103 | PROPERTIES COMPILE_FLAGS /DYY_NO_UNISTD_H) |
104 | endif (WINDOWS) | 104 | endif (WINDOWS) |
105 | 105 | ||
106 | if (WINDOWS) | 106 | if (WINDOWS AND NOT CYGWIN) |
107 | get_filename_component(M4_PATH ${M4} PATH) | 107 | get_filename_component(M4_PATH ${M4} PATH) |
108 | add_custom_command( | 108 | add_custom_command( |
109 | OUTPUT | 109 | OUTPUT |
@@ -118,7 +118,7 @@ if (WINDOWS) | |||
118 | ${CMAKE_CURRENT_SOURCE_DIR}/indra.y | 118 | ${CMAKE_CURRENT_SOURCE_DIR}/indra.y |
119 | ) | 119 | ) |
120 | include_directories(${CMAKE_CURRENT_SOURCE_DIR}/windows) | 120 | include_directories(${CMAKE_CURRENT_SOURCE_DIR}/windows) |
121 | else (WINDOWS) | 121 | else (WINDOWS AND NOT CYGWIN) |
122 | add_custom_command( | 122 | add_custom_command( |
123 | OUTPUT | 123 | OUTPUT |
124 | ${CMAKE_CURRENT_BINARY_DIR}/indra.y.cpp | 124 | ${CMAKE_CURRENT_BINARY_DIR}/indra.y.cpp |
@@ -131,7 +131,7 @@ else (WINDOWS) | |||
131 | DEPENDS | 131 | DEPENDS |
132 | ${CMAKE_CURRENT_SOURCE_DIR}/indra.y | 132 | ${CMAKE_CURRENT_SOURCE_DIR}/indra.y |
133 | ) | 133 | ) |
134 | endif (WINDOWS) | 134 | endif (WINDOWS AND NOT CYGWIN) |
135 | 135 | ||
136 | if (DARWIN) | 136 | if (DARWIN) |
137 | # Mac OS X 10.4 compatibility | 137 | # Mac OS X 10.4 compatibility |