aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
-rw-r--r--ChangeLog.txt8
-rw-r--r--linden/indra/cmake/00-Common.cmake10
-rw-r--r--linden/indra/cmake/ViewerArtwork.cmake14
-rw-r--r--linden/indra/llaudio/CMakeLists.txt1
-rw-r--r--linden/indra/newview/CMakeLists.txt1
5 files changed, 24 insertions, 10 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt
index 7a9fefa..3003c69 100644
--- a/ChangeLog.txt
+++ b/ChangeLog.txt
@@ -1,5 +1,13 @@
12009-12-01 McCabe Maxsted <hakushakukun@gmail.com> 12009-12-01 McCabe Maxsted <hakushakukun@gmail.com>
2 2
3 * Moved the viewer artwork to its own CMake file.
4
5 new file: linden/indra/cmake/ViewerArtwork.cmake
6 modified: linden/indra/cmake/00-Common.cmake
7 modified: linden/indra/llaudio/CMakeLists.txt
8 modified: linden/indra/newview/CMakeLists.txt
9
10
3 * Removed libpng12-0.dll from CopyWinLibs.cmake. 11 * Removed libpng12-0.dll from CopyWinLibs.cmake.
4 12
5 modified: linden/indra/cmake/CopyWinLibs.cmake 13 modified: linden/indra/cmake/CopyWinLibs.cmake
diff --git a/linden/indra/cmake/00-Common.cmake b/linden/indra/cmake/00-Common.cmake
index 746a3bf..49fdb5b 100644
--- a/linden/indra/cmake/00-Common.cmake
+++ b/linden/indra/cmake/00-Common.cmake
@@ -3,17 +3,7 @@
3# Compilation options shared by all Second Life components. 3# Compilation options shared by all Second Life components.
4 4
5include(Variables) 5include(Variables)
6include(Prebuilt)
7 6
8# Download viewer artwork even when using standalone
9
10if (STANDALONE)
11 set(STANDALONE OFF)
12 use_prebuilt_binary(artwork)
13 set(STANDALONE ON)
14else (STANDALONE)
15 use_prebuilt_binary(artwork)
16endif (STANDALONE)
17 7
18# Portable compilation flags. 8# Portable compilation flags.
19 9
diff --git a/linden/indra/cmake/ViewerArtwork.cmake b/linden/indra/cmake/ViewerArtwork.cmake
new file mode 100644
index 0000000..f01109a
--- /dev/null
+++ b/linden/indra/cmake/ViewerArtwork.cmake
@@ -0,0 +1,14 @@
1# -*- cmake -*-
2#
3# Download viewer artwork even when using standalone
4
5include(Variables)
6include(Prebuilt)
7
8if (NOT STANDALONE)
9 use_prebuilt_binary(artwork)
10else (NOT STANDALONE)
11 set(STANDALONE OFF)
12 use_prebuilt_binary(artwork)
13 set(STANDALONE ON)
14endif (NOT STANDALONE)
diff --git a/linden/indra/llaudio/CMakeLists.txt b/linden/indra/llaudio/CMakeLists.txt
index 70041e7..0a668f9 100644
--- a/linden/indra/llaudio/CMakeLists.txt
+++ b/linden/indra/llaudio/CMakeLists.txt
@@ -2,6 +2,7 @@
2 2
3project(llaudio) 3project(llaudio)
4 4
5# Current starting point for CMake. Seems rather arbitrary - MC
5include(00-Common) 6include(00-Common)
6include(Audio) 7include(Audio)
7include(OPENAL) 8include(OPENAL)
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 26c9b21..cafe004 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -35,6 +35,7 @@ include(GooglePerfTools)
35include(TemplateCheck) 35include(TemplateCheck)
36include(UI) 36include(UI)
37include(UnixInstall) 37include(UnixInstall)
38include(ViewerArtwork)
38include(ViewerMiscLibs) 39include(ViewerMiscLibs)
39 40
40if (WINDOWS) 41if (WINDOWS)