diff options
-rw-r--r-- | linden/indra/CMakeLists.txt | 10 | ||||
-rw-r--r-- | linden/indra/cmake/libgcrypt.cmake | 2 | ||||
-rw-r--r-- | linden/indra/cmake/libgpg-error.cmake | 2 | ||||
-rw-r--r-- | linden/indra/libgcrypt/CMakeLists.txt | 7 | ||||
-rw-r--r-- | linden/indra/libgpg-error/CMakeLists.txt | 1 | ||||
-rw-r--r-- | linden/indra/libotr/CMakeLists.txt | 6 |
6 files changed, 18 insertions, 10 deletions
diff --git a/linden/indra/CMakeLists.txt b/linden/indra/CMakeLists.txt index e3b5fa8..e3643d3 100644 --- a/linden/indra/CMakeLists.txt +++ b/linden/indra/CMakeLists.txt | |||
@@ -38,8 +38,8 @@ add_subdirectory(cmake) | |||
38 | # [$PLOTR$] | 38 | # [$PLOTR$] |
39 | if (WINDOWS) | 39 | if (WINDOWS) |
40 | add_subdirectory(${LIBS_OPEN_PREFIX}gpg.vs) | 40 | add_subdirectory(${LIBS_OPEN_PREFIX}gpg.vs) |
41 | add_subdirectory(${LIBS_OPEN_PREFIX}libgcrypt) | ||
42 | add_subdirectory(${LIBS_OPEN_PREFIX}libgpg-error) | 41 | add_subdirectory(${LIBS_OPEN_PREFIX}libgpg-error) |
42 | add_subdirectory(${LIBS_OPEN_PREFIX}libgcrypt) | ||
43 | endif (WINDOWS) | 43 | endif (WINDOWS) |
44 | 44 | ||
45 | # if ON will cause linux to link in static OTR like windows does | 45 | # if ON will cause linux to link in static OTR like windows does |
@@ -64,10 +64,6 @@ add_subdirectory(${LIBS_OPEN_PREFIX}llvfs) | |||
64 | add_subdirectory(${LIBS_OPEN_PREFIX}llwindow) | 64 | add_subdirectory(${LIBS_OPEN_PREFIX}llwindow) |
65 | add_subdirectory(${LIBS_OPEN_PREFIX}llxml) | 65 | add_subdirectory(${LIBS_OPEN_PREFIX}llxml) |
66 | 66 | ||
67 | # [$PLOTR$] | ||
68 | add_subdirectory(${LIBS_OPEN_PREFIX}libotr) | ||
69 | # [/$PLOTR$] | ||
70 | |||
71 | add_subdirectory(${LIBS_OPEN_PREFIX}lscript) | 67 | add_subdirectory(${LIBS_OPEN_PREFIX}lscript) |
72 | 68 | ||
73 | if (WINDOWS AND EXISTS ${LIBS_CLOSED_DIR}copy_win_scripts) | 69 | if (WINDOWS AND EXISTS ${LIBS_CLOSED_DIR}copy_win_scripts) |
@@ -109,6 +105,10 @@ if (VIEWER) | |||
109 | add_dependencies(viewer solaris-crash-logger) | 105 | add_dependencies(viewer solaris-crash-logger) |
110 | endif (LINUX) | 106 | endif (LINUX) |
111 | 107 | ||
108 | # [$PLOTR$] | ||
109 | add_subdirectory(${LIBS_OPEN_PREFIX}libotr) | ||
110 | # [/$PLOTR$] | ||
111 | |||
112 | add_subdirectory(${VIEWER_PREFIX}newview) | 112 | add_subdirectory(${VIEWER_PREFIX}newview) |
113 | add_dependencies(viewer meta-impy-bin) | 113 | add_dependencies(viewer meta-impy-bin) |
114 | endif (VIEWER) | 114 | endif (VIEWER) |
diff --git a/linden/indra/cmake/libgcrypt.cmake b/linden/indra/cmake/libgcrypt.cmake index 6ac93b9..057addf 100644 --- a/linden/indra/cmake/libgcrypt.cmake +++ b/linden/indra/cmake/libgcrypt.cmake | |||
@@ -5,6 +5,6 @@ set(LIBGCRYPT_INCLUDE_DIRS | |||
5 | ) | 5 | ) |
6 | 6 | ||
7 | set(LIBGCRYPT_LIBRARIES | 7 | set(LIBGCRYPT_LIBRARIES |
8 | ${CMAKE_CURRENT_SOURCE_DIR}/../libgcrypt/libgcrypt-1.2.2/lib | 8 | gcrypt |
9 | ) | 9 | ) |
10 | 10 | ||
diff --git a/linden/indra/cmake/libgpg-error.cmake b/linden/indra/cmake/libgpg-error.cmake index e2df9f7..b83adee 100644 --- a/linden/indra/cmake/libgpg-error.cmake +++ b/linden/indra/cmake/libgpg-error.cmake | |||
@@ -5,6 +5,6 @@ set(LIBGPG-ERROR_INCLUDE_DIRS | |||
5 | ) | 5 | ) |
6 | 6 | ||
7 | set(LIBGPG-ERROR_LIBRARIES | 7 | set(LIBGPG-ERROR_LIBRARIES |
8 | ${CMAKE_CURRENT_SOURCE_DIR}/../libgpg-error/libgpg-error-1.0/lib | 8 | gpg-error |
9 | ) | 9 | ) |
10 | 10 | ||
diff --git a/linden/indra/libgcrypt/CMakeLists.txt b/linden/indra/libgcrypt/CMakeLists.txt index 31c547f..1b6794c 100644 --- a/linden/indra/libgcrypt/CMakeLists.txt +++ b/linden/indra/libgcrypt/CMakeLists.txt | |||
@@ -144,9 +144,10 @@ include_directories(${LIBGCRYPT_INCLUDE_DIRS}) | |||
144 | 144 | ||
145 | add_library(libgcrypt STATIC IMPORTED) | 145 | add_library(libgcrypt STATIC IMPORTED) |
146 | 146 | ||
147 | set_target_properties(libgcrypt PROPERTIES | 147 | # Happy this is not needed, but leaving it around for reference. |
148 | IMPORTED_LOCATION ${CMAKE_CURRENT_SOURCE_DIR}/../libgcrypt/libgcrypt-1.2.2/lib/libgcrypt.a | 148 | #set_target_properties(libgcrypt PROPERTIES |
149 | ) | 149 | # IMPORTED_LOCATION ${CMAKE_CURRENT_SOURCE_DIR}/../libgcrypt/libgcrypt-1.2.2/lib/libgcrypt.a |
150 | # ) | ||
150 | 151 | ||
151 | # This wont work until 2.8.4 sigh | 152 | # This wont work until 2.8.4 sigh |
152 | #add_dependencies(libgcrypt EP_libgcrypt) | 153 | #add_dependencies(libgcrypt EP_libgcrypt) |
diff --git a/linden/indra/libgpg-error/CMakeLists.txt b/linden/indra/libgpg-error/CMakeLists.txt index a595ab8..b3db72e 100644 --- a/linden/indra/libgpg-error/CMakeLists.txt +++ b/linden/indra/libgpg-error/CMakeLists.txt | |||
@@ -66,6 +66,7 @@ include_directories(${LIBGPG-ERROR_INCLUDE_DIRS}) | |||
66 | 66 | ||
67 | add_library(libgpg-error STATIC IMPORTED) | 67 | add_library(libgpg-error STATIC IMPORTED) |
68 | 68 | ||
69 | # Happy this is not needed, but leaving it around for reference. | ||
69 | #set_target_properties(libgpg-error PROPERTIES | 70 | #set_target_properties(libgpg-error PROPERTIES |
70 | # IMPORTED_LOCATION ${CMAKE_CURRENT_SOURCE_DIR}/../libgpg-error/libgpg-error-1.0/lib/libgpg-error.a | 71 | # IMPORTED_LOCATION ${CMAKE_CURRENT_SOURCE_DIR}/../libgpg-error/libgpg-error-1.0/lib/libgpg-error.a |
71 | # ) | 72 | # ) |
diff --git a/linden/indra/libotr/CMakeLists.txt b/linden/indra/libotr/CMakeLists.txt index b9da8f1..f0561d8 100644 --- a/linden/indra/libotr/CMakeLists.txt +++ b/linden/indra/libotr/CMakeLists.txt | |||
@@ -63,3 +63,9 @@ target_link_libraries(libotr | |||
63 | gcrypt | 63 | gcrypt |
64 | gpg-error | 64 | gpg-error |
65 | ) | 65 | ) |
66 | |||
67 | # Not sure if either or both are needed, does not seem to hurt. | ||
68 | # Still does not make things build in the right sequence. sigh | ||
69 | add_dependencies(libotr EP_libgcrpt) | ||
70 | add_dependencies(libotr libgcrypt) | ||
71 | |||