aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
-rw-r--r--linden/indra/llcommon/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/linden/indra/llcommon/CMakeLists.txt b/linden/indra/llcommon/CMakeLists.txt
index 5d590a9..ff1d548 100644
--- a/linden/indra/llcommon/CMakeLists.txt
+++ b/linden/indra/llcommon/CMakeLists.txt
@@ -203,3 +203,12 @@ target_link_libraries(
203 ${WINDOWS_LIBRARIES} 203 ${WINDOWS_LIBRARIES}
204 ) 204 )
205 205
206if (DARWIN)
207 # don't embed a full path in the library's install name
208 set_target_properties(
209 llcommon
210 PROPERTIES
211 BUILD_WITH_INSTALL_RPATH 1
212 INSTALL_NAME_DIR "@executable_path/../Resources"
213 )
214endif (DARWIN)