aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden
diff options
context:
space:
mode:
authorMcCabe Maxsted2009-02-25 01:09:07 -0700
committerMcCabe Maxsted2009-02-25 01:09:07 -0700
commitfdf4d97d4d9ce64eee4142e491509106be5b716b (patch)
tree18ea2f2bf7a312de623635326872996355a411ec /linden
parentChanged the show/hide shortcuts to be linux friendly (diff)
downloadmeta-impy-fdf4d97d4d9ce64eee4142e491509106be5b716b.zip
meta-impy-fdf4d97d4d9ce64eee4142e491509106be5b716b.tar.gz
meta-impy-fdf4d97d4d9ce64eee4142e491509106be5b716b.tar.bz2
meta-impy-fdf4d97d4d9ce64eee4142e491509106be5b716b.tar.xz
Added menu_pie_hud.xml, removed legacy rate pie menu references
Diffstat (limited to 'linden')
-rw-r--r--linden/indra/newview/CMakeLists.txt1
-rw-r--r--linden/indra/newview/llselectmgr.cpp2
-rw-r--r--linden/indra/newview/lltoolpie.cpp6
-rw-r--r--linden/indra/newview/llviewermenu.cpp9
-rw-r--r--linden/indra/newview/llviewermenu.h3
5 files changed, 16 insertions, 5 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 4024fdd..1e48d28 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -1120,6 +1120,7 @@ set(viewer_XUI_FILES
1120 skins/default/xui/en-us/menu_login.xml 1120 skins/default/xui/en-us/menu_login.xml
1121 skins/default/xui/en-us/menu_pie_attachment.xml 1121 skins/default/xui/en-us/menu_pie_attachment.xml
1122 skins/default/xui/en-us/menu_pie_avatar.xml 1122 skins/default/xui/en-us/menu_pie_avatar.xml
1123 skins/default/xui/en-us/menu_pie_hud.xml
1123 skins/default/xui/en-us/menu_pie_land.xml 1124 skins/default/xui/en-us/menu_pie_land.xml
1124 skins/default/xui/en-us/menu_pie_object.xml 1125 skins/default/xui/en-us/menu_pie_object.xml
1125 skins/default/xui/en-us/menu_pie_self.xml 1126 skins/default/xui/en-us/menu_pie_self.xml
diff --git a/linden/indra/newview/llselectmgr.cpp b/linden/indra/newview/llselectmgr.cpp
index 7547dd2..fe1755b 100644
--- a/linden/indra/newview/llselectmgr.cpp
+++ b/linden/indra/newview/llselectmgr.cpp
@@ -3444,7 +3444,7 @@ void LLSelectMgr::deselectAllIfTooFar()
3444 3444
3445 // HACK: Don't deselect when we're navigating to rate an object's 3445 // HACK: Don't deselect when we're navigating to rate an object's
3446 // owner or creator. JC 3446 // owner or creator. JC
3447 if (gPieObject->getVisible() || gPieRate->getVisible() ) 3447 if (gPieObject->getVisible())
3448 { 3448 {
3449 return; 3449 return;
3450 } 3450 }
diff --git a/linden/indra/newview/lltoolpie.cpp b/linden/indra/newview/lltoolpie.cpp
index de10045..63b6e34 100644
--- a/linden/indra/newview/lltoolpie.cpp
+++ b/linden/indra/newview/lltoolpie.cpp
@@ -336,10 +336,14 @@ BOOL LLToolPie::pickAndShowMenu(BOOL always_show)
336 336
337 gPieAvatar->show(x, y, mPieMouseButtonDown); 337 gPieAvatar->show(x, y, mPieMouseButtonDown);
338 } 338 }
339 else if (object->isAttachment()) 339 else if (object->isAttachment() && !object->isHUDAttachment())
340 { 340 {
341 gPieAttachment->show(x, y, mPieMouseButtonDown); 341 gPieAttachment->show(x, y, mPieMouseButtonDown);
342 } 342 }
343 else if (object->isHUDAttachment())
344 {
345 gPieHUD->show(x, y, mPieMouseButtonDown);
346 }
343 else 347 else
344 { 348 {
345 // BUG: What about chatting child objects? 349 // BUG: What about chatting child objects?
diff --git a/linden/indra/newview/llviewermenu.cpp b/linden/indra/newview/llviewermenu.cpp
index b7f4a40..31fdcc3 100644
--- a/linden/indra/newview/llviewermenu.cpp
+++ b/linden/indra/newview/llviewermenu.cpp
@@ -251,6 +251,7 @@ LLPieMenu *gPieSelf = NULL;
251LLPieMenu *gPieAvatar = NULL; 251LLPieMenu *gPieAvatar = NULL;
252LLPieMenu *gPieObject = NULL; 252LLPieMenu *gPieObject = NULL;
253LLPieMenu *gPieAttachment = NULL; 253LLPieMenu *gPieAttachment = NULL;
254LLPieMenu *gPieHUD = NULL;
254LLPieMenu *gPieLand = NULL; 255LLPieMenu *gPieLand = NULL;
255 256
256// local constants 257// local constants
@@ -263,7 +264,6 @@ const std::string SAVE_INTO_TASK_INVENTORY("Save Object Back to Object Contents"
263LLMenuGL* gAttachSubMenu = NULL; 264LLMenuGL* gAttachSubMenu = NULL;
264LLMenuGL* gDetachSubMenu = NULL; 265LLMenuGL* gDetachSubMenu = NULL;
265LLMenuGL* gTakeOffClothes = NULL; 266LLMenuGL* gTakeOffClothes = NULL;
266LLPieMenu* gPieRate = NULL;
267LLPieMenu* gAttachScreenPieMenu = NULL; 267LLPieMenu* gAttachScreenPieMenu = NULL;
268LLPieMenu* gAttachPieMenu = NULL; 268LLPieMenu* gAttachPieMenu = NULL;
269LLPieMenu* gAttachBodyPartPieMenus[8]; 269LLPieMenu* gAttachBodyPartPieMenus[8];
@@ -610,10 +610,11 @@ void init_menus()
610 610
611 gAttachScreenPieMenu = gMenuHolder->getChild<LLPieMenu>("Object Attach HUD"); 611 gAttachScreenPieMenu = gMenuHolder->getChild<LLPieMenu>("Object Attach HUD");
612 gAttachPieMenu = gMenuHolder->getChild<LLPieMenu>("Object Attach"); 612 gAttachPieMenu = gMenuHolder->getChild<LLPieMenu>("Object Attach");
613 gPieRate = gMenuHolder->getChild<LLPieMenu>("Rate Menu");
614 613
615 gPieAttachment = LLUICtrlFactory::getInstance()->buildPieMenu("menu_pie_attachment.xml", gMenuHolder); 614 gPieAttachment = LLUICtrlFactory::getInstance()->buildPieMenu("menu_pie_attachment.xml", gMenuHolder);
616 615
616 gPieHUD = LLUICtrlFactory::getInstance()->buildPieMenu("menu_pie_hud.xml", gMenuHolder);
617
617 gPieLand = LLUICtrlFactory::getInstance()->buildPieMenu("menu_pie_land.xml", gMenuHolder); 618 gPieLand = LLUICtrlFactory::getInstance()->buildPieMenu("menu_pie_land.xml", gMenuHolder);
618 619
619 /// 620 ///
@@ -626,6 +627,7 @@ void init_menus()
626 gPieAvatar->setBackgroundColor( pie_color ); 627 gPieAvatar->setBackgroundColor( pie_color );
627 gPieObject->setBackgroundColor( pie_color ); 628 gPieObject->setBackgroundColor( pie_color );
628 gPieAttachment->setBackgroundColor( pie_color ); 629 gPieAttachment->setBackgroundColor( pie_color );
630 gPieHUD->setBackgroundColor( pie_color );
629 gPieLand->setBackgroundColor( pie_color ); 631 gPieLand->setBackgroundColor( pie_color );
630 632
631 color = gColors.getColor( "MenuPopupBgColor" ); 633 color = gColors.getColor( "MenuPopupBgColor" );
@@ -1475,6 +1477,9 @@ void cleanup_menus()
1475 delete gPieAttachment; 1477 delete gPieAttachment;
1476 gPieAttachment = NULL; 1478 gPieAttachment = NULL;
1477 1479
1480 delete gPieHUD;
1481 gPieHUD = NULL;
1482
1478 delete gPieLand; 1483 delete gPieLand;
1479 gPieLand = NULL; 1484 gPieLand = NULL;
1480 1485
diff --git a/linden/indra/newview/llviewermenu.h b/linden/indra/newview/llviewermenu.h
index e003e90..c2f880e 100644
--- a/linden/indra/newview/llviewermenu.h
+++ b/linden/indra/newview/llviewermenu.h
@@ -147,14 +147,15 @@ extern LLPieMenu *gPieSelf;
147extern LLPieMenu *gPieAvatar; 147extern LLPieMenu *gPieAvatar;
148extern LLPieMenu *gPieObject; 148extern LLPieMenu *gPieObject;
149extern LLPieMenu *gPieAttachment; 149extern LLPieMenu *gPieAttachment;
150extern LLPieMenu *gPieHUD;
150extern LLPieMenu *gPieLand; 151extern LLPieMenu *gPieLand;
151extern LLPieMenu* gPieRate;
152 152
153// Pie menus 153// Pie menus
154extern LLPieMenu *gPieSelfSimple; 154extern LLPieMenu *gPieSelfSimple;
155extern LLPieMenu *gPieAvatarSimple; 155extern LLPieMenu *gPieAvatarSimple;
156extern LLPieMenu *gPieObjectSimple; 156extern LLPieMenu *gPieObjectSimple;
157extern LLPieMenu *gPieAttachmentSimple; 157extern LLPieMenu *gPieAttachmentSimple;
158extern LLPieMenu *gPieHUDSimple;
158extern LLPieMenu *gPieLandSimple; 159extern LLPieMenu *gPieLandSimple;
159 160
160// Needed to build menus when attachment site list available 161// Needed to build menus when attachment site list available