aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden
diff options
context:
space:
mode:
authorArmin Weatherwax2010-09-07 17:38:53 +0200
committerArmin Weatherwax2010-09-23 15:42:41 +0200
commitfcf35900271fbcb123b9d0d5652d79db0d1965fb (patch)
treef6f8591b5480b61615f9a610c65ebc46eb2b6761 /linden
parentupdate to viewer-external SLPlugin + webkit. Fixes (lots of) webpages not loa... (diff)
downloadmeta-impy-fcf35900271fbcb123b9d0d5652d79db0d1965fb.zip
meta-impy-fcf35900271fbcb123b9d0d5652d79db0d1965fb.tar.gz
meta-impy-fcf35900271fbcb123b9d0d5652d79db0d1965fb.tar.bz2
meta-impy-fcf35900271fbcb123b9d0d5652d79db0d1965fb.tar.xz
fix platform specific mime_type xml loading
note: mime_type<_nonwindowsplatform>.xml directs SLPlugin to the actual implementation. For using gstreamer on mac + win the file has to be changed (try the linux one :) )
Diffstat (limited to 'linden')
-rw-r--r--linden/indra/newview/CMakeLists.txt14
-rw-r--r--linden/indra/newview/llappviewer.cpp11
2 files changed, 10 insertions, 15 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 6fd259a..3dabb3b 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -1547,19 +1547,7 @@ if (WINDOWS)
1547 COMMENT "Copying Quicktime Plugin to the runtime folder." 1547 COMMENT "Copying Quicktime Plugin to the runtime folder."
1548 ) 1548 )
1549 1549
1550 # Copying the mime_types.xml file to app_settings 1550
1551 set(mime_types_source "${CMAKE_SOURCE_DIR}/newview/skins/default/xui/en-us")
1552 set(mime_types_dest "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings")
1553 add_custom_command(
1554 TARGET ${VIEWER_BINARY_NAME} POST_BUILD
1555 COMMAND ${CMAKE_COMMAND}
1556 ARGS
1557 -E
1558 copy_if_different
1559 ${mime_types_source}/mime_types_windows.xml
1560 ${mime_types_dest}/mime_types.xml
1561 COMMENT "Copying mime_types_windows.xml to mime_types.xml."
1562 )
1563 1551
1564endif (WINDOWS) 1552endif (WINDOWS)
1565 1553
diff --git a/linden/indra/newview/llappviewer.cpp b/linden/indra/newview/llappviewer.cpp
index a9a6052..f422f33 100644
--- a/linden/indra/newview/llappviewer.cpp
+++ b/linden/indra/newview/llappviewer.cpp
@@ -707,8 +707,15 @@ bool LLAppViewer::init()
707 LLViewerJointMesh::updateVectorize(); 707 LLViewerJointMesh::updateVectorize();
708 708
709 // load MIME type -> media impl mappings 709 // load MIME type -> media impl mappings
710 LLMIMETypes::parseMIMETypes( std::string("mime_types.xml") ); 710 std::string mime_types_name;
711 711#if LL_DARWIN
712 mime_types_name = "mime_types_mac.xml";
713#elif LL_LINUX
714 mime_types_name = "mime_types_linux.xml";
715#else
716 mime_types_name = "mime_types.xml";
717#endif
718 LLMIMETypes::parseMIMETypes( mime_types_name );
712 719
713 // Copy settings to globals. *TODO: Remove or move to appropriage class initializers 720 // Copy settings to globals. *TODO: Remove or move to appropriage class initializers
714 settings_to_globals(); 721 settings_to_globals();