diff options
author | McCabe Maxsted | 2011-03-14 12:05:01 -0700 |
---|---|---|
committer | McCabe Maxsted | 2011-03-14 12:09:22 -0700 |
commit | c8902bbebbc3c71ec1417bf3a92ba41386c704b2 (patch) | |
tree | ee0d5d30cef5abbd1036e1319ed72f7b327e7d0f /linden | |
parent | Forgot to include the licenses file in the artwork package (diff) | |
download | meta-impy-c8902bbebbc3c71ec1417bf3a92ba41386c704b2.zip meta-impy-c8902bbebbc3c71ec1417bf3a92ba41386c704b2.tar.gz meta-impy-c8902bbebbc3c71ec1417bf3a92ba41386c704b2.tar.bz2 meta-impy-c8902bbebbc3c71ec1417bf3a92ba41386c704b2.tar.xz |
Added cmake files to the solution. This should've been done AGES ago
Diffstat (limited to 'linden')
-rw-r--r-- | linden/indra/cmake/CMakeLists.txt | 119 | ||||
-rw-r--r-- | linden/indra/cmake/cmake_dummy.cpp | 30 |
2 files changed, 149 insertions, 0 deletions
diff --git a/linden/indra/cmake/CMakeLists.txt b/linden/indra/cmake/CMakeLists.txt index e69de29..4a7d633 100644 --- a/linden/indra/cmake/CMakeLists.txt +++ b/linden/indra/cmake/CMakeLists.txt | |||
@@ -0,0 +1,119 @@ | |||
1 | # -*- cmake -*- | ||
2 | |||
3 | include(00-Common) | ||
4 | |||
5 | project(cmake) | ||
6 | |||
7 | set(cmake_SOURCE_FILES | ||
8 | CMakeLists.txt | ||
9 | |||
10 | 00-Common.cmake | ||
11 | APR.cmake | ||
12 | Audio.cmake | ||
13 | BerkeleyDB.cmake | ||
14 | Boost.cmake | ||
15 | BuildVersion.cmake | ||
16 | CARes.cmake | ||
17 | CMakeCopyIfDifferent.cmake | ||
18 | CopyBackToSource.cmake | ||
19 | CopyWinLibs.cmake | ||
20 | CSharpMacros.cmake | ||
21 | CURL.cmake | ||
22 | DBusGlib.cmake | ||
23 | DirectX.cmake | ||
24 | ELFIO.cmake | ||
25 | ExamplePlugin.cmake | ||
26 | EXPAT.cmake | ||
27 | FindAPR.cmake | ||
28 | FindBerkeleyDB.cmake | ||
29 | FindCARes.cmake | ||
30 | FindELFIO.cmake | ||
31 | FindGooglePerfTools.cmake | ||
32 | FindHunSpell.cmake | ||
33 | FindJsonCpp.cmake | ||
34 | FindLLQtWebkit.cmake | ||
35 | FindMono.cmake | ||
36 | FindMT.cmake | ||
37 | FindMySQL.cmake | ||
38 | FindNDOF.cmake | ||
39 | FindOpenJPEG.cmake | ||
40 | FindSCP.cmake | ||
41 | FindTut.cmake | ||
42 | FindXmlRpcEpi.cmake | ||
43 | FindZLIB.cmake | ||
44 | FMOD.cmake | ||
45 | FreeType.cmake | ||
46 | Glui.cmake | ||
47 | Glut.cmake | ||
48 | GooglePerfTools.cmake | ||
49 | GStreamer010Plugin.cmake | ||
50 | HUNSPELL.cmake | ||
51 | JPEG.cmake | ||
52 | JsonCpp.cmake | ||
53 | Linking.cmake | ||
54 | LLAddBuildTest.cmake | ||
55 | LLAudio.cmake | ||
56 | LLCharacter.cmake | ||
57 | LLCommon.cmake | ||
58 | LLCrashLogger.cmake | ||
59 | LLDatabase.cmake | ||
60 | LLImage.cmake | ||
61 | LLImageJ2COJ.cmake | ||
62 | LLInventory.cmake | ||
63 | LLMath.cmake | ||
64 | LLMessage.cmake | ||
65 | LLPlugin.cmake | ||
66 | LLPrimitive.cmake | ||
67 | LLRender.cmake | ||
68 | LLScene.cmake | ||
69 | LLUI.cmake | ||
70 | LLVFS.cmake | ||
71 | LLWindow.cmake | ||
72 | LLXML.cmake | ||
73 | LScript.cmake | ||
74 | MediaPluginBase.cmake | ||
75 | MonoDeps.cmake | ||
76 | MonoEmbed.cmake | ||
77 | Mozlib.cmake | ||
78 | MySQL.cmake | ||
79 | NDOF.cmake | ||
80 | OPENAL.cmake | ||
81 | OpenGL.cmake | ||
82 | OpenJPEG.cmake | ||
83 | OpenSSL.cmake | ||
84 | PluginAPI.cmake | ||
85 | PNG.cmake | ||
86 | Prebuilt.cmake | ||
87 | PulseAudio.cmake | ||
88 | Python.cmake | ||
89 | QuickTimePlugin.cmake | ||
90 | RunBuildTest.cmake | ||
91 | TemplateCheck.cmake | ||
92 | Tut.cmake | ||
93 | UI.cmake | ||
94 | UnixInstall.cmake | ||
95 | Variables.cmake | ||
96 | ViewerArtwork.cmake | ||
97 | ViewerMiscLibs.cmake | ||
98 | WebKitLibPlugin.cmake | ||
99 | XmlRpcEpi.cmake | ||
100 | ZLIB.cmake | ||
101 | ) | ||
102 | |||
103 | source_group("Shared Rules" FILES ${cmake_SOURCE_FILES}) | ||
104 | |||
105 | set(master_SOURCE_FILES | ||
106 | ../CMakeLists.txt | ||
107 | ../develop.py | ||
108 | ) | ||
109 | |||
110 | source_group("Master Rules" FILES ${master_SOURCE_FILES}) | ||
111 | |||
112 | set_source_files_properties(${cmake_SOURCE_FILES} ${master_SOURCE_FILES} | ||
113 | PROPERTIES HEADER_FILE_ONLY TRUE) | ||
114 | |||
115 | add_library(cmake | ||
116 | cmake_dummy.cpp | ||
117 | ${cmake_SOURCE_FILES} | ||
118 | ${master_SOURCE_FILES} | ||
119 | ) | ||
diff --git a/linden/indra/cmake/cmake_dummy.cpp b/linden/indra/cmake/cmake_dummy.cpp new file mode 100644 index 0000000..25191e2 --- /dev/null +++ b/linden/indra/cmake/cmake_dummy.cpp | |||
@@ -0,0 +1,30 @@ | |||
1 | /** | ||
2 | * @file cmake_dummy.cpp | ||
3 | * | ||
4 | * $LicenseInfo:firstyear=2008&license=viewergpl$ | ||
5 | * | ||
6 | * Copyright (c) 2008-2009, Linden Research, Inc. | ||
7 | * | ||
8 | * Second Life Viewer Source Code | ||
9 | * The source code in this file ("Source Code") is provided by Linden Lab | ||
10 | * to you under the terms of the GNU General Public License, version 2.0 | ||
11 | * ("GPL"), unless you have obtained a separate licensing agreement | ||
12 | * ("Other License"), formally executed by you and Linden Lab. Terms of | ||
13 | * the GPL can be found in doc/GPL-license.txt in this distribution, or | ||
14 | * online at http://secondlifegrid.net/programs/open_source/licensing/gplv2 | ||
15 | * | ||
16 | * There are special exceptions to the terms and conditions of the GPL as | ||
17 | * it is applied to this Source Code. View the full text of the exception | ||
18 | * in the file doc/FLOSS-exception.txt in this software distribution, or | ||
19 | * online at | ||
20 | * http://secondlifegrid.net/programs/open_source/licensing/flossexception | ||
21 | * | ||
22 | * By copying, modifying or distributing this software, you acknowledge | ||
23 | * that you have read and understood your obligations described above, | ||
24 | * and agree to abide by those obligations. | ||
25 | * | ||
26 | * ALL LINDEN LAB SOURCE CODE IS PROVIDED "AS IS." LINDEN LAB MAKES NO | ||
27 | * WARRANTIES, EXPRESS, IMPLIED OR OTHERWISE, REGARDING ITS ACCURACY, | ||
28 | * COMPLETENESS OR PERFORMANCE. | ||
29 | * $/LicenseInfo$ | ||
30 | */ | ||