aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/scripts/linux/config-SL-source
diff options
context:
space:
mode:
authorDavid Walter Seikel2013-08-30 21:42:45 +1000
committerDavid Walter Seikel2013-08-30 21:42:45 +1000
commit56a1de48ee43bfacbd3ef2859f392082a26bc814 (patch)
tree03bd6092dab42985e536b84d2f311a3a12e4edb4 /linden/scripts/linux/config-SL-source
parentAdded a licensing note about gpg.vs, as used to build OTR on Windows. (diff)
parentMerge remote-tracking branch 'origin/next' into WL-refactor (diff)
downloadmeta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.zip
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.gz
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.bz2
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.xz
Merge remote-tracking branch 'imprudence/next' into next
Unless otherwise stated, Imprudence changes accepted. The three images seem to be the same. Conflicts: .gitignore linden/indra/develop.py linden/indra/llcommon/llsdserialize_xml.cpp linden/indra/newview/CMakeLists.txt Manually combined MOAP, OTR, and WL changes from both. linden/indra/newview/app_settings/default_grids.xml Manually merged the grid collection. Also updated IG info. linden/indra/newview/hippoupdate.cpp linden/indra/newview/llettherebelight.cpp Just used the Imprudence copy. linden/indra/newview/llviewermessage.cpp Keep unbranding. linden/indra/newview/llvoavatar.cpp Manually merge client tags. linden/indra/newview/res/viewerRes.rc Manually merge version from Impy. linden/indra/newview/skins/dark/colors_base.xml Keep unbranding. linden/indra/newview/skins/default/html/unabletoconnect.png linden/indra/newview/skins/default/textures/icon_top_pick.tga linden/indra/newview/skins/default/xui/en-us/floater_about.xml Manual merging of contributors. linden/indra/newview/skins/gemini/colors_base.xml Keep unbranding. linden/indra/newview/skins/gemini/textures/icon_top_pick.tga linden/indra/newview/viewer_manifest.py Manually merged boost, gstreamer, OTR, and name. linden/indra/newview/viewerinfo.cpp Manually merge the comment.
Diffstat (limited to 'linden/scripts/linux/config-SL-source')
-rw-r--r--linden/scripts/linux/config-SL-source22
1 files changed, 21 insertions, 1 deletions
diff --git a/linden/scripts/linux/config-SL-source b/linden/scripts/linux/config-SL-source
index 174d7d4..f60fd92 100644
--- a/linden/scripts/linux/config-SL-source
+++ b/linden/scripts/linux/config-SL-source
@@ -9,6 +9,9 @@
9# accordingly, so that you (should) end up with a properly packaged client. 9# accordingly, so that you (should) end up with a properly packaged client.
10 10
11PWD=`pwd` 11PWD=`pwd`
12os_extra=''
13ionice='ionice -c 3'
14
12 15
13# Where the sources of the client will be held (defaults to "./linden"): 16# Where the sources of the client will be held (defaults to "./linden"):
14PATH_TO_SOURCES="$PWD/../.." 17PATH_TO_SOURCES="$PWD/../.."
@@ -18,6 +21,8 @@ PATH_TO_PATCHES="$PWD/../../patches"
18TEMP_DIR="/tmp/SL-$USER" 21TEMP_DIR="/tmp/SL-$USER"
19mkdir -p $TEMP_DIR 22mkdir -p $TEMP_DIR
20 23
24TYPE="RelWithDebInfo"
25
21USE_SYSTEM_GTK="no" 26USE_SYSTEM_GTK="no"
22USE_SYSTEM_SDL="no" 27USE_SYSTEM_SDL="no"
23USE_SYSTEM_SSL="no" 28USE_SYSTEM_SSL="no"
@@ -53,7 +58,7 @@ USE_SYSTEM_BOOST="no"
53# You may add tune flags here, to optimize the code for your processor. 58# You may add tune flags here, to optimize the code for your processor.
54# Example, for an Athlon XP: 59# Example, for an Athlon XP:
55# TUNE_FLAGS="-march=athlon-xp" 60# TUNE_FLAGS="-march=athlon-xp"
56TUNE_FLAGS="-fomit-frame-pointer -frename-registers -ftree-vectorize -fweb -fexpensive-optimizations -msse -mfpmath=sse" 61TUNE_FLAGS="-O2 -fomit-frame-pointer -frename-registers -ftree-vectorize -fweb -fexpensive-optimizations -msse -mfpmath=sse"
57# Set this to "yes" to force vectorization use in the viewer code (only for 62# Set this to "yes" to force vectorization use in the viewer code (only for
58# processors with SSE or Altivec units, and only if you did enable them via 63# processors with SSE or Altivec units, and only if you did enable them via
59# the TUNE_FLAGS. 64# the TUNE_FLAGS.
@@ -61,3 +66,18 @@ FORCE_VECTORIZE="yes"
61 66
62# When using gcc v4.3 or later, you might have to set this to yes... 67# When using gcc v4.3 or later, you might have to set this to yes...
63ALLOW_WARNINGS="yes" 68ALLOW_WARNINGS="yes"
69
70
71# Change it all for cygwin.
72if [ "$OSTYPE" == "cygwin" ] ; then
73 os_extra='-G nmake'
74 ionice=''
75 USE_SYSTEM_LIBSTDC="no"
76 TUNE_FLAGS="/EHsc /GR /Zm1000 /DWIN32 /D_WINDOWS "
77 FORCE_VECTORIZE="no"
78 ALLOW_WARNINGS="no"
79fi
80
81
82# Work around python problems.
83export PYTHONUNBUFFERED='True'