diff options
author | McCabe Maxsted | 2010-10-08 23:00:04 -0700 |
---|---|---|
committer | McCabe Maxsted | 2010-10-08 23:00:04 -0700 |
commit | d946bcb0b6f47f8520f456497d0af2e950cc0924 (patch) | |
tree | 4986f5a6d1c16d98fecd3f463a95a0f4e6aaba8c /linden/indra | |
parent | Changed version to Experimental 2010.10.06-hotfix (diff) | |
parent | Merge branch 'weekly-rebase' into weekly (diff) | |
download | meta-impy-d946bcb0b6f47f8520f456497d0af2e950cc0924.zip meta-impy-d946bcb0b6f47f8520f456497d0af2e950cc0924.tar.gz meta-impy-d946bcb0b6f47f8520f456497d0af2e950cc0924.tar.bz2 meta-impy-d946bcb0b6f47f8520f456497d0af2e950cc0924.tar.xz |
Merge branch 'weekly-next' into weekly
Diffstat (limited to 'linden/indra')
-rw-r--r-- | linden/indra/cmake/GStreamer.cmake | 18 | ||||
-rw-r--r-- | linden/indra/cmake/LLMedia.cmake | 1 | ||||
-rw-r--r-- | linden/indra/cmake/OPENAL.cmake | 14 | ||||
-rw-r--r-- | linden/indra/llmedia/CMakeLists.txt | 2 | ||||
-rw-r--r-- | linden/indra/newview/app_settings/settings.xml | 2 | ||||
-rw-r--r-- | linden/indra/newview/llappviewer.cpp | 3 | ||||
-rw-r--r-- | linden/indra/newview/llselectmgr.cpp | 29 | ||||
-rw-r--r-- | linden/indra/newview/lltoolplacer.cpp | 13 | ||||
-rw-r--r-- | linden/indra/newview/llviewermenufile.cpp | 5 | ||||
-rw-r--r-- | linden/indra/newview/llviewerparcelmgr.cpp | 22 | ||||
-rw-r--r-- | linden/indra/newview/primbackup.cpp | 31 | ||||
-rw-r--r-- | linden/indra/newview/skins/default/xui/en-us/floater_mini_map.xml | 2 | ||||
-rw-r--r-- | linden/indra/newview/skins/default/xui/en-us/floater_snapshot.xml | 4 |
13 files changed, 121 insertions, 25 deletions
diff --git a/linden/indra/cmake/GStreamer.cmake b/linden/indra/cmake/GStreamer.cmake index f5f9c03..9c5e9f7 100644 --- a/linden/indra/cmake/GStreamer.cmake +++ b/linden/indra/cmake/GStreamer.cmake | |||
@@ -1,12 +1,22 @@ | |||
1 | # -*- cmake -*- | 1 | # -*- cmake -*- |
2 | include(Prebuilt) | 2 | include(Prebuilt) |
3 | 3 | ||
4 | # Maybe libxml and glib should have their own .cmake files | 4 | if (STANDALONE) |
5 | include(FindPkgConfig) | ||
6 | |||
7 | pkg_check_modules(GSTREAMER REQUIRED gstreamer-0.10) | ||
8 | pkg_check_modules(GSTREAMER_PLUGINS_BASE REQUIRED gstreamer-plugins-base-0.10) | ||
9 | pkg_check_modules(GSTREAMER_VIDEO REQUIRED gstreamer-video-0.10) | ||
10 | |||
11 | else (STANDALONE) | ||
12 | |||
13 | # libxml and glib should have their own .cmake files | ||
5 | use_prebuilt_binary(libxml) | 14 | use_prebuilt_binary(libxml) |
6 | use_prebuilt_binary(glib) | 15 | use_prebuilt_binary(glib) |
7 | 16 | ||
8 | set(GSTREAMER_FOUND ON FORCE BOOL) | 17 | set(GSTREAMER_FOUND ON FORCE BOOL) |
9 | set(GSTREAMER_PLUGINS_BASE_FOUND ON FORCE BOOL) | 18 | set(GSTREAMER_PLUGINS_BASE_FOUND ON FORCE BOOL) |
19 | set(GSTREAMER_VIDEO_FOUND ON FORCE BOOL) | ||
10 | 20 | ||
11 | use_prebuilt_binary(gstreamer) | 21 | use_prebuilt_binary(gstreamer) |
12 | use_prebuilt_binary(gstreamer-plugins) | 22 | use_prebuilt_binary(gstreamer-plugins) |
@@ -105,9 +115,11 @@ else (WINDOWS) | |||
105 | 115 | ||
106 | endif (WINDOWS) | 116 | endif (WINDOWS) |
107 | 117 | ||
108 | if (GSTREAMER_FOUND AND GSTREAMER_PLUGINS_BASE_FOUND) | 118 | endif (STANDALONE) |
119 | |||
120 | if (GSTREAMER_FOUND AND GSTREAMER_PLUGINS_BASE_FOUND AND GSTREAMER_VIDEO_FOUND) | ||
109 | set(GSTREAMER ON CACHE BOOL "Build with GStreamer streaming media support.") | 121 | set(GSTREAMER ON CACHE BOOL "Build with GStreamer streaming media support.") |
110 | endif (GSTREAMER_FOUND AND GSTREAMER_PLUGINS_BASE_FOUND) | 122 | endif (GSTREAMER_FOUND AND GSTREAMER_PLUGINS_BASE_FOUND AND GSTREAMER_VIDEO_FOUND) |
111 | 123 | ||
112 | if (GSTREAMER) | 124 | if (GSTREAMER) |
113 | add_definitions(-DLL_GSTREAMER_ENABLED=1) | 125 | add_definitions(-DLL_GSTREAMER_ENABLED=1) |
diff --git a/linden/indra/cmake/LLMedia.cmake b/linden/indra/cmake/LLMedia.cmake index 8a36a69..e7769db 100644 --- a/linden/indra/cmake/LLMedia.cmake +++ b/linden/indra/cmake/LLMedia.cmake | |||
@@ -10,4 +10,5 @@ set(LLMEDIA_LIBRARIES | |||
10 | llmedia | 10 | llmedia |
11 | ${GSTREAMER_LIBRARIES} | 11 | ${GSTREAMER_LIBRARIES} |
12 | ${GSTREAMER_PLUGINS_BASE_LIBRARIES} | 12 | ${GSTREAMER_PLUGINS_BASE_LIBRARIES} |
13 | ${GSTREAMER_VIDEO_LIBRARIES} | ||
13 | ) | 14 | ) |
diff --git a/linden/indra/cmake/OPENAL.cmake b/linden/indra/cmake/OPENAL.cmake index 4f0e0cc..b9efd57 100644 --- a/linden/indra/cmake/OPENAL.cmake +++ b/linden/indra/cmake/OPENAL.cmake | |||
@@ -2,11 +2,21 @@ | |||
2 | 2 | ||
3 | include(Variables) | 3 | include(Variables) |
4 | include(Linking) | 4 | include(Linking) |
5 | include(FindPkgConfig) | ||
5 | 6 | ||
6 | set(OPENAL ON CACHE BOOL "Enable OpenAL") | 7 | set(OPENAL ON CACHE BOOL "Enable OpenAL") |
7 | 8 | ||
9 | # If STANDALONE but NOT PKG_CONFIG_FOUND we should fail, | ||
10 | # but why try to find it as prebuilt? | ||
11 | if (OPENAL AND STANDALONE AND PKG_CONFIG_FOUND) | ||
8 | 12 | ||
9 | if (OPENAL) | 13 | # This module defines |
14 | # OPENAL_INCLUDE_DIRS | ||
15 | # OPENAL_LIBRARIES | ||
16 | # OPENAL_FOUND | ||
17 | pkg_check_modules(OPENAL REQUIRED freealut) # freealut links with openal. | ||
18 | |||
19 | elseif (OPENAL) | ||
10 | 20 | ||
11 | # message(STATUS "Building with OpenAL audio support") | 21 | # message(STATUS "Building with OpenAL audio support") |
12 | 22 | ||
@@ -110,4 +120,4 @@ if (OPENAL) | |||
110 | "Found OpenAL and ALUT libraries successfully" | 120 | "Found OpenAL and ALUT libraries successfully" |
111 | ) | 121 | ) |
112 | 122 | ||
113 | endif (OPENAL) | 123 | endif (OPENAL AND STANDALONE AND PKG_CONFIG_FOUND) |
diff --git a/linden/indra/llmedia/CMakeLists.txt b/linden/indra/llmedia/CMakeLists.txt index c7b5cd1..f3c8e30 100644 --- a/linden/indra/llmedia/CMakeLists.txt +++ b/linden/indra/llmedia/CMakeLists.txt | |||
@@ -15,6 +15,7 @@ include(Mozlib) | |||
15 | include_directories( | 15 | include_directories( |
16 | ${GSTREAMER_INCLUDE_DIRS} | 16 | ${GSTREAMER_INCLUDE_DIRS} |
17 | ${GSTREAMER_PLUGINS_BASE_INCLUDE_DIRS} | 17 | ${GSTREAMER_PLUGINS_BASE_INCLUDE_DIRS} |
18 | ${GSTREAMER_VIDEO_INCLUDE_DIRS} | ||
18 | ${LLAUDIO_INCLUDE_DIRS} | 19 | ${LLAUDIO_INCLUDE_DIRS} |
19 | ${LLCOMMON_INCLUDE_DIRS} | 20 | ${LLCOMMON_INCLUDE_DIRS} |
20 | ${LLIMAGE_INCLUDE_DIRS} | 21 | ${LLIMAGE_INCLUDE_DIRS} |
@@ -75,5 +76,6 @@ target_link_libraries( | |||
75 | llmedia | 76 | llmedia |
76 | ${GSTREAMER_LIBRARIES} | 77 | ${GSTREAMER_LIBRARIES} |
77 | ${GSTREAMER_PLUGINS_BASE_LIBRARIES} | 78 | ${GSTREAMER_PLUGINS_BASE_LIBRARIES} |
79 | ${GSTREAMER_VIDEO_LIBRARIES} | ||
78 | ${QUICKTIME_LIBRARY} | 80 | ${QUICKTIME_LIBRARY} |
79 | ) | 81 | ) |
diff --git a/linden/indra/newview/app_settings/settings.xml b/linden/indra/newview/app_settings/settings.xml index aeb5c0b..b38bf9a 100644 --- a/linden/indra/newview/app_settings/settings.xml +++ b/linden/indra/newview/app_settings/settings.xml | |||
@@ -6683,7 +6683,7 @@ | |||
6683 | <key>Comment</key> | 6683 | <key>Comment</key> |
6684 | <string>Double resolution of snapshot from current window resolution</string> | 6684 | <string>Double resolution of snapshot from current window resolution</string> |
6685 | <key>Persist</key> | 6685 | <key>Persist</key> |
6686 | <integer>1</integer> | 6686 | <integer>0</integer> |
6687 | <key>Type</key> | 6687 | <key>Type</key> |
6688 | <string>Boolean</string> | 6688 | <string>Boolean</string> |
6689 | <key>Value</key> | 6689 | <key>Value</key> |
diff --git a/linden/indra/newview/llappviewer.cpp b/linden/indra/newview/llappviewer.cpp index 2496d13..96fc451 100644 --- a/linden/indra/newview/llappviewer.cpp +++ b/linden/indra/newview/llappviewer.cpp | |||
@@ -1189,6 +1189,9 @@ bool LLAppViewer::cleanup() | |||
1189 | { //*might* crash imprudence TODO: fix the voiceclient instead | 1189 | { //*might* crash imprudence TODO: fix the voiceclient instead |
1190 | //this deletes all your buddies | 1190 | //this deletes all your buddies |
1191 | LLAvatarTracker::instance().reset(); | 1191 | LLAvatarTracker::instance().reset(); |
1192 | // reset group data. Blame LL for the need to clear a member variable through a global | ||
1193 | LLGroupMgr::getInstance()->clearGroups(); | ||
1194 | gAgent.mGroups.clear(); | ||
1192 | } | 1195 | } |
1193 | 1196 | ||
1194 | //reset balance for not playing the UI-Sound | 1197 | //reset balance for not playing the UI-Sound |
diff --git a/linden/indra/newview/llselectmgr.cpp b/linden/indra/newview/llselectmgr.cpp index 83abcf4..1634950 100644 --- a/linden/indra/newview/llselectmgr.cpp +++ b/linden/indra/newview/llselectmgr.cpp | |||
@@ -64,6 +64,7 @@ | |||
64 | #include "llinventorymodel.h" | 64 | #include "llinventorymodel.h" |
65 | #include "llmenugl.h" | 65 | #include "llmenugl.h" |
66 | #include "llmutelist.h" | 66 | #include "llmutelist.h" |
67 | #include "llparcel.h" // RezWithLandGroup | ||
67 | #include "llstatusbar.h" | 68 | #include "llstatusbar.h" |
68 | #include "llsurface.h" | 69 | #include "llsurface.h" |
69 | #include "lltool.h" | 70 | #include "lltool.h" |
@@ -77,6 +78,7 @@ | |||
77 | #include "llviewermenu.h" | 78 | #include "llviewermenu.h" |
78 | #include "llviewerobject.h" | 79 | #include "llviewerobject.h" |
79 | #include "llviewerobjectlist.h" | 80 | #include "llviewerobjectlist.h" |
81 | #include "llviewerparcelmgr.h" // RezWithLandGroup | ||
80 | #include "llviewerregion.h" | 82 | #include "llviewerregion.h" |
81 | #include "llviewerstats.h" | 83 | #include "llviewerstats.h" |
82 | #include "llvoavatar.h" | 84 | #include "llvoavatar.h" |
@@ -3135,7 +3137,20 @@ void LLSelectMgr::packDuplicateOnRayHead(void *user_data) | |||
3135 | msg->nextBlockFast(_PREHASH_AgentData); | 3137 | msg->nextBlockFast(_PREHASH_AgentData); |
3136 | msg->addUUIDFast(_PREHASH_AgentID, gAgent.getID() ); | 3138 | msg->addUUIDFast(_PREHASH_AgentID, gAgent.getID() ); |
3137 | msg->addUUIDFast(_PREHASH_SessionID, gAgent.getSessionID() ); | 3139 | msg->addUUIDFast(_PREHASH_SessionID, gAgent.getSessionID() ); |
3138 | msg->addUUIDFast(_PREHASH_GroupID, gAgent.getGroupID() ); | 3140 | LLUUID group_id = gAgent.getGroupID(); |
3141 | if (gSavedSettings.getBOOL("RezWithLandGroup")) | ||
3142 | { | ||
3143 | LLParcel *parcel = LLViewerParcelMgr::getInstance()->getAgentParcel(); | ||
3144 | if (gAgent.isInGroup(parcel->getGroupID())) | ||
3145 | { | ||
3146 | group_id = parcel->getGroupID(); | ||
3147 | } | ||
3148 | else if (gAgent.isInGroup(parcel->getOwnerID())) | ||
3149 | { | ||
3150 | group_id = parcel->getOwnerID(); | ||
3151 | } | ||
3152 | } | ||
3153 | msg->addUUIDFast(_PREHASH_GroupID, group_id); | ||
3139 | msg->addVector3Fast(_PREHASH_RayStart, data->mRayStartRegion ); | 3154 | msg->addVector3Fast(_PREHASH_RayStart, data->mRayStartRegion ); |
3140 | msg->addVector3Fast(_PREHASH_RayEnd, data->mRayEndRegion ); | 3155 | msg->addVector3Fast(_PREHASH_RayEnd, data->mRayEndRegion ); |
3141 | msg->addBOOLFast(_PREHASH_BypassRaycast, data->mBypassRaycast ); | 3156 | msg->addBOOLFast(_PREHASH_BypassRaycast, data->mBypassRaycast ); |
@@ -3907,6 +3922,18 @@ void LLSelectMgr::packAgentAndSessionAndGroupID(void* user_data) | |||
3907 | void LLSelectMgr::packDuplicateHeader(void* data) | 3922 | void LLSelectMgr::packDuplicateHeader(void* data) |
3908 | { | 3923 | { |
3909 | LLUUID group_id(gAgent.getGroupID()); | 3924 | LLUUID group_id(gAgent.getGroupID()); |
3925 | if (gSavedSettings.getBOOL("RezWithLandGroup")) | ||
3926 | { | ||
3927 | LLParcel *parcel = LLViewerParcelMgr::getInstance()->getAgentParcel(); | ||
3928 | if (gAgent.isInGroup(parcel->getGroupID())) | ||
3929 | { | ||
3930 | group_id = parcel->getGroupID(); | ||
3931 | } | ||
3932 | else if (gAgent.isInGroup(parcel->getOwnerID())) | ||
3933 | { | ||
3934 | group_id = parcel->getOwnerID(); | ||
3935 | } | ||
3936 | } | ||
3910 | packAgentAndSessionAndGroupID(&group_id); | 3937 | packAgentAndSessionAndGroupID(&group_id); |
3911 | 3938 | ||
3912 | LLDuplicateData* dup_data = (LLDuplicateData*) data; | 3939 | LLDuplicateData* dup_data = (LLDuplicateData*) data; |
diff --git a/linden/indra/newview/lltoolplacer.cpp b/linden/indra/newview/lltoolplacer.cpp index d5c4de1..00b0c9f 100644 --- a/linden/indra/newview/lltoolplacer.cpp +++ b/linden/indra/newview/lltoolplacer.cpp | |||
@@ -67,6 +67,7 @@ | |||
67 | 67 | ||
68 | #include "llparcel.h" // RezWithLandGroup | 68 | #include "llparcel.h" // RezWithLandGroup |
69 | #include "llviewerparcelmgr.h" // RezWithLandGroup | 69 | #include "llviewerparcelmgr.h" // RezWithLandGroup |
70 | #include "roles_constants.h" // Ele: Land Group Override | ||
70 | 71 | ||
71 | const LLVector3 DEFAULT_OBJECT_SCALE(0.5f, 0.5f, 0.5f); | 72 | const LLVector3 DEFAULT_OBJECT_SCALE(0.5f, 0.5f, 0.5f); |
72 | 73 | ||
@@ -264,9 +265,11 @@ BOOL LLToolPlacer::addObject( LLPCode pcode, S32 x, S32 y, U8 use_physics ) | |||
264 | gMessageSystem->addUUIDFast(_PREHASH_SessionID, gAgent.getSessionID()); | 265 | gMessageSystem->addUUIDFast(_PREHASH_SessionID, gAgent.getSessionID()); |
265 | // RezWithLandGroup 2009-05, If avatar is in land group/land owner group, | 266 | // RezWithLandGroup 2009-05, If avatar is in land group/land owner group, |
266 | // it rezzes it with it to prevent autoreturn/whatever | 267 | // it rezzes it with it to prevent autoreturn/whatever |
267 | if ( gSavedSettings.getBOOL("RezWithLandGroup") ) | 268 | |
269 | // Ele: if agent is in land group and has create powers but the tag is not active, force it to enable build seamlessly | ||
270 | LLParcel *parcel = LLViewerParcelMgr::getInstance()->getAgentParcel(); | ||
271 | if ( gSavedSettings.getBOOL("RezWithLandGroup")) | ||
268 | { | 272 | { |
269 | LLParcel *parcel = LLViewerParcelMgr::getInstance()->getAgentParcel(); | ||
270 | if ( gAgent.isInGroup(parcel->getGroupID()) ) | 273 | if ( gAgent.isInGroup(parcel->getGroupID()) ) |
271 | { | 274 | { |
272 | gMessageSystem->addUUIDFast(_PREHASH_GroupID, parcel->getGroupID()); | 275 | gMessageSystem->addUUIDFast(_PREHASH_GroupID, parcel->getGroupID()); |
@@ -280,7 +283,11 @@ BOOL LLToolPlacer::addObject( LLPCode pcode, S32 x, S32 y, U8 use_physics ) | |||
280 | gMessageSystem->addUUIDFast(_PREHASH_GroupID, gAgent.getGroupID()); | 283 | gMessageSystem->addUUIDFast(_PREHASH_GroupID, gAgent.getGroupID()); |
281 | } | 284 | } |
282 | } | 285 | } |
283 | else | 286 | else if (gAgent.hasPowerInGroup(parcel->getGroupID(), GP_LAND_ALLOW_CREATE) && !parcel->getIsGroupOwned()) |
287 | { | ||
288 | gMessageSystem->addUUIDFast(_PREHASH_GroupID, parcel->getGroupID()); | ||
289 | } | ||
290 | else | ||
284 | { | 291 | { |
285 | gMessageSystem->addUUIDFast(_PREHASH_GroupID, gAgent.getGroupID()); | 292 | gMessageSystem->addUUIDFast(_PREHASH_GroupID, gAgent.getGroupID()); |
286 | } | 293 | } |
diff --git a/linden/indra/newview/llviewermenufile.cpp b/linden/indra/newview/llviewermenufile.cpp index 364dcfd..432fcc5 100644 --- a/linden/indra/newview/llviewermenufile.cpp +++ b/linden/indra/newview/llviewermenufile.cpp | |||
@@ -43,6 +43,7 @@ | |||
43 | #include "llfloaternamedesc.h" | 43 | #include "llfloaternamedesc.h" |
44 | #include "llfloatersnapshot.h" | 44 | #include "llfloatersnapshot.h" |
45 | #include "llinventorymodel.h" // gInventory | 45 | #include "llinventorymodel.h" // gInventory |
46 | #include "llinventoryview.h" // open_texture() | ||
46 | #include "llresourcedata.h" | 47 | #include "llresourcedata.h" |
47 | #include "llfloaterperms.h" | 48 | #include "llfloaterperms.h" |
48 | #include "llstatusbar.h" | 49 | #include "llstatusbar.h" |
@@ -875,7 +876,9 @@ void temp_upload_done_callback(const LLUUID& uuid, void* user_data, S32 result, | |||
875 | item->updateServer(TRUE); | 876 | item->updateServer(TRUE); |
876 | gInventory.updateItem(item); | 877 | gInventory.updateItem(item); |
877 | gInventory.notifyObservers(); | 878 | gInventory.notifyObservers(); |
878 | }else // if(result >= 0) | 879 | open_texture(item_id, std::string("Texture: ") + item->getName(), TRUE, LLUUID::null, FALSE); |
880 | } | ||
881 | else // if(result >= 0) | ||
879 | { | 882 | { |
880 | LLSD args; | 883 | LLSD args; |
881 | args["FILE"] = LLInventoryType::lookupHumanReadable(data->mInventoryType); | 884 | args["FILE"] = LLInventoryType::lookupHumanReadable(data->mInventoryType); |
diff --git a/linden/indra/newview/llviewerparcelmgr.cpp b/linden/indra/newview/llviewerparcelmgr.cpp index 61b91fe..257ce0d 100644 --- a/linden/indra/newview/llviewerparcelmgr.cpp +++ b/linden/indra/newview/llviewerparcelmgr.cpp | |||
@@ -651,15 +651,21 @@ BOOL LLViewerParcelMgr::agentCanBuild() const | |||
651 | { | 651 | { |
652 | if (mAgentParcel) | 652 | if (mAgentParcel) |
653 | { | 653 | { |
654 | return (gAgent.isGodlike() | 654 | const LLUUID parcel_group = mAgentParcel->getGroupID(); |
655 | || (mAgentParcel->allowModifyBy( | 655 | const LLUUID active_group = gAgent.getGroupID(); |
656 | gAgent.getID(), | 656 | |
657 | gAgent.getGroupID()))); | 657 | if (gAgent.isGodlike()) |
658 | } | 658 | return true; |
659 | else | 659 | |
660 | { | 660 | if (mAgentParcel->allowModifyBy(gAgent.getID(), active_group)) |
661 | return gAgent.isGodlike(); | 661 | return true; |
662 | |||
663 | // Ele: enable build option if we are in the land group and we have create powers, even if the group tag is not active | ||
664 | if (gAgent.isInGroup(parcel_group) && gAgent.hasPowerInGroup(parcel_group, GP_LAND_ALLOW_CREATE)) | ||
665 | return true; | ||
662 | } | 666 | } |
667 | |||
668 | return gAgent.isGodlike(); | ||
663 | } | 669 | } |
664 | 670 | ||
665 | BOOL LLViewerParcelMgr::agentCanTakeDamage() const | 671 | BOOL LLViewerParcelMgr::agentCanTakeDamage() const |
diff --git a/linden/indra/newview/primbackup.cpp b/linden/indra/newview/primbackup.cpp index 63043f0..adbc4de 100644 --- a/linden/indra/newview/primbackup.cpp +++ b/linden/indra/newview/primbackup.cpp | |||
@@ -350,6 +350,34 @@ void primbackup::pre_export_object() | |||
350 | bool primbackup::check_perms( LLSelectNode* node ) | 350 | bool primbackup::check_perms( LLSelectNode* node ) |
351 | { | 351 | { |
352 | LLPermissions *perms = node->mPermissions; | 352 | LLPermissions *perms = node->mPermissions; |
353 | // We check to see if there are megaprims in SL we can export. | ||
354 | // Cludgy, but the only option considering LL's TPV policy. | ||
355 | if (gHippoGridManager->getConnectedGrid()->isSecondLife()) | ||
356 | { | ||
357 | bool is_sl_megaprim = false; | ||
358 | for (int i = 0; i < 3; ++i) | ||
359 | { | ||
360 | if (node->getObject()->getScale().mV[i] > 10) | ||
361 | { | ||
362 | is_sl_megaprim = true; | ||
363 | break; | ||
364 | } | ||
365 | } | ||
366 | |||
367 | if (is_sl_megaprim) | ||
368 | { | ||
369 | // The following avatars in Second Life have given Imprudence permission for their full-perm | ||
370 | // megaprims to be exported even if that means changing the creator from themselves: | ||
371 | // McCabe_Maxsted ("3fc0478f-1c40-48a1-b8a7-3b7062efeda1"); | ||
372 | // Gene_Replacement ("adfacb56-390b-4fdc-9216-3494f1c59862"); | ||
373 | return ((perms->getCreator() == LLUUID("3fc0478f-1c40-48a1-b8a7-3b7062efeda1") || | ||
374 | perms->getCreator() == LLUUID("adfacb56-390b-4fdc-9216-3494f1c59862") || | ||
375 | perms->getCreator() == gAgent.getID()) && | ||
376 | perms->getOwner() == gAgent.getID() && | ||
377 | (PERM_ITEM_UNRESTRICTED & perms->getMaskOwner()) == PERM_ITEM_UNRESTRICTED); | ||
378 | } | ||
379 | } | ||
380 | |||
353 | return (gAgent.getID() == perms->getOwner() && | 381 | return (gAgent.getID() == perms->getOwner() && |
354 | gAgent.getID() == perms->getCreator() && | 382 | gAgent.getID() == perms->getCreator() && |
355 | (PERM_ITEM_UNRESTRICTED & | 383 | (PERM_ITEM_UNRESTRICTED & |
@@ -1111,7 +1139,4 @@ void primbackup::upload_next_asset() | |||
1111 | "Uploaded texture", | 1139 | "Uploaded texture", |
1112 | NULL, | 1140 | NULL, |
1113 | NULL); | 1141 | NULL); |
1114 | |||
1115 | |||
1116 | } | 1142 | } |
1117 | |||
diff --git a/linden/indra/newview/skins/default/xui/en-us/floater_mini_map.xml b/linden/indra/newview/skins/default/xui/en-us/floater_mini_map.xml index 8dfd43c..e02abe2 100644 --- a/linden/indra/newview/skins/default/xui/en-us/floater_mini_map.xml +++ b/linden/indra/newview/skins/default/xui/en-us/floater_mini_map.xml | |||
@@ -1,7 +1,7 @@ | |||
1 | <?xml version="1.0" encoding="utf-8" standalone="yes" ?> | 1 | <?xml version="1.0" encoding="utf-8" standalone="yes" ?> |
2 | 2 | ||
3 | <floater name="minimap" short_title="Mini-Map" | 3 | <floater name="minimap" short_title="Mini-Map" |
4 | height="455" width="200" min_height="400" min_width="240" | 4 | height="455" width="200" min_height="325" min_width="200" |
5 | follows="top|right" can_close="true" can_drag_on_left="false" | 5 | follows="top|right" can_close="true" can_drag_on_left="false" |
6 | can_minimize="true" can_resize="true" can_tear_off="false" | 6 | can_minimize="true" can_resize="true" can_tear_off="false" |
7 | rect_control="FloaterMiniMapRect"> | 7 | rect_control="FloaterMiniMapRect"> |
diff --git a/linden/indra/newview/skins/default/xui/en-us/floater_snapshot.xml b/linden/indra/newview/skins/default/xui/en-us/floater_snapshot.xml index 3b039de..db4d1e1 100644 --- a/linden/indra/newview/skins/default/xui/en-us/floater_snapshot.xml +++ b/linden/indra/newview/skins/default/xui/en-us/floater_snapshot.xml | |||
@@ -136,10 +136,10 @@ | |||
136 | </combo_box> | 136 | </combo_box> |
137 | 137 | ||
138 | <spinner bottom_delta="-25" decimal_digits="0" follows="left|top" height="20" | 138 | <spinner bottom_delta="-25" decimal_digits="0" follows="left|top" height="20" |
139 | increment="32" label="Width" label_width="30" left="10" max_val="6016" | 139 | increment="32" label="Width" label_width="30" left="10" max_val="4096" |
140 | min_val="32" name="snapshot_width" width="95" allow_text_entry="false"/> | 140 | min_val="32" name="snapshot_width" width="95" allow_text_entry="false"/> |
141 | <spinner bottom_delta="0" decimal_digits="0" follows="left|top" height="20" | 141 | <spinner bottom_delta="0" decimal_digits="0" follows="left|top" height="20" |
142 | increment="32" label="Height" label_width="35" left="110" max_val="6016" | 142 | increment="32" label="Height" label_width="35" left="110" max_val="4096" |
143 | min_val="32" name="snapshot_height" width="95" allow_text_entry="false"/> | 143 | min_val="32" name="snapshot_height" width="95" allow_text_entry="false"/> |
144 | <check_box bottom_delta="-20" follows="left|top" label="Constrain Proportions" left="10" | 144 | <check_box bottom_delta="-20" follows="left|top" label="Constrain Proportions" left="10" |
145 | name="keep_aspect_check" /> | 145 | name="keep_aspect_check" /> |