diff options
author | McCabe Maxsted | 2011-02-10 03:53:39 -0700 |
---|---|---|
committer | McCabe Maxsted | 2011-02-10 03:53:39 -0700 |
commit | c23341b1b11c860c9029678f494156cbbe155c08 (patch) | |
tree | 06eb5c48ac8d522a117b37af95a07f356192bd6d /linden/indra | |
parent | Merge branch 'armin/weekly' into weekly (diff) | |
download | meta-impy-c23341b1b11c860c9029678f494156cbbe155c08.zip meta-impy-c23341b1b11c860c9029678f494156cbbe155c08.tar.gz meta-impy-c23341b1b11c860c9029678f494156cbbe155c08.tar.bz2 meta-impy-c23341b1b11c860c9029678f494156cbbe155c08.tar.xz |
Enabled gstreamer10 media plugin in CMake for Windows
Diffstat (limited to 'linden/indra')
-rwxr-xr-x | linden/indra/media_plugins/CMakeLists.txt | 10 | ||||
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 24 |
2 files changed, 20 insertions, 14 deletions
diff --git a/linden/indra/media_plugins/CMakeLists.txt b/linden/indra/media_plugins/CMakeLists.txt index a4c6b18..7c224b4 100755 --- a/linden/indra/media_plugins/CMakeLists.txt +++ b/linden/indra/media_plugins/CMakeLists.txt | |||
@@ -8,8 +8,14 @@ if (LINUX) | |||
8 | add_subdirectory(gstreamer010) | 8 | add_subdirectory(gstreamer010) |
9 | endif (LINUX) | 9 | endif (LINUX) |
10 | 10 | ||
11 | if (WINDOWS OR DARWIN) | 11 | # We use gstreamer for audio, quicktime for media on win-- MC |
12 | if (WINDOWS) | ||
13 | add_subdirectory(gstreamer010) | ||
14 | add_subdirectory(quicktime) | ||
15 | endif (WINDOWS) | ||
16 | |||
17 | if (DARWIN) | ||
12 | add_subdirectory(quicktime) | 18 | add_subdirectory(quicktime) |
13 | endif (WINDOWS OR DARWIN) | 19 | endif (DARWIN) |
14 | 20 | ||
15 | add_subdirectory(example) | 21 | add_subdirectory(example) |
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index 0eb5b41..dedced0 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -1373,7 +1373,7 @@ if (WINDOWS) | |||
1373 | DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1373 | DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1374 | ) | 1374 | ) |
1375 | 1375 | ||
1376 | add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit) # Removed media_plugin_gstreamer010 | 1376 | add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010) |
1377 | 1377 | ||
1378 | if (PACKAGE) | 1378 | if (PACKAGE) |
1379 | add_custom_target(package ALL DEPENDS ${CMAKE_CFG_INTDIR}/touched.bat) | 1379 | add_custom_target(package ALL DEPENDS ${CMAKE_CFG_INTDIR}/touched.bat) |
@@ -1589,17 +1589,17 @@ if (WINDOWS) | |||
1589 | COMMENT "Copying WebKit Plugin to the runtime folder." | 1589 | COMMENT "Copying WebKit Plugin to the runtime folder." |
1590 | ) | 1590 | ) |
1591 | 1591 | ||
1592 | #get_target_property(BUILT_GSTREAMER_PLUGIN media_plugin_gstreamer010 LOCATION) | 1592 | get_target_property(BUILT_GSTREAMER_PLUGIN media_plugin_gstreamer010 LOCATION) |
1593 | # add_custom_command( | 1593 | add_custom_command( |
1594 | # TARGET ${VIEWER_BINARY_NAME} POST_BUILD | 1594 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD |
1595 | # COMMAND ${CMAKE_COMMAND} | 1595 | COMMAND ${CMAKE_COMMAND} |
1596 | # ARGS | 1596 | ARGS |
1597 | # -E | 1597 | -E |
1598 | # copy_if_different | 1598 | copy_if_different |
1599 | # ${BUILT_GSTREAMER_PLUGIN} | 1599 | ${BUILT_GSTREAMER_PLUGIN} |
1600 | # ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin | 1600 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin |
1601 | # COMMENT "Copying Gstreamer Plugin to the runtime folder." | 1601 | COMMENT "Copying Gstreamer Plugin to the runtime folder." |
1602 | # ) | 1602 | ) |
1603 | 1603 | ||
1604 | get_target_property(BUILT_QUICKTIME_PLUGIN media_plugin_quicktime LOCATION) | 1604 | get_target_property(BUILT_QUICKTIME_PLUGIN media_plugin_quicktime LOCATION) |
1605 | add_custom_command( | 1605 | add_custom_command( |