diff options
author | Aleric Inglewood | 2010-11-10 15:10:05 +0100 |
---|---|---|
committer | Aleric Inglewood | 2010-11-10 15:10:05 +0100 |
commit | a5ee390cdfcd89a5b747743894bd5661e00f77f0 (patch) | |
tree | 219c3b2464a7037f593bd01d7fbd8a4052bea9e5 /linden/indra | |
parent | IMP-692: SNOW-713: Merge branch 'weekly' into SNOW-713 (diff) | |
parent | Install unstripped binary in packaged when --type=Debug (diff) | |
download | meta-impy-a5ee390cdfcd89a5b747743894bd5661e00f77f0.zip meta-impy-a5ee390cdfcd89a5b747743894bd5661e00f77f0.tar.gz meta-impy-a5ee390cdfcd89a5b747743894bd5661e00f77f0.tar.bz2 meta-impy-a5ee390cdfcd89a5b747743894bd5661e00f77f0.tar.xz |
Merge branch 'weekly' into SNOW-713
Diffstat (limited to 'linden/indra')
-rw-r--r-- | linden/indra/lib/python/indra/util/llmanifest.py | 3 | ||||
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 3 | ||||
-rwxr-xr-x | linden/indra/newview/viewer_manifest.py | 12 |
3 files changed, 16 insertions, 2 deletions
diff --git a/linden/indra/lib/python/indra/util/llmanifest.py b/linden/indra/lib/python/indra/util/llmanifest.py index 3444a15..fc777b2 100644 --- a/linden/indra/lib/python/indra/util/llmanifest.py +++ b/linden/indra/lib/python/indra/util/llmanifest.py | |||
@@ -121,6 +121,9 @@ ARGUMENTS=[ | |||
121 | default=""), | 121 | default=""), |
122 | dict(name='artwork', description='Artwork directory.', default=DEFAULT_SRCTREE), | 122 | dict(name='artwork', description='Artwork directory.', default=DEFAULT_SRCTREE), |
123 | dict(name='build', description='Build directory.', default=DEFAULT_SRCTREE), | 123 | dict(name='build', description='Build directory.', default=DEFAULT_SRCTREE), |
124 | dict(name='buildtype', | ||
125 | description='Set to DEBUG if this is a debug build.', | ||
126 | default="RELEASE"), | ||
124 | dict(name='channel', | 127 | dict(name='channel', |
125 | description="""The channel to use for updates, packaging, settings name, etc.""", | 128 | description="""The channel to use for updates, packaging, settings name, etc.""", |
126 | default=get_channel), | 129 | default=get_channel), |
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index 8683bae..dff759e 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -1356,6 +1356,7 @@ if (WINDOWS) | |||
1356 | --channel=${VIEWER_CHANNEL} | 1356 | --channel=${VIEWER_CHANNEL} |
1357 | --login_channel=${VIEWER_LOGIN_CHANNEL} | 1357 | --login_channel=${VIEWER_LOGIN_CHANNEL} |
1358 | --standalone=${STANDALONE} | 1358 | --standalone=${STANDALONE} |
1359 | --buildtype=${CMAKE_BUILD_TYPE} | ||
1359 | --grid=${GRID} | 1360 | --grid=${GRID} |
1360 | --source=${CMAKE_CURRENT_SOURCE_DIR} | 1361 | --source=${CMAKE_CURRENT_SOURCE_DIR} |
1361 | --artwork=${ARTWORK_DIR} | 1362 | --artwork=${ARTWORK_DIR} |
@@ -1434,6 +1435,7 @@ if (LINUX) | |||
1434 | ARGS | 1435 | ARGS |
1435 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1436 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1436 | --standalone=${STANDALONE} | 1437 | --standalone=${STANDALONE} |
1438 | --buildtype=${CMAKE_BUILD_TYPE} | ||
1437 | --grid=${GRID} | 1439 | --grid=${GRID} |
1438 | --channel=${VIEWER_CHANNEL} | 1440 | --channel=${VIEWER_CHANNEL} |
1439 | --login_channel=${VIEWER_LOGIN_CHANNEL} | 1441 | --login_channel=${VIEWER_LOGIN_CHANNEL} |
@@ -1498,6 +1500,7 @@ if (DARWIN) | |||
1498 | ARGS | 1500 | ARGS |
1499 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1501 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1500 | --standalone=${STANDALONE} | 1502 | --standalone=${STANDALONE} |
1503 | --buildtype=${CMAKE_BUILD_TYPE} | ||
1501 | --grid=${GRID} | 1504 | --grid=${GRID} |
1502 | --configuration=${CMAKE_CFG_INTDIR} | 1505 | --configuration=${CMAKE_CFG_INTDIR} |
1503 | --channel=${VIEWER_CHANNEL} | 1506 | --channel=${VIEWER_CHANNEL} |
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py index 30c0271..f9c34d6 100755 --- a/linden/indra/newview/viewer_manifest.py +++ b/linden/indra/newview/viewer_manifest.py | |||
@@ -162,6 +162,8 @@ class ViewerManifest(LLManifest): | |||
162 | 162 | ||
163 | def standalone(self): | 163 | def standalone(self): |
164 | return self.args['standalone'] == "ON" | 164 | return self.args['standalone'] == "ON" |
165 | def debug(self): | ||
166 | return self.args['buildtype'] == "DEBUG" | ||
165 | def grid(self): | 167 | def grid(self): |
166 | return self.args['grid'] | 168 | return self.args['grid'] |
167 | def channel(self): | 169 | def channel(self): |
@@ -990,7 +992,10 @@ class LinuxManifest(ViewerManifest): | |||
990 | class Linux_i686Manifest(LinuxManifest): | 992 | class Linux_i686Manifest(LinuxManifest): |
991 | def construct(self): | 993 | def construct(self): |
992 | super(Linux_i686Manifest, self).construct() | 994 | super(Linux_i686Manifest, self).construct() |
993 | self.path("imprudence-stripped","bin/do-not-directly-run-imprudence-bin") | 995 | if self.debug(): |
996 | self.path("imprudence-bin","bin/do-not-directly-run-imprudence-bin") | ||
997 | else: | ||
998 | self.path("imprudence-stripped","bin/do-not-directly-run-imprudence-bin") | ||
994 | 999 | ||
995 | self.path("../llcommon/libllcommon.so", "lib/libllcommon.so") | 1000 | self.path("../llcommon/libllcommon.so", "lib/libllcommon.so") |
996 | 1001 | ||
@@ -1108,7 +1113,10 @@ class Linux_i686Manifest(LinuxManifest): | |||
1108 | class Linux_x86_64Manifest(LinuxManifest): | 1113 | class Linux_x86_64Manifest(LinuxManifest): |
1109 | def construct(self): | 1114 | def construct(self): |
1110 | super(Linux_x86_64Manifest, self).construct() | 1115 | super(Linux_x86_64Manifest, self).construct() |
1111 | self.path("imprudence-stripped","bin/do-not-directly-run-imprudence-bin") | 1116 | if self.debug(): |
1117 | self.path("imprudence-bin","bin/do-not-directly-run-imprudence-bin") | ||
1118 | else: | ||
1119 | self.path("imprudence-stripped","bin/do-not-directly-run-imprudence-bin") | ||
1112 | # self.path("../linux_crash_logger/linux-crash-logger-stripped","linux-crash-logger.bin") | 1120 | # self.path("../linux_crash_logger/linux-crash-logger-stripped","linux-crash-logger.bin") |
1113 | 1121 | ||
1114 | self.path("../llcommon/libllcommon.so", "lib64/libllcommon.so") | 1122 | self.path("../llcommon/libllcommon.so", "lib64/libllcommon.so") |