aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra
diff options
context:
space:
mode:
authorMcCabe Maxsted2010-04-03 16:12:15 -0700
committerMcCabe Maxsted2010-04-03 16:12:35 -0700
commita222cbb5160138871aa3fbf8b7a9305346338943 (patch)
tree2690f5c824f97c8df7ddff049cce977568b97be3 /linden/indra
parentFixed some ported settings that were missing from settings_per_account.xml (diff)
downloadmeta-impy-a222cbb5160138871aa3fbf8b7a9305346338943.zip
meta-impy-a222cbb5160138871aa3fbf8b7a9305346338943.tar.gz
meta-impy-a222cbb5160138871aa3fbf8b7a9305346338943.tar.bz2
meta-impy-a222cbb5160138871aa3fbf8b7a9305346338943.tar.xz
Created new Advanced preferences panel, ready for filling
Diffstat (limited to 'linden/indra')
-rw-r--r--linden/indra/newview/CMakeLists.txt3
-rw-r--r--linden/indra/newview/llfloaterpreference.cpp15
-rw-r--r--linden/indra/newview/llfloaterpreference.h2
-rw-r--r--linden/indra/newview/llprefsadvanced.cpp58
-rw-r--r--linden/indra/newview/llprefsadvanced.h50
-rw-r--r--linden/indra/newview/skins/default/xui/en-us/panel_preferences_advanced.xml5
6 files changed, 132 insertions, 1 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index b339947..f75360c 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -310,6 +310,7 @@ set(viewer_SOURCE_FILES
310 llpatchvertexarray.cpp 310 llpatchvertexarray.cpp
311 llpolymesh.cpp 311 llpolymesh.cpp
312 llpolymorph.cpp 312 llpolymorph.cpp
313 llprefsadvanced.cpp
313 llprefschat.cpp 314 llprefschat.cpp
314 llprefsim.cpp 315 llprefsim.cpp
315 llprefsvoice.cpp 316 llprefsvoice.cpp
@@ -735,6 +736,7 @@ set(viewer_HEADER_FILES
735 llpatchvertexarray.h 736 llpatchvertexarray.h
736 llpolymesh.h 737 llpolymesh.h
737 llpolymorph.h 738 llpolymorph.h
739 llprefsadvanced.h
738 llprefschat.h 740 llprefschat.h
739 llprefsim.h 741 llprefsim.h
740 llprefsvoice.h 742 llprefsvoice.h
@@ -1244,6 +1246,7 @@ set(viewer_XUI_FILES
1244 skins/default/xui/en-us/panel_overlaybar.xml 1246 skins/default/xui/en-us/panel_overlaybar.xml
1245 skins/default/xui/en-us/panel_place_small.xml 1247 skins/default/xui/en-us/panel_place_small.xml
1246 skins/default/xui/en-us/panel_place.xml 1248 skins/default/xui/en-us/panel_place.xml
1249 skins/default/xui/en-us/panel_preferences_advanced.xml
1247 skins/default/xui/en-us/panel_preferences_audio.xml 1250 skins/default/xui/en-us/panel_preferences_audio.xml
1248 skins/default/xui/en-us/panel_preferences_chat.xml 1251 skins/default/xui/en-us/panel_preferences_chat.xml
1249 skins/default/xui/en-us/panel_preferences_general.xml 1252 skins/default/xui/en-us/panel_preferences_general.xml
diff --git a/linden/indra/newview/llfloaterpreference.cpp b/linden/indra/newview/llfloaterpreference.cpp
index 17a59cc..c468a5e 100644
--- a/linden/indra/newview/llfloaterpreference.cpp
+++ b/linden/indra/newview/llfloaterpreference.cpp
@@ -62,6 +62,7 @@
62#include "llpanelmsgs.h" 62#include "llpanelmsgs.h"
63#include "llpanelweb.h" 63#include "llpanelweb.h"
64#include "llpanelskins.h" 64#include "llpanelskins.h"
65#include "llprefsadvanced.h"
65#include "llprefschat.h" 66#include "llprefschat.h"
66#include "llprefsvoice.h" 67#include "llprefsvoice.h"
67#include "llprefsim.h" 68#include "llprefsim.h"
@@ -132,7 +133,8 @@ LLPreferenceCore::LLPreferenceCore(LLTabContainer* tab_container, LLButton * def
132 mAudioPanel(NULL), 133 mAudioPanel(NULL),
133 mMsgPanel(NULL), 134 mMsgPanel(NULL),
134 mSkinsPanel(NULL), 135 mSkinsPanel(NULL),
135 mLCDPanel(NULL) 136 mLCDPanel(NULL),
137 mPrefsAdvanced(NULL)
136{ 138{
137 mGeneralPanel = new LLPanelGeneral(); 139 mGeneralPanel = new LLPanelGeneral();
138 mTabContainer->addTabPanel(mGeneralPanel, mGeneralPanel->getLabel(), FALSE, onTabChanged, mTabContainer); 140 mTabContainer->addTabPanel(mGeneralPanel, mGeneralPanel->getLabel(), FALSE, onTabChanged, mTabContainer);
@@ -192,6 +194,10 @@ LLPreferenceCore::LLPreferenceCore(LLTabContainer* tab_container, LLButton * def
192 mTabContainer->addTabPanel(mSkinsPanel, mSkinsPanel->getLabel(), FALSE, onTabChanged, mTabContainer); 194 mTabContainer->addTabPanel(mSkinsPanel, mSkinsPanel->getLabel(), FALSE, onTabChanged, mTabContainer);
193 mSkinsPanel->setDefaultBtn(default_btn); 195 mSkinsPanel->setDefaultBtn(default_btn);
194 196
197 mPrefsAdvanced = new LLPrefsAdvanced();
198 mTabContainer->addTabPanel(mPrefsAdvanced, mPrefsAdvanced->getLabel(), FALSE, onTabChanged, mTabContainer);
199 mPrefsAdvanced->setDefaultBtn(default_btn);
200
195 if (!mTabContainer->selectTab(gSavedSettings.getS32("LastPrefTab"))) 201 if (!mTabContainer->selectTab(gSavedSettings.getS32("LastPrefTab")))
196 { 202 {
197 mTabContainer->selectFirstTab(); 203 mTabContainer->selectFirstTab();
@@ -251,6 +257,11 @@ LLPreferenceCore::~LLPreferenceCore()
251 delete mSkinsPanel; 257 delete mSkinsPanel;
252 mSkinsPanel = NULL; 258 mSkinsPanel = NULL;
253 } 259 }
260 if (mPrefsAdvanced)
261 {
262 delete mPrefsAdvanced;
263 mPrefsAdvanced = NULL;
264 }
254 265
255} 266}
256 267
@@ -267,6 +278,7 @@ void LLPreferenceCore::apply()
267 mPrefsIM->apply(); 278 mPrefsIM->apply();
268 mMsgPanel->apply(); 279 mMsgPanel->apply();
269 mSkinsPanel->apply(); 280 mSkinsPanel->apply();
281 mPrefsAdvanced->apply();
270 282
271 // hardware menu apply 283 // hardware menu apply
272 LLFloaterHardwareSettings::instance()->apply(); 284 LLFloaterHardwareSettings::instance()->apply();
@@ -295,6 +307,7 @@ void LLPreferenceCore::cancel()
295 mPrefsIM->cancel(); 307 mPrefsIM->cancel();
296 mMsgPanel->cancel(); 308 mMsgPanel->cancel();
297 mSkinsPanel->cancel(); 309 mSkinsPanel->cancel();
310 mPrefsAdvanced->cancel();
298 311
299 // cancel hardware menu 312 // cancel hardware menu
300 LLFloaterHardwareSettings::instance()->cancel(); 313 LLFloaterHardwareSettings::instance()->cancel();
diff --git a/linden/indra/newview/llfloaterpreference.h b/linden/indra/newview/llfloaterpreference.h
index f48696f..894d242 100644
--- a/linden/indra/newview/llfloaterpreference.h
+++ b/linden/indra/newview/llfloaterpreference.h
@@ -56,6 +56,7 @@ class LLPrefsVoice;
56class LLPrefsIM; 56class LLPrefsIM;
57class LLPanelMsgs; 57class LLPanelMsgs;
58class LLPanelSkins; 58class LLPanelSkins;
59class LLPrefsAdvanced;
59class LLScrollListCtrl; 60class LLScrollListCtrl;
60 61
61class LLPreferenceCore 62class LLPreferenceCore
@@ -92,6 +93,7 @@ private:
92 LLPanelWeb *mWebPanel; 93 LLPanelWeb *mWebPanel;
93 LLPanelMsgs *mMsgPanel; 94 LLPanelMsgs *mMsgPanel;
94 LLPanelLCD *mLCDPanel; 95 LLPanelLCD *mLCDPanel;
96 LLPrefsAdvanced *mPrefsAdvanced;
95}; 97};
96 98
97// Floater to control preferences (display, audio, bandwidth, general. 99// Floater to control preferences (display, audio, bandwidth, general.
diff --git a/linden/indra/newview/llprefsadvanced.cpp b/linden/indra/newview/llprefsadvanced.cpp
new file mode 100644
index 0000000..c25f04b
--- /dev/null
+++ b/linden/indra/newview/llprefsadvanced.cpp
@@ -0,0 +1,58 @@
1/**
2* @file llprefsadvanced.cpp
3* @brief Advanced preferences options for Imprudence
4*
5* $LicenseInfo:firstyear=2009&license=viewergpl$
6*
7* Copyright (c) 2010, McCabe Maxsted
8*
9* Imprudence Viewer Source Code
10* The source code in this file ("Source Code") is provided to you
11* under the terms of the GNU General Public License, version 2.0
12* ("GPL"). Terms of the GPL can be found in doc/GPL-license.txt in
13* this distribution, or online at
14* http://secondlifegrid.net/programs/open_source/licensing/gplv2
15*
16* There are special exceptions to the terms and conditions of the GPL as
17* it is applied to this Source Code. View the full text of the exception
18* in the file doc/FLOSS-exception.txt in this software distribution, or
19* online at http://secondlifegrid.net/programs/open_source/licensing/flossexception
20*
21* By copying, modifying or distributing this software, you acknowledge
22* that you have read and understood your obligations described above,
23* and agree to abide by those obligations.
24*
25* ALL SOURCE CODE IS PROVIDED "AS IS." THE AUTHOR MAKES NO
26* WARRANTIES, EXPRESS, IMPLIED OR OTHERWISE, REGARDING ITS ACCURACY,
27* COMPLETENESS OR PERFORMANCE.
28* $/LicenseInfo$
29*/
30
31#include "llviewerprecompiledheaders.h"
32
33#include "llprefsadvanced.h"
34
35#include "lluictrlfactory.h"
36
37LLPrefsAdvanced::LLPrefsAdvanced()
38{
39 LLUICtrlFactory::getInstance()->buildPanel(this, "panel_preferences_advanced.xml");
40}
41
42LLPrefsAdvanced::~LLPrefsAdvanced()
43{
44 // Children all cleaned up by default view destructor.
45}
46
47BOOL LLPrefsAdvanced::postBuild()
48{
49 return TRUE;
50}
51
52void LLPrefsAdvanced::apply()
53{
54}
55
56void LLPrefsAdvanced::cancel()
57{
58}
diff --git a/linden/indra/newview/llprefsadvanced.h b/linden/indra/newview/llprefsadvanced.h
new file mode 100644
index 0000000..382156e
--- /dev/null
+++ b/linden/indra/newview/llprefsadvanced.h
@@ -0,0 +1,50 @@
1/**
2* @file llprefsadvanced.h
3* @brief Advanced preferences options for Imprudence
4*
5* $LicenseInfo:firstyear=2009&license=viewergpl$
6*
7* Copyright (c) 2010, McCabe Maxsted
8*
9* Imprudence Viewer Source Code
10* The source code in this file ("Source Code") is provided to you
11* under the terms of the GNU General Public License, version 2.0
12* ("GPL"). Terms of the GPL can be found in doc/GPL-license.txt in
13* this distribution, or online at
14* http://secondlifegrid.net/programs/open_source/licensing/gplv2
15*
16* There are special exceptions to the terms and conditions of the GPL as
17* it is applied to this Source Code. View the full text of the exception
18* in the file doc/FLOSS-exception.txt in this software distribution, or
19* online at http://secondlifegrid.net/programs/open_source/licensing/flossexception
20*
21* By copying, modifying or distributing this software, you acknowledge
22* that you have read and understood your obligations described above,
23* and agree to abide by those obligations.
24*
25* ALL SOURCE CODE IS PROVIDED "AS IS." THE AUTHOR MAKES NO
26* WARRANTIES, EXPRESS, IMPLIED OR OTHERWISE, REGARDING ITS ACCURACY,
27* COMPLETENESS OR PERFORMANCE.
28* $/LicenseInfo$
29*/
30
31#ifndef LLPREFSADVANCED_H
32#define LLPREFSADVANCED_H
33
34#include "llpanel.h"
35
36class LLPrefsAdvanced : public LLPanel
37{
38public:
39 LLPrefsAdvanced();
40 ~LLPrefsAdvanced();
41
42 BOOL postBuild();
43
44 void apply();
45 void cancel();
46
47private:
48};
49
50#endif // LLPREFSADVANCED_H
diff --git a/linden/indra/newview/skins/default/xui/en-us/panel_preferences_advanced.xml b/linden/indra/newview/skins/default/xui/en-us/panel_preferences_advanced.xml
new file mode 100644
index 0000000..31d1ffd
--- /dev/null
+++ b/linden/indra/newview/skins/default/xui/en-us/panel_preferences_advanced.xml
@@ -0,0 +1,5 @@
1<?xml version="1.0" encoding="utf-8" standalone="yes" ?>
2<panel border="true" bottom="-409" enabled="true" follows="left|top|right|bottom"
3 height="408" label="Advanced" left="102" mouse_opaque="true"
4 name="advanced_panel" width="517">
5</panel>