aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra
diff options
context:
space:
mode:
authorAleric Inglewood2010-09-30 02:39:58 +0200
committerMcCabe Maxsted2010-10-01 23:58:07 -0700
commit970221a7aaa211cf26ac9f0a4362a21447db622c (patch)
tree318c534734651894693eb02db2c3369f2088665c /linden/indra
parentSNOW-86: Dangerous macro leads to possible wrong code (diff)
downloadmeta-impy-970221a7aaa211cf26ac9f0a4362a21447db622c.zip
meta-impy-970221a7aaa211cf26ac9f0a4362a21447db622c.tar.gz
meta-impy-970221a7aaa211cf26ac9f0a4362a21447db622c.tar.bz2
meta-impy-970221a7aaa211cf26ac9f0a4362a21447db622c.tar.xz
VWR-14426: Link step fails on Linux when LDFLAGS is set
See http://redmine.imprudenceviewer.org/issues/572
Diffstat (limited to 'linden/indra')
-rw-r--r--linden/indra/linux_crash_logger/CMakeLists.txt2
-rw-r--r--linden/indra/newview/CMakeLists.txt2
2 files changed, 2 insertions, 2 deletions
diff --git a/linden/indra/linux_crash_logger/CMakeLists.txt b/linden/indra/linux_crash_logger/CMakeLists.txt
index 6f6754e..4b19e28 100644
--- a/linden/indra/linux_crash_logger/CMakeLists.txt
+++ b/linden/indra/linux_crash_logger/CMakeLists.txt
@@ -38,7 +38,7 @@ list(APPEND linux_crash_logger_SOURCE_FILES
38 ${linux_crash_logger_HEADER_FILES} 38 ${linux_crash_logger_HEADER_FILES}
39 ) 39 )
40 40
41list(APPEND CMAKE_EXE_LINKER_FLAGS -Wl,--as-needed) 41set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--as-needed")
42 42
43add_executable(linux-crash-logger ${linux_crash_logger_SOURCE_FILES}) 43add_executable(linux-crash-logger ${linux_crash_logger_SOURCE_FILES})
44 44
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 1816ff9..f762923 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -993,7 +993,7 @@ endif (DARWIN)
993 993
994if (LINUX) 994if (LINUX)
995 LIST(APPEND viewer_SOURCE_FILES llappviewerlinux.cpp) 995 LIST(APPEND viewer_SOURCE_FILES llappviewerlinux.cpp)
996 LIST(APPEND CMAKE_EXE_LINKER_FLAGS -Wl,--as-needed) 996 SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--as-needed")
997 997
998 set(viewer_LIBRARIES 998 set(viewer_LIBRARIES
999 Xinerama 999 Xinerama