aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra
diff options
context:
space:
mode:
authorMcCabe Maxsted2010-09-07 17:59:58 -0700
committerArmin Weatherwax2010-09-23 15:38:28 +0200
commit891b747e8b6aa0b9e4a99311804438b37c8c05b4 (patch)
tree02f1aab528e5af5a29accb22f716699eb7e4062c /linden/indra
parentAdded missing plugins notifications (diff)
downloadmeta-impy-891b747e8b6aa0b9e4a99311804438b37c8c05b4.zip
meta-impy-891b747e8b6aa0b9e4a99311804438b37c8c05b4.tar.gz
meta-impy-891b747e8b6aa0b9e4a99311804438b37c8c05b4.tar.bz2
meta-impy-891b747e8b6aa0b9e4a99311804438b37c8c05b4.tar.xz
CMake now runs correctly on Windows
Diffstat (limited to 'linden/indra')
-rw-r--r--linden/indra/cmake/ExamplePlugin.cmake16
-rw-r--r--linden/indra/llplugin/CMakeLists.txt8
2 files changed, 24 insertions, 0 deletions
diff --git a/linden/indra/cmake/ExamplePlugin.cmake b/linden/indra/cmake/ExamplePlugin.cmake
new file mode 100644
index 0000000..599787a
--- /dev/null
+++ b/linden/indra/cmake/ExamplePlugin.cmake
@@ -0,0 +1,16 @@
1# -*- cmake -*-
2include(Linking)
3include(Prebuilt)
4
5if (STANDALONE)
6 set(EXAMPLEPLUGIN OFF CACHE BOOL
7 "EXAMPLEPLUGIN support for the llplugin/llmedia test apps.")
8else (STANDALONE)
9 set(EXAMPLEPLUGIN ON CACHE BOOL
10 "EXAMPLEPLUGIN support for the llplugin/llmedia test apps.")
11endif (STANDALONE)
12
13if (WINDOWS)
14elseif (DARWIN)
15elseif (LINUX)
16endif (WINDOWS)
diff --git a/linden/indra/llplugin/CMakeLists.txt b/linden/indra/llplugin/CMakeLists.txt
index 6706775..e41cdf7 100644
--- a/linden/indra/llplugin/CMakeLists.txt
+++ b/linden/indra/llplugin/CMakeLists.txt
@@ -48,6 +48,14 @@ set(llplugin_HEADER_FILES
48set_source_files_properties(${llplugin_HEADER_FILES} 48set_source_files_properties(${llplugin_HEADER_FILES}
49 PROPERTIES HEADER_FILE_ONLY TRUE) 49 PROPERTIES HEADER_FILE_ONLY TRUE)
50 50
51if(WORD_SIZE EQUAL 64)
52 if(WINDOWS)
53 add_definitions(/FIXED:NO)
54 else(WINDOWS) # not windows therefore gcc LINUX and DARWIN
55 add_definitions(-fPIC)
56 endif(WINDOWS)
57endif (WORD_SIZE EQUAL 64)
58
51list(APPEND llplugin_SOURCE_FILES ${llplugin_HEADER_FILES}) 59list(APPEND llplugin_SOURCE_FILES ${llplugin_HEADER_FILES})
52 60
53add_library (llplugin ${llplugin_SOURCE_FILES}) 61add_library (llplugin ${llplugin_SOURCE_FILES})