aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra
diff options
context:
space:
mode:
authorMcCabe Maxsted2010-11-09 19:00:50 -0700
committerMcCabe Maxsted2010-11-09 19:00:50 -0700
commit52c9b5122b80723de2329afd3f2574eb3143d8c9 (patch)
treec734ec7ff3cb0f3880a4e20d0036622a2e580384 /linden/indra
parentfix: add missing AllowEditingOfTrees setting (diff)
parentInstall unstripped binary in packaged when --type=Debug (diff)
downloadmeta-impy-52c9b5122b80723de2329afd3f2574eb3143d8c9.zip
meta-impy-52c9b5122b80723de2329afd3f2574eb3143d8c9.tar.gz
meta-impy-52c9b5122b80723de2329afd3f2574eb3143d8c9.tar.bz2
meta-impy-52c9b5122b80723de2329afd3f2574eb3143d8c9.tar.xz
Merge remote branch 'aleric/weekly' into weekly
Diffstat (limited to 'linden/indra')
-rw-r--r--linden/indra/lib/python/indra/util/llmanifest.py3
-rw-r--r--linden/indra/newview/CMakeLists.txt3
-rwxr-xr-xlinden/indra/newview/viewer_manifest.py12
3 files changed, 16 insertions, 2 deletions
diff --git a/linden/indra/lib/python/indra/util/llmanifest.py b/linden/indra/lib/python/indra/util/llmanifest.py
index 3444a15..fc777b2 100644
--- a/linden/indra/lib/python/indra/util/llmanifest.py
+++ b/linden/indra/lib/python/indra/util/llmanifest.py
@@ -121,6 +121,9 @@ ARGUMENTS=[
121 default=""), 121 default=""),
122 dict(name='artwork', description='Artwork directory.', default=DEFAULT_SRCTREE), 122 dict(name='artwork', description='Artwork directory.', default=DEFAULT_SRCTREE),
123 dict(name='build', description='Build directory.', default=DEFAULT_SRCTREE), 123 dict(name='build', description='Build directory.', default=DEFAULT_SRCTREE),
124 dict(name='buildtype',
125 description='Set to DEBUG if this is a debug build.',
126 default="RELEASE"),
124 dict(name='channel', 127 dict(name='channel',
125 description="""The channel to use for updates, packaging, settings name, etc.""", 128 description="""The channel to use for updates, packaging, settings name, etc.""",
126 default=get_channel), 129 default=get_channel),
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index a4d99f2..77de749 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -1356,6 +1356,7 @@ if (WINDOWS)
1356 --channel=${VIEWER_CHANNEL} 1356 --channel=${VIEWER_CHANNEL}
1357 --login_channel=${VIEWER_LOGIN_CHANNEL} 1357 --login_channel=${VIEWER_LOGIN_CHANNEL}
1358 --standalone=${STANDALONE} 1358 --standalone=${STANDALONE}
1359 --buildtype=${CMAKE_BUILD_TYPE}
1359 --grid=${GRID} 1360 --grid=${GRID}
1360 --source=${CMAKE_CURRENT_SOURCE_DIR} 1361 --source=${CMAKE_CURRENT_SOURCE_DIR}
1361 --artwork=${ARTWORK_DIR} 1362 --artwork=${ARTWORK_DIR}
@@ -1434,6 +1435,7 @@ if (LINUX)
1434 ARGS 1435 ARGS
1435 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py 1436 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1436 --standalone=${STANDALONE} 1437 --standalone=${STANDALONE}
1438 --buildtype=${CMAKE_BUILD_TYPE}
1437 --grid=${GRID} 1439 --grid=${GRID}
1438 --channel=${VIEWER_CHANNEL} 1440 --channel=${VIEWER_CHANNEL}
1439 --login_channel=${VIEWER_LOGIN_CHANNEL} 1441 --login_channel=${VIEWER_LOGIN_CHANNEL}
@@ -1498,6 +1500,7 @@ if (DARWIN)
1498 ARGS 1500 ARGS
1499 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py 1501 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1500 --standalone=${STANDALONE} 1502 --standalone=${STANDALONE}
1503 --buildtype=${CMAKE_BUILD_TYPE}
1501 --grid=${GRID} 1504 --grid=${GRID}
1502 --configuration=${CMAKE_CFG_INTDIR} 1505 --configuration=${CMAKE_CFG_INTDIR}
1503 --channel=${VIEWER_CHANNEL} 1506 --channel=${VIEWER_CHANNEL}
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py
index 6dcd977..cc22748 100755
--- a/linden/indra/newview/viewer_manifest.py
+++ b/linden/indra/newview/viewer_manifest.py
@@ -162,6 +162,8 @@ class ViewerManifest(LLManifest):
162 162
163 def standalone(self): 163 def standalone(self):
164 return self.args['standalone'] == "ON" 164 return self.args['standalone'] == "ON"
165 def debug(self):
166 return self.args['buildtype'] == "DEBUG"
165 def grid(self): 167 def grid(self):
166 return self.args['grid'] 168 return self.args['grid']
167 def channel(self): 169 def channel(self):
@@ -945,7 +947,10 @@ class LinuxManifest(ViewerManifest):
945class Linux_i686Manifest(LinuxManifest): 947class Linux_i686Manifest(LinuxManifest):
946 def construct(self): 948 def construct(self):
947 super(Linux_i686Manifest, self).construct() 949 super(Linux_i686Manifest, self).construct()
948 self.path("imprudence-stripped","bin/do-not-directly-run-imprudence-bin") 950 if self.debug():
951 self.path("imprudence-bin","bin/do-not-directly-run-imprudence-bin")
952 else:
953 self.path("imprudence-stripped","bin/do-not-directly-run-imprudence-bin")
949 954
950 if (not self.standalone()) and self.prefix("../../libraries/i686-linux/lib_release_client", dst="lib"): 955 if (not self.standalone()) and self.prefix("../../libraries/i686-linux/lib_release_client", dst="lib"):
951 self.path("libapr-1.so.0") 956 self.path("libapr-1.so.0")
@@ -1061,7 +1066,10 @@ class Linux_i686Manifest(LinuxManifest):
1061class Linux_x86_64Manifest(LinuxManifest): 1066class Linux_x86_64Manifest(LinuxManifest):
1062 def construct(self): 1067 def construct(self):
1063 super(Linux_x86_64Manifest, self).construct() 1068 super(Linux_x86_64Manifest, self).construct()
1064 self.path("imprudence-stripped","bin/do-not-directly-run-imprudence-bin") 1069 if self.debug():
1070 self.path("imprudence-bin","bin/do-not-directly-run-imprudence-bin")
1071 else:
1072 self.path("imprudence-stripped","bin/do-not-directly-run-imprudence-bin")
1065# self.path("../linux_crash_logger/linux-crash-logger-stripped","linux-crash-logger.bin") 1073# self.path("../linux_crash_logger/linux-crash-logger-stripped","linux-crash-logger.bin")
1066 1074
1067 self.path("linux_tools/launch_url.sh","launch_url.sh") 1075 self.path("linux_tools/launch_url.sh","launch_url.sh")