aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra
diff options
context:
space:
mode:
authorAleric Inglewood2010-10-17 22:34:20 +0200
committerAleric Inglewood2010-10-17 22:34:20 +0200
commit13dc7326705ec9b8219bef3ee339de499626d237 (patch)
treeb039ac70125979bb9d1b0f0594a16b7f067c57e5 /linden/indra
parentAdd LLQTWEBKIT_INCLUDE_DIR to indra/llplugin/CMakeLists.txt (diff)
downloadmeta-impy-13dc7326705ec9b8219bef3ee339de499626d237.zip
meta-impy-13dc7326705ec9b8219bef3ee339de499626d237.tar.gz
meta-impy-13dc7326705ec9b8219bef3ee339de499626d237.tar.bz2
meta-impy-13dc7326705ec9b8219bef3ee339de499626d237.tar.xz
Find Qt4 with find_package on STANDALONE.
If Qt is found in a non-standard place, you still have to set LD_LIBRARY_PATH yourself (to $QTDIR/lib) before running imprudence of course (or the webkit plugin will silently fail).
Diffstat (limited to 'linden/indra')
-rw-r--r--linden/indra/cmake/WebKitLibPlugin.cmake12
1 files changed, 11 insertions, 1 deletions
diff --git a/linden/indra/cmake/WebKitLibPlugin.cmake b/linden/indra/cmake/WebKitLibPlugin.cmake
index 3eafe77..9c56838 100644
--- a/linden/indra/cmake/WebKitLibPlugin.cmake
+++ b/linden/indra/cmake/WebKitLibPlugin.cmake
@@ -3,6 +3,16 @@ include(Linking)
3include(Prebuilt) 3include(Prebuilt)
4 4
5if (STANDALONE) 5if (STANDALONE)
6 # The minimal version, 4.4.3, is rather arbitrary: it's the version in Debian/Lenny.
7 find_package(Qt4 4.4.3 COMPONENTS QtCore QtGui QtNetwork QtOpenGL REQUIRED)
8 include(${QT_USE_FILE})
9 set(QTDIR $ENV{QTDIR})
10 if (QTDIR AND NOT "${QT_BINARY_DIR}" STREQUAL "${QTDIR}/bin")
11 message(FATAL_ERROR "\"${QT_BINARY_DIR}\" is unequal \"${QTDIR}/bin\"; "
12 "Qt is found by looking for qmake in your PATH. "
13 "Please set your PATH such that 'qmake' is found in \$QTDIR/bin, "
14 "or unset QTDIR if the found Qt is correct.")
15 endif (QTDIR AND NOT "${QT_BINARY_DIR}" STREQUAL "${QTDIR}/bin")
6 find_package(LLQtWebkit REQUIRED QUIET) 16 find_package(LLQtWebkit REQUIRED QUIET)
7 set(WEBKITLIBPLUGIN OFF CACHE BOOL 17 set(WEBKITLIBPLUGIN OFF CACHE BOOL
8 "WEBKITLIBPLUGIN support for the llplugin/llmedia test apps.") 18 "WEBKITLIBPLUGIN support for the llplugin/llmedia test apps.")
@@ -36,7 +46,7 @@ elseif (DARWIN)
36 ) 46 )
37elseif (LINUX) 47elseif (LINUX)
38 if (STANDALONE) 48 if (STANDALONE)
39 set(WEBKIT_PLUGIN_LIBRARIES ${LLQTWEBKIT_LIBRARY}) 49 set(WEBKIT_PLUGIN_LIBRARIES ${LLQTWEBKIT_LIBRARY} ${QT_LIBRARIES})
40 else (STANDALONE) 50 else (STANDALONE)
41 set(WEBKIT_PLUGIN_LIBRARIES 51 set(WEBKIT_PLUGIN_LIBRARIES
42 llqtwebkit 52 llqtwebkit