aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/win_crash_logger
diff options
context:
space:
mode:
authorJacek Antonelli2009-04-30 13:04:20 -0500
committerJacek Antonelli2009-04-30 13:07:16 -0500
commitca8149ca6d157eb4b5fc8ba0e5ba3a6e56f72e7e (patch)
tree8348301d0ac44a524f1819b777686bf086907d76 /linden/indra/win_crash_logger
parentSecond Life viewer sources 1.22.11 (diff)
downloadmeta-impy-ca8149ca6d157eb4b5fc8ba0e5ba3a6e56f72e7e.zip
meta-impy-ca8149ca6d157eb4b5fc8ba0e5ba3a6e56f72e7e.tar.gz
meta-impy-ca8149ca6d157eb4b5fc8ba0e5ba3a6e56f72e7e.tar.bz2
meta-impy-ca8149ca6d157eb4b5fc8ba0e5ba3a6e56f72e7e.tar.xz
Second Life viewer sources 1.23.0-RC
Diffstat (limited to 'linden/indra/win_crash_logger')
-rw-r--r--linden/indra/win_crash_logger/CMakeLists.txt9
-rw-r--r--linden/indra/win_crash_logger/StdAfx.cpp3
-rw-r--r--linden/indra/win_crash_logger/StdAfx.h3
-rw-r--r--linden/indra/win_crash_logger/llcrashloggerwindows.cpp7
-rw-r--r--linden/indra/win_crash_logger/llcrashloggerwindows.h3
-rw-r--r--linden/indra/win_crash_logger/resource.h3
-rw-r--r--linden/indra/win_crash_logger/win_crash_logger.cpp3
-rw-r--r--linden/indra/win_crash_logger/win_crash_logger.h3
8 files changed, 23 insertions, 11 deletions
diff --git a/linden/indra/win_crash_logger/CMakeLists.txt b/linden/indra/win_crash_logger/CMakeLists.txt
index d15377a..2702268 100644
--- a/linden/indra/win_crash_logger/CMakeLists.txt
+++ b/linden/indra/win_crash_logger/CMakeLists.txt
@@ -72,12 +72,17 @@ target_link_libraries(windows-crash-logger
72 ${LLCOMMON_LIBRARIES} 72 ${LLCOMMON_LIBRARIES}
73 ${WINDOWS_LIBRARIES} 73 ${WINDOWS_LIBRARIES}
74 ${DXGUID_LIBRARY} 74 ${DXGUID_LIBRARY}
75 user32
76 gdi32
77 ole32
78 oleaut32
79 Wldap32
75 ) 80 )
76 81
77if (WINDOWS) 82if (WINDOWS)
78 set_target_properties(windows-crash-logger 83 set_target_properties(windows-crash-logger
79 PROPERTIES 84 PROPERTIES
80 LINK_FLAGS "/NODEFAULTLIB:MSVCRT" 85 LINK_FLAGS "/NODEFAULTLIB:LIBCMT"
81 LINK_FLAGS_DEBUG "/NODEFAULTLIB:LIBCMT /NODEFAULTLIB:MSVCRTD" 86 LINK_FLAGS_DEBUG "/NODEFAULTLIB:\"LIBCMT;LIBCMTD;MSVCRT\""
82 ) 87 )
83endif (WINDOWS) 88endif (WINDOWS)
diff --git a/linden/indra/win_crash_logger/StdAfx.cpp b/linden/indra/win_crash_logger/StdAfx.cpp
index f2f54bf..0204976 100644
--- a/linden/indra/win_crash_logger/StdAfx.cpp
+++ b/linden/indra/win_crash_logger/StdAfx.cpp
@@ -17,7 +17,8 @@
17 * There are special exceptions to the terms and conditions of the GPL as 17 * There are special exceptions to the terms and conditions of the GPL as
18 * it is applied to this Source Code. View the full text of the exception 18 * it is applied to this Source Code. View the full text of the exception
19 * in the file doc/FLOSS-exception.txt in this software distribution, or 19 * in the file doc/FLOSS-exception.txt in this software distribution, or
20 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20 * online at
21 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
21 * 22 *
22 * By copying, modifying or distributing this software, you acknowledge 23 * By copying, modifying or distributing this software, you acknowledge
23 * that you have read and understood your obligations described above, 24 * that you have read and understood your obligations described above,
diff --git a/linden/indra/win_crash_logger/StdAfx.h b/linden/indra/win_crash_logger/StdAfx.h
index 0aeef9f..021a995 100644
--- a/linden/indra/win_crash_logger/StdAfx.h
+++ b/linden/indra/win_crash_logger/StdAfx.h
@@ -17,7 +17,8 @@
17 * There are special exceptions to the terms and conditions of the GPL as 17 * There are special exceptions to the terms and conditions of the GPL as
18 * it is applied to this Source Code. View the full text of the exception 18 * it is applied to this Source Code. View the full text of the exception
19 * in the file doc/FLOSS-exception.txt in this software distribution, or 19 * in the file doc/FLOSS-exception.txt in this software distribution, or
20 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20 * online at
21 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
21 * 22 *
22 * By copying, modifying or distributing this software, you acknowledge 23 * By copying, modifying or distributing this software, you acknowledge
23 * that you have read and understood your obligations described above, 24 * that you have read and understood your obligations described above,
diff --git a/linden/indra/win_crash_logger/llcrashloggerwindows.cpp b/linden/indra/win_crash_logger/llcrashloggerwindows.cpp
index f63d309..c9e01c8 100644
--- a/linden/indra/win_crash_logger/llcrashloggerwindows.cpp
+++ b/linden/indra/win_crash_logger/llcrashloggerwindows.cpp
@@ -17,7 +17,8 @@
17* There are special exceptions to the terms and conditions of the GPL as 17* There are special exceptions to the terms and conditions of the GPL as
18* it is applied to this Source Code. View the full text of the exception 18* it is applied to this Source Code. View the full text of the exception
19* in the file doc/FLOSS-exception.txt in this software distribution, or 19* in the file doc/FLOSS-exception.txt in this software distribution, or
20* online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20* online at
21* http://secondlifegrid.net/programs/open_source/licensing/flossexception
21* 22*
22* By copying, modifying or distributing this software, you acknowledge 23* By copying, modifying or distributing this software, you acknowledge
23* that you have read and understood your obligations described above, 24* that you have read and understood your obligations described above,
@@ -258,8 +259,8 @@ bool LLCrashLoggerWindows::init(void)
258 if(!ok) return false; 259 if(!ok) return false;
259 260
260 /* 261 /*
261 mbstowcs(gProductName, mProductName.c_str(), sizeof(gProductName)/sizeof(gProductName[0])); 262 mbstowcs( gProductName, mProductName.c_str(), LL_ARRAY_SIZE(gProductName) );
262 gProductName[ sizeof(gProductName)/sizeof(gProductName[0]) - 1 ] = 0; 263 gProductName[ LL_ARRY_SIZE(gProductName) - 1 ] = 0;
263 swprintf(gProductName, L"Second Life"); 264 swprintf(gProductName, L"Second Life");
264 */ 265 */
265 266
diff --git a/linden/indra/win_crash_logger/llcrashloggerwindows.h b/linden/indra/win_crash_logger/llcrashloggerwindows.h
index cf8a855..e6a9c77 100644
--- a/linden/indra/win_crash_logger/llcrashloggerwindows.h
+++ b/linden/indra/win_crash_logger/llcrashloggerwindows.h
@@ -17,7 +17,8 @@
17* There are special exceptions to the terms and conditions of the GPL as 17* There are special exceptions to the terms and conditions of the GPL as
18* it is applied to this Source Code. View the full text of the exception 18* it is applied to this Source Code. View the full text of the exception
19* in the file doc/FLOSS-exception.txt in this software distribution, or 19* in the file doc/FLOSS-exception.txt in this software distribution, or
20* online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20* online at
21* http://secondlifegrid.net/programs/open_source/licensing/flossexception
21* 22*
22* By copying, modifying or distributing this software, you acknowledge 23* By copying, modifying or distributing this software, you acknowledge
23* that you have read and understood your obligations described above, 24* that you have read and understood your obligations described above,
diff --git a/linden/indra/win_crash_logger/resource.h b/linden/indra/win_crash_logger/resource.h
index 715f284..54b9b4b 100644
--- a/linden/indra/win_crash_logger/resource.h
+++ b/linden/indra/win_crash_logger/resource.h
@@ -17,7 +17,8 @@
17* There are special exceptions to the terms and conditions of the GPL as 17* There are special exceptions to the terms and conditions of the GPL as
18* it is applied to this Source Code. View the full text of the exception 18* it is applied to this Source Code. View the full text of the exception
19* in the file doc/FLOSS-exception.txt in this software distribution, or 19* in the file doc/FLOSS-exception.txt in this software distribution, or
20* online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20* online at
21* http://secondlifegrid.net/programs/open_source/licensing/flossexception
21* 22*
22* By copying, modifying or distributing this software, you acknowledge 23* By copying, modifying or distributing this software, you acknowledge
23* that you have read and understood your obligations described above, 24* that you have read and understood your obligations described above,
diff --git a/linden/indra/win_crash_logger/win_crash_logger.cpp b/linden/indra/win_crash_logger/win_crash_logger.cpp
index 512a67d..22837d2 100644
--- a/linden/indra/win_crash_logger/win_crash_logger.cpp
+++ b/linden/indra/win_crash_logger/win_crash_logger.cpp
@@ -17,7 +17,8 @@
17 * There are special exceptions to the terms and conditions of the GPL as 17 * There are special exceptions to the terms and conditions of the GPL as
18 * it is applied to this Source Code. View the full text of the exception 18 * it is applied to this Source Code. View the full text of the exception
19 * in the file doc/FLOSS-exception.txt in this software distribution, or 19 * in the file doc/FLOSS-exception.txt in this software distribution, or
20 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20 * online at
21 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
21 * 22 *
22 * By copying, modifying or distributing this software, you acknowledge 23 * By copying, modifying or distributing this software, you acknowledge
23 * that you have read and understood your obligations described above, 24 * that you have read and understood your obligations described above,
diff --git a/linden/indra/win_crash_logger/win_crash_logger.h b/linden/indra/win_crash_logger/win_crash_logger.h
index f537262..0bd42b1 100644
--- a/linden/indra/win_crash_logger/win_crash_logger.h
+++ b/linden/indra/win_crash_logger/win_crash_logger.h
@@ -17,7 +17,8 @@
17 * There are special exceptions to the terms and conditions of the GPL as 17 * There are special exceptions to the terms and conditions of the GPL as
18 * it is applied to this Source Code. View the full text of the exception 18 * it is applied to this Source Code. View the full text of the exception
19 * in the file doc/FLOSS-exception.txt in this software distribution, or 19 * in the file doc/FLOSS-exception.txt in this software distribution, or
20 * online at http://secondlifegrid.net/programs/open_source/licensing/flossexception 20 * online at
21 * http://secondlifegrid.net/programs/open_source/licensing/flossexception
21 * 22 *
22 * By copying, modifying or distributing this software, you acknowledge 23 * By copying, modifying or distributing this software, you acknowledge
23 * that you have read and understood your obligations described above, 24 * that you have read and understood your obligations described above,