diff options
author | David Walter Seikel | 2013-04-18 14:03:24 +1000 |
---|---|---|
committer | David Walter Seikel | 2013-04-18 14:03:24 +1000 |
commit | 8fa60cf0f49c872402aa72d486e1f900a166d951 (patch) | |
tree | b59b8c227a248802332d041ec6a5bc7b9df1286a /linden/indra/newview | |
parent | Potential fix for http://redmine.kokuaviewer.org/issues/1215 but needs testing. (diff) | |
download | meta-impy-8fa60cf0f49c872402aa72d486e1f900a166d951.zip meta-impy-8fa60cf0f49c872402aa72d486e1f900a166d951.tar.gz meta-impy-8fa60cf0f49c872402aa72d486e1f900a166d951.tar.bz2 meta-impy-8fa60cf0f49c872402aa72d486e1f900a166d951.tar.xz |
New branch for building with nmake.
This is a branch, coz it's still crap.
Diffstat (limited to 'linden/indra/newview')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 4 | ||||
-rwxr-xr-x | linden/indra/newview/viewer_manifest.py | 8 |
2 files changed, 6 insertions, 6 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index b9c41fc..9172aa0 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -1326,7 +1326,7 @@ if (WINDOWS) | |||
1326 | 1326 | ||
1327 | # sets the 'working directory' for debugging from visual studio. | 1327 | # sets the 'working directory' for debugging from visual studio. |
1328 | if (NOT UNATTENDED) | 1328 | if (NOT UNATTENDED) |
1329 | if (NOT self.using_express) | 1329 | if (USE_VSTOOL) |
1330 | add_custom_command( | 1330 | add_custom_command( |
1331 | TARGET ${VIEWER_BINARY_NAME} PRE_BUILD | 1331 | TARGET ${VIEWER_BINARY_NAME} PRE_BUILD |
1332 | COMMAND ${CMAKE_SOURCE_DIR}/tools/vstool/vstool.exe | 1332 | COMMAND ${CMAKE_SOURCE_DIR}/tools/vstool/vstool.exe |
@@ -1338,7 +1338,7 @@ if (WINDOWS) | |||
1338 | ${CMAKE_CURRENT_SOURCE_DIR} | 1338 | ${CMAKE_CURRENT_SOURCE_DIR} |
1339 | COMMENT "Setting the ${VIEWER_BINARY_NAME} working directory for debugging." | 1339 | COMMENT "Setting the ${VIEWER_BINARY_NAME} working directory for debugging." |
1340 | ) | 1340 | ) |
1341 | endif (NOT self.using_express) | 1341 | endif (USE_VSTOOL) |
1342 | endif (NOT UNATTENDED) | 1342 | endif (NOT UNATTENDED) |
1343 | 1343 | ||
1344 | add_custom_command( | 1344 | add_custom_command( |
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py index bcdf4a9..718c3d2 100755 --- a/linden/indra/newview/viewer_manifest.py +++ b/linden/indra/newview/viewer_manifest.py | |||
@@ -244,7 +244,7 @@ class WindowsManifest(ViewerManifest): | |||
244 | elif self.configuration().lower() == "debug": | 244 | elif self.configuration().lower() == "debug": |
245 | self.path(self.find_existing_file('debug/imprudence-bin.exe'), dst=self.final_exe()) | 245 | self.path(self.find_existing_file('debug/imprudence-bin.exe'), dst=self.final_exe()) |
246 | else: | 246 | else: |
247 | self.path(self.find_existing_file('release/imprudence-bin.exe', 'releasesse2/imprudence-bin.exe', 'relwithdebinfo/imprudence-bin.exe', 'debug/imprudence-bin.exe'), dst=self.final_exe()) | 247 | self.path(self.find_existing_file('release/imprudence-bin.exe', 'releasesse2/imprudence-bin.exe', 'relwithdebinfo/imprudence-bin.exe', 'debug/imprudence-bin.exe', 'imprudence-bin.exe'), dst=self.final_exe()) |
248 | 248 | ||
249 | # copy over the the pdb file for the regular or SSE2 versions if we don't already have one copied | 249 | # copy over the the pdb file for the regular or SSE2 versions if we don't already have one copied |
250 | symbol_ver = '.'.join(self.args['version']) | 250 | symbol_ver = '.'.join(self.args['version']) |
@@ -281,7 +281,7 @@ class WindowsManifest(ViewerManifest): | |||
281 | #self.path("fmod.dll") | 281 | #self.path("fmod.dll") |
282 | 282 | ||
283 | # For spellchecking | 283 | # For spellchecking |
284 | if self.prefix(src=self.args['configuration'], dst=""): | 284 | if self.prefix(src=os.path.join(self.args['configuration'], "Release"), dst=""): |
285 | self.path("libhunspell.dll") | 285 | self.path("libhunspell.dll") |
286 | self.end_prefix() | 286 | self.end_prefix() |
287 | 287 | ||
@@ -289,12 +289,12 @@ class WindowsManifest(ViewerManifest): | |||
289 | self.path("llkdu.dll.2.config") | 289 | self.path("llkdu.dll.2.config") |
290 | 290 | ||
291 | # Get llcommon and deps. | 291 | # Get llcommon and deps. |
292 | if self.prefix(src=self.args['configuration'], dst=""): | 292 | if self.prefix(src=os.path.join(self.args['configuration'], "Release"), dst=""): |
293 | self.path('libapr-1.dll') | 293 | self.path('libapr-1.dll') |
294 | self.path('libaprutil-1.dll') | 294 | self.path('libaprutil-1.dll') |
295 | self.path('libapriconv-1.dll') | 295 | self.path('libapriconv-1.dll') |
296 | self.path('llcommon.dll') | ||
297 | self.end_prefix() | 296 | self.end_prefix() |
297 | self.path('llcommon.dll') | ||
298 | 298 | ||
299 | # For textures | 299 | # For textures |
300 | if self.prefix(src="../../libraries/i686-win32/lib/release", dst=""): | 300 | if self.prefix(src="../../libraries/i686-win32/lib/release", dst=""): |