diff options
author | David Walter Seikel | 2011-12-05 16:22:37 +1000 |
---|---|---|
committer | David Walter Seikel | 2011-12-05 16:22:37 +1000 |
commit | 3823dbda902c1f68dd25055edca0602e1c74d804 (patch) | |
tree | bf6850779d234070ef71eae6e6e5ca27c7b54457 /linden/indra/newview | |
parent | Revert "Another possible fix for misplaced HUDs?" (diff) | |
parent | Linux: allow cross compiling the 32bit viewer on a x86_64 platform (diff) | |
download | meta-impy-3823dbda902c1f68dd25055edca0602e1c74d804.zip meta-impy-3823dbda902c1f68dd25055edca0602e1c74d804.tar.gz meta-impy-3823dbda902c1f68dd25055edca0602e1c74d804.tar.bz2 meta-impy-3823dbda902c1f68dd25055edca0602e1c74d804.tar.xz |
Merge branch 'next' of git://github.com/ArminW/imprudence into next
Conflicts:
linden/indra/newview/viewer_manifest.py
Conflicted with the OTR stuff, simple fix.
Diffstat (limited to 'linden/indra/newview')
-rw-r--r-- | linden/indra/newview/llfloaterabout.cpp | 5 | ||||
-rw-r--r-- | linden/indra/newview/llfloaterregioninfo.cpp | 11 | ||||
-rw-r--r-- | linden/indra/newview/llvoiceclient.cpp | 19 | ||||
-rwxr-xr-x | linden/indra/newview/viewer_manifest.py | 107 |
4 files changed, 52 insertions, 90 deletions
diff --git a/linden/indra/newview/llfloaterabout.cpp b/linden/indra/newview/llfloaterabout.cpp index 13795e5..06bee7d 100644 --- a/linden/indra/newview/llfloaterabout.cpp +++ b/linden/indra/newview/llfloaterabout.cpp | |||
@@ -261,8 +261,11 @@ LLFloaterAbout::LLFloaterAbout() | |||
261 | support.append("\n"); | 261 | support.append("\n"); |
262 | 262 | ||
263 | // TODO: Implement media plugin version query | 263 | // TODO: Implement media plugin version query |
264 | 264 | #if LL_LINUX | |
265 | support.append("Qt Webkit Version: 4.7.4 (version number hard-coded)"); | ||
266 | #else | ||
265 | support.append("Qt Webkit Version: 4.6 (version number hard-coded)"); | 267 | support.append("Qt Webkit Version: 4.6 (version number hard-coded)"); |
268 | #endif | ||
266 | support.append("\n"); | 269 | support.append("\n"); |
267 | 270 | ||
268 | if (gPacketsIn > 0) | 271 | if (gPacketsIn > 0) |
diff --git a/linden/indra/newview/llfloaterregioninfo.cpp b/linden/indra/newview/llfloaterregioninfo.cpp index 8810a5c..08bda48 100644 --- a/linden/indra/newview/llfloaterregioninfo.cpp +++ b/linden/indra/newview/llfloaterregioninfo.cpp | |||
@@ -1726,11 +1726,7 @@ void LLPanelEstateInfo::onClickRemoveEstateManager(void* user_data) | |||
1726 | //--------------------------------------------------------------------------- | 1726 | //--------------------------------------------------------------------------- |
1727 | // Kick from estate methods | 1727 | // Kick from estate methods |
1728 | //--------------------------------------------------------------------------- | 1728 | //--------------------------------------------------------------------------- |
1729 | struct LLKickFromEstateInfo | 1729 | |
1730 | { | ||
1731 | LLPanelEstateInfo *mEstatePanelp; | ||
1732 | LLUUID mAgentID; | ||
1733 | }; | ||
1734 | 1730 | ||
1735 | void LLPanelEstateInfo::onClickKickUser(void *user_data) | 1731 | void LLPanelEstateInfo::onClickKickUser(void *user_data) |
1736 | { | 1732 | { |
@@ -1757,10 +1753,7 @@ void LLPanelEstateInfo::onKickUserCommit(const std::vector<std::string>& names, | |||
1757 | LLPanelEstateInfo* self = (LLPanelEstateInfo*)userdata; | 1753 | LLPanelEstateInfo* self = (LLPanelEstateInfo*)userdata; |
1758 | if(!self) return; | 1754 | if(!self) return; |
1759 | 1755 | ||
1760 | //keep track of what user they want to kick and other misc info | 1756 | |
1761 | LLKickFromEstateInfo *kick_info = new LLKickFromEstateInfo(); | ||
1762 | kick_info->mEstatePanelp = self; | ||
1763 | kick_info->mAgentID = ids[0]; | ||
1764 | 1757 | ||
1765 | //Bring up a confirmation dialog | 1758 | //Bring up a confirmation dialog |
1766 | LLSD args; | 1759 | LLSD args; |
diff --git a/linden/indra/newview/llvoiceclient.cpp b/linden/indra/newview/llvoiceclient.cpp index c5b5e99..4a5fb48 100644 --- a/linden/indra/newview/llvoiceclient.cpp +++ b/linden/indra/newview/llvoiceclient.cpp | |||
@@ -1212,13 +1212,22 @@ void LLVoiceClient::terminate() | |||
1212 | // ms_sleep(2000); | 1212 | // ms_sleep(2000); |
1213 | gVoiceClient->connectorShutdown(); | 1213 | gVoiceClient->connectorShutdown(); |
1214 | gVoiceClient->closeSocket(); // Need to do this now -- bad things happen if the destructor does it later. | 1214 | gVoiceClient->closeSocket(); // Need to do this now -- bad things happen if the destructor does it later. |
1215 | 1215 | ||
1216 | // This will do unpleasant things on windows. | 1216 | LL_DEBUGS("IdleCallbacks") << "IdleCallbacks deleteFunction " |
1217 | // killGateway(); | 1217 | << "called from LLVoiceClient" << LL_ENDL; |
1218 | 1218 | gIdleCallbacks.deleteFunction(idle, gVoiceClient); | |
1219 | |||
1220 | if (isGatewayRunning()) | ||
1221 | { | ||
1222 | // This will do unpleasant things on windows. | ||
1223 | // AW: no unpleasant things observed on windows, | ||
1224 | // guess they came from sloppy cleanup. | ||
1225 | killGateway(); | ||
1226 | } | ||
1227 | |||
1219 | // Don't do this anymore -- LLSingleton will take care of deleting the object. | 1228 | // Don't do this anymore -- LLSingleton will take care of deleting the object. |
1220 | // delete gVoiceClient; | 1229 | // delete gVoiceClient; |
1221 | 1230 | ||
1222 | // Hint to other code not to access the voice client anymore. | 1231 | // Hint to other code not to access the voice client anymore. |
1223 | gVoiceClient = NULL; | 1232 | gVoiceClient = NULL; |
1224 | } | 1233 | } |
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py index cb226fe..e350af0 100755 --- a/linden/indra/newview/viewer_manifest.py +++ b/linden/indra/newview/viewer_manifest.py | |||
@@ -948,13 +948,16 @@ class Linux_i686Manifest(LinuxManifest): | |||
948 | self.path("libSDL-1.2.so.0") | 948 | self.path("libSDL-1.2.so.0") |
949 | self.path("libELFIO.so") | 949 | self.path("libELFIO.so") |
950 | self.path("libopenjpeg.so.2") | 950 | self.path("libopenjpeg.so.2") |
951 | self.path("libxml2.so.2") | ||
952 | self.path("libz.so") | 951 | self.path("libz.so") |
953 | self.path("libz.so.1") | 952 | self.path("libz.so.1") |
954 | 953 | ||
955 | # OpenAL | 954 | # OpenAL |
956 | self.path("libopenal.so.1.12.854", "libopenal.so.1") | 955 | self.path("libalut.so") |
957 | self.path("libalut.so.0.1.0", "libalut.so.0") | 956 | self.path("libalut.so.0") |
957 | self.path("libalut.so.0.0.0") | ||
958 | self.path("libopenal.so") | ||
959 | self.path("libopenal.so.1") | ||
960 | self.path("libopenal.so.1.13.0") | ||
958 | 961 | ||
959 | # GTK+ and dependencies | 962 | # GTK+ and dependencies |
960 | ## Lets just use the system libraries for all of these: | 963 | ## Lets just use the system libraries for all of these: |
@@ -1047,7 +1050,6 @@ class Linux_i686Manifest(LinuxManifest): | |||
1047 | self.end_prefix("bin") | 1050 | self.end_prefix("bin") |
1048 | 1051 | ||
1049 | if self.prefix(src="vivox-runtime/i686-linux", dst="lib"): | 1052 | if self.prefix(src="vivox-runtime/i686-linux", dst="lib"): |
1050 | self.path("libalut.so") | ||
1051 | self.path("libortp.so") | 1053 | self.path("libortp.so") |
1052 | self.path("libvivoxsdk.so") | 1054 | self.path("libvivoxsdk.so") |
1053 | self.end_prefix("lib") | 1055 | self.end_prefix("lib") |
@@ -1076,22 +1078,37 @@ class Linux_x86_64Manifest(LinuxManifest): | |||
1076 | self.path("libapr-1.so.0") | 1078 | self.path("libapr-1.so.0") |
1077 | self.path("libaprutil-1.so.0") | 1079 | self.path("libaprutil-1.so.0") |
1078 | self.path("libdb-4.2.so") | 1080 | self.path("libdb-4.2.so") |
1079 | self.path("libcrypto.so.0.9.8") | 1081 | self.path("libcrypto.so") |
1082 | self.path("libcrypto.so.1.0.0") | ||
1080 | self.path("libexpat.so.1") | 1083 | self.path("libexpat.so.1") |
1081 | self.path("libhunspell-1.2.so.0.0.0", "libhunspell-1.2.so.0") | 1084 | self.path("libhunspell-1.2.so.0.0.0", "libhunspell-1.2.so.0") |
1082 | self.path("libssl.so.0.9.8") | 1085 | self.path("libssl.so") |
1086 | self.path("libssl.so.1.0.0") | ||
1083 | self.path("libuuid.so", "libuuid.so.1") | 1087 | self.path("libuuid.so", "libuuid.so.1") |
1084 | self.path("libSDL-1.2.so.0") | 1088 | self.path("libSDL-1.2.so.0") |
1085 | self.path("libELFIO.so") | 1089 | self.path("libELFIO.so") |
1086 | self.path("libjpeg.so.7") | 1090 | self.path("libjpeg.so.7") |
1087 | self.path("libpng12.so.0") | 1091 | self.path("libpng12.so.0") |
1088 | self.path("libopenjpeg.so.2") | 1092 | self.path("libopenjpeg.so.2") |
1089 | self.path("libxml2.so.2") | ||
1090 | #self.path("libz.so.1") #not needed | ||
1091 | 1093 | ||
1094 | self.path("libcares.so") | ||
1095 | self.path("libcares.so.2") | ||
1096 | self.path("libcares.so.2.0.0") | ||
1097 | self.path("libcurl.so") | ||
1098 | self.path("libcurl.so.4") | ||
1099 | self.path("libcurl.so.4.2.0") | ||
1100 | self.path("libz.so.1.2.5") | ||
1101 | self.path("libz.so.1") | ||
1102 | self.path("libz.so") | ||
1092 | # OpenAL | 1103 | # OpenAL |
1093 | self.path("libopenal.so.1.12.854", "libopenal.so.1") | 1104 | |
1094 | self.path("libalut.so.0.1.0", "libalut.so.0") | 1105 | self.path("libopenal.so") |
1106 | self.path("libopenal.so.1") | ||
1107 | self.path("libopenal.so.1.13.0") | ||
1108 | self.path("libalut.so") | ||
1109 | self.path("libalut.so.0") | ||
1110 | self.path("libalut.so.0.0.0") | ||
1111 | |||
1095 | # GTK+ and dependencies | 1112 | # GTK+ and dependencies |
1096 | ## Lets just use the system libraries for all of these: | 1113 | ## Lets just use the system libraries for all of these: |
1097 | ##self.path("libatk-1.0.so.0") | 1114 | ##self.path("libatk-1.0.so.0") |
@@ -1106,69 +1123,6 @@ class Linux_x86_64Manifest(LinuxManifest): | |||
1106 | # self.path("libpangox-1.0.so.0") # and crash if not compatible or present. | 1123 | # self.path("libpangox-1.0.so.0") # and crash if not compatible or present. |
1107 | # self.path("libpangoxft-1.0.so.0") # So we depend system gdk pixbufs and pango anyway. | 1124 | # self.path("libpangoxft-1.0.so.0") # So we depend system gdk pixbufs and pango anyway. |
1108 | ##self.path("libpixman-1.so.0") | 1125 | ##self.path("libpixman-1.so.0") |
1109 | |||
1110 | #KILL IT WITH FIRE | ||
1111 | ## Gstreamer libs | ||
1112 | #self.path("libgstbase-0.10.so.0") | ||
1113 | #self.path("libgstreamer-0.10.so.0") | ||
1114 | #self.path("libgstaudio-0.10.so.0") | ||
1115 | #self.path("libgstbase-0.10.so.0") | ||
1116 | #self.path("libgstcontroller-0.10.so.0") | ||
1117 | #self.path("libgstdataprotocol-0.10.so.0") | ||
1118 | #self.path("libgstinterfaces-0.10.so.0") | ||
1119 | #self.path("libgstnetbuffer-0.10.so.0") | ||
1120 | #self.path("libgstpbutils-0.10.so.0") | ||
1121 | #self.path("libgstriff-0.10.so.0") | ||
1122 | #self.path("libgstrtp-0.10.so.0") | ||
1123 | #self.path("libgstrtsp-0.10.so.0") | ||
1124 | #self.path("libgstsdp-0.10.so.0") | ||
1125 | #self.path("libgsttag-0.10.so.0") | ||
1126 | #self.path("libgstvideo-0.10.so.0") | ||
1127 | |||
1128 | ## Gstreamer plugin dependencies | ||
1129 | #self.path("libfaad.so.0") | ||
1130 | #self.path("libogg.so.0") | ||
1131 | #self.path("libtheora.so.0") | ||
1132 | #self.path("libvorbis.so.0") | ||
1133 | #self.path("libvorbisenc.so.2") | ||
1134 | #self.path("liboil-0.3.so.0") | ||
1135 | |||
1136 | ## Gstreamer plugins | ||
1137 | #if self.prefix("gstreamer-plugins"): | ||
1138 | #self.path("libgstalsa.so") | ||
1139 | #self.path("libgstasf.so") | ||
1140 | #self.path("libgstaudioconvert.so") | ||
1141 | #self.path("libgstaudioresample.so") | ||
1142 | #self.path("libgstautodetect.so") | ||
1143 | #self.path("libgstavi.so") | ||
1144 | #self.path("libgstcoreelements.so") | ||
1145 | #self.path("libgstcoreindexers.so") | ||
1146 | #self.path("libgstdecodebin2.so") | ||
1147 | #self.path("libgstdecodebin.so") | ||
1148 | #self.path("libgstesd.so") | ||
1149 | #self.path("libgstfaad.so") | ||
1150 | #self.path("libgstffmpeg.so") | ||
1151 | #self.path("libgstffmpegcolorspace.so") | ||
1152 | #self.path("libgstgnomevfs.so") | ||
1153 | #self.path("libgsticydemux.so") | ||
1154 | #self.path("libgstid3demux.so") | ||
1155 | #self.path("libgstmpegdemux.so") | ||
1156 | #self.path("libgstmultifile.so") | ||
1157 | #self.path("libgstmultipart.so") | ||
1158 | #self.path("libgstogg.so") | ||
1159 | #self.path("libgstossaudio.so") | ||
1160 | #self.path("libgstplaybin.so") | ||
1161 | #self.path("libgstpulse.so") | ||
1162 | #self.path("libgstqtdemux.so") | ||
1163 | #self.path("libgstqueue2.so") | ||
1164 | #self.path("libgsttcp.so") | ||
1165 | #self.path("libgsttheora.so") | ||
1166 | #self.path("libgsttypefindfunctions.so") | ||
1167 | #self.path("libgstudp.so") | ||
1168 | #self.path("libgstvideoscale.so") | ||
1169 | #self.path("libgstvolume.so") | ||
1170 | #self.path("libgstvorbis.so") | ||
1171 | #self.path("libgstwavparse.so") | ||
1172 | 1126 | ||
1173 | #self.end_prefix("gstreamer-plugins") | 1127 | #self.end_prefix("gstreamer-plugins") |
1174 | # [$PLOTR$] these two are not needed when STATIC_LIBOTR_ETC is on in .../linden/indra/CMakeLists.txt | 1128 | # [$PLOTR$] these two are not needed when STATIC_LIBOTR_ETC is on in .../linden/indra/CMakeLists.txt |
@@ -1176,7 +1130,7 @@ class Linux_x86_64Manifest(LinuxManifest): | |||
1176 | # self.path("libotr.so.2") | 1130 | # self.path("libotr.so.2") |
1177 | # [/$PLOTR$] | 1131 | # [/$PLOTR$] |
1178 | self.end_prefix("lib64") | 1132 | self.end_prefix("lib64") |
1179 | 1133 | ||
1180 | 1134 | ||
1181 | # Vivox runtimes and libs | 1135 | # Vivox runtimes and libs |
1182 | if self.prefix(src="vivox-runtime/i686-linux", dst="bin"): | 1136 | if self.prefix(src="vivox-runtime/i686-linux", dst="bin"): |
@@ -1192,9 +1146,12 @@ class Linux_x86_64Manifest(LinuxManifest): | |||
1192 | # 32bit libs needed for voice | 1146 | # 32bit libs needed for voice |
1193 | if self.prefix("../../libraries/x86_64-linux/lib_release_client/32bit-compat", dst="lib32"): | 1147 | if self.prefix("../../libraries/x86_64-linux/lib_release_client/32bit-compat", dst="lib32"): |
1194 | self.path("libalut.so") | 1148 | self.path("libalut.so") |
1149 | self.path("libalut.so.0") | ||
1150 | self.path("libalut.so.0.0.0") | ||
1195 | self.path("libidn.so.11") | 1151 | self.path("libidn.so.11") |
1152 | self.path("libopenal.so") | ||
1196 | self.path("libopenal.so.1") | 1153 | self.path("libopenal.so.1") |
1197 | # self.path("libortp.so") | 1154 | self.path("libopenal.so.1.13.0") |
1198 | self.path("libuuid.so.1") | 1155 | self.path("libuuid.so.1") |
1199 | self.end_prefix("lib32") | 1156 | self.end_prefix("lib32") |
1200 | 1157 | ||