aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/mozilla-powerpc-darwin-readme.txt
diff options
context:
space:
mode:
authorJacek Antonelli2008-08-15 23:44:46 -0500
committerJacek Antonelli2008-08-15 23:44:46 -0500
commit38d6d37f2d982fa959e9e8a4a3f7e1ccfad7b5d4 (patch)
treeadca584755d22ca041a2dbfc35d4eca01f70b32c /linden/indra/newview/mozilla-powerpc-darwin-readme.txt
parentREADME.txt (diff)
downloadmeta-impy-38d6d37f2d982fa959e9e8a4a3f7e1ccfad7b5d4.zip
meta-impy-38d6d37f2d982fa959e9e8a4a3f7e1ccfad7b5d4.tar.gz
meta-impy-38d6d37f2d982fa959e9e8a4a3f7e1ccfad7b5d4.tar.bz2
meta-impy-38d6d37f2d982fa959e9e8a4a3f7e1ccfad7b5d4.tar.xz
Second Life viewer sources 1.13.2.12
Diffstat (limited to 'linden/indra/newview/mozilla-powerpc-darwin-readme.txt')
-rw-r--r--linden/indra/newview/mozilla-powerpc-darwin-readme.txt71
1 files changed, 71 insertions, 0 deletions
diff --git a/linden/indra/newview/mozilla-powerpc-darwin-readme.txt b/linden/indra/newview/mozilla-powerpc-darwin-readme.txt
new file mode 100644
index 0000000..be67ad3
--- /dev/null
+++ b/linden/indra/newview/mozilla-powerpc-darwin-readme.txt
@@ -0,0 +1,71 @@
1NOTE: these directions have been obsoleted. There are now shell scripts that will check out, build, and package the necessary pieces
2of the mozilla code in lindelib/mozilla-1.8.0/mac-build. I'm leaving this file here for historical interest.
3-------------
4Written by Monroe on June 17, 2005.
5
6Here's how to rebuild the Mozilla components for the Mac build.
7
8Check out the mozilla source from cvs
9
10cd to the mozilla directory (the same one that contains client.mk)
11
12cp .mozconfig.opt.shared.small .mozconfig
13
14Add the following line to the .mozconfig file you just created:
15
16ac_add_options --with-macos-sdk=/Developer/SDKs/MacOSX10.2.8.sdk
17
18make -f client.mk build
19
20wait a while.
21
22The build products you need to extract are in objdir-opt-shared-small/dist/bin and objdir-opt-shared-small/dist/lib.
23
24Copy the following to linden/libraries/firefox-1.0.4/<arch>/lib_release and linden/libraries/firefox-1.0.4/<arch>/lib_release:
25
26objdir-opt-shared-small/dist/lib/libembed_base_s.a
27objdir-opt-shared-small/dist/lib/libxpcomglue_s.a
28objdir-opt-shared-small/dist/bin/libxpcom.dylib
29objdir-opt-shared-small/dist/bin/libplds4.dylib
30objdir-opt-shared-small/dist/bin/libplc4.dylib
31objdir-opt-shared-small/dist/bin/libnspr4.dylib
32objdir-opt-shared-small/dist/bin/libgkgfx.dylib
33
34This first part should be repeated with .mozconfig.debug.shared.small to generate the libraries in the two matching lib_debug directories. The debug version of the bin directory is prohibitively large, so we're just using the release version of that part.
35
36Much of the contents of objdir-opt-shared-small/dist/bin also needs to go into a tar file that will be used when generating the application bundle.
37
38The bin directory will be populated with symlinks. If you just tar it up as-is, you'll get a tar file full of symlinks, which is not useful.
39
40Use 'cp -RL source dest' to make a copy of the bin directory with all symlinks expanded. This will be more useful.
41
42Remove things that aren't needed. This includes at least:
43
44asdecode
45firefox
46firefox-bin
47firefox-config
48LICENSE
49nsinstall
50mangle
51regxpcom
52regchrome
53README.txt
54run-mozilla.sh
55xpcshell
56xpt_dump
57shlibsign
58xpt_link
59xpidl
60xpicleanup
61
62There may be other pieces that aren't needed as well. I expect this will be refined moving forward.
63
64Because of the way the tar file will be expanded (directly inside the application bundle, in Contents/MacOS), it's important to create it so that it won't expand at a subdirectory of the current path. The way to to this is to cd to the dist/bin directory and do something like this:
65
66tar -zcvf ../mozilla-powerpc-darwin.tgz .
67
68This will create a tar file containing everything in the current directory, and will place the file one level up (so it doesn't interfere with its own creation). This file should replace the file with the above name checked into cvs in linden/indra/newview/. One of the lines in the shell script phase of the build extracts it appropriately into the application bundle.
69
70If any of this is unclear, please contact Monroe and I'll try to clarify and update this file.
71