aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/llwearablelist.cpp
diff options
context:
space:
mode:
authorJacek Antonelli2009-09-09 12:27:11 -0500
committerJacek Antonelli2009-09-10 02:26:28 -0500
commite944c5086e47e92e7952e5a43c68f01108899656 (patch)
treec47ff63c4dcae473cd07a0dbcbc9d52636e6061e /linden/indra/newview/llwearablelist.cpp
parentCommented out Linux tarball building. (diff)
parentlooks like working now (diff)
downloadmeta-impy-e944c5086e47e92e7952e5a43c68f01108899656.zip
meta-impy-e944c5086e47e92e7952e5a43c68f01108899656.tar.gz
meta-impy-e944c5086e47e92e7952e5a43c68f01108899656.tar.bz2
meta-impy-e944c5086e47e92e7952e5a43c68f01108899656.tar.xz
Merged 'armin/grid-manager5' into login-manager
Conflicts: linden/indra/newview/CMakeLists.txt linden/indra/newview/llpanellogin.cpp
Diffstat (limited to 'linden/indra/newview/llwearablelist.cpp')
-rw-r--r--linden/indra/newview/llwearablelist.cpp10
1 files changed, 8 insertions, 2 deletions
diff --git a/linden/indra/newview/llwearablelist.cpp b/linden/indra/newview/llwearablelist.cpp
index 2d4f26a..4e91975 100644
--- a/linden/indra/newview/llwearablelist.cpp
+++ b/linden/indra/newview/llwearablelist.cpp
@@ -42,6 +42,9 @@
42#include "llviewerstats.h" 42#include "llviewerstats.h"
43#include "llnotify.h" 43#include "llnotify.h"
44 44
45#include "llstartup.h"
46#include "llpanellogin.h"
47
45// Globals 48// Globals
46LLWearableList gWearableList; // Globally constructed; be careful that there's no dependency with gAgent. 49LLWearableList gWearableList; // Globally constructed; be careful that there's no dependency with gAgent.
47 50
@@ -185,12 +188,15 @@ void LLWearableList::processGetAssetReply( const char* filename, const LLAssetID
185 args["[TYPE]"] = LLAssetType::lookupHumanReadable(data->mAssetType); 188 args["[TYPE]"] = LLAssetType::lookupHumanReadable(data->mAssetType);
186 if (data->mName.empty()) 189 if (data->mName.empty())
187 { 190 {
188 LLNotifyBox::showXml("FailedToFindWearableUnnamed", args); 191 // work around missing avatar part spam on grid to grid teleport login
192 if(LLStartUp::shouldAutoLogin() && !gLoginHandler.mPassword.empty())
193 LLNotifyBox::showXml("FailedToFindWearableUnnamed", args);
189 } 194 }
190 else 195 else
191 { 196 {
192 args["[DESC]"] = data->mName; 197 args["[DESC]"] = data->mName;
193 LLNotifyBox::showXml("FailedToFindWearable", args); 198 if(LLStartUp::shouldAutoLogin() && !gLoginHandler.mPassword.empty())
199 LLNotifyBox::showXml("FailedToFindWearable", args);
194 } 200 }
195 } 201 }
196 // Always call callback; wearable will be NULL if we failed 202 // Always call callback; wearable will be NULL if we failed