aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/llvoiceclient.h
diff options
context:
space:
mode:
authorDavid Seikel2011-06-04 00:17:28 +1000
committerDavid Seikel2011-06-04 00:17:28 +1000
commit492eaaf4eec82327116f2605e3d8becf94bec1b3 (patch)
treedcddd674cb4861445c3ec5aaa59325b99a437614 /linden/indra/newview/llvoiceclient.h
parentSet the real bare minimum prim size to 0.00001, as 0 sized objects cause bugs. (diff)
parentFixing the menu to actually use its color options reveals how broken the whol... (diff)
downloadmeta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.zip
meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.gz
meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.bz2
meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.xz
Merge branch 'next' of git://github.com/jacek/imprudence into next
Conflicts (manually merged): linden/indra/llcommon/llversionviewer.h linden/indra/llvfs/lldir.cpp linden/indra/llvfs/lldir_mac.cpp linden/indra/newview/CMakeLists.txt linden/indra/newview/English.lproj/InfoPlist.strings linden/indra/newview/Info-Imprudence.plist linden/indra/newview/Info-meta-impy.plist linden/indra/newview/llappviewer.cpp linden/indra/newview/llpanellogin.cpp linden/indra/newview/packaging/mac/Info.plist.in linden/indra/newview/res/viewerRes.rc linden/indra/newview/skins/default/xui/en-us/floater_about.xml linden/indra/newview/skins/default/xui/en-us/panel_preferences_advanced.xml linden/indra/newview/skins/default/xui/en-us/panel_preferences_graphics1.xml linden/indra/newview/skins/default/xui/en-us/panel_preferences_im.xml linden/indra/newview/skins/default/xui/en-us/panel_preferences_skins.xml linden/indra/newview/skins/default/xui/en-us/panel_preferences_web.xml linden/indra/newview/skins/default/xui/zh/menu_viewer.xml linden/indra/newview/skins/default/xui/zh/panel_group_general.xml linden/indra/newview/viewer_manifest.py linden/indra/newview/viewerversion.cpp linden/indra/newview/viewerversion.h linden/install.xml Also some post merge tweaks.
Diffstat (limited to 'linden/indra/newview/llvoiceclient.h')
-rw-r--r--linden/indra/newview/llvoiceclient.h19
1 files changed, 15 insertions, 4 deletions
diff --git a/linden/indra/newview/llvoiceclient.h b/linden/indra/newview/llvoiceclient.h
index 9ef3be9..f5c6d87 100644
--- a/linden/indra/newview/llvoiceclient.h
+++ b/linden/indra/newview/llvoiceclient.h
@@ -424,11 +424,15 @@ static void updatePosition(void);
424 const std::string& account_name, 424 const std::string& account_name,
425 const std::string& password, 425 const std::string& password,
426 const std::string& voice_sip_uri_hostname, 426 const std::string& voice_sip_uri_hostname,
427 const std::string& voice_account_server_uri); 427 const std::string& voice_account_server_uri,
428 const LLUUID& response_id);
429
428 void loginSendMessage(); 430 void loginSendMessage();
429 void logout(); 431 void logout();
430 void logoutSendMessage(); 432 void logoutSendMessage();
431 433
434 void loadDaemon(const std::string& scheme);
435
432 void accountListBlockRulesSendMessage(); 436 void accountListBlockRulesSendMessage();
433 void accountListAutoAcceptRulesSendMessage(); 437 void accountListAutoAcceptRulesSendMessage();
434 438
@@ -474,7 +478,8 @@ static void updatePosition(void);
474 const std::string &credentials); 478 const std::string &credentials);
475 void setSpatialChannel( 479 void setSpatialChannel(
476 const std::string &uri, 480 const std::string &uri,
477 const std::string &credentials); 481 const std::string &credentials,
482 const LLUUID& response_id);
478 // start a voice session with the specified user 483 // start a voice session with the specified user
479 void callUser(const LLUUID &uuid); 484 void callUser(const LLUUID &uuid);
480 485
@@ -519,7 +524,7 @@ static void updatePosition(void);
519 524
520 void close(); 525 void close();
521 void start(); 526 void start();
522 527 void setPIRCapResponseID(const LLUUID& response_id){ mPIRCapResponseID = response_id; }
523 private: 528 private:
524 529
525 // internal state for a simple state machine. This is used to deal with the asynchronous nature of some of the messages. 530 // internal state for a simple state machine. This is used to deal with the asynchronous nature of some of the messages.
@@ -595,7 +600,13 @@ static void updatePosition(void);
595 std::string mAccountDisplayName; 600 std::string mAccountDisplayName;
596 std::string mAccountFirstName; 601 std::string mAccountFirstName;
597 std::string mAccountLastName; 602 std::string mAccountLastName;
598 603
604 bool mAccountActive;
605 bool mVAPRequested;
606 std::string mDaemonScheme;
607 LLUUID mVAPCapResponseID;
608 LLUUID mPIRCapResponseID;
609
599 bool mTuningMode; 610 bool mTuningMode;
600 float mTuningEnergy; 611 float mTuningEnergy;
601 std::string mTuningAudioFile; 612 std::string mTuningAudioFile;